Having problems with your Hoover F7220900 SteamVac V2 Upright Vacuum ?

Suction Problem I took my unit to my work and used it, when I returned home it wouldn't suck up anything. I took the recovery take out and it has inward suction. Shouldn't that be outward, so it goes into the tank? It also blows out of the bottom by the brushes. I check the filter in the bottom and that is fine. Is it possible that it is somehow reversed the direction of the air flow (rotor running backwards)? I am perplexed. What am I missing?


Answers :

There is a stand pipe seal where the bucket sits on, and if it isn't there or out of place could cause a suction problem like you said yours is doing. In the picture it is #10. The motor seal may have gone bad and is leaking # 15.
\015\0120ba4ca9.jpg
Repair Help & Product Troubleshooting for Hoover F7220900 SteamVac V2 Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Suction Problem I took my unit to my work and used it, when I returned home it wouldn't suck up anything. I took the recovery take out and it has inward suction. Shouldn't that be outward, so it goes into the tank? It also blows out of the bottom by the brushes. I check the filter in the bottom and that is fine. Is it possible that it is somehow reversed the direction of the air flow (rotor running backwards)? I am perplexed. What am I missing?


There is a stand pipe seal where the bucket sits on, and if it isn't there or out of place could cause a suction problem like you said yours is doing. In the picture it is #10. The motor seal may have gone bad and is leaking # 15.\015\012 ... Hoover F7220900 SteamVac V2 Upright Vacuum

I have a DC07 and the brush wasn't rotating and I had no suction at the brush but perfect suction through the hose. I noticed a large build up of dog hair around the brush so I took off the cover plate and removed all the hair, cleaned inside the floor/brush housing and cleaned out the hose. I also cleaned the filter and removed the other air access cover and made sure that they were clear. I put everything back and the brush still doesn't turn and there is still no suction through the bottom


Hi and welcome to FixYa. I am Kelly. \015\012\015\012Here is a link that can assist you in your quest for the missing suction: \015\012\015\012 ... Dyson DC07 Bagless Upright Cyclonic Vacuum

It has no suction. It was fine yesterday. I washed the dirt container and the filter, let it dry and put it back in the vacuum. Today my vacuum isnt picking up any dirt and has no suction. When I took the hose out of the back, it started blowing dust and dirt out but still no suction.


Look for a place where the vacuum line has to turn in a near 90 degree turn. It's easy for it to get stopped up there. ... Vacuums

Ive changed the filter and checked the hoses but vacuum doesnt pick up ...when its on the dust is being blown out the bottom of the vacuum....i took the canister off to test the suction its fine...also cleaned the filter ...help!


Have you check the roller brush and drive belt? It may be your belt has broke or is slipping and therefore not turning the brush.\015\012Turn on machine and power head see if brush is turning if it is put a small amount of pressure on the rol ... Kenmore Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

My Bissell ProHeat 2x is pouring water out of the bottom anytime it's turned on. I had it in the shop for no water, took it back again for the same problem, took it back again because it had no suction, finally took it apart and found the problem with the suction and fixed it myself. Worked fine for a day and now it is constantly leaking water, if it's turned on, and is useless for anything except for making a mess.


Took the unit apart and discovered my heater had small pinholes in the metal and they had put in silicone, instead of a gasket, which didn't seal. So much for the place I took it to "saving" my heater for me. I repaired it myself by getting a few o ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

I have a Dirt Devil Vision and when I put a clean canister back in place the suction at the bottom of the filter clogs up and very rarely go into the canister. Also where the air blows out of the motor, I will get particals that will blow out. I have checked where the belt is and also the suction tube. Do you have any ideas how to fix this problem?


Yes your intake hose is clogged thats the clear hose you can see it on the bottom from the back.disconnect the upper hose from your intake hose and try to push a coat hanger through with the end of the coat hangers end bent till its rounded so you do ... Dirt Devil M086700 Vision Bagless Upright Vacuum

My vax power 8, 2200 watts 300 air watts 4L capacity upright Hoover is brand new, I emptied out the dust/dirt collecter and cleaned the motor filter yesterday for the first time, i switched it on and all fine, the brush is spinning and the hose is sucking, put the Hoover to work it's fine for about 30 seconds then then suction stops and its dead it won't collect no more, so switched off taken apart again and the motor filter is blocked and full of dust, so I unblocked it, do the same process aga


I had the same problem. It looks like the seal on the lid on the bottom of the cylinder has fallen out when it was emptied. There is no longer a proper vacuum being created so you don't get the cyclone effect and the dirt doesn't collect where its su ... Vacuums

Hoover upright bagless vacum.motor runs, brush turns, no suction through hole behind brush roller. however there is suction going out of dust cannister filter flap to motor. what could possible problems be?


Sorry to read about your problem, I hope this helps you out.you have a clog between the brush and bagI tried to help you. Please help me and Rate/Vote on my response, thanks and good luck ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Took my miele canister vacuum cleaner in for repair because the cord had a break in it creating a short. He said it also needed an inter filter ($12.29) and the carbon brushes were worn out ($21.95). Is that possible? Also wanted to service the motor and put in a new seal ($49.95) Shouldn't that include the inter filter and carbon brushes?


Depending on the age of the vacuum and how much use it gets, the first two are possible. I would question the brushes as they should last for several years.\015\012The servicing is generally for labor only and doesn't include parts. I do reco ... Miele Vacuums

Not sucking from bottom into bag, but blows out the side filter,..yet it DOES **** FROM HOSE ATTACHMENT. How can this be?...the.belt is fine recently replace, the rollers clean..I can feel anything i


Here is a diagram ,it's probably the hose behind the brush bar thats blocked.http://www.vacsite.com/en/bissell-parts-1/bissell-parts/3522-powerf ... Bissell 3522 PowerForce Bagged Upright Vacuum

Brush will not spin. filters are clean, no clogs, belt is fine. remove canister, it works fine plenty of suction.


Probably a good idea to remove the brush and clean as best you can.\015\012Add some WD40 at each end by the plastic clips and turn by hand until they move freely.\015\012Reassemble being sure the belt is on properly. ... Bissell 37604 Lift-Off Pet Bagless Upright / Canister Vacuum CleanerVacuum

Flames and fine carbon particles came out of my Dydon DC29 which also partly melted the bottom filter. The motor is still working tho. I feel that the brushes are gone. How to get to the motor and where to get new brushes???


Hi Joel,I'm sorry to hear about your experience with your DC29. We'd appreciate the opportunity to provide further assistance, so if possible, please call us on 1800 239 766. Alternatively, if you email your contact details to us at ... Dyson Vacuums

It seems to be blowing dirt around not suking but when removing the attachment to clean stairs etc the pipe works fine have washed filteR ? SLIM UPRIGHT DC ALLERGY 18. Have cleaned out filter emptied cylinder taken any bits of cotton or hairs from brushes..........


... Dyson DC07 Bagless Upright Cyclonic Vacuum

My vacuum does not have suction power through the beater bar attachment. It feels as if it is "blowing" out of the bottom of the filter basket, but no suction power.


... Dyson Ball DC24 Bagless Upright Vacuum

I have a Eureka Contour model 2900 type A upright vacuum, the roller works fine nothing clogged, took it apart motor blade is free of debris, no suction from tube and blasts OUT air from the front HEPA filter location. New bag, New belt, nothing in hose.any clues as to why this can be happenning? Air should not be blasting out of the HEPA filter.


Even with your explanation,it seems the hose is clogged.Try taking the hose off,then blow through it or pour water through it.If this doesn't do it,make sure the suction canals are going to the proper areas. ... Eureka 2900A / 2901A Contour Bagged Upright Vacuum

I have a dirt devil ultra vision turbo, it lost suction. took it apart blew it out with the air hose, I think we put the bottom plate on wrong but can't figure out how it goes, it is blowing dirt out but the suction hose works.


... Dirt Devil Vision Turbo W/Bonus Upright Vacuum Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

I cleaned out my brush in the bottom front, cleaned out the small tubing going into the canister, and the canister itself. I also changed the filter.I snapped everything back into place, but Since then, it doesn't seem to have any suction and there seems to be a space between the canister and the bottom of the vacumm where the canister sits. At that area, you can feel air coming out when trying to vacumm and it just doesn't pick up, it seems to be just blowing stuff around.


You need to really look at it some thing is out of line you shooed not have\015\012any spaces in the top or bottom\015\012pull the canister back out and look at the pins that you lined up with the\015\012to ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Bad Motor I have purchased two of the Kenmore direct drive beltless systems with Progressive systems. The first died after a year, the vacuum motor start making a grinding noies. I pulled the side HEPA filter and could see a fine coating of graphite like dust. Took it to a vacuum repair shop. They said the brushes were going and thus the motor was shot. I liked the vacuum and bought a second, 1 year later the motor is making a slight noise that and removing the HEPA filter I find a slight metall


That dust is from the carbon brushes on the motor. You may need to check them, and also clean out the motor compartment. A slight noise could be a motor bearing starting to go. Does the smell like rubber or electrical. If rubber, then the belt h ... Vacuums

Very little suction from vacuum is occurring after I pulled a string from the roller. Hot air is blowing out of unit. Was working fine until I pulled out a string...Suction is occurring from wand.The brushes now make a loud sound too when activated...do I have to take the unit apart to readjust them or something?


Yes re adjust ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Suction Problem I was vacuuming and stopped to empty the cannister. When I started vacuuming again - the suction wasn't working properly. The vacuum was just pushing stuff around the floor. I cleaned the hair out the brush on the bottom and it still isn't working. It was working fine before I emptied the tube :( I can't figure out what happened.Help!


Greetings from GoVacuum,\015\012\015\012I believe what may have happened is that your vacuum cleaner belt has either broken, or been stretched so far that ithe brushes are no longer spinning fast enough. \015\012\015\012Here' ... Vacuums

Took my Hoover Steam Vac apart to clean it and now it won't **** up the water but was working fine before I got the bright idea to clean it. Took four screws out but did not touch the motor. It puts out water and the brushes rotate but no suction? Thank you for your help, Cathy


The suction is created by the motor and is pulled to the motor through the flexible hose. The hose could have pulled off at one end or it could have torn in a spot where there is more pull on the hose like when you lay the handle down to empty dirty ... Hoover F7431-900 SteamVac Vacuum

DC14 the suction is fine from the hose and brush bar wasnt turning with no suction at all from the bottom of the vacuum


Hi there,I'm sorry to hear you're having difficulties with your DC14. If it doesn't seem to be picking up as well as usual, it's possible that there's a blockage in the system, and you may need to give the filter a wash. The e ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0900 seconds