Having problems with your Hoover F7431-900 SteamVac Vacuum ?

No suction My Hoover Steam Cleaner does not have any suction. We have cleaned, checked belts and filter. Still does not work.


Answers :

I laid my cleaner down and checked it all out and actually vacumed the insides out (we have a lot of animals at our house) and then put the Recovery tank bank on and it worked fine.
I had a a low suction problem. Mine was easily fixed. Stand in front of the machine. When you remove the recovery tank there are the notches on the front of the tank that fit down into the machine. In the right hole in which the right notch fits, there should be a black rubber washer on the machine. Mine somehow came off and feel into the machine therefore there was practically no suction as the seal was not airtight. I only discovered this when I took apart the machine and found it floating around. Just something to check.
Repair Help & Product Troubleshooting for Hoover F7431-900 SteamVac Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

No suction My Hoover Steam Cleaner does not have any suction. We have cleaned, checked belts and filter. Still does not work.


I laid my cleaner down and checked it all out and actually vacumed the insides out (we have a lot of animals at our house) and then put the Recovery tank bank on and it worked fine. ... Hoover F7431-900 SteamVac Vacuum

Low suction I have a Hoover central vacuum system. I've reset the fuse box, checked the fuses, all of the lines are clear and there are no holes for escaped air to travel out. The filter has been cleaned as well. The vac works well with high suction when hooked directly to the unit, however when using any of the indoor connections there is extremely low suction. The machine still turns on so I do not believe it is an electronic issue. I have troubleshooted the issue as best I could and would


... Hoover L2310 GUV Central System Vacuum

My hose no longer works no suction buth the vacuume still works how do i fix I checked the hose checked the filters nothing works to get my hose so it has suction.


Check the following after unplugging the power cord from the outlet.\012\012- Check for suction at the back of the unit, after removing the hose where it attaches to the back of the vacuum. If there is NO suction, the machine will need to be ta ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

The vacuum i've had for 6 months has very liittle suction power. checked that the belt is on. cleaned filter. checked to see if hoses were clogged. I used a super vac to suction any debris out of vacuum. still little suction power


As this unit has 3 filters on it, a lot of people forget about the one filter that will cause all of your trouble here. \012\012There is the exhaust hepa filter, no problem, your unit is pretty new, it shouldn't be a problem. \012Th ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

Burned smell hi, I have used my hoover 4 times and is starting to smell as something burned, I checked the troobleshouting part of the owner manual and it says that check the belt, I already did that and everything is ok I used the hoover again and still smelling bad and start to work very slow I better shut off it.. what could I do??


If the motor slowed down this would indicate a bad motor. not cost effective on this model to replace unless under warranty. it is not uncommon these days to see a motor go bad every now and then.\015\012\015\012What are the first 4 digit ... Hoover U5507900 Elite Rewind Bagless Upright Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.


Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

I have a Dyson DC07 and it has lost suction. I have checked the belt, cleaned the circular filter and emptied the dirt chamber. The hose still has plenty of suction but I can't use the hose the vacuum the entire house.


Here are some things you can check.First you need to see if the problem is with the suction or agitation.If the suction on the hose for using the attachments is low you either need new filters a new cyclone(they are not cleanable) or it is clogg ... Dyson DC07 Bagless Upright Cyclonic Vacuum

Vacuum My vacuum is loosing it's suction power. I've checked the belt and it's in perfect shape...I've bought a new filter cup...I've checked for clogs and there aren't any...I've cleaned the entire machine...and I still can't find the source of the problem.


You checked the belt, but I bet it has stretched and won't drive the brush roll under load like it should. Belts only last a few months the stretch and should be replaced. Iff you have suction at the hose, then it has to be down below, either belt/ ... Eureka Whirlwind 4480 Upright Vacuum

I have a Eureka Altima vaccuum and it no longer suctions like it use to and also has a burning smell. I have cleaned all filters, brush, hoses, and filters. There are no blockages. I have also checked the belt and it's still good. Any other ideas as to what may be the problem?


This bagless model gets buildup of really fine dirt in the motor and starts to clog up the fan airducts. You will need to take the motor out and clean it. ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

Oreck XL21 just will not work at all any more. Beater is clean - belt is fine. Fresh bag - inflates. Took the thing apart - checked for blockages at intake, bag entry, and the tube. It just doesn't vacuum anything. No suction at all for anything stronger than air. I'd say it doesn't ****, but that would be ironic. Are these known for just "quitting" after a while? We take it in for maintenance as recommended to replace filters, etc. Is there some miracle trick to make it work or sho


Did you make sure the brush turns freely? Even though it is clean, if it does not turn freely with the belt, it will not beat the carpet and pull debris up into the unit.\015\012\015\012Another (drastic?) thing to try would be to take the unit ... Vacuums

Hello, I have a Eureka 71b handheld vacuum. There is literally no suction. I checked the hose and it is NOT clogged. I thought it might be the filter so I bought a new filter. Still no filter. The rot


... Eureka Vacuums

I have a Hoover Windtunnel Model U573-960, the belt turns the bar still has alot of life on it. I have very little to no suction at the end of attachment hose. I replaced filters and looked for blockagaes with no luck.


... Hoover Vacuums

We have a 25512/13 and suddendly the powermate is not pulling forward and sucking. We checked the belt and it is ok. The light stopped working when it stopped thrusting forward. When we remoe the powermate, it seems that there is still suction. Can you help us?


... Kenmore 25512/ 25513 Progressive Canister Vacuum

When I turn on the Hoover U5780-900 it seems the motor just starts to rev up and stays that way until I shut it off. I have replaced all the belts, made sure there were not any blockages, and checked the filters. It still does it. Any other ideas.


... Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum

Hello i own the bissle proheat steamer it turns on but no water or soap or suction from floor or the utensiles ive taken the take off the back to scope out anything that could be in the way but dont see anything the motor is making that clogged vacume noise witch makes me believe something could be stuck somewhere in it but it could also be no water is getting to the pump or despencer but the brissels still work belt for that is good where would i be best to check and where is the location of th


... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

Hello,We have an Hoover Mach 5 Cyclonic vacuum that has no suction. We have cleaned and checked all hoses, belts & filters. Please help us.


With this model, remove the dust tank, and turn it on, check for suction at the lower intake. If you have suction, install the tank and remove hose, and check for suction there. keep following until youn lose it. Then you problem will be between thos ... Hoover U5194-900 Mach5 Multi-Chamber Cyclonic Vacuum Cleaner Bagless Vacuum

I just used my Bissell Proheat, when I heard the vacuum sound get lower and lower then suddenly something "gave" and it got very loud and started emitting a burnt rubber smell. It still worked to put liquid into the carpet; seemed to have trouble getting it out. I checked the tank, filters, belt, and roller and all seemed OK - but when I started up again and looked down I saw sparks in the motor/belt area and shut it down immediately. Any thoughts?


The bearing that is located at the top of the vacuum motor has failed . Because of that the shaft of the motor's rotor is out of position and the pulley attached to it has started rubbing on the other pulleys, giving you that smell. the spark appear ... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

I bought a Hoover Wind Tunnel in January 2008. At first it worked great though very noisy. Now it will not pick up small fuzz on medium shag carpeting. I have checked the bag, the filter, the belt, and obstructions and there are none. Plus the noise level has increased. What is wrong? I am very dissatisfied.


Http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=563001 Generic problem for all Vacuums I bought a Hoover Wind posted by smithcarolj1 on May 01, 2008 I bought a Hoover Wind Tunnel in January 2008. At first it wo ... Vacuums

The dirt devil vision wide glide Model 086700W appears to have no suction. I have cleaned the hoses and filter and still there is nothing being picked up. Also, I have checked the belt.


There must be a blockage after the hose, check where the hose plugs into the vacuum. make sure unit is un plugged for safety ... Vacuums

The suction still works but the primary floor vacuum doesn't. I checked the belt and its not broken. The engine that runs the floor vacuum doesn't engage like it used to


The belt doesn't have to be broken to affect the the way the vacuum picks up on carpet. If the belt is stretched then it will slip and not turn the roller brush properly. Here is the manual and belts you need: ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Noise Hi... I was doing normal house work and had been using it on carpet... I put it on floor for my hardwood floors and picked up loose clean cat litter and went to put it back on carpet and it made a horrible noise like it was rubbing. cleaned the filter... cleaned the roller thingi ...checked the belt and it is still making that horrible noise. It does not make the noise when I have it on floor but as soon as I put it on carpet it screams at me. Help! Please and thanks Linda


Hi Linda,\015\012Sounds like clutch problems, try to move the lever for carpet/floor back and forth a few times maybe it will free up. If it still makes the grinding noise, the clutch assembly will have to be replaced. Let me know, i can even ... Dyson DC07 Bagless Upright Cyclonic Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

The vacuum does not have suction. I have cleaned the filters, checked the hose paths and the hose won't **** anything up. I even checked with all the filters removed, still no suction. It is blowing air out the exhaust.


Have you checked the belt? ... Bissell 89Q9 Bagless Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1163 seconds