Having problems with your Hoover Platinum Collection Upright Vacuum ?

Hoover Elite upright is making a very loud noise. I changed the bag, cleaned the roller and checked the belt. What else can I look at?


Answers :

Repair Help & Product Troubleshooting for Hoover Platinum Collection Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Hoover Elite upright is making a very loud noise. I changed the bag, cleaned the roller and checked the belt. What else can I look at?


... Hoover Platinum Collection Upright Vacuum

My Oreck XL upright is blowing out instead of sucking in. I changed the bag and cleaned the brushes; I also cleaned out the main "pipe." I looked for a place to change settings and couldn't find any, so I know I didn't inadvertently switch something. The brushes seem to be spinning at the correct speed. Thank you, Julia Byrem


... Oreck XL2200 Bagged Upright Vacuum

My Oreck is hopping on my carpet while vacuuming. It is fine when pushed away - it hops and leaves marks on my carpet when I pull it back. I have changed the bag and cleaned off the roller and checked for a clog. All are fine.


My first thought is to change the belt.If it is stretched this is a common symptom.You can go to youtube and my chanell is sewvacmd.Their is a video on how to change it.Hope this helps. ... Oreck XL2200 Bagged Upright Vacuum

I have a dirt devil featherlite plus and all of the sudden it started pushing hard and smells hot. I cleaned the roller, changed the bag, checked the belt. The belt is a little wore, but not bad.


If it is pushing hard then you still have a belt problem. It may not be broken but the belt is stretched out too long and will not turn the roller brush fast enough to make it push easy. ... Dirt Devil M085500 Featherlite Plus Bagged Upright Vacuum

Sudden loss of suction. Using a dirt devil upright. Checked the belts that were changed recently and working. Changed the half full bag. No change. Checked for blockages and as far as I can see there are none. The blower is working as much as it ever was I think but I;m stumped.


R u sure there is nothing cought in the hose? ... Dirt Devil Featherlite Bagged VacuumVacuum

Hoover tempo upright is clogged. I can only vac for a few minutes, then I have to unplug it and turn it over and clean out the under part under the roller. It is totally stuffed with dirt and dust and carpet fibers. I have a new bag in. It is like it is clogged up inbetween the bag and the roller. Also gets clogged when using the hose. It is maybe a year old. How can I take it apart and unclog it?


Disconnect the hose and head and wands. Drop a quarter thru the hose, the handle sometimes clogs. peer thru the wands and inspect the elbow on the head for blockage as well ... Vacuums

No power to sensor SR 12. I also have cleaned rollers and filters and bags. I have reset the handle. When I hit the power the check brush and full bag lights flash once. That is the only power that is getting through.The unit was in storage for a bit and got wet but its been drying off for a couple months. Is there something I can check or replace. Its a great Vac.


... Windsor SR12 Sensor Bagged Upright Vacuum

We understand that your problem is: I currently own and use on a regular basis the Kenmore Progressive upright bagged vacuum. Model number 116.35923500. The headlight flickers and the intelliclean light stays red. Ive tried cleaning the intelliclean sensors, changed the bag, and cleaned off the agitator. Is this a power issue? Should I take it to the store? Any suggestions would be greatly appreciated


Welcome to fixya\012\012Hello\012\012 \012\012I have a solution for this ... Kenmore Progressive 35922 Bagged Upright Vacuum

Have a hoover windtunnel platinum. I have changed the bag ( hepa Q bag) but the bag light wont reset. so the vaccum wont turn on. I have unpluged it and let it set for a while with the new bag in and repluged it in. I have checked the brushes and it is all clean but it will not reset. This only the second bag so it is a new machine I should not be having problems. Is there some sore of reset button I can hit.


... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

I have a hoover windtunnel platinum. I have changed the bag ( hepa Q bag) but the bag light wont reset. so the vaccum wont turn on. I have unpluged it and let it set for a while with the new bag in and repluged it in. I have checked the brushes and it is all clean but it will not reset. This only the second bag so it is a new machine I should not be having problems. Is there some sore of reset button I can hit.


... Hoover Company Wind Tunnel U53019 Upright Vacuum

Weird noise i have a eureka the boss and i am getting a weird noise figured bag was full needed to change it so i did. Noise persisted so i checked make sure nothing was caught in the brushes. I even checked the belt it was fine replaced with a new one.Still the noise is there help me I am out of what else to check.


Squealing ... Vacuums

I am having problems with the roller on my Oreck DTX-1300. It turns on and off intermittantly while I'm vacuuming. I have completly taken it apart and cleaned and inspected the roller unit.(I am very much mechanically inclined) This has stumped me, I have checked the electrical from the vacuum to the floor unit, and everything else that I could think of. Question: what does the metal sensore plate on the bottom of the roller unit do?? Anything anybody can tell me, I would greatly appreciate. Cap


... Oreck DutchTech DTX1300A Bagged Canister Vacuum

My Kenmore Progressive keeps burning up belts even after I have changed the bag, cleaned the filters and checked to make sure the agitator was clean and free turning


On the left hand side, just above the handle release, is a lever to adjust if you are doing hard wood or carpet cleaning. When adjusted for hard wood, that lever releases the belt and just uses the "vacuum" function. When set for carpet it engages ... Kenmore Vacuums

No suction I just replaced the bag, and normally after this I have a lot of suction. Now that I have changed the bag I have less suction that I had before. Not even enough to picj up dog hair. I snaked he hose and checked all of the connections. It seems to have an air leak but no amount of tape will fix this. I cleaned the filer as well with warm water and dried it and re installed but still absolutely no suction. I am ready to throw it out! Any suggestions would be appreciated


1, Does the blower (discharge) side blow bunches of air??Yes: Something is clogged from the bag to the hose end. Try blowing out the hose from the discharge side.Or: The bag is not properly seated. Make sure that the plastic piece is ... Kenmore 23313 Whispertone Bagged Canister Vacuum

I have a Kenmore 116.36932 (upright-bagless vacuum) that the motor protector by-pass valve has opened. I've clean out the area between the agitator brush where the flexible extension hose starts. There was some blockage there. I checked the rest of the system (extenstion hose, back filter area, pipe area to canister and area to side filter. I took the 2 filters out and the by-pass valve is still open. Where else could there be a blockage that I can take apart to clean and put back together


... Vacuums

Oreck Upright Hi Redev, I'm not sure what model I have (about 6 years old...upright, looks like the one in the picture). I changed the belt (which was torn) and then the next time I used it, it cut off on me. Now if won't turn on at all. (I turn the switch on and off and nothing happens as if it is not plugged in but it is!). I noticed at the top where the power cord enters the handle, it is all frayed. Could the electrical wires have detached? Anything you think I should check before taking it


The cord could be bad and will ahve to be replaced. It would have to have a problem inside the handle or down by the motor. ... Oreck XL2600 Vacuum

My Dirt Devil M082476 Full Bag indicator light keeps coming on when I turn my vacum up to full intensity. I have tried changing the bag and checked that all hose is clear. If I leave the vacum on low intensity the suction is minimal and does not increas when I turn up the suction. Is there a solution to this? I look forward to your response


... Dirt Devil M084105 Jaguar Vacuum

When I flip the switch on my sebo x1 upright, a red light comes to the brush and bag icons. However, I cleaned out the hose and checked to make sure there is no obstruction from the brush to the hose also, or from the hose to the bag. It is clear that juice is coming to the vacuum, but there is no sign of life except the two red lights.


Thanks for contacting fixya. You should pull out the bag and reset the machine. You should take all the user replaceable items. And turn it on. You will get lot of errors. Then turn the machine off. Put back all the accessor ... Sebo Automatic X1 Bagged Upright Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

Windtunnel bag vacuum won't pick anything up. changed bag, clean roller , now what?


I would try changing the belts. You can get the belts you need here:Hoover Windtunnel Replacement Belts ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Suction vacuum one day fine next not having great suction picking up big things but not feeling that deep down suction rolling too too easy changed bag, belt and cleaned roller it is like it is gliding over but not really getting deep visible cannot even tell I went over carpet


Don't panic! Easy fix!\015\012\015\012I was having the same problem, but I removed the base plate from the bottom of the vaccum (5 screws on mine), revealing the roller and the engine. Just behind the roller is an intake tube. Mine had ... Oreck XL Ultra Bagged Upright Vacuum

Bought a Kenmore Progressive canister vacuum at a garage sale that looked in better than average condition, filters clean, new bag, all accessories intact, some debris in roller brush. problem is no suction when turned on. There does not appear to be any obstruction in hose. did not have manual


Hello,Carnister vacuum cleaners are all built with the same principle in mind. A motor \015\012generates power which powers a vacuum which, in turn, creates suction to\015\012 lift debris. The most common areas of suction loss are within ... Kenmore 25512/ 25513 Progressive Canister Vacuum

My vacuum is not picking up like it is suppose to, the bag is clean, there is nothing trapped in the hose, what else can I check?


<span style="FONT-FAMILY: Arial; BACKGROUND: white; COLOR: black; FONT-SIZE: 10.5pt">Hi,<br />Here is a tip that I wrote about my Bissel but I bet you have the same problem and the hose is clogged...<br /><br />Bissell Bagless ... Hoover U6476-900 WindTunnel Vacuum

It leaves dirt and fluff in the rollers not in the filter. So is not cleaning properly. There is never anf fluff at all in the filter. Also the lid does not close properly and we constantly get the 'check tank' light coming on. It leaves streaky marks across the floor and seems to leave the floor too wet (hence the streaks). Look forward to hearing from you.


Is there something stuck in the air passage between the tank and inlet ... iRobot 5800 Scooba Vacuum

I have a Sanitaire model SC886 upright vacuum. It's about a year old. I replaced the belt , cleaned bag , checked for blockage in impeller fan and now it makes a noise , like a grinding noise or something . Could you tell me how to fix it ?


The bearings in the motor needs to be checked,or the impeller is damage. ... Eureka SC886 Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1240 seconds