Having problems with your Hoover S5604 Central Vacuuming System Power Unit Vacuum ?

I have one central vacuum location that does not receive power. All other locations work. I do get suction but just no power. What should I do first to test power to location.


Answers :

Remove the face plate from the wall and test the low voltage wiring behind. Before undoing the screws where the wiring connects, reach inside the inlet and feel the two brass pin connections. There should be spring tension behind each. Underneath the screws where the wires connect there is a spring which pushes on the brass terminal in the inlet so do not remove the screws fully.
The wiring is low voltage so you can short across the terminals with and insulated set of pliers.If you do this and the vac does not start you need to check where the inlet wiring connects into the main wiring circuit. It should run along the pipe. There should be continuity from each wire back to the vac itself.
Post back to advise how you make out.
Repair Help & Product Troubleshooting for Hoover S5604 Central Vacuuming System Power Unit Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have one central vacuum location that does not receive power. All other locations work. I do get suction but just no power. What should I do first to test power to location.


You need to use a circiut tester (electrician test probe) on the two terminals the hose plugs in to to see if power is present to connect to. The receptacle likely has damage to the power connection from arcing from the hose previously not fully plu ... Hoover Powermax U5242-930 Vacuum

I have one central vacuum location that does not receive power. All other locations work. I do get suction but just no power. What should I do first to test power to location.


Remove the face plate from the wall and test the low voltage wiring behind. Before undoing the screws where the wiring connects, reach inside the inlet and feel the two brass pin connections. There should be spring tension behind each. Underneath the ... Hoover S5604 Central Vacuuming System Power Unit Vacuum

Recently purchase SC-N500 vacuum cleaner. Worked well only the first 2 times I used it to clean up plaster dust from floor after sanding. Since then it has not worked at all well wiht very poor suction. Fluff gets stuck in the hose and has to be manually removed. Suction power is very poor. I have washed the filter to remove the dust with no difference. Who do I contact in Brisbane to service or assess the problem further.


... Sanyo Vacuums

Poor suction absolutely loved the machine when I first got it. I have dogs so it is getting a work out. however, the suction isn't as great as when I first got it. I have cleaned the washable filter and empty the cylinder after every vacuum. When I use the hose, the suction just isn't there. anything else I can do?


OK- I had the same problem and I took it to sears for service, It still wasn't great. So I proceeded to pull out all of the filters, including the internal filter that is not easy to get get to. I washed it and air dried it, put it all back together ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

My kenmore model no 116.22512200 canister vacuum power head has no suction & doesn't pick up even though it shows all the signs that it is getting power. The junior power mate works fine.


... Kenmore Vacuums

My Hoover SteamVac has been doing a wonderful job but in two instances, after emptying the dirty water and reattaching the reservoir, the machine has lost suction. The first time I was able to make it work again after taking it apart and putting it back together about 10 times. I don't know what I did that fixed it but as long as it worked again, I was happy. But it's happened again and I can't get it to vacuum. I can see that it isn't clogged. Can you please help me????


Look for the lower tank filter to be clean. also make sure the lower tank lid is on properly. latch when installed on machine. Make sure the front panel duct is on the lower tank. ... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

My Dyson animal seems to have an electrical issue that I am unable to pinpoint. Neither the wand nor the floor vac have any suction AT ALL. In fact the vac makes absolutely no sound and you wouldn't even know that it had power to it unless the rollers are turned on, the rollers work just fine. I had this problem start about a month ago and then it just started working again after messing with it for a while, now it has happened again and I am getting a little agitated! Please Help!!!!!!!!!!!


There is a filter inside the canister, and by your description it sounds like it needs to be cleaned. if you remove the filter and blow it out using a air compressor or using a slightly ridged brush and tapping the filter out this should solve your ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

I have the Hoover upright windtunnel and have used it only once. It worked wonderfully the first time but now only the hand tool has suction. I can't find the book that came with it though. How do I get the main vacuum to work?


Seems like you must have suction at th hose. The either a belt came off or it is plugged up at the dirt inlet by the brush roll. Some Hoovers have a spring loaded door that opens and closes depending on whether the handle is down or in its upright ... Hoover Vacuums

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u


Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

Hi -- I have a Kirby Sentria and it is great except that I am getting no suction at all through the big silver power head. Suction through all the other attachments works well. I haev tried it with the roller belt on and off, and that doesn't seem to make a difference. Am I missing something?? Thanks!


You can take off the power head and look in that whole where the belt is and see if there is a paper towel or something in there clogging it up. Also tug on the belt and make sure it is tight - because if it is loose it is broken and you ... Kirby Vacuums

Dyson DC07: When I first got this vacuum, it was so powerful that it lifted my area rugs off the floor. It is so weak it barely works. I have removed and cleaned the filter, but I can?t seem to improve the suction. What am I doing wrong? How do I fix it?


Hello,\015\012\015\012If your vacuum runs but still leaves dirt behind, the culprit could be the drive belt or an obstruction. If the agitator brush slips or won't turn, the belt is bad and needs to be replaced. If suction is weak when yo ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

My vax power 8, 2200 watts 300 air watts 4L capacity upright Hoover is brand new, I emptied out the dust/dirt collecter and cleaned the motor filter yesterday for the first time, i switched it on and all fine, the brush is spinning and the hose is sucking, put the Hoover to work it's fine for about 30 seconds then then suction stops and its dead it won't collect no more, so switched off taken apart again and the motor filter is blocked and full of dust, so I unblocked it, do the same process aga


I had the same problem. It looks like the seal on the lid on the bottom of the cylinder has fallen out when it was emptied. There is no longer a proper vacuum being created so you don't get the cyclone effect and the dirt doesn't collect where its su ... Vacuums

Hello i own the bissle proheat steamer it turns on but no water or soap or suction from floor or the utensiles ive taken the take off the back to scope out anything that could be in the way but dont see anything the motor is making that clogged vacume noise witch makes me believe something could be stuck somewhere in it but it could also be no water is getting to the pump or despencer but the brissels still work belt for that is good where would i be best to check and where is the location of th


... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

What do you do to get the most suction power from the DC04 dyson zorbster. It seems the only way to do it is to bang it which can't be the right way.The settings at the bottom do not seem to work and I have no instructions.


Clean or change the filters every 3 months and maybe have it serviced every year  ... Vacuums

Lost Suction This is my second hoover steamvac and i am having the same problem with my new one as i did with the old one that i tossed out. I have used it about 12 times and it worked great the first 6 times... Now i'll empty a full tank of water and only half will get sucked back up. I have tried taking it apart and cleaning and also the rubber seal had some gaps so i sealed those thinking that it was leaking air from there...can anyone help? I am so close to chucking this one and buying somet


Usually when there is no suction, one cause is the lid to the recovery tank is not on all of the way in the back. Also if you have that foam filter on the underneath side of the recovery tank lid, it needs to have a 1/4 in or so gap from the top of ... Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum

Hi, I have been given a beautiful Husqvarna Prisma 980 and the power seems to have stopped getting to the machine.. The first time I plugged it in it worked, all the lights came up where they are supposed to, then the second time nothing =( Some help would be appreciated as I would like to fix it instead of throwing it in the bin Thanks Vicky


If you're really serious about getting this machine running, you need a service manual. Here is a .pdf download manual:\015\012 ... Vacuums

116 31811010 Vaccum motor stopped working during use. It's getting power, lights and brush rotation, but no suction.


... Vacuums

The model is Miele S538, but I did not see it on the list. The suction power button( ) increasing the power does not work. The suction power button (-) decreasing the power does work.


... Miele Leo S5381 Canister HEPA Vacuum Cleaner Bagged Vacuum

I have a bissell pro heat model 7901-B that has power but no water circulation. I was told that the previous owner used it without water and that she couldn't get it the power on. I bought it off of her and cleaned it out and now the power works, but there is no water circulation. The brushes run and heater works, just can't seem to get it to circulate water. Thankyou for your time, Don


... Bissell Carpet Cleaner Powerbrush Deep Cleaner Vacuum

Beam solaire hose only works to suction The power head isn't working. Have another hose and the power head does work on that one so I know it is the hose


... Vacuums

My hose no longer works no suction buth the vacuume still works how do i fix I checked the hose checked the filters nothing works to get my hose so it has suction.


Check the following after unplugging the power cord from the outlet.\012\012- Check for suction at the back of the unit, after removing the hose where it attaches to the back of the vacuum. If there is NO suction, the machine will need to be ta ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

When taking the handle/wand back to use it seems to lose the suction power regardless of what setting I use. Upon several times of standing it back up it seems to engage the suction power correctly is there a button or something that does not always engage to get power? can I fix it


When you say taking handle back I assume you mean the action to start rotation of brushes. Had simular problem and found by removing brush from tube and then cleaning "baked on rubbish" in plastic tube (so you can see clearly through tube) Clean with ... Dyson DC28 Animal Bagless Upright Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

Suction hose I can't get the suction hose to work...and I have cleaned it out to make sure it isn't plugged. There is a small amount of suction just not enought to pick anything up.....the floor part works great...what could be the problem


I would first double check the hose, remove it and drop a marble through it to be sure. make sure the bag is new and also check the filter underneath the bag if it is clogged it could cut the suction. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My power brushes on my bissel carpet cleaner stopped working. They do not rotate. This is the 2nd power cleaner I have bought and it has the same problem as the first one. What is the problem with the power brushes. After 3 uses they stop working. Bissel Proheat 2X Model #8920


You need to change the belt(s). You can find the belts for this model here. http://www.vacbelts.com/bissell-proheat-belt-combo-pack.htm ... Bissell 8910 ProHeat Clear View Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0917 seconds