Having problems with your Hoover U5491-900 Bagged Upright Vacuum ?

The brush is spinning (and has been cleaned), there is a new bag, but we get no suction.

Answers :

The reason the brush is not spinning is because the belt is stretched or broken. You can get a replacement belt here:

Hoover U5491-900 Belt
Repair Help & Product Troubleshooting for Hoover U5491-900 Bagged Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

The brush is spinning (and has been cleaned), there is a new bag, but we get no suction.

The reason the brush is not spinning is because the belt is stretched or broken. You can get a replacement belt here:Hoover U5491-900 Belt ... Hoover U5491-900 Bagged Upright Vacuum

I have a Kirby G series diamond edition. There seems to be no suction when I turn on the vaccum. The bag inflates, but the roller does not turn. It has a new belt and the roller brush is clean. Any suggestion on what I might do to increase the suction and get the roller bar moving?


I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

My electrolux oxygen cannister has the "bag change" light on when there is a new bag. The light stays on when the suction power is high (to pick up small particles) and it won't pick up, but the ight goes off when the suction power is low (to pick up big objects). I changed the hepa filter, cleaned the motor filter and changed bags, but all that didn't help.

You may have a clog in the hose, and/or the inlet by the brush roll. A clog will turn on that light as well as a full bag. ... Vacuums

Bissell powerforce My lower pickup tube became clogged so I removed it and cleaned it out and reinstalled it.Now everything runs good but the vaccum want pick up any dirt .I replaced the bag andf when I turn it on it just exhaust air but does not have any suction,I tired tp pull the bag door of while it was running whick I could not do so it has plenty of suction inside just not getting any outside can you help?

... Bissell Vacuums

Vacuum has new bag but won't pick up dirt. Cleaned flat filter and it made it worse. Do I need to replace rectangular filter or can I clean it. If so , how? If not, do I need to take it in for repair, ir should I get new parts? Thanks!

It's clogged somewhere. Disconnect the hoses where you can and check for obstructions. Run a coat hanger down the hose if you need to to clear the obstruction. ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

My Kirby vacuum is a G100 upright. It has no suction. It has been cleaned and the bag is empty (new bag). My mother-in-law bought the same kind and hers is doing the same thing. It has no suction and won't pick up anything. Thank you, Rachel Souza - [email protected]

... Kirby Vacuums

My Bissell cleanview is NOT suctioning well, all filters, nozzles, attachements, canisters and belts are clean and in good repair. We've pretty much made sure everything that I can get to without completely dismantling the vacuum is super clean and/or new... still poor suction

Did u check the filter above the dirt cup?\015\012\015\012twist the yellow piece and wash the filter ... Bissell 3594 CleanView PowerTrak Bagless Upright Vacuum

Poor suction (new bag, clean filter, clear hose)

Check the impeller on the moter it may be missing a fin or two (question does it make any unusual noise or vibration ?) ... Vacuums

My eureka vacuum won't suction and starts to smoke when I try to use it. It sounds like it is suctioning when I first turn it on, but after about 20 seconds it begins to smell like burning and does not suction at all. I have tried cleaning and unclogging the filter and everything. It's bagless so I don't need a new bag.

The problem is that your belt is stretched and worn. This causes that burning smell and it also causes the vacuum to not pick up well. You need to replace the belt. Here is the belt you need and the manual with instructions: ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

Suction vacuum one day fine next not having great suction picking up big things but not feeling that deep down suction rolling too too easy changed bag, belt and cleaned roller it is like it is gliding over but not really getting deep visible cannot even tell I went over carpet

Don't panic! Easy fix!\015\012\015\012I was having the same problem, but I removed the base plate from the bottom of the vaccum (5 screws on mine), revealing the roller and the engine. Just behind the roller is an intake tube. Mine had ... Oreck XL Ultra Bagged Upright Vacuum

No suction--blocked hose was cleaned out, but there is no suction now. I put in a new bag and air filter, also.

You may have a broken belt that turns the brush.Jim ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

My Hoover Windtunnel, 12-amp, UGG16-900 (or U6616-900 - hard to make out the "G"s from the "6"s) suddenly lost suction this morning. The dirt collection thing is completely clean (I always clean it out after using), the side filter is dirty but not destructively so, and I can see nor feel any obstructions in the hoses. Should I take it in (a real hassle in NYC) or get a new dyson? LOL.

Usually on this machine the door/valve assembly is to blame. if something gets caught in the door/valve assembly it can break this part. you can take it in to see what the est. would be. hope this helps ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Hi, My problem is that I'm getting hardley any suction when I vacuum. The machine has a new bag and the rollers are turning, just no suction. Thanks!

Take out the brushroller and check the hole where the dirt goes into the machine for clogs.\015\012\015\012Marci ... Hoover Vacuums

My upright kenmore progressive vacuum will not suction up when using the sweeper. It will suction things when I use one of the tools. I have put in a new bag and have tried to see if anything is blocking the bottom. It sometimes makes a very loud noise when I try to vacuum. If I press the intell clean on and off yellow button the noise may go away but it still does not work.

Double check hose placement, making sure you have the hose inserted into the correct slot. The long attachment nozzle stores in the front hole on the right, and the sucking hose inserts into the rear hole on the right. I know this is too simple of a ... Vacuums

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?

As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

No suction I have new belts. Everything is clean. No clogs. When I turn it on it smells like rubber , the brush doesnt spin. Everything seems to be free flowing.. Roller brush isnt stuck on the ends. Took off hose to make sure no clogs anywhere. There is not even suction thru the hose with the handle in upright position.

Generally, the problem is that the belt is not running the brushes.  This is caused by one of the following:\015\012\015\012\015\012beater brush is jammed.  This is either an object stuck in the brush or im ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Hoover tempo upright is clogged. I can only vac for a few minutes, then I have to unplug it and turn it over and clean out the under part under the roller. It is totally stuffed with dirt and dust and carpet fibers. I have a new bag in. It is like it is clogged up inbetween the bag and the roller. Also gets clogged when using the hose. It is maybe a year old. How can I take it apart and unclog it?

Disconnect the hose and head and wands. Drop a quarter thru the hose, the handle sometimes clogs. peer thru the wands and inspect the elbow on the head for blockage as well ... Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

Lost Suction This is my second hoover steamvac and i am having the same problem with my new one as i did with the old one that i tossed out. I have used it about 12 times and it worked great the first 6 times... Now i'll empty a full tank of water and only half will get sucked back up. I have tried taking it apart and cleaning and also the rubber seal had some gaps so i sealed those thinking that it was leaking air from there...can anyone help? I am so close to chucking this one and buying somet

Usually when there is no suction, one cause is the lid to the recovery tank is not on all of the way in the back. Also if you have that foam filter on the underneath side of the recovery tank lid, it needs to have a 1/4 in or so gap from the top of ... Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum

Little green machine pro heat pet the collection tank wasn't collection and dirty water was coming out of the bottom. i took it apart, cleaned it up and put a new "duckbill" gasket in. then it quit spraying, but i think i got that working again. now after i spray and get a good foam on the carpet, i switch to suction and it seems very weak. i can see the water moving (trickling) from the head into the hose but it is not reaching the collection tank -- actually, i am not sure where its goin


Bought a Kenmore Progressive canister vacuum at a garage sale that looked in better than average condition, filters clean, new bag, all accessories intact, some debris in roller brush. problem is no suction when turned on. There does not appear to be any obstruction in hose. did not have manual

Hello,Carnister vacuum cleaners are all built with the same principle in mind. A motor \015\012generates power which powers a vacuum which, in turn, creates suction to\015\012 lift debris. The most common areas of suction loss are within ... Kenmore 25512/ 25513 Progressive Canister Vacuum

The brush spins but the the dirt is not getting into the bag. i cleaned the hoses now it's not sucking anything up.

If the motor is running you should get some kind of sucktion, if no sucktion or wont blow any air out, check the house making sure is clear of any obtruction, the best way is looking in the house by have one person hold one end and other pull the hou ... Vacuums

No suction, clean bag and new belt,good brush

... Eureka Sanitaire SC4570 Bagged Upright Vacuum

I have an old hoover turbopower approx 1986 i think its a U1102, the prob is it doesnt pick up anymore and i wondered if it had some sort of filter on it, ive cleaned all the tubes put new bag on but its still got weak suction, could you make any suggestions, thanks

Theres a tube that come up and emty's into the bag that tube is clogged.take the bag out and get a coat hanger and put a bend in it so the end is round then work it down the tube to push out the clog ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1091 seconds