Having problems with your Hoover U5507900 Elite Rewind Bagless Upright Vacuum ?

When i use the power brush attachment, dust flies out of the hole that the hose attaches to... is there a way to prevent this or is it just how it works?


Answers :

This is the nature of this vacuum, the roller will always spin, when the vac is turned on. You can either cover wit tape or maybe find a sock to put in it (remember to remove sock) when putting hose back
Repair Help & Product Troubleshooting for Hoover U5507900 Elite Rewind Bagless Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

When i use the power brush attachment, dust flies out of the hole that the hose attaches to... is there a way to prevent this or is it just how it works?


This is the nature of this vacuum, the roller will always spin, when the vac is turned on. You can either cover wit tape or maybe find a sock to put in it (remember to remove sock) when putting hose back ... Hoover U5507900 Elite Rewind Bagless Upright Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.


Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

I have the Eureka The Boss Power PLus Model # 4703 Type A. When using the detached hose and wand it works OK; however, when using the Vacuum with the hose attached it doesn't work well at all.


... Vacuums

My Kirby shampooer - G4 - hardly used any water from the tank and no suds at all. Pet hair did blow out of the small slotted holes in the tray as I moved the shampooer back and forth, but the carpet was basically dry. I did vacuum before shampooing, so the brush part seemed to work great during shampooing, but no water! The small screen was stuck in the crook of the hose that attached to the tank so I did get that out and put it on the small hole on the tank, but it didn't make any difference. I


Few things:Make sure the sponge and the valve under the sponge (water tank) is clean.Make sure you follow the instructions (f you do not have the manual you can find one ... Kirby Ultimate G Bagged Upright Vacuum

My Windsor Sensor XP12 says the bag is full when it's not. I have removed the hose, brush, and filter and cleaned everything. I can put a bag on without the cover and it works great. However, when I add the bag to the front cover and close the latch the right way, it does not work. I'm thinking that the cover is not seating the bag correctly over the hole, but I can't figure out how to fix it. Any suggestions?


... Windsor SR12 Sensor Bagged Upright Vacuum

The power brush floor rug attachment on my Eureka 6997 A Oxygen Canister Vacuum goes on an off as I use it. I replaced the The power cord from the handle has 2 plug in connections: 1 at the handle / upper wand 1 at the lower wand top of the power brush attachment I replaced the entire wand assembly and it worked great for a year or so and now it's doing the same thing again. I was told to keep the power switch on the handle set to off when connecting the power brush attachment or it will bu


This is from the prongs not making a good connection causing an arch inside the plugg causing what looks like rust on the plugg. I would try snugging up the connection by squeezing the female section to get a better connection on the prongs when it i ... Vacuums

Power head attachment works great when plugged into the hose part of the vacuum. The problem is when I attach it to the tube for normal use there is no power. I have checked all the connections and switched the power switch on and off still no power from tube to power head. Is there anything else I can try? Model Callisto


Try having someone turn the machine on and off while you pull the cord in and out with the cord more angled towards the on/off switch. Sometimes these models have a break in the cord rewind and will not put the power through to the motor. ... Miele Vacuums

I have a Kirby Generation 3 that will not power on with the Carpet Brush attachement BUT will power on with the hose attachment. Please advise. Thanks


Make sure everything is lined up and and bag is fully attached. If it does not work after that, you could have a defective safety switch. Take it you an Authorized Kirby Dealer. Don't pay more than $40 for this repair. ... Kirby Generation 3 Bagged Upright Vacuum

Brushes We have A Proheat Select X2. Brand new, using for the first time, heater works, liquid dispenser works, Power brushes on machine and on extension attachment do not turn. Any thoughts? Thanks gigi2244


If the floor brushes don't turn, there is a motor for that and it maybe bad, On the attchment, vacuum is what turns those brushes, On the tank there is a knob to turn for the floor or hose, is it turned for the right application? other then that, y ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

Have a canister model Lux5500-ser#F35365B and power nozzle number N115Q-problem: The power nozzel does not stay completely connected to the hose-there seems to be some slipage where the hose connects to the nozzel-preventing a solid connection and the unit from working properly. I tried to tighten the connections on the nozzel, but this has not helped


... Electrolux Guardian Bagged Canister Vacuum

HOOVER STEAMVAC Model# F5842-9RM 120v 12 amp Carpet Cleanerworks well. Hooked up upholstrey attachment, used it. Reassembled to standard operation, the aggitator brushes do not work. I dis assembled brush insert verything good. ran cleaner and the square hole that the bushes insert into did not rotate with cleaner on. turned off lightly tried to turn mechinism in machine no luck. Reassembled aganin, reinserted cleaning tool, then disconnected it. agitator still doesn't work. toggled switch


... Hoover Vacuums

Bissell Healthy Home Vacuum brush stopped working. The hose attachment works fine, just the brush on bottom. Without taking it completely apart, it shows no sign of blockage. Any suggestions? Or, will I have to take it apart?


You will have to remove the bottom plate to get at the brush. The drive belt either slipped off or broke, this will have to be replaced. ... Vacuums

The brush wouldn't work when the selector switch was in carpet mode. Took the power head apart and removed the motor. Everything o.k. in the power head. Checked and found that the neutural wire had pulled out of the connector, the connector was never crimped at the factory. What a day! Took 2 hours and a large pizza to get it done. Neutral wire was in the hose just below the handle. Reconnected the wire and crimped it, put everything back together. It works!!!!


Great. ... Kenmore Vacuums

Rented triumph 430 and cant figure out how to work the accessories. I have the vac hose and a smaller hose attached ro dispense solution. There appears to be no way to plug in the smaller clear hose. Was I supposed to get another length of hose to connect from fitting on accessory to machine?


Yes don. call the store where u rented and tell them. ... Vacuums

Where can I order the following parts for my 1952 KENMORE SEWING MACHINE MODEL #117583, SERIAL #48054: : #5107 carbon motor brush (2) #5110 motor brush spring (2) #5111 motor brush spring cap (2) String for starter control lever Pulleys, screw and nut washer to attach string control Best sewing machine ever and still working like new, and I want to keep it that way. Thanks.


... Vacuums

My bissell Proheat will not spray any liquid on the floor, the brushes are working properly, my attachment hoses all work properly, there is just no liquid coming out to clean the floors, any suggestions...?


... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

Our unit is 7024A Electrolux Oxygen 3 - it seems to work great but suddenly, the head or 'power brush' or whatever it is called - has died. I checked by removing the hose and plugging it directly into the body, but it is still dead. Without that motorized head working, the vacuum is useless. Is it worth replacing? The unit is only about 1 year old and has seen light use only. Very frustrating, since it was the most expensive unit in the store:(


... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

My carpet cleaning brush does not turn on. The vacuum cleaner works fine but the the carpet cleaning attachment does not get any power so the light does not come on & the brush does not spin


... Kenmore 25512/ 25513 Progressive Canister Vacuum

The Delta power head is not working. Brush is not turning.


... Electrolux EL6989A Bagged Canister Vacuum

Clogged hose A makeup brush (about 3.5 inches long) was sucked up through the vacuum hose. It won't come back through the same way it came in because the bristles in the brush are expanded. We can see the brush on the side of the hose that connects to the canister but can't get it around the bend of the 360 part of the hose... is there any way to take the hose apart more?


... Kenmore 25512/ 25513 Progressive Canister Vacuum

Water leak I just bought this steamer a few days ago, and already I am having problems, when I fill the water tank that your suppost to fill the water runs out before I even turn the machine on. I have tried using plugs to keep it from doing this just so I can shampoo my carpet, this seems to work to a point, considering the fact that there are two holes underneath close to the brushes and one just a little ways back from that location. Do you know if this is something that should have plugs or


If you just pruchased this, then it is under warranty, take it along with proof of purchase to a warranty repair shop and have them fix it. If water just runs out, then there may be a seal missing or a water line off. ... Eureka Atlantis 2595A Upright Wet/Dry Vacuum

My Bissell Pro Heat Pet will spray water but not pick it up when cleaning the carpet. Is there anything I can do to fix it? The furniture attachment hose picks up water well. It seems like it could be a bit more powerful of a draw on water. I don't know it that has something to do with why the floor cleaning sucktion doesn't work. Thank you for your time. Jenn


Normal\012 0\012 \012 \012 \012 \012 \012 \012 MicrosoftInternetExplorer4\012 \012\012\012\012\012\012 /* Style Definitions */\012 table.MsoNormalTable\012\011{mso-style-name:"Table Normal";\012\011mso-tstyle-rowband-size:0;\012\011mso-ts ... Bissell Vacuums

Electrolux Oxygen Upright 5035: Shut down after 5 minutes of normal cleaning with hose. Power to switch OK with Fluke Tester. Neither vacuum motor or the brush elevator works.(2 different switches)


Hi from uk may i suggest you try this ? recheck as you have done that although you have power to the switch ? you may not have the neutral wire feed back to the plug to complete the elec circuit have come across this problem many times and ... Electrolux Vacuums

My 8 yr old kenmore vacuum works well - however the hose has worn under the handle where there is a hole (resulting in decreased suction power). I'd like instructions on opening the handle and bypassing the worn piece of tubing rather than replacing it for $129. Some of the handle screws remove easily but the last one doesn't loosen easily.


Hi,Have you tried spraying the stubborn screw with WD40 and let it soaked for a while? Other than these screws holding the handle together, there would no other way of opening it up. Hope this be of initial help/idea. ... Kenmore Vacuums

I have an Easy-Flo central vac unit. The handle on the electric hose has a switch on the handle. With the switch on ''O'' in the center, it's off. On the left, is the ''I'' position. The vacuum runs but the power brush doesn't. On the right is the ''II'' position. The switch won't flip that way. It feels stuck. It feels as if there is something underneath of it that won't let it push that direction. I have the switch out of the handle, but I can't seem to get the actual black casing around the


Switches are not usually designed to be dissembled.I would strongly suggest that you dont take the switch apart. you are better off getting a new one. then if you feel like it you can take the old switch apart and if it dosnt work you still hav ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1053 seconds