Having problems with your Hoover U5753-900 WindTunnel Bagless Upright Vacuum ?

Vacuum no longer picks up. you can still hear suction. what could be the problem?


Answers :

It sounds like a seal has dislodged, which is common when cleaning out or emptying dust trap, double check all seals and make sure compartments are fitted back together correctly.
Repair Help & Product Troubleshooting for Hoover U5753-900 WindTunnel Bagless Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Vacuum no longer picks up. you can still hear suction. what could be the problem?


It sounds like a seal has dislodged, which is common when cleaning out or emptying dust trap, double check all seals and make sure compartments are fitted back together correctly. ... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

My Model number 11635923502 kenmore vacuum is making a deep suctioning noise as if something is stuck in it. We have cleaned out the filters and all the vacuum lines thinking it was clogged. It is still making this noise and we are frustrated as to what could be causing this problem. The unit does not have much suction.


... Kenmore Progressive Upright Vacuum with InteliClean System Slate Blue

** suction The best way to describe it is that when I was vacuuming I could see dust clouds at the front of the vacuum where the light is swirling around in the air. It was like it was blowing dust around instead of picking it up. I checked the tubing and found that it was clogged with some paper and hair ***** etc.... So I cleaned it out and tried it again and it still was not picking up properly. I had my husband take all the tubing apart to check for other clogging and there was none. When I


You have an airflow problem. You may still have a blocked intake or tube, also check the filter. The air is supposed to go in the bottom (of course) and I'm sure you k**w where it goes out. You probably can **te a reduction in exhaust. If this is ... Oreck XL Ultra Bagged Upright Vacuum

No suction i have a bissell lift off revolution vacuum. I have cleaned all the filters and emptied out the canister made sure that the hoses are not plugged but it will not pick up unless you use the hose. the floor brush is clean and still no suction coming from under the vacuum... could you help me please


Is there a blockage in the small hose in the bottom of the machine \015\012take of the pod and you will see the small hose, \015\012Is the main hose pushed into the bottom housing ... Bissell 37603 Upright Vacuum

The vacuum does not have suction from the beater bar. The wand has good suction and the belt is still in place on the bar. There are no apparent clogs. What could be the problem


... Dyson DC07 Bagless Upright Cyclonic Vacuum

I have a DC14. About a wk ago it was making loud sound and bar stopped turning. i unclogged everything....now the suction works great. However, the bar still wont turn. The belt inside is still intact and isnt loose. Several solutions suggested resetting the "Red" button...i have searched the vacuum over and over. there is NO red or any other color reset button. The bar is set down perfectly in there, the cover plate is installed properly. What other problems could there be? Or do i just need to


... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

I've had my Dyson DC14 vacuum cleaner now for approximately 9 months and been very happy with my purchase. However, It is used sparingly maybe twice a week at the very most. The problem is when I try to use the item on my carpet, you have to push really hard to get it to move. It's as though the suction power is far to strong. It certainly doesn't glide as I think it should. It still picks up as usual but I cannot imagine that having to 'force' the machine to move is the normal operating procedu


Thanks for your question!I'm sorry that you haven't received an answer yet.The response rate on FixYa FREE questions is usually over 80%, but sometimes questions go un-answered when:1. the question is unclear, incomplete, or poorly ... Dyson DC14 All floors Bagless Upright Cyclonic Vacuum

No suction i have a hoover supreme wind tunnel vac and its relatively new and the suction, well......sucks. It wont pick anything up! I am extremely frustrated! I picked up a ball of fuzz off the carpet and held it under the vacuum and it still wouldn't **** it up. I then shoved the fuzz up INTO the vacuum. It fell right back out. I may as well not even vacuum. Please help!


I have found more vacuums on the way to the dump because they were full. Check. Is it full?\015\012If not the air way is clogged. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I have a Kenmore canister vacuum - model 25614506. Some time ago, I was not able to turn the vacuum off with the on/off switch, but could still use the vacuum. Turned if off/on by pulling the plug. The other day when I went to plug it in, I heard a pop. Now the sweeper runs but the vacuum cleaner does not **** - no air flow. What could be the problem. The cleaner is only 4 years old.


The motor has an inline fuse ... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

It has no suction. It was fine yesterday. I washed the dirt container and the filter, let it dry and put it back in the vacuum. Today my vacuum isnt picking up any dirt and has no suction. When I took the hose out of the back, it started blowing dust and dirt out but still no suction.


Look for a place where the vacuum line has to turn in a near 90 degree turn. It's easy for it to get stopped up there. ... Vacuums

Poor suction I have a hoover hush s5627 vacuum purchased about 4 years ago from Costco. It's suction power isn't so good anymore. I've checked all the lines & hoses and they're clear and I've changed the bag. I even disconnected the pipe from the vacuum unit and held my hand over the intake. While the machine roars like a jet engine the suction power just ain't like it used to be. What could possibly be the problem?


This vaccuum has a Fan Blade inside connected to the motor that spins to create the suction you feel. After a few years of use (and misuse) the blades on this (plastic) fan will be broken off, thus damaging the unit. These Fans are replaceable if yo ... Vacuums

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

My Dyson Animal has good suction and works fine for actually picking up dirt, but when I use the vacuum with the roller, I hear a grinding/rumbling noise. Its only when I use the vacuum with the brush rotating. It does not happen hen I shut the roller brush off. The belt is fine. I cannot figure out what is wrong as there are no clogs, debris, or foreign objects stuck in the brush or in the belt. The noise seems to be the only issue. The vacuum picks up fine. It just doesn't sound right a


Trace the path of the suction into the tank and see if there is anything loose or ingested.\015\012Also, remove the brush and clean as best you can. Perhaps there is something caught in it. Lubricate where it makes sense with some WD40. ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Suction Problem I was vacuuming and stopped to empty the cannister. When I started vacuuming again - the suction wasn't working properly. The vacuum was just pushing stuff around the floor. I cleaned the hair out the brush on the bottom and it still isn't working. It was working fine before I emptied the tube :( I can't figure out what happened.Help!


Greetings from GoVacuum,\015\012\015\012I believe what may have happened is that your vacuum cleaner belt has either broken, or been stretched so far that ithe brushes are no longer spinning fast enough. \015\012\015\012Here' ... Vacuums

I HAVE A FANTOM VACUUM CLEANER MOD.#F1205400. I PURCHASED IT ABOUT 6 OR SO YEARS AGO.IT WORKS PERFECT,AS FAR AS SUCTION, THE ONLY PROBLEM IS ABOUT 2 MONTHS AGO,SOMETHING HAPPENED TO IT AND IT GOT VERY LOUD, KIND OF LIKE A CAR WITHOUT MUFFLER. I TOOK IT APART,AND FOUND NOTHING OBVIOUS. CAN YOU GIVE ME SOME IDEA OF WHAT I CAN CHECK TO RESOLVE THIS PROBLEM. AS I SAID BEFORE IT STILL VACUUMS GREAT. THANK YOU, VINCE


You probably have a bad motor bearing. I don't know if the motor is available now or, these older Fantom's are obsolete along with most of their parts. ... Vacuums

Low suction Have a Powr-Flite PF 18, suction is good at motor, but low at where hose comes out of top of vacuum. Could new lid seals help the problem? Where can I get new seals for this model. Also my zip is 98801 and my shop is not listed, could you add it please? Sew Creative 1139 N. Princeton Wenatchee, Wa 98801 509-663-5516 Thanks, Lauren-Sew Creative


Replacing the motor cover solved the problem, it must have been warped and was letting suction out thru it. ... Vacuums

I have a power drive baggless vacuum cleaner...it runs well, but suddenly it seems to have lost most of the suction coming through the hose and floor area. When I remove the dirt container, the suction below it seems strong. I have had it to repair twice--they have tuned it up and replaced all filters and belt. It still does not pick up well when I vacuum or use the hose. Can you help ?


There is something stopping it up,you will have to dissasemble the unit to find the blockage,this is the most likely problem. ... Hoover U6660-900 WindTunnel Bagless Upright Vacuum

My filter queen just had the motor rebuilt last year and was basically a brand new unit when I got it back. It is not picking anything up now when I vacuum. The beater bar on the carpet attachment is turning fine and when I take all the attachments off the hose I can feel the suction being created like it should be picking up debris just fine. I have emptied the canister even when it did not have much in it; however, it still will not pick anything up off the carpet. It picks up debris tempo


It sounds as if you have a clog inside the "Power Nozzel". They mention that there are "no user serviceable parts within the Majestic® Power Nozzle" My advice would be to see if you can see a clog with in reachable distance and try to remove the ... Filter Queen Vacuums

Suction hose I can't get the suction hose to work...and I have cleaned it out to make sure it isn't plugged. There is a small amount of suction just not enought to pick anything up.....the floor part works great...what could be the problem


I would first double check the hose, remove it and drop a marble through it to be sure. make sure the bag is new and also check the filter underneath the bag if it is clogged it could cut the suction. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Low suction I have a Hoover central vacuum system. I've reset the fuse box, checked the fuses, all of the lines are clear and there are no holes for escaped air to travel out. The filter has been cleaned as well. The vac works well with high suction when hooked directly to the unit, however when using any of the indoor connections there is extremely low suction. The machine still turns on so I do not believe it is an electronic issue. I have troubleshooted the issue as best I could and would


... Hoover L2310 GUV Central System Vacuum

My eureka vacuum was fine but then suddenly got loud. We cleaned the filters and replaced the belts, but it is still loud. We have not seen any clogs in the tubing or in the vacuum. What other problems could the vacuum have to make it loud?


The noise could be coming from the Beater Bar's ball bearings. ... Vacuums

No suction whether I'm using the tools or using the vacuum upright, there is no suction. I have checked the hose to make it is not clogged- still no suction. What is the problem?


Your intake hose might be clogged at the bottom ,it the clear hose that comes up from the bottom .you will see it from the back.take the dirt cup off there is a filter inside that most likely is clogged ... Dirt Devil M086700 Vision Bagless Upright Vacuum

Blue Moon S658 Miele vacuum problem where suction cuts off. The power light stays on. Sometimes I lose full suction, and other times I just lose partial suction. This shows on the handle by going from 1000 to 400, or nothing. Any thoughts on what this could be?


This is a problem with the circuit board in the SES-125 hose. If you replace the hose, this problem will stop. Unfortunately this is the only solution to this problem. \015\012\015\012-R ... Miele Blue Moon Bagged Canister Vacuum

No suction vacuum working fine and suddenly, no suction at all....what could be the problem? no suction through the machine from either the wand or the floor/brush side


Sucked up a sock?? No seriously.. it may be as simple as that or that an on board filter is clogged. Check your manual for all filters and Hepa/screens and others. Also, is the unit making any odd noises since the non -suction scenario? Whining or s ... Dyson DC14 All floors Bagless Upright Cyclonic Vacuum

We have a Bissell Power Clean vacuum, Model# 92L3P. A few days ago the vacuum started revving extremely high. We still have suction, but the RPMs sound like they're through the roof. At first the problem was sporadic, but now it's consistent every time the vacuum is turned on.


... Bissell Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1410 seconds