Having problems with your Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum ?

Sparks fly from bottom of vacuum when plugged into outlet.


Answers :

Repair Help & Product Troubleshooting for Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Sparks fly from bottom of vacuum when plugged into outlet.


... Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum

The last time the vacuum cleaner was used the outlet sparked causing it to smoke when turning on vacuum cleaner. I replaced the outlet and plugged it in and things seemed o.k. Today I turned on the vacuum, it stayed on for a mili second and went off. I checked the switch on the vacuum and it showed voltage coming and going, but would not turn on again. I checked all the wires in the area of the switch all seemed o.k. I thought maybe there might be a short in the cord. When I went to plug


... Sharp Twin Energy EC-12TWT4 Bagged Upright Vacuum

Plugged in my vacuum and the outlet sparked


... Envirocare Hoover Windtunnel, Twin Chamber Bagless Vacuum Filter

The Oreck vacuum motor sparks the stop running. Plugged to another outlet, the motor did the same things, run for few seconds with sparks and stopped again.


... Oreck XL2200 Bagged Upright Vacuum

Dyson DC23 Vacuum shut off and came on. Thought it was a problem at the electrical outlet as when moving plug it would come on again. Seen canister was full, emptied it and cyclone was quite plugged up so poked out the dirt. Had dog hairs in it as well as some ashes I had just vacuumed. Plugged unit in again and pressed switch. Will not come on. Tried another outlet. Is there a reset button somewhere or could the ashes have seized the motor. What can I try besides taking it to a repair sho


... Dyson DC23 Bagless Canister Cyclonic Vacuum

Miele Champagne Vacuum Cleaner Model S548 I was using the vacuum as normal, moved locations so I plugged into another outlet & suddenly there was no power to the vacuum! I tried it in several other outlets, tried the reset button... & still no power to the vacuum. Any ideas what could be causing this? Any info would be greatly appreciated. Thank you!


Greetings from ,\015\012 \015\012This definitely sound like a cord reel issue to me. This is really the only problem that I ever see on a Miele vacuum cleaner. 9 times out of 10 the cord reel needs to be changed. If you purcha ... Miele Blue Moon Bagged Canister Vacuum

This Model likes to shoot electrical sparks between the plug and wall outlet when plugging in. I'm afraid I'm going to burn out an outlet.


This sounds might hazardous! Worry less about burning out an outlet, and more about the risk of electrocuting yourself!\015\012\015\012There's an electrical short-circuit somewhere, and the first place to look is the flex. Flex often gets damag ... Hoover U8311900 WindTunnel 2 Vacuum

After I run my vacuum for a couple of minutes it shuts off. If I unplug the vacuum and plug it into a different outlet most of the time it will start working again.


I would say check inside the plug and make sure the connections are tight. If the vacume runs fine on the other socket outlet then it will bw a faulty socket which cuts your hoover out. Can buy a new socket frount from diy stores for about 2-3 pounds ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Plugged vacuum hose behind beater brush plugged. no slide lock to open bottom panel


... Fantom Vacums Vacuums

I plugged in my kirby G4 and when i turned it on there was a loud popping sound and sparks came out from the back of the vacuum. Does this mean the motor blew and the vacuum is garbage now?


Oh,I would say so.Does it run at all now,or just shut off completely?If you turn it on,do you get any kind of smell? ... Kirby G4 Bagged Upright Vacuum

Dead motor? My 8 year old Miele S251i has worked fine, until I was recently vacuuming and moved the plug from one outlet to another. When I restarted the vacuum, it made rrrrr.....rrrrrr....rrrrr noises and smelled like something was burning. I turned it off, and it's shown no signs of life since. Sound like a motor problem? I've taken the cover off and looked at the cord and seen the motor, nothing looks obviously wrong, but I'm also not mechanical.


... Miele S251 Flamenco II Bagged Canister Vacuum

I have only used this mop a few times because everytime I go to plug it in the outlet, there are sparks. I have tried three different outlets. Is there a recall on this??


Hi,No, but hopefully you are in warranty...1 year...Here is a tip that I wrote about the Euro-Pro Shark Steam Mop and why it maynot be getting steam to the head... ... Euro-Pro Shark Steam Mop - Gray/ Purple Vacuum

I was vacuuming and all of a sudden the vacuum went off. I thought maybe I unplugged it on accident but it was still plugged in and the outlet is working. I cleaned all the filters and everything looks fine, do you know what it could be? We have only had it for 2 months.


There is a reset button on a lot of the kenmore vacuums, find that and press it - on mine is on the exterior of the machine on the head above the brushroll ... Vacuums

My Sanitaire Commercial vacuum SC5815 A-2 does not turn on. It is quite new and seems to be "totally dead." Serial number: 0632005978 It is firmly plugged in, I have tried numerous electrical outlets, and I have tried the on-off switch numerous times. I wonder if there is a simple circuit breaker switch somewhere on the vacuum that I could switch without going to a repair shop? Or, I wonder if some latch is loose that shuts off the current, but I have checked the latches and they are clo


... Electrolux Sanitaire True HEPA Upright Commercial Vacuum Red EUKSC5713A

Have a 2yr old Broan VX6000C built in vacuum. Has power when plugged in I have disconnected unit from the wall and the wires to the outlets are also disconnected and the power unit still runs as soon as it is plugged in???


... Broan-NuTone Vacuums

My Hoover Pet Cyclonic upright stopped working while I was using it. The bottom felt really hot so I emptied the canister & laid the vacuum down with the bottom in the air to cool off & went back in an hour or so, I even tried a different plug in but it still won't turn back on. I don't know what else to try.


This just happened to me. Any solutions or insights? I need to know asap. ... Dirt Devil Hoover Uh70085 Pet Cyclonic? Upright Vacuum

I have a central vacuum system. When I disconnect the hose from a wall outlet the central canister does not shut down dispite my turning off the vacuum at the handle of the hose. The only way I can get the system to shut down is to pull the plug at the canister. What gives? Rob


What I'm hearing is the canister(Not the Powerhead) portion of the unit is running all the time unless you unplug it. this problem could be caused by a short in one of your low voltage lines running through the house. To determine that just unplug on ... Vacuums

While I was vacuuming it stopped. It's still plugged in and the outlet is good (other things work plugged in it). It's not clogged and it won't turn back on.


If it isnt a blown fuse in the plug, then this could be a faulty cable or switch, but could also be a faulty motor.The motor also has a built in over-current protection device which normally automatically resets itself, but if the motor h ... Dyson DC07 Bagless Upright Cyclonic Vacuum

We just were vacuuming and it stopped as if we blew a fuse. I checked the breaker and it is on and plugged something else in the outlet with no problem but the vacuum won't turn on. Any suggestions?


You said you checked the main breaker but did you change the fuse in the plug ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

My electrolux canister oygen vacuum cleaner will not turn on when plugged in. it quit working when I disconnected the hose while running? It does not have power when plugged in to the electrical outlet


This is often caused by a failure of a fuse on the Sumo board, or\015\012occasionally by a failure of the cord reel. Here are some instructions on how to check these things as a\015\012response to a different thread, but I will repost them here: ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

When plugged into electric outlet(checked power OK) the indicator icon on the top of the vacuum is not lit and the vacuum will not operate?


If the power indicator is not working, and your outlet is okay, then the problem is going to be in the cord or wiring. Carefully check the visible portion of the cord. If there are any cuts, or insulation scraped away, take the machine to an author ... Electrolux Epic 6500 Vacuum

My Kenmore Progressive canister vacuum cleaner no. 116 20712008 will ot start. I plugged it in different outlets with not success. What I sould do? Adam


Check fuse ... Vacuums

We have a dirt devil cylinder vacuum cleaner with bag and when we plugged it in tonight it made a loud noise and a horrible smell came out of it. We could also see some blue sparks inside it. I was wondering of you could help?


Http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=830037\015\012Generic problem for all Vacuums\015\012We have a dirt devil\015\012Posted by smilingreb o ... Vacuums

We have a 2001 Kirby G vacuum. The cleaning lady was using it in one room, then brought it to another room and plugged it into another receptacle. It wouldn't start. Naturally we tried other outlets on other circuits without success. Is a switch or motor demise this abrupt? Is it worth pursuing repair?


Hi,Such an abrupt fault is more than likely a very simple fault, such as a loose wire or damaged electrical cord or a faulty switch. I would most certainly check or have these components checked before purchasing a new machine. They should be r ... Vacuums

I have a Kenmore DuraPower Dual Cyclone Action 12 Amp that just randomly stopped right in the middle of vacuuming. I assumed the plug had come out of the wall so I went to check and this wasn't the issue. I tried multiple outlets and that wasn't the issue. I made sure nothing was stuck and there is nothing stuck. Nothing happens when I press the red "ON" button. What could this be? Thanks!


... Kenmore Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0758 seconds