Having problems with your Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum ?

Self propelled model. when plugged in vac won't start, dead no lights, no sounds


Answers :

You may have a bad plug/cord. sometimes the transmission on the motor goes bad. any vac shop can fix it.
Repair Help & Product Troubleshooting for Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Self propelled model. when plugged in vac won't start, dead no lights, no sounds


You may have a bad plug/cord. sometimes the transmission on the motor goes bad. any vac shop can fix it. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Magic chef model #MCWC45A Serial # 0902mcwc45a09720. It is a bit over a year old. it just went dead. no compressor sound.No interior light. Unplugged it, and after a day plugged it back the the compressor started running. it ran for about an hr the it shut off. the cooler was cool inside. i noticed the compressor was hot to touch.


Hi, It sounds like the compressor is going bad, but you can try to change the start components and overload to make sure they aren't at fault......Check out these tips that I wrote about that... it is a great place to starttro ... Vacuums

I have a Kenmore Progressive upright model 216-37100800. It is only around 1.5 years old. My wife said that one day after she plugged it and turned it on, it whirred up but then shut off. Since then it will not start. I have noticed that right after I plug it in, if I try to turn it on, the first yellow light in the series of dirt sensor lights turns on then shuts off. After that the light will not light up on pressing the power button, unless I unplug it and plug it back in again. I have seen o


... Kenmore 25512/ 25513 Progressive Canister Vacuum

My Shark steam cleaner S3325 wont start. Only used it 2 times. when plugged in the start light should come on and go off when the ready light goes on. Instead the ready light goes on and there is no heat. Any suggestiins will be appreciated.Thank you, Mary A


... Euro-Pro S3325 Handheld Steam Vacuum

Kenmore canister model 116.25513506 wont turn on. when handle switch is turned to floor. vac motor does not turn on. When switch is turned to carpet, floor nozzle works but vac motor does not. I checked fuse, all o.k. checked continuity for plug, o.k. removed wires for bag full switch...motor wont run. I wired motor directly power cord...motor runs. Thinking it must be the circuit board, how do I bypass it or test it?


... Vacuums

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???


Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

I have a kenmore upright model 116.36933 vac. motor wont stop unless i pull th plug the buttons work on everything else but stopping the vac


... Vacuums

We have a zenith dehumidifier model ZD300 & the bucket full light keeps flashing. the percentage number wont go higher than 1%. we have turned it off/on & unplugged it. When we do this it will reset to 40% for about 2 seconds & then goes back to 1% & the bucket full light starts flashing again. The bucket is empty & we have cleaned the filter. We have only had this dehumidifier about 7 months. Please help us.


I've had the same issue with mine. I am a 12 year refrigeration tech. I checked the float switch which would normally cause that indication light. However manually pushing the switch and then checking it with an electric meter that was not the case. ... Vacuums

We have an Eureka The Boss Central Vac Model ACV2001B. When you plug in the vac the motor starts momentarily and then stops. What could be the problem? Thank you.


Most likely there is a short in the low voltage wiring in the hose. ... Vacuums

My hoover, self propelled windtunnel ,on off switch will not shutoff. the second the electrical plug is put in the wall socket, the vacum starts running and you cannot shut it down with the on off switch


... Hoover Vacuums

Good Morning, A friend recently gave me her Hoover windtunnel model U630-900 vacuum. It is a self propelled vac. It comes on but is hard to push and will not really pick up any dust particles on the carpet. It has a funny smell also. I saw where one of you Q & A you said to check the roller brush. I thought maybe a belt may be off or something, but I do not have a manual to know where to begin checking. Could you tell what to check and also if there is anywhere online to download the manua


... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

Hoover vac 6432-900 reverse cable broke this model # is correct about 12 years old wind tunnel bagged self propelled


The quick and easy here is to just splice the cable and tape it. If you just cut the insulation back to get to the wire and get a couple 'barrel connector' at the hardware store. These are crimp style connectors and you need a small crimper to put th ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Self propelled vac: goes great on hard floor or hard slick carpet. Goes backwards fine but will not pull itself forward very well. Requires some effor to push it forward. I have adjusted the cable so the lever on the motor goes as far forward as possible. Suggestions? Model U6446-900


Dear Nasherrill,\015\012\015\012I've found a friend! I thought I was the only person in the world who owned the Hoover Model U6446-900! This model does not appear on the http ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Belts I have a Hoover self-propelled windtunnel, purchased 6-04. It gets light use. I have replaced the v belt 3 times, once under warranty, and it must be replaced again. It appears to be in very good condition, but is stretched too big. When I purchased 2 v belts a year ago, one was already too stretched,but when my Dad took it back, the salesman put it on another model and said it was fine (Dad never mentioned this to me). Is there a way to adjust the vacuum to hold the belt tighter? Do t


It is the flat belt that gets stretched and should be replaced at least every 6 months. The V belt wears down so it won't it right in the brush roll V. Maybe the belt tensioner wheel has a problem, sometimes they get hook up and won't engage the V ... Vacuums

Bissell model 3575 vac won't run, when I turned the switch to on it tried to start, and now won't. The light turns on. Is there a fuse or reset button??


... Bissell 3575 CleanView Upright Vacuum

I have a Hoover self-propelled windtunnel, purchased 6-04. It gets light use. I have replaced the v belt 3 times, once under warranty, and it must be replaced again. It appears to be in very good condition, but is stretched too big. When I purchased 2 v belts a year ago, one was already too stretched,but when my Dad took it back, the salesman put it on another model and said it was fine (Dad never mentioned this to me). Is there a way to adjust the vacuum to hold the belt tighter? Do they re


Http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=675093\015\012Generic problem for all Vacuums\015\012I have a Hoover self-propelled\015\012Posted by kl ... Vacuums

I have Hoover Windtunnel Vac Model U5421-9RM. It is DEAD. I plugged it in and nothing is happening. Is there a reset button (and if so, where) or a fuse (if so, where)? AND what other options or trubleshooting areas should I try?


Pls call me at 1 866 416 7408\015\012thx\015\012chris ... Hoover Vacuums

Miele s4210 carina bagged vac,wont start,tried fuse in plug,ok,no click on switch ,should there be a click?


... Miele S4210 Carina Bagged Canister Vacuum

Dirt Devil Quick Power hand vac model 0896 won't charge. Red light doesn't go on when plugged into wall. We've lost our manual, need help troubleshooting.


... Dirt Devil M0896 Quick Power Bagless Handheld Vacuum

I have an Electrolux compact power 1500 hoover which wont work at the moment, when i plug it in and switch it on the green bulb lights up but no sound or suction. any ideas??


... Electrolux Compact Canister Vacuum Powerhead Belt

Motor just makes 4 or 5 small clicking noises when you pull the trigger, then stops. The little lights illumintae around the "max" button as well. However, the motor does not engage in the slightest. There is no blockage at all. I have owned the vac for 10 months and know the sounds of blockage and clear them immediately. I just used it in the morning, plugged it back in and it has not worked since. Any ideas?


... Dyson DC35 Handheld Vacuum

I have a Hoover WindTunnel, Self-propelled model, and it was working great until I ran over a portion of the cord, then it started making a bad noise and I noticed the roller is not moving consistently...I suspect I may have stetched the V-Belt...do you think so?


The V belt usually wears down first. Remove the roller and belt to visually check for wear and belt material in the roller pulley. I would change the flat belt as well. Also, replace the cord if any wires are exposed ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Question mark light has come on my vacuum and it wont run. I replaced the bag, but it wont start. I don't have a new filter is that the problem?


... Electrolux Vacuums

Hoover 6485-900 self propelled will not roll. Self propel switch seems flimsy and I can't tell if it's working. New vac used about five times. I can see a wire moving down near the rollers when I engage the self propel but the wheels don't turn. Thanks for any assistance you can provide.


... Vacuums

Shop-vac model 90L550A motor wont run


Yes replacing the link would work, but that would not fix the cause. You have either pulled the wiring to the point of pulling apart the connection or there is a short. Which would be in the way of a grounding effect causing the link to heat and melt ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0911 seconds