Having problems with your Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum ?

Hoover windtunnel dirt finder light stays red. We've cleaned the elbow the roller the hose and have a clean bag. The vacuum is new only had it for 3 months.

Answers :

I'm not sure about a 3 month old vac, I'd probably go the warranty route. However, for the older vacs thy start getting false positives. The sensor is simply a microphone hooked to a computer chip detecting sounds of dirt entering the bag.
\015\012To rig it to start working, you'll need to remove the tool accessory tray and elbow that enters the back of the vac, and attached to the bag. This will reveal the microphone at the elbow, and wire that runs into the bottom area of the vac. When on, a large amount of air comes from the bottom screw and area where the wires enter. My fix was to clean up the microphone contact points a little bit with a screwdriver, and then leave the vac running while putting in dampering in the hole at the bottom, and around the back of the elbow. Cotton balls and electrical tape at the bottom hole, and napkins around the outside of the elbow (wedged between the back of the vac assembly and elbow did the trick). The schematic for the vac is here: http<colon>//www<dot>vacsrus<dot>com/CartGenie/pg_U6485900<dot>asp
Look for micrphone.
Repair Help & Product Troubleshooting for Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Hoover windtunnel dirt finder light stays red. We've cleaned the elbow the roller the hose and have a clean bag. The vacuum is new only had it for 3 months.

I'm not sure about a 3 month old vac, I'd probably go the warranty route. However, for the older vacs thy start getting false positives. The sensor is simply a microphone hooked to a computer chip detecting sounds of dirt entering the bag. \ ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Unbeknownst to me, someone took the bag out of my Kenmore Progressive vacuum and failed to replace it. I have been vacuuming without a bag for months, and today the vacuum stopped sucking. When I opened up the front to replace the bag, tons of dirt and dust came pouring out. I thoroughly cleaned the vacuum, put in a new bag, but still no sucking power. Just dust coming from the rear vents where one of the filters is. Is the vacuum ruined, or is it a simple solution of buying a new filter?

Sounds like you need to buy a new motor. All that grit and dust will ruin a motor and I'm surprised it lasted as long as it did.\015\012This is where a vacuum that won't run without a bag would have been nice. (Aerus for one) ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

Bought a Kenmore Progressive canister vacuum at a garage sale that looked in better than average condition, filters clean, new bag, all accessories intact, some debris in roller brush. problem is no suction when turned on. There does not appear to be any obstruction in hose. did not have manual

Hello,Carnister vacuum cleaners are all built with the same principle in mind. A motor \015\012generates power which powers a vacuum which, in turn, creates suction to\015\012 lift debris. The most common areas of suction loss are within ... Kenmore 25512/ 25513 Progressive Canister Vacuum

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

Hoover tempo upright is clogged. I can only vac for a few minutes, then I have to unplug it and turn it over and clean out the under part under the roller. It is totally stuffed with dirt and dust and carpet fibers. I have a new bag in. It is like it is clogged up inbetween the bag and the roller. Also gets clogged when using the hose. It is maybe a year old. How can I take it apart and unclog it?

Disconnect the hose and head and wands. Drop a quarter thru the hose, the handle sometimes clogs. peer thru the wands and inspect the elbow on the head for blockage as well ... Vacuums

Hover Elite Rewind I've only had this vacuum a few months and I really liked it until now. There is almost no suction from anywhere in the vacuum, and I've cleaned all the filters and rollers with my shop vac and made sure that everything was assembled correctly. It used to be really quiet now it is quite loud and it keeps over heating, and shutting off. At this point I have no idea what could cause this problem, the machine is nearly brand new and I can't afford a new one at this point.

You have to clean out the hose under the bottom of the vacuum cleaner. To do this you have to remove the bottom plate the covers the brush it has about 6 screws. Also remove the brush and belt in order to thourhly clean it. I had the same issue you h ... Vacuums

The red light comes on when the bag is not full (in fact I put in a new one). When the hose is removed, the light goes off. How do I clean the small hose that leads to the bottom of the vacuum and the main hose?

If it has a clog caused by a hair ball or some other object, a "properly bent" coat hanger can be used to fish it out. ... Vacuums

I have 2 Hoover Wind Tunnel-self propelled bagged vacuums-U6433-900 model.The roller bar does not agitate, the self propelled feature does not work and, in general, the vacuum is not performing well. I have replaced the roller bar, the v belt and the wide belt. The filters have been replaced and it has a new bag. I have had both of these since 2004 and they were fairly expensive $200 each) but if the repairs are prohibitive, I might as well get new vacuums. Suggestions? I just spent $100 for bel

The Hoover WindTunnel self propelled is a machine that we see in our retail stores (Vacuums Unlimited) constantly. The benefit of having a supposed "self-propelled" machine wears of quickly after the numerous time you will need to take this machine ... Hoover Vacuums

Vacuum won't pick up. hose is not clogged. new bag. roller turns.

Change the belt/s. It does not have to be broken to not function properly. ... Vacuums

Eureka victory upright has no suction.has new bag and hoses are clear. Filters are clean,brush roller works fine.

... Kenmore Vacuums

Vacuum trips off as soon as started: new bag, free roller, clean filter.

How old is the unit? ... Eureka Smartvac 4870 Bagged Upright Vacuum

I was vacuuming my room and all of a sudden I hear this loud noise, then notice the roller brush isn't spinning. Thinking too much hair was caught I separated it from the rod and hose to clean it out, but noticed that the roller brush didn't move at all while I was cleaning it. I've cleaned the brush before and it would roll around with little effort, but this time I couldn't move it at all. After removing hair and string I put the vacuum back together and started it up, but the noise continued,

It sounds like if the rod is clean then there is debree inside the roller where the rod fits in too. ... Hoover Platinum Cyclonic Bagless Canister Vacuum With Power Nozzle

The hose is disconnected, new bag in unit, new filter, unit runs when hose is detached but immediately turns off when hose is attached but hose has no obstruction, etc.. i was told i need some sort of valve. HELP! I have birds, a cat and 2 large dogs and no vacuum :)

There is a vacuum hose that attaches inside the unit to a round clear plactic piece. In most cases you can simply cut the small vacuum hose and it will fix the problem. ... Electrolux Epic 3500 Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!

... Miele Vacuums

When I flip the switch on my sebo x1 upright, a red light comes to the brush and bag icons. However, I cleaned out the hose and checked to make sure there is no obstruction from the brush to the hose also, or from the hose to the bag. It is clear that juice is coming to the vacuum, but there is no sign of life except the two red lights.

Thanks for contacting fixya. You should pull out the bag and reset the machine. You should take all the user replaceable items. And turn it on. You will get lot of errors. Then turn the machine off. Put back all the accessor ... Sebo Automatic X1 Bagged Upright Vacuum


From the Argos website... they must repair or replace or refund, up to 1 year. The squeaky wheel gets the grease, go over her head.\015\012 \015\012If there's a fault with the product...\015\012We've made it easier!\015\012 ... Vacuums

Vacuum has new bag but won't pick up dirt. Cleaned flat filter and it made it worse. Do I need to replace rectangular filter or can I clean it. If so , how? If not, do I need to take it in for repair, ir should I get new parts? Thanks!

It's clogged somewhere. Disconnect the hoses where you can and check for obstructions. Run a coat hanger down the hose if you need to to clear the obstruction. ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

My Hoover Mach 5 model number u5194-900 series ZF12.O will vacuum for about 15-10 min then it shuts its self off and will not turn back on., I have cleaned out all the hoses, filters and cleaned off brush. What can I do to fix this so that it will **** into the chamber. The hoses get clogged and it doesn't appear to be sucking into the "bag area"

... Hoover U5194-900 Mach5 Multi-Chamber Cyclonic Vacuum Cleaner Bagless Vacuum

My vacuum has suction with the long tube assembly but not any significant suction down by the rollers. I assume there is a clog or a problem between where the hose attaches to the machine and the rollers but I can't figure out where to look for it. HELP. I've only had this vacuum for a few months and I'm really dissapointed!

Go to the bottom of the machine and to the rhs of the rollers you can see the pipe - also remove hex panel on back and remove hose from elbow , i also found that a filter cx did wonders ... Miele S7210 Bagged Upright Vacuum

My new Kenmoore Powermate 116 canister has poor suction. I have no pets and light dust. Its not picking up small particles on the wood floor with the floor attachment. When I put my hand to the suction it feels weak. Cleared hose and changed bag. Using again, same issues. This should not be happening with a new vacuum. Is it a bad design in the elbow joint of the hose? I want to return this!!!!

First of all disassemble the handle and hose as much as possible and examine the inside. Make sure there is not any significant debris lodged in the hose somewhere like a plastic bag or something.\015\012\015\012Also check at the top of t ... Kenmore 23912 Progressive PowerMate Bagged Canister Vacuum

The hose line leading out from the roller compartment is clogged and I can't access it to clean it out. How can I clean out that portion of the hose. I am assuming this is the problem because I can see it is full and the bag is not filling with anything.

If you have access to a short "snake" for cleaning sink drains, this could solve the problem for you.\015\012Use is manually to insert into the hose and carefully work it around to see if you can clear the clog this way. ... Vacuums

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

My hoover vacuum runs for about 10-15 minutes then the saftey feature shuts it off(overheat?). i have taking it apart a cleaned it with no results, added new bag also. after an hour it cools down and works again. do i just need a new vacuum?

Do you have suction through the tools? Does it look like it picks up when it runs? The machine could be clogged and that would cause the problem, but unfortunately the sensor that shuts the machine off could be bad if the machine isnt clogged. Its no ... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

Wondering if the head is plugged up because it makes a sound like air is escaping somewhere. I've replaced the original cloth bag with a comparable "O" paper bag from Sears. I tried to see if there was a clog in the hose by placing a broom handle in the hose to see if something would loosen. I also cleaned the filter and the air filter. If the head is plugged, how can I fix it? We can't get the vacuum apart. Thanks.

I had this problem, but suction improved when the attachments were properly secured in their holders. ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

Vaccum is making a loud high pitched sound, doesn't work well through the hose or the floor piece and shuts its self off after about 5 minutes. I have cleaned the entire vacuum out several times but this problem persists. Usually after I clean it, it'll work for a couple months, not this time. Vacuum is only 2 years old, is this typical?

... Dirt Devil Featherlight Bagless Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 1.0030 seconds