Having problems with your Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum ?

HOOVER 6430-900 Runs for about a minute or two and shuts off. Wait a while and it will run again. Changed the belts, new bag, new filter. Seems to put out a lot of heat when running.

Answers :

Hoover Fined for Failing to Report Vacuum Cleaner Fire Hazard\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012

\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012(function(){\015\012 var e9 =new expo9_ad();\015\012 e9.size ="160x600,120x600";\015\012 e9.showAd();\015\012})();\015\012\015\012\015\012\015\012\015\012_qoptions = { tags:"ADSDAQ.LAWPOLITICS,501500," }; _qacct="p-01-0VIaSjnOLg";setTimeout("quantserve()",3000);\015\012
\015\012\015\012January 16, 2007
hoover.jpgHoover Fined for Failing to Report Vacuum Cleaner Fire Hazard
Whirlpool Spins Off Hoover
Hoover Recalls Self-Propelled Vacuum Cleaners
Consumer Complaints
Hoover Company Inc. has agreed to pay a $750,000 civil penalty to settle allegations that it failed to report to the U.S. Consumer Product Safety Commission (CPSC) the sale of vacuum cleaners with defective on-off switches that can overheat and cause the vacuum cleaner to catch fire.
\015\012In April 2005, Hoover conducted a recall of 636,000 Hoover Self-Propelled Upright Vacuum Cleaners because of defective on-off switches.
\015\012In June 2004, after CPSC received notice of several vacuum cleaner incidents, the Commission staff requested Hoover provide a full report of incident information. In July 2004, when Hoover submitted a full report, it had notice of 260 consumer incidents, of which 141 involved reports of fire. Additionally, there was one report of a minor burn injury.
\015\012Hoover first learned of a vacuum cleaner switch on one of these units overheating and melting in April 1999.
\015\012Federal law requires firms to report to CPSC immediately (within 24 hours) after obtaining information reasonably supporting the conclusion that a product contains a defect which could create a substantial risk of injury to the public, presents an unreasonable risk of serious injury or death, or violates a federal safety standard.
\015\012These Hoover Self-Propelled Upright Vacuum Cleaners are plastic, upright vacuums with the brand name �Hoover� and words "Self Propelled" printed on the front of the product.
\015\012Only those Hoover Self-Propelled Upright Vacuum Cleaners manufactured between May 1998 and November 1999 are included in the recall that is the subject of this penalty.
\015\012HOOVER 6430-900
\015\012Posted by Cknlips on Jun 11, 2008
\015\012Runs for about a minute or two and shuts off. Wait a while and it will run again. Changed the belts, new bag, and new filter. Seems to put out a lot of heat when running.
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. Hoover U6437-900 / U6439-900 Windtunnel Vacuum. The vacuum may have a heat sensor and it may be protecting the motor from a burn out situation. If the bag, belt and filter are clean then it may be the heat sensor or the motor may need some maintenance on the unit. Please feel free to contact your local vac dealer in your area. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.

\015\012http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

\015\012Thanks, Don the Vac Man
Go Ahead. Use Us.

Repair Help & Product Troubleshooting for Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

HOOVER 6430-900 Runs for about a minute or two and shuts off. Wait a while and it will run again. Changed the belts, new bag, new filter. Seems to put out a lot of heat when running.

Hoover Fined for Failing to Report Vacuum Cleaner Fire Hazard\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\01 ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I have an Ecectrolux Epic canister vacuum. As soon as it starts sucking, the vacuum cuts off. I put a new filter and bag in, but it doesn't seem to help. If I open the front where the bag goes, take the bag out and depress the safety button the vacuum will run. Need some help or direction. Thank you

Try this.\015\012Disconnect hose. Turn machine on and place hand over intake. If it shuts off immediately, first try turning dial on top of machine so largest dot matches up with arrow. Turn on and place hand over intake again. If it still ... Electrolux Vacuums

I have a Eureka 4800 series the Boss upright with a bag and Hepa filter. I love it! I was just vacuuming with the hose part and all was well and then suddenly the lower brush came on and a "burning" smell followed. Thought it was the belt so my husband was going to put on the new belt which I had on hand! When he turned it over, the "bar" that holds the belt looks as though it "shot through" the plastic side of the housing on the vacuum. There is melted plastic on the outside of the vacuum and o

I had the same problem. Take out the old belt if possible. Remove the 4 screws inside the filter and the 3 on the front of that housing. pull out the foam around the motor. carefully pull out the suction tube that is press fit against the motor. ... Eureka 4874 Bagged Upright Vacuum

Hoover self-propelled windtunnel U6430-900 flat belt gets hot & becomes hard to push. It has a filter bag. Purchased 8/2/01. Took one plate off bottom. Used a compressor to blow out dirt & dust. Put new thin belt on.

Belts get hot when fibers from carpet get wound arounf the belts mounting shaft. Best to take a razor and cut off any fibers so the belt doesn't get hot again ... Hoover Self-Propelled WindTunnel Bagless Upright VacuumVacuum

My nilfisk action sucks for a few minutes then over heats and sometimes blows dust out and the bag explodes. The pipe is not blocked and I have cleaned filters and put a new bag in but still thesame thing is happening

Their has to be an obstruction in the system causing this issue ... Vacuums

Windtunnel belt I have a new Hoover Windtunnel canister. The belt keeps coming off. It happened a couple weeks ago (several times after putting the belt back on) so I assumed I might need a new belt as it might have dried out at the store. I ordered new belts and today I used it for about an hour and the belt came off again, twice. There doesn't seem to be anything to hold the belt on the stem as it seems to slip off. I have tried it centered, to the left and to the right....can you help. I am v

I've successfully used a compatible belt - Royal 104425001 .It's still new, but for the time being at least - it works. ... Hoover S3765-040 WindTunnel Bagless Canister Vacuum

We have bissell pro heat and I have put new belts on and took off the top plastic cover I blew out the lines and I still can't get it to pump water or solution. The red little spinner flow indicater does'nt get water, if I pour water into it it runs out the front. I guess I don't know what else to do. The machine worked fine the last time we used it about 6 months ago. Any suggesttions?

Did you check and make sure the belt is still on right? They do come off from time to time.There are like 6 long screws holding the top cover to the bottom. The are real pain in the behind to put back together once you take them off. T ... Bissell Vacuums

We have a new hoover bagless that is a couple months old. The pet hair attachment stopped working. I disassembled it found lots of hair wound around the various rollers and removed - painstakingly thorough i might add. Problem is the brush still wont spin and now the belt seems loose - I think I put it all back together correctly but wondering if there is a trick to this?

Without the model number, I can't look it up, but this has a 1 years warranty on it, maybe take it to a warranty shop. Just take proof of purchase, model and serial numbers. ... Vacuums

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But

Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u

Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

Krups espresso machine Type F927 It doesn't seem to build enough pressure. I've run cleaner/descaler through it several times and put in a new water filter. Ideas?

Make sure the button that turns on the top is all the way turned to the right. I have had similar instance where the button was slightly turned and it did not work. ... Vacuums

Unbeknownst to me, someone took the bag out of my Kenmore Progressive vacuum and failed to replace it. I have been vacuuming without a bag for months, and today the vacuum stopped sucking. When I opened up the front to replace the bag, tons of dirt and dust came pouring out. I thoroughly cleaned the vacuum, put in a new bag, but still no sucking power. Just dust coming from the rear vents where one of the filters is. Is the vacuum ruined, or is it a simple solution of buying a new filter?

Sounds like you need to buy a new motor. All that grit and dust will ruin a motor and I'm surprised it lasted as long as it did.\015\012This is where a vacuum that won't run without a bag would have been nice. (Aerus for one) ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have the Aerus Lux7000-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)

Hi, you very likely have a defective control valve under the dial on top of\015\012the vac , or a kink or blockage in the tiny pressure hose that feeds\015\012the air from the throat of the vac or the back of the bag chamber\015\012against the two si ... Electrolux Guardian Bagged Canister Vacuum

Noise My Dyson DC08 is making a loud, rough, vibration/noise that seems to be coming from the from the rotating brush housing. I replaced the old belt which was several years old and slipping. When I run the motor with the new belt removed the machine sounds normal. The bearings on the rotating brush seem to be running smoothly when turned by hand both when out of the brush holder and when installed in the machine. I can't find anything rubbing on the belt or rotating brush. I applied a bit o

Hi there, it's Jack at Dyson.\012I'm sorry to hear you're having difficulty with your Dyson vacuum. From your \012description, it sounds like the model number you've supplied may not be correct, \012as DC08 is a cylinder vacuum which doesn't use ... Dyson DC08 Cylinder Bagless Canister Cyclonic Vacuum

I have the electrolux guardian-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)

Hi,\015\012Check your hose you have something stuck in the hose...stretch it out straight and run something through it to push out whatever is stuck in there...\015\012\015\012heatman101 ... Electrolux Guardian Bagged Canister Vacuum

I have 2 Hoover Wind Tunnel-self propelled bagged vacuums-U6433-900 model.The roller bar does not agitate, the self propelled feature does not work and, in general, the vacuum is not performing well. I have replaced the roller bar, the v belt and the wide belt. The filters have been replaced and it has a new bag. I have had both of these since 2004 and they were fairly expensive $200 each) but if the repairs are prohibitive, I might as well get new vacuums. Suggestions? I just spent $100 for bel

The Hoover WindTunnel self propelled is a machine that we see in our retail stores (Vacuums Unlimited) constantly. The benefit of having a supposed "self-propelled" machine wears of quickly after the numerous time you will need to take this machine ... Hoover Vacuums

I have two old identical 5842's that I use in the garage and around the house. The belt broke on one so I bought a bag of 2 genuine Eurika "U" belts, which is the correct belt for this vacuum. They were obviously smaller than the original belt because they were not stretched out. When I put the new belt on it lasted about 20 minutes and then came off. I put it back on and ran the vacuum with the cover off to see what was wrong. Everything looked fine except the belt rides to the outside edge of

Not 100% sure this is the remedy for that particular problem, but I would take the time to clean both of the brushes that the belts operate, one on each machine.\015\012Remove the brushes and clean as best you can. At the end of each brush there sho ... Eureka Whirlwind Litespeed 5840 Bagless Upright Cyclonic Vacuum

Replaces the belt on dirt devil dynamite pluse model put everything back together started it and it burt the new belt up that fast. I put it around the beater brush and the metal bar I thought it should go around, yet it seemed like there should be something else there to put the belt on. What do you suggest? Do you have picture I could go by?

The metal bar you put it around if the bar itself does not spin it is going to burn the belt up. Every thing that the belt is supposed to go around has to turn or the belt will rub on the piece not moving and brake. ... Vacuums

I have a Hoover Windtunnel U 6439-900. The agitator brush will not turn. I installed 2 new belts, # 38528034, and # 38528-035 There is so much slack in belt # 3852034 (brush drive) that it cannot grip the brush. There does not seem to be any adjustment to take up the slack. I've put in new belts twice now & cannot get brush to rotate or tighten the belt to the brush.

... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Brushes run freely on the cog and I put on 2 new belts and new brushes on my Bissell Proheatx2 the brushes do not turn when the machine is running even if I have the handle in the relesed position

I know how frustrating it can be when the brushes don't turn when you're ready to clean.Here's a quick link to troubleshooting steps to assist you:\015\012 ... Bissell Vacuums


The vac is over heating. First, you should try a new filter. Also, keep in mind that after cleaning the filter, make sure that it fully dries. Using a wet or damp filter clogs it quickly. Second, turn the vac upside down and make sure that the roller ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

I have a Eureka Contour model 2900 type A upright vacuum, the roller works fine nothing clogged, took it apart motor blade is free of debris, no suction from tube and blasts OUT air from the front HEPA filter location. New bag, New belt, nothing in hose.any clues as to why this can be happenning? Air should not be blasting out of the HEPA filter.

Even with your explanation,it seems the hose is clogged.Try taking the hose off,then blow through it or pour water through it.If this doesn't do it,make sure the suction canals are going to the proper areas. ... Eureka 2900A / 2901A Contour Bagged Upright Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?

Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1454 seconds