Having problems with your Hoover U6630-900 WindTunnel Bagless Upright Vacuum ?

Vacuum stops My Wind Tunnel stops working in a very short time when using. It takes awhile for it turn back on. It still shuts off quick. I have cleaned the hoses and inside of the power brush. This doesn't correct problem. Delbert Briggs


Answers :

Your thermal cutout is tripping. This only happens when the motor heat gets very high, and the reason it takes a while to turn back on is that the motor has to cool down before it will reset. Ensure that absolutely every air pathway is clear, because a lack of airflow will overheat your motor. If they are, you have probably blown a motor bearing, which unfortunately is not economically feasible to repair since it requires a whole new motor.
\015\012
\015\012-R
Repair Help & Product Troubleshooting for Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Vacuum stops My Wind Tunnel stops working in a very short time when using. It takes awhile for it turn back on. It still shuts off quick. I have cleaned the hoses and inside of the power brush. This doesn't correct problem. Delbert Briggs


Your thermal cutout is tripping. This only happens when the motor heat gets very high, and the reason it takes a while to turn back on is that the motor has to cool down before it will reset. Ensure that absolutely every air pathway is clear, because ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

CANISTER IS GETTING POWER BUT NO SUCTION FROM HOSE AND DOESNT SEEM LIKE THERE IS POWER GOING TO HOSE..I HAVE CLEANED OUT THE FILTER AND CHECKED ALL BREAKERS...


Hello,Carnister vacuum cleaners are all built with the same \015\012principle in mind. A motor \015\012generates power which powers a vacuum which, in turn, creates suction to\015\012 lift debris. The most common areas of suction loss are ... Hoover S5615 Hush Central System Vacuum

I HAVE A BISSELL PROHEAT CARPET CLEANER 7920 I DISSEMBLY IT TO CLEAN IT. I DON'T KNOW IF I PUT THE HOSES BACK IN THE RIGHT LOCATION BECAUSE AFTER I PUT IT BACK TOGETHER IT'S LEAKING WATER ALL OVER THE FLOOR BUT IT WILL RECOVER THE WATER FROM THE FLOOR AND THE SOLUTION WON'T SPARY OUT I THINK THE HOSES ARE NOT IN THEIR RIGHT LOCATION TO STOP THE FLOW WHEN IT'S NOT SUPPOSE TO BE COMING OUT CONSTANTLY HELP PLEASE IS THEIR A HOSE DIAGRAM FOR THE HOSES INSIDE THE CARPET CLEANER


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

I HAVE A BISSELL PROHEAT CARPET CLEANER I DISSEMBLY IT TO CLEAN IT. I DON'T KNOW IF I PUT THE HOSES BACK IN THE RIGHT LOCATION BECAUSE AFTER I PUT IT BACK TOGETHER IT'S LEAKING WATER ALL OVER THE FLOOR BUT IT WILL RECOVER THE WATER FROM THE FLOOR AND THE SOLUTION WON'T SPARY OUT I THINK THE HOSES ARE NOT IN THEIR RIGHT LOCATION TO STOP THE FLOW WHEN IT'S NOT SUPPOSE TO BE COMING OUT CONSTANTLY HELP PLEASE IS THEIR A HOSE DIAGRAM FOR THE HOSES INSIDE THE CARPET CLEANER


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

Stops Immediately. We have a Beam Serenity model 2100 installed in the home and when the hose is inserted into the wall it turns on for a few seconds and then shuts off on it's own. Turning the handle's power switch off/on restarts the unit only to have it once again stop after a few more seconds. The canaster is clean. What could be causing this stopping issue? Thanks.


The Relay Control Board in the 2100 is bad. Replace and it should work just fine. ... Beam Industries 2900 Serenity Plus Central System Vacuum

The brushes spin very, very slowly and stop altogether sometimes - like they just don't have any power behind them.I've cleaned the brushes and also turned it on without the brushes inside to see if the female plug that the brushes go into turns - it does, but not very fast. My husband said he thought he smelled something - like burning. Is there a way to take the underside cover off and clean something?


... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

My vax power 8, 2200 watts 300 air watts 4L capacity upright Hoover is brand new, I emptied out the dust/dirt collecter and cleaned the motor filter yesterday for the first time, i switched it on and all fine, the brush is spinning and the hose is sucking, put the Hoover to work it's fine for about 30 seconds then then suction stops and its dead it won't collect no more, so switched off taken apart again and the motor filter is blocked and full of dust, so I unblocked it, do the same process aga


I had the same problem. It looks like the seal on the lid on the bottom of the cylinder has fallen out when it was emptied. There is no longer a proper vacuum being created so you don't get the cyclone effect and the dirt doesn't collect where its su ... Vacuums

The brush on my bissell helix (model 22C1-2) stopped working all of a sudden today. The hose still sucks and everything. I even cleaned the spinning brush and it still doesnt work. I just bought it in August.


... Vacuums

I am cleaning the hose to the underneath of the vacum. It is clogged. I need a picture from the manual to show how it all goes back in after i am done. I have a dirt devil quick power compact.. UD... something I have been looking for the manula online. unable to find it.


Go to the website below. Search for your product; either by model number of by type. When you find your model the parts page will also include a link to the manual.\015\012\015\012 ... Dirt Devil Vacuums

Press the power button on - good got a green light (new battery) press the clean button - got a green light iRobot runs for a couple of seconds and stops, then starts, then stops. After two or three times I now have a red light on for the Status. All of the wheels seem to be clean. I used compressed air to clean the underside. But still have the start stop problem.


How many times does the red light blink before it pauses? ... iRobot Roomba Discovery SE Bagless Robotic Vacuum

I have a DC07 and the brush wasn't rotating and I had no suction at the brush but perfect suction through the hose. I noticed a large build up of dog hair around the brush so I took off the cover plate and removed all the hair, cleaned inside the floor/brush housing and cleaned out the hose. I also cleaned the filter and removed the other air access cover and made sure that they were clear. I put everything back and the brush still doesn't turn and there is still no suction through the bottom


Hi and welcome to FixYa. I am Kelly. \015\012\015\012Here is a link that can assist you in your quest for the missing suction: \015\012\015\012 ... Dyson DC07 Bagless Upright Cyclonic Vacuum

I have cleaned & cleaned this thing! It runs for about 2 mins & stops, says "Clean Brushes"! and now it's very noticeable it's not picking up well... but is picking up a bit. I take the dust bin out, and the brushes spin.... and it has much more power.... and is very clear it is working! But it's useless without the dust bin! LOL It's only 9 months old.... called customer service, but it was the one time it worked just fine! Of course, I thought I'd stop here first before calling again! Than


Ok, this is a "Brush Height Adjustment" issue. It will probably work great on a hard surface but on carpet the brushes bog. If you've taken the unit apart already...Sorry....do it again. When you do, you'll see a String which allows the brushes to " ... iRobot Roomba 560 Robotic Vacuum

The solution has stopped going out the hose. The hose seems to be deep inside the machine. How do I get to it to unclog it?


The hose unhooks by the motor. But it could be the valve in the hose head. Maybe this picture will help:\015\012\015\012 ... Hoover F5866-900 SteamVac Deluxe Wet/Dry Vacuum

I have excellent suction power through the vac, but when I try to use the hose there is no suction power there. I have cleaned everything and it is definitely clean and clear. I've also used the reset button.


When you use the upright Dyson, the handle has to be in the upright position for the hose to work. In this position, there should be a clear way through for the suction to the hose, and the suction for the normal sweeper should be off. This is all ... Sharper Image Dyson Slim DC18 All Floors Vacuum

I received robot one week ago,it has stopped running,no power. It stopped in the middle of cleaning yesterday,I put it on the docking bay,but it is not powering up. no light when I push poer on,nosound,nothing. everything is plugged in properly.


Greetings from GoVaucum.com,Just out of curiosity what type of Robot do you have?Thanks,Chris JonesGoVacuum.com ... Vacuums

My electrolux ambassador power wand quit working. I replaced the switch that shuts it off when the roller stops, but it wasn't the problem. The on/off switch is fine, the motor is fine. We have traced the problem to the wires inside the canister by opening the inside cover to the bag container. We see the power cords going into the canister but we're not able to get to anything. We can't find any screws to undo that would open it up in order to follow the wires deep into the canister. We've bypa


... Electrolux Vacuums

I recently lost power to the power head. Thinking the hose was not sending current to the head, I bought a new hose. It did not solve my problem. I have since noticed that a warning symbel is appearing that indicates what looks like a key with TA inside. The vacumn has good suction. Please advise John.


Hi\015\012\015\012Please check the link bellow to diagnose your problem…..\015\012\015\012http://home.howstuffw ... Electrolux Epic 6500 Vacuum

Miele Blue moon vacuum motor surging on and off and power light flashing. After many surges of the motor (on->off->on-> off etc), the motor no longer attempting to start as ferquently ie. now off for many seconds and may turn on for 1 second.. sometimes stops turming on and just power light flashes. There is also no voltage at the plug for the hose for the power head. I noticed that the vacuum first started having probs when hair was caught in the power head and the ovetrheating light went on


... Miele Blue Moon Bagged Canister Vacuum

My Eureka/The Boss doesn't seem to have the suction power it had. However, when I place my hand under the hose, it has good suction, then when I try to pull in a small particle, it doesn't, unless I have the hose nozzle completely over the particle. The vac is 10 yrs. old. I cleaned everything. Someone said the belt. Would the belt matter if the hose doesn't **** well? It is just old and worn out? It did shut off recently do to overheating. Help. Thanks. Lorraine


Doesn't "The Boss" Vacuum have a filter? Perhaps your filter is clogged and not allowing it to work properly. ... Vacuums

I have a miele S712 (2 yrs old worked fine yesterday) - I had been doing some diy work inside and had the vac on just to reduce some of the dust in the air - after a while the vacuum fizzled out. I guessed it had overheated and took it outside to cool down - when I tried to turn it back on pressing the power button gives it power and it starts to **** but it won't STAY on, soon as you release the power button it stops, and the orange bag indicator is showing full. As I have a compressor I took


You have got dust in the micro switch and it is not latching on, if you look at this and clean it, that will solve your problem, however blowing the motir has probably wrecked the motor bearings. ... Miele Vacuums

Brushes only work when Dust Bin is removed!! I have cleaned & cleaned this thing! It runs for about 2 mins & stops, says "Clean Brushes"! and now it's very noticeable it's not picking up well... but is picking up a bit. I take the dust bin out, and the brushes spin.... and it has much more power.... and is very clear it is working! But it's useless without the dust bin! LOL It's only 9 months old.... called customer service, but it was the one time it worked just fine! Of course, I thought I'


HI, If the brushes work , without the bin, the problem , the problem could be caused , due the failure at the bin lock mechanism. There is a sensor that checks if the BIN is connected properly or not. This problem is best resolved by getting ... iRobot Roomba 560 Robotic Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

I have a tank style vacuum. When I vacuum with the power head it dims and slows down when I push the power head back and forth, but it powers back up louder when I stop pushing it If i remove the powerhead from the hose the vacuum works fine.


Most likely the belt. Thats the cheapest so try it first ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

I have the eureka bagless capture. The main hose is what I am interested in. I cracked the end of the hose where I would attach other parts such as the slim attachment for corners and to get inside the pillows in my chair, The part that I broke is on the very end of the hose. I had the plastic part clogged with some hair and during the process of getting it cleaned out, the part that I am speaking about is broken. Can you help me. I thank you, Mo moss


Change the hose part try a company called cds they r in the midlands but they courier parts\015\012out 2u dont have their no 2 hand u will need the model number try the\015\012web marting ... Eureka Uno 2998AZ Bagless Upright Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0967 seconds