Having problems with your Hoover Vacuums ?

Hoover windtunnel t series vacuum won't turn on. power source has been checked so it's something with the vacuum

Answers :

Repair Help & Product Troubleshooting for Hoover Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Hoover windtunnel t series vacuum won't turn on. power source has been checked so it's something with the vacuum

... Hoover Vacuums

I have a Series G Kirby Model G7D. The other day when I was vacuuming all of a sudden the TechDrive (Power Drive Assist N/D) pedal fell off. I see the hole that it goes into but when I put it in it's loose and falls out and doesn't control the power drive anymore. When I shook the vacuum I heard something rattling around inside the vacuum head. So I unscrewed the bottom and looked inside and found a small metal part labeled K3 on one side and T on the other side. It looks like it would fit

Hi, I have a Kirby G4 and i'v replaced the carbon brushes myself using a step by step guide however since its been back together it worked for about five minutes it then started sparking from the inside!!(a lot!!) I'v obviously touched something i sh ... Kirby Ultimate G Bagged Upright Vacuum

I have a Eureka Upright vacuum (4800 Series). When I try to start it by turning the switch on, it wont. For few days, I was able to get around this problem by repeatedly turning the switch on and off until it turned on but that does not work any more. Could it be something related to the switch it self or the power cable. My wife mentioned that one of my kids might have pulled the power cable too hard (at the back of the vacuum). Any help to solve this problem will be very much appreciated. Tha

... Eureka Smartvac 4870 Bagged Upright Vacuum

Vacuum My vacuum is loosing it's suction power. I've checked the belt and it's in perfect shape...I've bought a new filter cup...I've checked for clogs and there aren't any...I've cleaned the entire machine...and I still can't find the source of the problem.

You checked the belt, but I bet it has stretched and won't drive the brush roll under load like it should. Belts only last a few months the stretch and should be replaced. Iff you have suction at the hose, then it has to be down below, either belt/ ... Eureka Whirlwind 4480 Upright Vacuum

I have a Eureka Power Plus vacuum, model 4702, type A. To start off, it never really had great suction. Marginal at best. Then today I was vacuuming and smelled something burning and turned off the vacuum. At that point, smoke started pouring out from the bottom of the vacuum so I layed it on it's side and the smoke cleared but I never found the source. Is it safe to turn on again after I let it cool down or is my vacuum "shot?"

... Vacuums

Good Morning, A friend recently gave me her Hoover windtunnel model U630-900 vacuum. It is a self propelled vac. It comes on but is hard to push and will not really pick up any dust particles on the carpet. It has a funny smell also. I saw where one of you Q & A you said to check the roller brush. I thought maybe a belt may be off or something, but I do not have a manual to know where to begin checking. Could you tell what to check and also if there is anywhere online to download the manua

... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

I have a Hoover windtunnel T series. Model #UH70105. The system check indicator was almost red so I cleaned the filter. There are no clogs and it vacuums fine without the hose, but when I go to use the hose there is very little suction and all the vacuum dust flys out of the end the hose piece fits into when not in use. Can you please tell me what is wrong?

... Hoover Vacuums

I have a Hoover WindTunnel Bagless Vacuum Cleaner, Model #U5753-900, Serial number 110600215585, which I purchased from Loew's on 3/31/07. With it, came a Hoove Slider for hard floor surfaces, Model #S2105, Serial number 050500084989. The Slider strted making a noise--I thought something had been caught in the roller, but discovered, it had not; so I and my husband proceeded to take the Slider apart. I believe one of the belts had come off; but when we took the screws off the bottom to check

... Vacuums

Hi, I have a Hoover windtunnel t series vacuum. It was working fine until the last couple of times I used it. It just does **** uo the dirt. It **** a little, but not as strong as it used to be. Already checked for clogs (didn't find) and cleaned it and still doesn't work. Any ideas? Thanks!

This model, along with some similar ones, has been recalled. Stop using immediately. See the following site for information.\015\012\015\012 ... Hoover UH70205 WindTunnel TSeries Rewind Plus Bagless Upright Vacuum

Hoover Windtunnel U5750-900 Agitator brush is weak. It turns fine if I tilt the vacuum back, but it slows to almost 1/4 speed when it touches carpet, even on the highest carpet setting. I've replaced the agitator belt twice. The brush used to turn powerfully even on the lowest (Hard Floor) setting. Ideas? I should probably lube the agitator brush ball bearings, and re-check the belt, but, other than that, I'm stumped.

... Hoover U5750-900 WindTunnel Bagless Upright Vacuum

My Miele capricorn has started making an odd noise. It seems like something is blocking the engine. I've turned if off and on, and reset it and it still have the odd, almost loud barking noise. The power nozzle also does not seem to be working. I've checked the connections. Right before this happened I was using the vacuum. I didn't notice anything out of the ordinary until this.

Greetings,\015\012\015\012This is a major problem. The Miele vacuums motor should never make a loud noise, period. The way the motor is designed, it's quiet and should be quiet for the life of the motor. There are two motors on your ... Vacuums

I have a windtunnel 2 vacuum. It sucked up a cord that wrapped around the beater bar. Now the bar won't turn. There was no smoke or sign of something burning. The motor still runs and there is suction but no turning. We have it apart but nothing is obvious. What should I check?

Check the actual beater bar for movement. I have seen the plastic melting, and bearings seized under such circumstances. Also I am unsure by your question, but the motor that creates the vacuum (sucking) is different than the motor that spins your ... Vacuums

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos

It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

The vacuum i've had for 6 months has very liittle suction power. checked that the belt is on. cleaned filter. checked to see if hoses were clogged. I used a super vac to suction any debris out of vacuum. still little suction power

As this unit has 3 filters on it, a lot of people forget about the one filter that will cause all of your trouble here. \012\012There is the exhaust hepa filter, no problem, your unit is pretty new, it shouldn't be a problem. \012Th ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Was using my Miele Champagne vacuum, powered down, changed the bag, and now I have no power. I checked to make sure all lids were securely closed, still no power. Checked to make sure outlet was working, still no power...help.

Most likely the cord went bad, one side of it opened up, you will have to replace the cord reel asm. if this is the problem, Could also be a switch, electronic control or the motor. ... Miele Vacuums

Purchased a new, portable, vacuum this date. 4/24/08 at Gottschalk's. Got it home, unpacked it and installed attachments. plugged into a power source, and depressed the power switch, machine did not come on, used three different power sources to no avail. advise--- Reply to [email protected] asap

Being under warranty, I would take it back for an exchange. You don't want something brand new and it is dead on arrival. Either that or take it to a warranty shop for repair. You mess with it and that avoids the warranty. ... Vacuums

No power to sensor SR 12. I also have cleaned rollers and filters and bags. I have reset the handle. When I hit the power the check brush and full bag lights flash once. That is the only power that is getting through.The unit was in storage for a bit and got wet but its been drying off for a couple months. Is there something I can check or replace. Its a great Vac.

... Windsor SR12 Sensor Bagged Upright Vacuum

Kirby vacuum I have a G 6 kirby vacuum. The power cord has been checked and has continutity and replaced the power switch and the vacuum will still not run

There are 2 safety switchs, one on the front that the nozzle activates, and one on the side that the bag asembly activates. The motor brushes and/or armature maybe bad. ... Kirby Ultimate G Bagged Upright Vacuum

I bought the Eureka 4703D model vacuum and my very first time powering it on, it was extremely loud - abnormally loud, and I don't know if it is loud like that because I possibly put it together wrong, or there is something wrong with it or it was previously damaged and I would like to know if this is something I can fix myself or do I have to take it back apart and return it to Walmart where I purchased it from. When it makes the loud noise, it does vacuum fine but the noise is just unbearable

... Eureka Power Plus 4703D Bagless Upright Vacuum

Poor suction I have a hoover hush s5627 vacuum purchased about 4 years ago from Costco. It's suction power isn't so good anymore. I've checked all the lines & hoses and they're clear and I've changed the bag. I even disconnected the pipe from the vacuum unit and held my hand over the intake. While the machine roars like a jet engine the suction power just ain't like it used to be. What could possibly be the problem?

This vaccuum has a Fan Blade inside connected to the motor that spins to create the suction you feel. After a few years of use (and misuse) the blades on this (plastic) fan will be broken off, thus damaging the unit. These Fans are replaceable if yo ... Vacuums

A family member recently gave me their Kenmore Vacuum Cleaner (model 35821) and I did not notice that the power cord was missing at first. I tried to look closely at the manual online to see if this was something I would be able to purchase or if the vacuum was no longer any good. Do you happen to know if there is a replacement part for the actual power cord for this item?

Any power cord 17 gauge or lower will work ... Vacuums

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u

Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

Power head attachment works great when plugged into the hose part of the vacuum. The problem is when I attach it to the tube for normal use there is no power. I have checked all the connections and switched the power switch on and off still no power from tube to power head. Is there anything else I can try? Model Callisto

Try having someone turn the machine on and off while you pull the cord in and out with the cord more angled towards the on/off switch. Sometimes these models have a break in the cord rewind and will not put the power through to the motor. ... Miele Vacuums

No power i try to turn it on no power i treid different power source no luck check everything no power

It could be the switch button that you push to turn it on (2031199), or the switch (2031243) could be the problem. If not those 2, then the cord could be bad or even the motor (2031214). I would check that switch button first. ... Bissell 6594 PowerForce Bagless Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0993 seconds