Having problems with your iRobot 5800 Scooba Vacuum ?

Stuck on check tank indicator

\015 Power on ,\015\012clean button flashing green,\015\012check tank green,\015\012already primed empty and full,\015\012tried six times ,same result\015

Answers :

If your Scooba's Green Check Tank light is coming on immediately on startup, please try the following steps:

1. Remove and reseat Scooba's battery, ensuring that you hear it click into place.
2. Remove and reseat the brush head
3. Remove and reseat the vacuum port and filter. When replacing the filter, be sure to press firmly into the hole. There is a magnet on the filter that must connect with the magnet on the Scooba.
4. Fill Scooba’s Clean Tank with approximately 1 cup of cold water, shake vigorously, and empty it to remove any debris in the tank.
5. Empty the Dirty Tank, refill with water, and slosh it around to pick up any sediment. Empty the Dirty Tank again.
6. Refill Scooba’s Clean Tank with water, adding a pinch or two of table salt. Run the Scooba. If the issue persists, please follow the steps below:

With the tank removed, press the Power button and then the Clean button.

If the robot tries to start a cleaning cycle, power off the robot and repeat, pressing the Power button first and then the Clean button. If the pump makes a “whirring” or squirting sound and the robot does not start a cleaning cycle (Check Tank indicator will light), this indicates that the pump is working. Replace the tank and try starting a new cleaning cycle with the tank on.

If Scooba does begin a cleaning cycle the second time you press the Power and then the Clean button with the tank removed, the pump valve could be blocked with debris. Using a turkey baster, straw or sports bottle, force water through Scooba’s solution valve. Confirm that the baster, straw or sports bottle fits snugly over Scooba’s solution valve, push water through the system at least three times, and then try re-starting Scooba.

Below is a link to a diagram of these steps for visual reference:

Title: Scooba is not putting down cleaning solution
http://homesupport.irobot.com/cgi-bin/irobot_homesupport.cfg/php/enduser/std_adp.php?p_faqid=322&p_created=1167154849
Next suggestion is for those who did\015\012everything according iRobot and destiny brothers suggestions on the\015\012Web. Fort those who did everything (washing, primming, testing ect.)\015\012and are still stuck with Check Tank problem.
\015\012Suggestion is for those who understands\015\012little bit Scooba's internals and how it is functioning. \015\012
\015\012I only share my experience, so try it\015\012at your own risk! \015\012
\015\012
\015\012
\015\012The problem with Check Tank signal lays\015\012to the next roots: Dirty-Tank's High-Limit level-sensor (see Figure\015\0125. 'Electrical-Connector To High-Limit Sensor In The Dirty-Tank' on\015\012http://mysite.verizon.net/gsplews/Tanks_details.htm\015\012) sends wrong signal to the Scooba electronics. This sensor is\015\012resistor-based and is in low resistance as Dirty Tank fluid level\015\012reaches certain level and in high resistance if fluid level is low\015\012in Dirty Tank.
\015\012What I faced in my case Dirty-Tank's\015\012High-Limit level-sensor still is in low resistance mode while Dirty\015\012Tank is totally empty! I don't know exactly why it is like that; my\015\012guess sensor is is impure and washing procedure for Dirty Tank is not\015\012helping anymore.
\015\012Solution is next: you need to eliminate\015\012Dirty-Tank's High-Limit level-sensor. For this take small peace of\015\012sticky tape (thin one, but with good electrical insolation) and put\015\012around Electrical-Connector To High-Limit Sensor In The Dirty-Tank\015\012(see Figure 5. 'Electrical-Connector To High-Limit Sensor In The\015\012Dirty-Tank' on http://mysite.verizon.net/gsplews/Tanks_details.htm\015\012) You need very small peace of tape, just one layer. Don't put to\015\012much, as Connector still needs to fit to Scooba base.
\015\012That is it.
\015\012By putting tape on Sensor Connector you\015\012send “Dirty Tank is Empty” signal to Scooba Electronics and \015\012Check Tank problem should be gone and you run Scooba with no\015\012problems.
\015\012Keep in mind, you have modified Scooba\015\012version now!
\015\012This version has NO Dirty-Tank's\015\012High-Limit level-sensor functioning anymore! So run it at your own\015\012risk. \015\012
\015\012To run such modification keep next\015\012rules:
\015\012
    \015\012
  1. Always check if Dirty Tank is\015\012\011empty before running next cleaning cycle (as Dirty Tank Level sensor\015\012\011is not functioning you need visual inspection)
    \015\012\011
  2. \015\012
  3. NEWER run Scooba to to collect any\015\012\011spill fluid as you might overfill Dirty Tank (remember, Dirty Tank\015\012\011sensor is blocked by tape).
    \015\012
\015\012
\015\012
\015\012Suggestion for iRobot.
\015\012I Love Scooba and wish great success on\015\012next upgrade. My suggestion guys. Pls. make Dirty-Tank's High-Limit\015\012level-sensor visually inspectable and possible to clean manually with\015\012no sofisticated tolls :)
Repair Help & Product Troubleshooting for iRobot 5800 Scooba Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Stuck on check tank indicator


If your Scooba's Green Check Tank light is coming on immediately on startup, please try the following steps:1. Remove and reseat Scooba's battery, ensuring that you hear it click into place.2. Remove and reseat the brush head3 ... iRobot 5800 Scooba Vacuum

Hoover SteamVac Model F6056-900 SteamVac/SpinScrub. Indicator light and high pitch suction noise indicates that dirty water tank is full. However, water level indicator (yellow bobbing plastic thing) is at the bottom of the tank and there is no water in the tank. Have check all the hoses for clogs, none found. Checked water port from motor area to receptacle tank for clogs, none found. Fixed broken hose to upholstery wand with duck tape, (wire not broken, just cracked plastic hose). The onl


There are 2 filters, make sure they are clean, one is on the tank lid, the other is from the bottom, it is red, pull it out and clean it. If yours has a foam filter on the tank lid covering the yellow ball, make sure there is at least a 1/4 in. gap ... Hoover Vacuums

Bissell Pro-Heat 7901-1 no cleaning solution is pumped out. The flow indicator is spinning and the belt is spinning the beater bar. Have cleaned the flow indicator, checked vavles in the solution tank and water tank and they are working properly. Also checked the trigger to make sure it works okay. Any ideas?? Moody Fan


Bissell Pro Heat shampooer - Fill the soap dispenser with extremely hot water and shampoo with only water for a few minutes. There is often dried soap in the lines. Make sure that all filters are clean. Press the soap container and the water conta ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

Nothing spraying out of Bissell Powersteamer Proheat. I've check filter under flow indicator, pump belt is fine, cleaner in proper tank, bladder of water tank is full. We've had it for a very long time but it's barely been used. Can anyone help?


... Bissell 1698-1 PowerSteamer ProHeat Plus Upright Vacuum

Scooba 5800 "check tank" light always goes on. - I have checked tank. I have cleanout brushes, tank; rinsed, sloshed, dumped. The check tank light comes back on when I want to clean. What should I do now? Pat


... iRobot 5800 Scooba Vacuum

Hoover vacuum cleaner indicators stuck


The sensor is located in the tube that the bag mounts to, if you take the bag off of the unit and have an air compressor handy you can blow out the port hole this should dislodge the particulates that are causing the false reading, there is defintely ... Vacuums

I have a new scoba (irobot) the battery is charged the tanks were fillied and every time i hit the power button and then clean the machines "check the tank" light came on. i have done all the proper instruction checks an i have done all the trouble shooting section. the machine will only work (and that is for 5 minutes drying its head) when i hit power and the clean button twice. so obviously the machine is somewhat working


We had to prime the sensor. irobot suggested a turkey baster, but we didn't have oneso we used an empty visine bottle with the end snipped off and rinsed completely. this worked after the first try. thank you for your interest ... iRobot 5800 Scooba Vacuum

Bissell Big Green Machine just stopped working in mid-clean. Have emptied tank, rinsed tank, checked belt, checked brush and still nothing. Have even changed outlets. Suggestions?


The motor could have fried or the wires have been shaken off the motor terminals. ... Bissell 1697-7 Powersteamer Pro Deluxe Vacuum

How to disassemble the brush to empty anything that might be stuck inside of the brush? The motor seems to be overheating, all belts have been checked, all airways are clear and the filter is clean. The vacuum is vibrating and releasing a burning smell, but still sucking up dirt. There is nothing stuck on the outside of the brush, but is there a way to check inside of it to see if that is where a clog is occuring?


If there's a burning smell and the belts are fine, the problem is going to be hot wires causing the insulation to melt, or the motor going bad. Discontinue use and have it checked at a repair shop. ... Bissell 6594 PowerForce Bagless Upright Vacuum

How do I fix Bissell Quicksteamer leaking from water tank through wheels? After I place the filled Clean/Solution tank on the Lower body of the QuickSteamer, water pours out from the body of the machine through the wheels even before I turn the power switch on. I checked the tank and there are no holes in the plastic tank.


I have the same problem... seems to be because of a bad, or worn, rubber gasket. ... Bissell Vacuums

I am using my Hoover Steamvac FH5001 for the first time. It worked great until I had to empty the dirty water tank and refill the solution tank. Now it will not spray solution. I have double checked to make sure both tanks are inserted correctly, but to no avail.


Check all o rings to see if they are seated correctl= on the hoses that were disconnected. If not you will not receive suction to spray ... Vacuums

RAPIDE ULTRA W90-ru-b NO LONGER SPRAYS THE SHAMPOO ONTO THE CARPET. CHECKED THE TANK IS FITTED SECURELY,THE TANKS EITHER FULL OR EMPTY DEPENDING ON EITHER ITS THE TANK FOR SHAMPOO OR THE ONE FOR DIRTY WATER, AND ANYTHING ELSE I CAN THINK OF. IT STILL DOESN'T SPRAY.


... Vacuums

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

My Kirby shampooer - G4 - hardly used any water from the tank and no suds at all. Pet hair did blow out of the small slotted holes in the tray as I moved the shampooer back and forth, but the carpet was basically dry. I did vacuum before shampooing, so the brush part seemed to work great during shampooing, but no water! The small screen was stuck in the crook of the hose that attached to the tank so I did get that out and put it on the small hole on the tank, but it didn't make any difference. I


Few things:Make sure the sponge and the valve under the sponge (water tank) is clean.Make sure you follow the instructions (f you do not have the manual you can find one ... Kirby Ultimate G Bagged Upright Vacuum

It keeps telling me check tank


Prime Scooba's pump, as described ... iRobot 5800 Scooba Vacuum

Clean tank indicator keeps going off after tank has already been cleaned


The Roomba is noted to cut out operating correctly. Remove the housing and blow out dust from all circuist and any dirt and dust inside the entire unit. It should work correctly afterwards ... iRobot Scooba 380 Robotic Vacuum

I have Hoover Floormate Model H3004. The machine will no longer dispense the cleaning fluid due to the trigger assembly not engaging properly with the inlet/outlet on the Clean Water Solution Tank. I have checked and made sure the tank was seated properly.


... Hoover Floormate H3000 Upright Wet/Dry Vacuum

Tank Dispensing All the detergent empties out, but water does not. This is brand new. Have checked valves & everything checks out ok.


Nattim;\015\012\015\012What I have done is to forget about the detergent container which doesn't standup to ordinary use and go and buy a small tank sprayer and fill it with the detergent solution\015\012-----------and then spray th ... Hoover F7222-900 SteamVac Upright Vacuum

I just received My brand new hoover platinum lightweight upright UH30010 (with canister) which I ordered through ebay and today is just the SECOND time I used it but the check bag light indicator is already flashing. My husband and I live in a 1 bedroom (695 sq t) apartment (no kids or pets). I checked the bag and the dirt is just maybe two inches - far from the limit line showing on the bag..and I remembered the advertisement on TV that it can even last upto to six months depending on the usage


I have the same problem. If it was just an indicator light I could live with it, but mine actually shuts the vacuum off. I can only run the vacuum for 3-5 seconds before it turns itself off. Any ideas? ... Hoover Platinum Collection Upright Vacuum

I have a Kenmore DuraPower Dual Cyclone Action 12 Amp that just randomly stopped right in the middle of vacuuming. I assumed the plug had come out of the wall so I went to check and this wasn't the issue. I tried multiple outlets and that wasn't the issue. I made sure nothing was stuck and there is nothing stuck. Nothing happens when I press the red "ON" button. What could this be? Thanks!


... Kenmore Vacuums

The vacuum is making a noise like something is stuck when it is in the carpet position but not when in the floor position. I can't find anything that is stuck in the areas that I can see. I have cleaned the brush but it does not seem to want to turn. Does this machine need to be oiled so the roller will turn? Is there a way to check inside the motor? Do you think that because the brush won't turn that is making the noise? Do you know of any repair shops in the Lake Havasu City, Arizona area?


As far as the roller brush goes, yes, it does need to be cleaned. Follow the directions to remove it and clean as best you can of all debris. On both ends of the roller brush there will be two "holders" of sort that connect the brush to the frame o ... Dyson DC07 Bagless Upright Cyclonic Vacuum

My Hoover Steamvac is not sucking, it is blowing the air outwards. I was using it it was fine, then I emptied the dirty water tank (not the 1st time) and then it stopped working. Help please, I have taken both tanks off and checked their positions repeatedly


... Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum

I own an Essick Air humidefier Model D46-720 and it leaks. When I fill both tanks and put them in place they continue to fill the bottom untill it overflows onto the floor and continues to do this until the tanks are emptied. I cleaned it and checked the float which was fine and it still overflows.


... Vacuums

Light is flashing and saying check tank. tank is full.


Empty the tank, then fill the clean tank with plain water. Add a pinch of salt. Put the tank back on the Scooba and try it out. The problem is that Scooba's tank sensors rely on the conductivity of the fluid in the tank to guage the presence of clean ... iRobot 5800 Scooba Vacuum

Faithful Sebo X1 upright, about 12 years old, stopped working today. I replaced old with new dust bag, checked all dust paths were clear, checked main brush was clear/clean, and drive spindle rotated OK with fingers. When power switched on, the two red indicators briefly flash on then off, but nothing more happens, motor does not start - even with power reaching machine. Tried removing all consumables, refitting and turning on a few times to reset, no joy. Removed base cover, both belts were i


At 12 years, this vacuum has had a good long life. I suspect the motor is shot, but it could be due to faulty wiring and connections. A bad switch, break in the power cord, and worn brushes in the motor are other causes.\015\012I recommend ta ... Sebo Automatic X1 Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0430 seconds