Having problems with your iRobot Roomba 560 Robotic Vacuum ?

Runs for awhile then says error 2 please remove and clean roomba's brushes i do then runs for awhile and says same thing no dirt on brushes?


Answers :

I had the same problem. You must clean this parts and inside this parts:

Remove hair with cleaning tool
Remove Roomba's brush bearings
Clean Roomba's brush bearings with cleaning tool

e6d6702.jpg27239d5.jpga6b6a16.jpg
When cleaning the brushes and usual stuff doesn't work (e.g., you still \012get Error 2 just a few minutes after cleaning it out), it's because your\012 casing gears need to be cleaned out. This is a bit more involved than \012the usual cleaning, but still pretty easy. I did mine and it's like the \012Roomba is new again. Here's the guide:
http://www.robotshop.com/PDF/roomba-500-casing-gears.pdf
Repair Help & Product Troubleshooting for iRobot Roomba 560 Robotic Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Runs for awhile then says error 2 please remove and clean roomba's brushes i do then runs for awhile and says same thing no dirt on brushes?


I had the same problem. You must clean this parts and inside this parts: Remove hair with cleaning toolRemove Roomba's brush bearingsClean Roomba's brush bearings with cleaning tool ... iRobot Roomba 560 Robotic Vacuum

I have a roomba 551. Have cleaned and removed every bit of dirt and hair off it bu the brush cage won't close when the larger bush is put in. The cage will only click locked on one side, and the other side keeps hitting the brush and won't close. It's almost as if the bursh itself is not even, but this doesn't seem to be the case either. I've even tried removing the yellow rings, but makes no difference. Occasionally it runs fine, but most of the time the roomba just hobbles and clacks as i


Hi, had the same problem, it was like the main brush no longer fit into it's slot, so the brush cage would not latch. I discovered that the yellow bearing tip on the main brush twists off, and inside I found a lot of hair twisted around the pin. Th ... Vacuums

IRobot Roomba 560 Thumping, Says Clean Brushes, No Dirt in Cup


... iRobot Roomba 560 Robotic Vacuum

Brushes only work when Dust Bin is removed!! I have cleaned & cleaned this thing! It runs for about 2 mins & stops, says "Clean Brushes"! and now it's very noticeable it's not picking up well... but is picking up a bit. I take the dust bin out, and the brushes spin.... and it has much more power.... and is very clear it is working! But it's useless without the dust bin! LOL It's only 9 months old.... called customer service, but it was the one time it worked just fine! Of course, I thought I'


HI, If the brushes work , without the bin, the problem , the problem could be caused , due the failure at the bin lock mechanism. There is a sensor that checks if the BIN is connected properly or not. This problem is best resolved by getting ... iRobot Roomba 560 Robotic Vacuum

Irobot runs for awhile then says check brushes, brushes are clean, also doesn't pick up obvious debris


If its running id say check the in take for something blocking the in take as ive never had hands on with ibot cant be specific on the procedure if its not sensing in coming then it will think the brushes ... Vacuums

My Roomba stops within a few minutes of starting it and when I press the button, it says "Remove and Clean Roomba's Brushes." I have removed the brushes and cleaned them thoroughly, but within a few minutes, it stops again and says the same thing.


Hi,Accumulation of hair, dust and dirt in the Gearbox that prevents normal operation of the brushes. As a result, a power output is required to keep the brushes turning. As turning the brushes requires too much power, it con ... iRobot Roomba 4210 Bagless Robotic Vacuum

Noise My Dyson DC08 is making a loud, rough, vibration/noise that seems to be coming from the from the rotating brush housing. I replaced the old belt which was several years old and slipping. When I run the motor with the new belt removed the machine sounds normal. The bearings on the rotating brush seem to be running smoothly when turned by hand both when out of the brush holder and when installed in the machine. I can't find anything rubbing on the belt or rotating brush. I applied a bit o


Hi there, it's Jack at Dyson.\012I'm sorry to hear you're having difficulty with your Dyson vacuum. From your \012description, it sounds like the model number you've supplied may not be correct, \012as DC08 is a cylinder vacuum which doesn't use ... Dyson DC08 Cylinder Bagless Canister Cyclonic Vacuum

My iRobot Roomba runs for 5 minutes, then it say error 2 open brushes clean brushes, which i did, then 5 minutes later it start again saying error 2 clean brushes.


... iRobot Vacuums

In my (almost new) Dyson DC31 Animal the rolling brush tends to stop like the bearing was kind of difficult to turn. I opened the side carter and removed the little belt. Without the belt the engine runs regularly. I cleaned the little knots of hairs trapped in the bearing but still the brush runs for a while then stops, tries for a bit then stops again. I even tryed putting a bit of synthetic lubricant with apparently no result. Could it be a defective bearing? Thanks for your help.


... Dyson DC31 Animal Bagless Handheld Cyclonic Vacuum

Brushes won't fix back into holder without being forced, so Roomba clicks when it runs. It will only run a little while and then stop and say to clean Roomba's brushes.


It sounds like you didn't clean the bearings. On one end of each brush is a bearing, probably in a yellow housing. Pull the bearing off the axle, and you'll find it's full of hair underneath.Obviously, the brushes should turn freely and s ... Roomba Vacuums

Irobot run then shuts down-says check brushes-brushes clean-also when running does not pick up hair, and such on carpet.


Has a internal short. ... Vacuums

Cleaned and running well, taken downstairs, put to work my 530 has developed a distinct knock. about 1/2 second speed as going along. does not happen if brushes removed. machine runs for a few mins th


Click the link below :----http://wikisolutions.blogspot.in/2012/02/get-free-answers.html ... iRobot Roomba 530 Robotic Vacuum

My Roomba only works correctly when I leave out the rubbery type brush (not the fiber filled brush)...... when I leave the rubber one in, it doesn't pick up & then finally stops & says REMOVED BRUSHES..... I have cleaned every nook & cranny of this thing... inside & out. I finally found that if this one brush is left off.... it works great & has for 2 weeks??? What could be the problem?


Hi,\015\012First let’s try one more time to clear out anything that might be caught inside. For this disassemble the green brush cage unit, partially, from the blue box. This would expose the cover of the gear box. On t ... iRobot Roomba 560 Robotic Vacuum

My bissell model 18Z6 has developed a loud noise and vibration when the brush is running. I have removed the brush assy and cleaned all the hair, etc but still the noise. I ran the brush motor with the belt disconnected and all seemed ok, but of course there was no load on the motor. I suspect a problem with the brush assy bearings or axle or both but I hate to just throw parts at the problem. any suggestions would be greatly appreciated.


... Bissell Vacuums

My Roomba runs for a while and says error 2 to clean the brushes. This happens with cleaned brushes. And I have followed the instructoins. i have got a brand new set of brushes also. When inserting them the same problem continues. The floor is clean.


Remove the two round rings.....this has worked for me like a charm since! So glad to have the Roomba back up and running! ... iRobot Roomba 560 Robotic Vacuum

Dirt finder I have a Hoover U6439-900.  After the cleaner was used a few times, the dirt finder light cycles between green and red on the regular setting and will not go to green.  On the sensitive setting, the red light stays on most of the time.  I have tried to run the cleaner to remove any dirt but have not solved the problem.


The sensor may be bad, or it may be coated over with dirt. Re,ove the hose at the back of the vacuum, the head of the sensor is down inside that opening, reach in there and clean it off and see it that corrects the problem, if not replace the sensor ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

The vaccum has been cleaned and checked but the brush is not rotating and no suction at the bottom, but through the hose. In reading the instructions to remove the brush cover it says to lift tab one and release 2-4. Where is the tab for tab 1 can not find anything for tab one to be able to lift, nothing there any ideas for help would be greatlly appreciated/


3 on the front and one on the back. where the belt runs ... Bissell 6594 PowerForce Bagless Upright Vacuum

I need to know how to remove the dirt container on the eureka bagless vacuum. It says that it is easy to remove, yet we cant figure it out. is there some trick to it that we dont know?


There is a lever at the bottom of the dirt cup,turn it to the left and pull out the dirt cup.note while you have the dirt cup out make sure you clean all the filters there is one right above the dirt cup pull out on the right side and there is a filt ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

Same problem as voirjs 12/29/09 - runs a while & needs brushes cleaned w/same repeat scenario. have been doing all of the cleaning as felix80 said on 1/8/10; but it still continues the run awhile & need cleaning behavior. a more indepth solution is required.


I called iRobot Customer Support, and they are sending me a new cleaning head module. ... iRobot Roomba 560 Robotic Vacuum

Robot runs for about 5 min. then says clean brushes. brushes do not turn


The dust build up in these Roomba's do create a problem in all operating phases\015\012Keep in mind if taken apart every 6 months and cleaned inside they will operate like they should ... iRobot Roomba 560 Robotic Vacuum

I have cleaned & cleaned this thing! It runs for about 2 mins & stops, says "Clean Brushes"! and now it's very noticeable it's not picking up well... but is picking up a bit. I take the dust bin out, and the brushes spin.... and it has much more power.... and is very clear it is working! But it's useless without the dust bin! LOL It's only 9 months old.... called customer service, but it was the one time it worked just fine! Of course, I thought I'd stop here first before calling again! Than


Ok, this is a "Brush Height Adjustment" issue. It will probably work great on a hard surface but on carpet the brushes bog. If you've taken the unit apart already...Sorry....do it again. When you do, you'll see a String which allows the brushes to " ... iRobot Roomba 560 Robotic Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

Hi, There is a high pitched whirring sound coming from lower part of the vacuum. When I tilt it toward me (while standing in the normal vacuuming stance) the sound sometimes lessens for a minute or so. I have tried the following things: -cleaned the two sponge filters -emptied the dirt receptacle -removed the roller and cleaned it -cleaned the brushes -the belt is not ragged and does not seem floppy -checked all of the airways for clogs (including removing the wheel base) Can you help?


Your looking for some dirt stuck in some thing you didn't check yet. with the roller out and the belt out of the way run it to see if it still makes the noise. if it does then you looking at the impeller or the motor bearing themselfs those bearin ... Bissell 3750 Lift Off Bagless Upright Vacuum

I replaced the belt on my Dirt Devil Featherlite Bagless Vacuum and the brush roller rubs and makes a very loud noise when turned on. I have gone exactly by the manual instructions and made sure the belt and end caps were on correctly, but the bristles still rub the back and it makes a very loud noise. Without the brush roller in the vacuum, it sounds and runs normal. What could the problem be?


Http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=561283\015\012Generic problem for all Vacuums\015\012I replaced the belt on\015\012Posted by piggyt ... Vacuums

Bissell powerforce My lower pickup tube became clogged so I removed it and cleaned it out and reinstalled it.Now everything runs good but the vaccum want pick up any dirt .I replaced the bag andf when I turn it on it just exhaust air but does not have any suction,I tired tp pull the bag door of while it was running whick I could not do so it has plenty of suction inside just not getting any outside can you help?


... Bissell Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0833 seconds