Having problems with your Kenmore 23612 Progressive PowerMate Bagged Canister Vacuum ?

Kenmore Powermate power head not working

\015 I have a Kenmore Powermate vacuum. The power is turning on, but for some reason, the ?power head power is not coming on. I pushed the reset button, but nothing happened. Prior to this, I had tried to open the unit to check the bag. The power cord at the front (where it opens) did not detach itself, so I manually unplugged it and then plugged it back in after checking the bag. The suction unit on the handle works, but the main vacuum doesn't. Help! (Thanks!) Vacuum is a ten year-old Powermate.\015

Answers :

I've got the same problem. Try checking out the electrical connection where the hose attaches to the canister. The hot male terminal is corroded and the female socket is burned out. Its an unfortunate design flaw that every time you open the vacuum to replace the bag the electrical connection disconnects and reconnects. Not sure if I can find replacement parts for a 10 year old vacuum or if a home-made re-wiring job is in order. Will find out tomorrow.
Repair Help & Product Troubleshooting for Kenmore 23612 Progressive PowerMate Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Kenmore Powermate power head not working


I've got the same problem. Try checking out the electrical connection where the hose attaches to the canister. The hot male terminal is corroded and the female socket is burned out. Its an unfortunate design flaw that every time you open the vacuu ... Kenmore 23612 Progressive PowerMate Bagged Canister Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

The power head on my kenmore 22822 Canister Vacuum won't work? the power upholstery head works fine.


I have the kenmore whisper belt and i have a reset button on mine ... Kenmore 22822 Canister Vacuum

My kenmore model no 116.22512200 canister vacuum power head has no suction & doesn't pick up even though it shows all the signs that it is getting power. The junior power mate works fine.


... Kenmore Vacuums

I have a kenmore vaccum i changed the power cord for the powermate and still not working the model # 11652512202 it work for a second then stop working


Could be your off/on switch ... Kenmore 28614 Canister Vacuum

I am trying to disassemble a Kenmore Powermate vacuum head in order to access the power head belt.


Squeeze the sides of the lamp cover, and it will snap off. then you will see 2 screws under where it was the rest is obvious ... Vacuums

Hey I have a kenmore model 116.23185800c vacuum. The vacuum stopped working but the power head still works is there a reset for the motor


... Kenmore Vacuums

The motor on my Epic 6500 works, the hose is sucking, but the power head isn;t working... I tried the sidestep power head and that one works. Ive opened and replaced the belt and that is fine. The bulb was already burned out and wasn't replaced so I cant tell if theres power to the head. What else could it be?


Connect the power nozzle directly to the hose and try.\015\012Check the terminals where the wand connects to the PN. If any are discolored or cracked, that may be the problem.\015\012Open the PN and check for loose or broken wires and co ... Electrolux Epic 6500 Vacuum

My power head on my Kenmore canister sweeper dont work right.How do I get it apart and fix the problem?


Try pushing the reset button on the top of the power head first. There is a protection system on Kenmore canisters that protect the belt from breaking, and if something was vacuumed up into the head, it will cause this reset switch to activate to p ... Kenmore 23612 Progressive PowerMate Bagged Canister Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

My kenmore progressive canister vacuum's power head has stopped working. When I check for suction from the hose, it seems strong. Could it be a belt has broken? Is this a repair that I could do myself? Thank you!


... Kenmore Vacuums

Beam solaire hose only works to suction The power head isn't working. Have another hose and the power head does work on that one so I know it is the hose


... Vacuums

Central vacuum power head no work


Looks like a Beam central vacuum www.beamvac.com, and a Kenmore vacuum head.Reply what problems you are experiencing and I will try to help. ... Vacuums

The brush wouldn't work when the selector switch was in carpet mode. Took the power head apart and removed the motor. Everything o.k. in the power head. Checked and found that the neutural wire had pulled out of the connector, the connector was never crimped at the factory. What a day! Took 2 hours and a large pizza to get it done. Neutral wire was in the hose just below the handle. Reconnected the wire and crimped it, put everything back together. It works!!!!


Great. ... Kenmore Vacuums

Power head attachment works great when plugged into the hose part of the vacuum. The problem is when I attach it to the tube for normal use there is no power. I have checked all the connections and switched the power switch on and off still no power from tube to power head. Is there anything else I can try? Model Callisto


Try having someone turn the machine on and off while you pull the cord in and out with the cord more angled towards the on/off switch. Sometimes these models have a break in the cord rewind and will not put the power through to the motor. ... Miele Vacuums

Power head for Kenmore Canister Vac


Another potential problem for the increase in difficulty in turning the beater bar (drum) could stem from extremely dirty bearings, located at each end of the beater bar. I've seen hair knotted up to the point it chokes the bar and significantly redu ... Kenmore Whispertone 29512 Vacuum

Our Electrolux canister vacuum just stopped working when we were vacuuming the floor. The power does come on when the power head is attached but as soon as the power head is removed the power shuts off. I tried pressing the reset button but that doesn't help. Is there a solution that I can try at home?


Sound like you problem is in the connection going to the power head you will see a small screw on the power nozzel where it joins to the handle take out the screw and take it a part you will see where one of the bars have been disconnect from the pow ... Electrolux Guardian Bagged Canister Vacuum

I have a tank style vacuum. When I vacuum with the power head it dims and slows down when I push the power head back and forth, but it powers back up louder when I stop pushing it If i remove the powerhead from the hose the vacuum works fine.


Most likely the belt. Thats the cheapest so try it first ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

I have an older kenmore canister powermate 3.9 and the vacuum itself works fine but the powermate isn't sucking after a toy was sucked up last week. The toy is out but the powermate doesn't work. I assuming that is what it is called. The big long part that hooks to the canister that actually cleans the carpet. I would appreciate any help.


... Kenmore 25512/ 25513 Progressive Canister Vacuum

My power nozzle has stopped working. The vacuum itself is still working but not the power bar. I would like to order a power nozzle. Can you tell me how I can order a nozzle for a Kenmore Whisper Belt 12.0 amps


... Kenmore 23313 Whispertone Bagged Canister Vacuum

Kenmore intuition power head


... Kenmore Vacuums

How to disassemble a kenmore power head type EBK 340 L


... Vacuums

Power head motor is good,runs great from test cord switch seems to work. brush roll cleaned but power head motor will not run


If you have checked the power delivery down to the powerhead and you have current running to the powerhead, then you likely have a burned fuse. There is a fuse built into the powerhead motor and is usually located on the field winding. This is not ea ... Eureka 6831A Bagged Canister Vacuum

Our unit is 7024A Electrolux Oxygen 3 - it seems to work great but suddenly, the head or 'power brush' or whatever it is called - has died. I checked by removing the hose and plugging it directly into the body, but it is still dead. Without that motorized head working, the vacuum is useless. Is it worth replacing? The unit is only about 1 year old and has seen light use only. Very frustrating, since it was the most expensive unit in the store:(


... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

I have a new scoba (irobot) the battery is charged the tanks were fillied and every time i hit the power button and then clean the machines "check the tank" light came on. i have done all the proper instruction checks an i have done all the trouble shooting section. the machine will only work (and that is for 5 minutes drying its head) when i hit power and the clean button twice. so obviously the machine is somewhat working


We had to prime the sensor. irobot suggested a turkey baster, but we didn't have oneso we used an empty visine bottle with the end snipped off and rinsed completely. this worked after the first try. thank you for your interest ... iRobot 5800 Scooba Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0781 seconds