Having problems with your Kenmore 23812 Progressive PowerMate Bagged Canister Vacuum ?

Vaccum does not seem to have good suction replaced bag & hose is clear

\015 The vaccum does not seem to suck well. It sounds like there is an obstuction. I Have checked the hose, it is clear and there is a new bag on. Usually if the bag is full ort here is blockage the red performance light comes on, but that is not happening in this case. Is there another filter on this thing? If so where is it?\015

Answers :

Repair Help & Product Troubleshooting for Kenmore 23812 Progressive PowerMate Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Vaccum does not seem to have good suction replaced bag & hose is clear

... Kenmore 23812 Progressive PowerMate Bagged Canister Vacuum

No suction I just replaced the bag, and normally after this I have a lot of suction. Now that I have changed the bag I have less suction that I had before. Not even enough to picj up dog hair. I snaked he hose and checked all of the connections. It seems to have an air leak but no amount of tape will fix this. I cleaned the filer as well with warm water and dried it and re installed but still absolutely no suction. I am ready to throw it out! Any suggestions would be appreciated

1, Does the blower (discharge) side blow bunches of air??Yes: Something is clogged from the bag to the hose end. Try blowing out the hose from the discharge side.Or: The bag is not properly seated. Make sure that the plastic piece is ... Kenmore 23313 Whispertone Bagged Canister Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!

... Miele Vacuums

Kenmore progressive vacuum model: 116.25614506, I replaced the bag and filter and now it seems to **** the bag up against the hose outlet with very little suction at the hose end

... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

Burning smell took everything apart suction is working throughout hose and bag, replaced bag and belt, roller is turning seems to be missing the suction from the main floor section into the roller?

I had burning smell and some visible smoke which I tracked down to the handle area. The mains socket at the bottom of the handle had burned out. When I pulled the plug out I noticed that the prongs were blackened and scorched. I will replace the sock ... Oreck XL Ultra Bagged Upright Vacuum

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?

As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

Poor suction I have a hoover hush s5627 vacuum purchased about 4 years ago from Costco. It's suction power isn't so good anymore. I've checked all the lines & hoses and they're clear and I've changed the bag. I even disconnected the pipe from the vacuum unit and held my hand over the intake. While the machine roars like a jet engine the suction power just ain't like it used to be. What could possibly be the problem?

This vaccuum has a Fan Blade inside connected to the motor that spins to create the suction you feel. After a few years of use (and misuse) the blades on this (plastic) fan will be broken off, thus damaging the unit. These Fans are replaceable if yo ... Vacuums

Where do you hook the clear hose that is in the compartment with the motor ? Second where the vacuum hose connects to the bag it keeps cutting in and out of power. I replaced the female cord to motor and still cuts out."no suction "

Would you care to tell us the make and model of the vacuum you're asking about? ... Vacuums

Suction power greatly diminished . Bag replaced...hose is clear...Performance indicator light is on and red..much less suction that it should have'

Clean the filter. ... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

My versatility electrolux vacuum is 2 years old and it has lost its suction, i have replaced the filters and checked every hosing area i have access to, it seems to all be clear. I dont know what else to do, it has a higher pitched whinnig sound when it is on

It sounds like the fan blades have worn away until there's basically no air resistance, thus no air flow/suction. The whine is created by the motor turning at a higher speed due to lack of resistance. \015\012The fan wasn't covered by the wa ... Electrolux Vacuums

We have two of these vacuums and both of them have experienced the same problems. First the floor heighth adjustment doesn't work and now neither one will pick up on either carpet or floor when in the brush/floor mode. They both seem to work with the suction hose function. We have removed the back panel to see if there was an obstruction but it was clear. We have changed the bag and the small filter (not the HEPA filter) all to no avail. What else can we do? We are desperate to use our vacu

Did you check the powerhead for obstructions? With a bend in the tube just below where the hose connects, this is a common spot for clogs. To check, detach hose and drop a coin in the hole. If it doesn't drop through, a blockage is present. Use t ... Electrolux Oxygen 3 Upright Vacuum Cleaner - EL5035 Vacuum

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But

Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

I have a power drive baggless vacuum cleaner...it runs well, but suddenly it seems to have lost most of the suction coming through the hose and floor area. When I remove the dirt container, the suction below it seems strong. I have had it to repair twice--they have tuned it up and replaced all filters and belt. It still does not pick up well when I vacuum or use the hose. Can you help ?

There is something stopping it up,you will have to dissasemble the unit to find the blockage,this is the most likely problem. ... Hoover U6660-900 WindTunnel Bagless Upright Vacuum

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

My Eureka/The Boss doesn't seem to have the suction power it had. However, when I place my hand under the hose, it has good suction, then when I try to pull in a small particle, it doesn't, unless I have the hose nozzle completely over the particle. The vac is 10 yrs. old. I cleaned everything. Someone said the belt. Would the belt matter if the hose doesn't **** well? It is just old and worn out? It did shut off recently do to overheating. Help. Thanks. Lorraine

Doesn't "The Boss" Vacuum have a filter? Perhaps your filter is clogged and not allowing it to work properly. ... Vacuums

No suction I've only had my vacuum for a couple of months and it seem I have a similar problem but there is no clear blockage. It seems like I don't have adequate suction that reaches the accessory hoses nor the main one. I'm not sure where to start. I've taken the darn thing apart but I can't see any obvious malfunction. Any suggestions?

If you have low suction at the end of the hose, then you either have a clog in the hose or a clogged filter. Take the hose off and drop something in it to see if it comes out the other end. If you have suction at the end of the hose, then the dirt ... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

I cleaned out the hose and removed brush to clean and checked belt. Everything seems to work but will not pick up or suction on carpet. The hose is totally clear from clogs. I can see the floor from one end to the other. What am I missing that might be causing lack of suction?

Hi troupdavid,I see that your Vacuum is having issues with it suction, you mentioned that you took it a part to clean it, see steps below.\015\012\015\012Check if everything is inserted prope ... Hoover Tempo Widepath Upright Vacuum - Blue

Hi: We ahve a Tornado CV30 vacuum. The suction does not seems to be working properly. There is no suction at the tool hose and the bag does not seem to have air moving into it. Do you think there is a clog somewhere? The roller is moving. Thank you for youre help :) Kelly Branson, Mo.

To clear the clog, remove the hose and wand from the unit and separate them. The hose is\015\012released by pressing the white plastic ring in the housing. The two are\015\012separated by simply unscrewing them. Remember this threaded connection\015\ ... Tornado 93030 Wide Area Carpetkeeper Upright Vacuum

My old bissell 3510 upright vacuum seems to have no suction into the bag...I replaced a broken belt several days ago, and now the vacuum picks up debris, but seems to just collect it behind a wheel..The bag does not "puff out" like it used to...How can I fix this??

... Bissell 3510 PowerPartner Upright Vacuum

My new Kenmoore Powermate 116 canister has poor suction. I have no pets and light dust. Its not picking up small particles on the wood floor with the floor attachment. When I put my hand to the suction it feels weak. Cleared hose and changed bag. Using again, same issues. This should not be happening with a new vacuum. Is it a bad design in the elbow joint of the hose? I want to return this!!!!

First of all disassemble the handle and hose as much as possible and examine the inside. Make sure there is not any significant debris lodged in the hose somewhere like a plastic bag or something.\015\012\015\012Also check at the top of t ... Kenmore 23912 Progressive PowerMate Bagged Canister Vacuum

Bissell powerforce My lower pickup tube became clogged so I removed it and cleaned it out and reinstalled it.Now everything runs good but the vaccum want pick up any dirt .I replaced the bag andf when I turn it on it just exhaust air but does not have any suction,I tired tp pull the bag door of while it was running whick I could not do so it has plenty of suction inside just not getting any outside can you help?

... Bissell Vacuums

Vax 2400 performance pet. Suction too low/weak. changed both filters, but made no difference. hose clear although suction seems better without hose!

... Vacuums

My Dirt Devil M082476 Full Bag indicator light keeps coming on when I turn my vacum up to full intensity. I have tried changing the bag and checked that all hose is clear. If I leave the vacum on low intensity the suction is minimal and does not increas when I turn up the suction. Is there a solution to this? I look forward to your response

... Dirt Devil M084105 Jaguar Vacuum

No hose suction with replacement bag

The Bag must be blocking the port it connects to. Remove the bag and close it up. Test it again with no bag in it. If you have suction now, the bag is blocking the port. Maybe it is the wrong type, or installed wrong. ... Kenmore 28075 Bagged Canister Vacuum

My dyson DC24 has very poor suction - all filters clean and hoses seem to be clear. had it for just over a year

Hi there,I'm sorry to hear your DC24 doesn't seem to be picking up as well as it should be. From your description of the issue, it sounds as if there may be a blockage in the machine - to locate and remove this, please follow the steps shown ... Dyson Ball DC24 Bagless Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.5784 seconds