Having problems with your Kenmore 23913 Progressive PowerMate Bagged Canister Vacuum ?

My kenmore progressive canister vacuum won't start,any ideas, is there a fuse? it was on then just quit. I've checked all connections and made sure they are snug, and that it's still plugged in (!) model 116.


Answers :

Wire broken in several place along suction tubing. Replaced tubing and works fine
Repair Help & Product Troubleshooting for Kenmore 23913 Progressive PowerMate Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My kenmore progressive canister vacuum won't start,any ideas, is there a fuse? it was on then just quit. I've checked all connections and made sure they are snug, and that it's still plugged in (!) model 116.


Wire broken in several place along suction tubing. Replaced tubing and works fine ... Kenmore 23913 Progressive PowerMate Bagged Canister Vacuum

I have a Hoover SteamVac Spot/Deep Cleaner, model F5515. I've had it a little over 1 year. It will not extract dirty water from the floor. I've made sure the recovery tank is attached correctly and also that the stair tool is connected. Is there something else I can try??


... Vacuums

The power wand electrical connection on the power unit itself seems to be corroded. I think I need a new two wire plug to plug into the wand. the model is a Eureka 6984 A. I am able to disassemble the power unit if necessary and replace the wire and plug if one is available


Try hesco inc they have a on line store with all the vacs parts diagrams and fast shipping. ... Eureka Vacuums

Does the trivac 1100 have a fuse? My machine has suddenly stopped.I have checked the fuses in the plugs and also made sure that power is at the wall socket. I can see what loks like a fuse holder in the top of the machine near to the on/off switch but it is very tight so I want to be sure that it is a fuse before unscewing it. Thank you Jim


... Philips Vacuums

We have the GE sensor microwave WES1358DN1WW. It was made in 5/2009 & bought in July of 2010 brand new. it worked perfect til last week. i put something in it & it started to make a loud humming/vibrating noise. i assumed it was just something ontop of the microwaved & ignored it. 1 min later my food was still ice cold. we tried unplugging & plugging back in & made sure that it was clear of anything but it still makes noise & doesn't heat. GE charges $79 to look at it, & since the microwa


... Vacuums

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.


I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

Kirby shampooer The suds are not coming out of the shampooer. I made sure it was connected right. The sponge filter and the cap are attached. i have a g4 vacuum and the screen in in properly.. if i move at a snails pace i can get spots of suds about every 6 inches or so but not a lot. i have adjusted the on and off, if verified the video its put together correctly but it acts like no suction .. i thought of a small hole in the hose for the suds and cut off about 1 inch it act better but not by


On the shampooer tank, remove the screen cap from the little hole that the shampooer hose plugs onto. Clean the screen and make sure that it is not plugged up with debris. Make sure that the screen is securely glued to the cap all the way around the ... Kirby G4 Bagged Upright Vacuum

Power head attachment works great when plugged into the hose part of the vacuum. The problem is when I attach it to the tube for normal use there is no power. I have checked all the connections and switched the power switch on and off still no power from tube to power head. Is there anything else I can try? Model Callisto


Try having someone turn the machine on and off while you pull the cord in and out with the cord more angled towards the on/off switch. Sometimes these models have a break in the cord rewind and will not put the power through to the motor. ... Miele Vacuums

The power head of my Wertheim 3280 has simply stopped working. We have made sure that everything is connected properly.


... Vacuums

I have a Kenmore DuraPower Dual Cyclone Action 12 Amp that just randomly stopped right in the middle of vacuuming. I assumed the plug had come out of the wall so I went to check and this wasn't the issue. I tried multiple outlets and that wasn't the issue. I made sure nothing was stuck and there is nothing stuck. Nothing happens when I press the red "ON" button. What could this be? Thanks!


... Kenmore Vacuums

We have a black & decker bottom load water cooler. It has been continually running then stops and starts beeping. We have checked the connections, made sure the bottle is loaded properly. That the seal is tight and it still cointues to run and beep. Can you helpe me?


... Vacuums

Re. Proheat / Protech model No spray happens, I have made sure both the water bag is full & the cleaning fluid are both fully located, the water does seem to be getting into the carrier without having been sprayed.


Usually when it doesn't dispense water that means that the pump belt is worn. Here are the belts you need to replace and the manual:Biss ... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

NO POWER My Dyson DCO4 Absolute (purple&lime) won't' switch on. I've checked the plug fuse, wall socket and also filters and hoses on machine all seem fine so think the problem is with the on/off button (maybe loose wire or something) but how do i get to it, is there a special way to remove the green on/off button in order to check the connection? Thankyou in advance for the help i am sure you will be able to provide.


The problem is almost certainly a fatigue break in the flex. These usually happen where the flex enters the handle through the rubber sleeve near the on off switch. You will need to cut about four inches off the wire and reconnect it to the switch. ... Vacuums

I HAVE YOUR UNIT MODEL CD1493. THE POWER CORD PLUGS INTO THE BACK OF THE UNIT OK,BUT, IT A VERY WIGGLY CONNECTION. AS A RESULT THE UNIT OPERATES VERY INTERMITTENTLY. WHAT CAN I DO.


Hi,\012Try to spred the pins slightly so that they hold the plug more tightly...otherwise the only thing to do is to try and buy a replacement cord...\012\012heatman101 ... Vacuums

Replaced the pump and solenoid on my Bissell Proheat, model 9200 H, but not sure I got the tubing connected back right. Can anyone help me with this?


... Bissell 9200 Upright Vacuum

The beater assembly on our Majestic 360 is not working. We've pressed the reset button, checked the belt, made sure the connections were complete. Suction is reaching the unit. What's our next step? Thank you.


Check the power cord going to the unit with a volt/ohm meter. The wires break, UNPLUG and take plyers and slightly squeeze the female connections, and plug in again. ... Filter Queen Majestic Canister Vacuum

We have inherited a Filter Queen Majestic Triple Crown Model 99C vaccum and have no owners manual stating the year it was purchased and parts available. Our power hose electic wire connection (about 6 inches long) which plugs into the main unit is split in the hose attachment end. The motor sound went instantly quieter and I wondered if this was why when I found this frayed electical wire. It has not been used since this problem was found. How much is this single replacement part? I live


... Vacuums

Was vaccuming and vaccum quit. Tried unplugging and turning back on. Getting absolutely no power. unscrewed screw under handle and tried to make sure connection was being made. Don't really know what to do.


Ok..If you have a multimeter you can check plug fuse then switch and motor, if you put leads across the plug you will get some reading if its working.could be thermal cut out on the motor. ... Kenmore Magic Blue 24195 Bagged Canister Vacuum

My dyson DC17 will not turn on unless the handle is pulled back.(into the vacuuming position) The attachment hose will not work at all (0 suction thru it). I've checked the hose and made sure there is no obstruction. Any ideas?


Not sure if I can help, but I'll try. The DC17 has two motors: the vacuum motor and a separate motor for the brush bar. It is normal that the brush motor works only when the handle is pulled back in the vacuuming position - that's the way it's made. ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Kirby shampooer The suds are not coming out of the shampooer. I made sure it was connected right. The sponge filter and the cap are attached.


You may be missing the small round suds screen. It should cover the hole where the shampoo goes from the tank into the hose. It may be wedged sideways in the hose end. \015\012\015\012Marci ... Kirby Generation 3 Bagged Upright Vacuum

No suction i have a bissell lift off revolution vacuum. I have cleaned all the filters and emptied out the canister made sure that the hoses are not plugged but it will not pick up unless you use the hose. the floor brush is clean and still no suction coming from under the vacuum... could you help me please


Is there a blockage in the small hose in the bottom of the machine \015\012take of the pod and you will see the small hose, \015\012Is the main hose pushed into the bottom housing ... Bissell 37603 Upright Vacuum

Oreck Upright Hi Redev, I'm not sure what model I have (about 6 years old...upright, looks like the one in the picture). I changed the belt (which was torn) and then the next time I used it, it cut off on me. Now if won't turn on at all. (I turn the switch on and off and nothing happens as if it is not plugged in but it is!). I noticed at the top where the power cord enters the handle, it is all frayed. Could the electrical wires have detached? Anything you think I should check before taking it


The cord could be bad and will ahve to be replaced. It would have to have a problem inside the handle or down by the motor. ... Oreck XL2600 Vacuum

I have Hoover Floormate Model H3004. The machine will no longer dispense the cleaning fluid due to the trigger assembly not engaging properly with the inlet/outlet on the Clean Water Solution Tank. I have checked and made sure the tank was seated properly.


... Hoover Floormate H3000 Upright Wet/Dry Vacuum

I have a toledo model 5402 slicer and i'm not sure what it's called i think it's a capacitor do you know where i can find one it's a three prong plug


... Vacuums

My Lasko fan is a year old type wta, TP120 volt AC 60 Hz 0.38 amps... the tower turns on but it wont blow any air out... what could be the problem i already checked and made sure all the wires are still connected.


... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0681 seconds