Having problems with your Kenmore 25512/ 25513 Progressive Canister Vacuum ?

My vacuum cleaner stopped working without any smell or anything. I took to a local repair person and he said nothing wrong except motor he tried new hose, etc. And he wants to change the motor..


Answers :

I would go with the repair man and what he says. They know what they are talking about and if he was trying to rip you off he would have suggested many things to repair and then after you had spent a few hundred he would have told you to replace the motor. Instead he told you right away so my guess is he is honest and trustworthy. Iwoulds get the new motor. Just make surew to gat a warranty with it! good luck friend and dont forget ti click on the yes if this helped.
Repair Help & Product Troubleshooting for Kenmore 25512/ 25513 Progressive Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My vacuum cleaner stopped working without any smell or anything. I took to a local repair person and he said nothing wrong except motor he tried new hose, etc. And he wants to change the motor..


I would go with the repair man and what he says. They know what they are talking about and if he was trying to rip you off he would have suggested many things to repair and then after you had spent a few hundred he would have told you to replace the ... Kenmore 25512/ 25513 Progressive Canister Vacuum

Motor still runs--sounds like jet engine. do I need a new motor? or is there some sort of muffler that has malfunctioned? vacuum belongs to disabled mom---so trying to do work ourselves--cant afford much. dont see anything obviously wrong--but know nothing about electric motors.


This little vac I think is actually made by Samsung. If it is ROARING and vibrating, either the bearings or suction fan is in bad shape. Remove the lid as if to inspect the belt and see if there is a visible intake opening with a plastic fan rotatin ... Bissell 3590 CleanView Bagless Upright Vacuum

My lux 7000 has a new bag but when i start to use it with the power unit or without the unit shut's it self off i can reset the lites or the motor if you will by clicking the on off switch 4or 5 times and i'm ready to go again untill you start to work and off it goes you can repeat the switch thing as long as u want, it just won't let u vacuum ,it turn's it self off .I blew it all out but found nothing in it. if u don't try to vacuum it will run as long as u want to listen to it. Can you


Have you replace the afterfilter? It may also cause this if rather dirty. It's located under the tool caddy/air diffuser on the back half of the machine.\015\012Try this: Disconnect hose, turn on vacuum. Does it continue running? If so, pl ... Electrolux Lux 7000 Bagged Canister Vacuum

I was vacuuming and noticed that the bag needed changing. the red light with the ! inside the triangle also came on. When the bag was changed, the vacuum would not restart. The red light came on. Tried the reset button but nothing happened. Tried unplugging and re-plugging in and nothing happened. Replaced all the filters and still it wouldh't start. So I brought it downstairs and tried one more time to get it to start. it worked! Is there something wrong with the vacuum cleaner? Was it overheat


It was overheated that is why it worked downstairs after cooling off. ... Miele S548 Bagged Canister Vacuum

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?


Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

My new Kenmoore Powermate 116 canister has poor suction. I have no pets and light dust. Its not picking up small particles on the wood floor with the floor attachment. When I put my hand to the suction it feels weak. Cleared hose and changed bag. Using again, same issues. This should not be happening with a new vacuum. Is it a bad design in the elbow joint of the hose? I want to return this!!!!


First of all disassemble the handle and hose as much as possible and examine the inside. Make sure there is not any significant debris lodged in the hose somewhere like a plastic bag or something.\015\012\015\012Also check at the top of t ... Kenmore 23912 Progressive PowerMate Bagged Canister Vacuum

No I did not my hose on the dirt devil does not have much suction on it I took everything apart and found nothing wrong no clogs anywhere but when I add an attachment to the hose it loses all suction...I looked for a switch to change from regular vacuuming to attachment found nothing why is this??????? Need a manual where can I find some information and a download on line manual??????


Try this. There should be a little filter unerneath the tank. just clean that filter or replace it. (9 times 10) thats the problem.\015\012\015\012good luck. ... Dirt Devil Vision Turbo W/Bonus Upright Vacuum Vacuum

I have an Electrolux LITE upright carpet cleaner - about 15 years old. Suddenly last night when using it, from the normal motor (whooshing) sound, the motor suddenly went very slow and with a slight grinding sound. The brushes are now just turning round very slowly and areobviously not picking up anything. Has the motor gone or is this repairable, or should I just get a new cleaner? I have tried to open the machine from the bottom to see if anything is obviously wrong, but it looks complicated a


... Electrolux Vacuums

Our kenmore progressive model #11634922 was working fine today. And then - it's not. Plugged in - nothing is working on it. We let it cool down (though it didn't seem hot). Still nothing - no light, no motor. Tried it in some other plugs that we know are functioning well - and still nothing. Any idea what might be wrong with it? It's six years old but doesn't get heavy use. Thanks so much ~ Susan Golden


Hi, it could be a number of things, cord may be bad as well as a problem with the motor. There also is a fuse that could have blown. If you go to sears.com, click on parts, put in your model number, when the page loads, click on the first link ... Kenmore Vacuums

Loud noise I have a brand new Dyson and it is great on all my floors except one of my area rugs when it starts making this really loud vibrating noise. I am not sure why - nothing is stuck in the roller or vacuum and it doesn't make it on any of my other rugs. Also it is really hard to push whereas all the other floors it just glides. I don't want to return it but I also don't want to hear this sound every time I vacuum.


This is the clutch as it jams up in the brush. Usually happens with rugs that are not secured to the floor. ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

I want to put machine in my house but need 110 motor instead of 220. nothing wrong with motor or control box


I'm assuming that you brought a vacuum cleaner from a country that uses 220V to a country that uses 110V.You either have to change the motor to a 110V motor, or find a way of plugging the cleaner into a 220V supply.You could c ... Vacuums

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?


As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

Everything new central vac nutone vx 550 turns on and off by itself it trips the circuit breaker suction is great at times at other times there is no suction i had different inlets the suction was fine then went to half it compacity tried to change the inlets only changed one the system does whatever it wants to do


... Broan-NuTone VX550 Bagged Central System Vacuum

Won't start orange canister type,has change ba light hepa &motor filter,and power hose and beaterhead,put new filters in checkedthe hose,made sure it wasnt clogged


Take an AC VOLT Meter and place the leads of the meter where the power cord terminates,one on the white lead and one on the black. There should be 110-120 volts AC. If that is good then move one of your meter leads to the other side of the on switch ... Electrolux Epic 6500 Vacuum

I have a new Kenmore magic bued and I am about to change bags for the first time. Trying to do this the clip that is supposed to hod the bag close to the whole keeps coming off when I replace it and close the lid, turn on the vac the sucction is very low and it keeps showing the bag is full which is not true / what is going wrong here ? Thanks so much for supporting, Beba


Sorry to hear that you are having problems with you Kenmore Magic Blue.There is a so-called "bag full indicator", which will only turn red if it got some major blockage. This is the reason why there is no power suction.The "fu ... Kenmore Magic Blue 24195 Bagged Canister Vacuum

Faithful Sebo X1 upright, about 12 years old, stopped working today. I replaced old with new dust bag, checked all dust paths were clear, checked main brush was clear/clean, and drive spindle rotated OK with fingers. When power switched on, the two red indicators briefly flash on then off, but nothing more happens, motor does not start - even with power reaching machine. Tried removing all consumables, refitting and turning on a few times to reset, no joy. Removed base cover, both belts were i


At 12 years, this vacuum has had a good long life. I suspect the motor is shot, but it could be due to faulty wiring and connections. A bad switch, break in the power cord, and worn brushes in the motor are other causes.\015\012I recommend ta ... Sebo Automatic X1 Bagged Upright Vacuum

My Kirby G4 won't turn on. Everything is engaged as I normally do it, nothing is wrong with my power outlet, changed my hepa bag to a brand new one...


It could be a few different things. First make sure the emptor tank on the side of the unit is pushed all the way closest to the unit. ck to see if light comes on (that will tell you if you have power to the unit.) if so It is an internal problem. Or ... Kirby G4 Bagged Upright Vacuum

My Kirby G 2001 upright vacuum wont turn on. I tried another outlet and still nothing. I don't see a breaker switch anywhere. If you know of any common problems I would love to hear them. I am very mechanically inclined, I just was wondering if there are any common issues with the motors or power switches etc. so I don't waste a lot of time troubleshooting. Thanks


This might sound a bit silly but check to see if the cord is plugged into the machine correctly if it is check to see if the safety interlocks are all engaged. ... Vacuums

No spray My Bissell Pro Heat 7901 will not put out any spray. I Took the pump out so I could get at it and disconnected the hoses. I put the one on the input side and the other in a bottle of water. Put the belt on the pump and turned on the machine .Nothing at all coming out of the pump. Where can I get a new pump? Also the lever that goes to the little flapper at the top under the clear plastic piece on the front that connects to the knob that changes from tools to floor broke off. Where can I


Pump part number is 2107181, the diverter valve # 2136988. You can Bissell and they can tell you who may have parts near you, or you maybe able to order thru Bissell.com. Before you took it apart, were you getting water to spray out of the hose. I ... Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

No spray My Bissell Pro Heat 7901 will not put out any spray. I Took the pump out so I could get at it and disconnected the hoses. I put the one on the input side and the other in a bottle of water. Put the belt on the pump and turned on the machine .Nothing at all coming out of the pump. Where can I get a new pump? Also the lever that goes to the little flapper at the top under the clear plastic piece on the front that connects to the knob that changes from tools to floor broke off. Where can I


Search for bissell pro heat pump. bissell.com will not have it ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

At first when I tried starting my B & S I primed the motor and it ran for a few seconds and died. This happened twice. I drained the tank and took apart the cvarb and blew out the entire carb. Put it back together changed the plug and now nothing. Could it be that the priming diaphriam (#694395) has a hole and thus preventing gas to come up from the carb bowl?


Hi tifix1...\012Yes, that could cause your problem.\012I will offer a few more things to check and repair/replace, maybe there is a few things that you missed.\012Please take time to rate me\012\012Sounds like you have d ... Vacuums

Alto force 5000 pressure washer Q:- The motor cuts out and will not start again, I try changing fuses etc. Eventually it starts again? but for a short while before it cuts out again.


... Alto Vacuums

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after


... Vacuums

DYson DC07 not sucking properly when in upright mode. I have tried cleaning out pipes etc and even tried an old motor section I had in garage (replaced once under warranty as kept cutting out and they left old motor section here). Even the old motor section had same prob so this suggests its something in the rest of the vacuum cleaner (whats left after you have lifted off the green motor section and dust collection area if you see what I mean? Any advice weclome please.


Blocked filters ... Dyson DC07 Bagless Upright Cyclonic Vacuum

The hose is disconnected, new bag in unit, new filter, unit runs when hose is detached but immediately turns off when hose is attached but hose has no obstruction, etc.. i was told i need some sort of valve. HELP! I have birds, a cat and 2 large dogs and no vacuum :)


There is a vacuum hose that attaches inside the unit to a round clear plactic piece. In most cases you can simply cut the small vacuum hose and it will fix the problem. ... Electrolux Epic 3500 Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0895 seconds