Having problems with your Kenmore 28075 Bagged Canister Vacuum ?

No hose suction with replacement bag

\015 Worked fine for years. New number for bag --- "I" --- says it "replaces bag 50570" (correct number we bought for years)."Pulls" fine --- but no suction at hose. No apparent leaks. No blockage in hose...\015

Answers :

The Bag must be blocking the port it connects to. Remove the bag and close it up. Test it again with no bag in it. If you have suction now, the bag is blocking the port. Maybe it is the wrong type, or installed wrong.
Repair Help & Product Troubleshooting for Kenmore 28075 Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

No suction I just replaced the bag, and normally after this I have a lot of suction. Now that I have changed the bag I have less suction that I had before. Not even enough to picj up dog hair. I snaked he hose and checked all of the connections. It seems to have an air leak but no amount of tape will fix this. I cleaned the filer as well with warm water and dried it and re installed but still absolutely no suction. I am ready to throw it out! Any suggestions would be appreciated


1, Does the blower (discharge) side blow bunches of air??Yes: Something is clogged from the bag to the hose end. Try blowing out the hose from the discharge side.Or: The bag is not properly seated. Make sure that the plastic piece is ... Kenmore 23313 Whispertone Bagged Canister Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

Burning smell took everything apart suction is working throughout hose and bag, replaced bag and belt, roller is turning seems to be missing the suction from the main floor section into the roller?


I had burning smell and some visible smoke which I tracked down to the handle area. The mains socket at the bottom of the handle had burned out. When I pulled the plug out I noticed that the prongs were blackened and scorched. I will replace the sock ... Oreck XL Ultra Bagged Upright Vacuum

Kenmore progressive vacuum model: 116.25614506, I replaced the bag and filter and now it seems to **** the bag up against the hose outlet with very little suction at the hose end


... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

No hose suction with replacement bag


The Bag must be blocking the port it connects to. Remove the bag and close it up. Test it again with no bag in it. If you have suction now, the bag is blocking the port. Maybe it is the wrong type, or installed wrong. ... Kenmore 28075 Bagged Canister Vacuum

My hoover has no suction at the nozzle, though it has strong suction at the hose. This problem started after I replaced the vacuum bag for the first time.


There is a blockage behind the roller brush remove the roller plate and the roller and check the inlet hose for a blockage also remove the bag and chek the inlet to the bag for some type of obstruction. Don the Vacuum Doctor Alb, N.M. ... Hoover Tempo Widepath Upright Vacuum - Blue

Suction power greatly diminished . Bag replaced...hose is clear...Performance indicator light is on and red..much less suction that it should have'


Clean the filter. ... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

Where do you hook the clear hose that is in the compartment with the motor ? Second where the vacuum hose connects to the bag it keeps cutting in and out of power. I replaced the female cord to motor and still cuts out."no suction "


Would you care to tell us the make and model of the vacuum you're asking about? ... Vacuums

Vaccum does not seem to have good suction replaced bag & hose is clear


... Kenmore 23812 Progressive PowerMate Bagged Canister Vacuum

Kirby My Kirby is less than a year old.  It's suction is no longer strong. I tried cleaning the hose and even replacing the bag.  Do you have any other suggestions.  By the way, I have the Sentera model.  Thank You


Here is a link to my online troubleshooting guide. Hope it helps...\015\012\015\012http://r ... Kirby Generation 3 Bagged Upright Vacuum

Suction Hose The suction hose has cracked so the suction feature no longer works. I would like to replace it, but cannot find that it is a replaceable part. Hopefully someone else has a solution.


Go to0 http://www.thehooverstore.com/h3000.html there also is a parts break down. You can email them at ... Hoover Floormate H3000 Upright Wet/Dry Vacuum

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But


Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.


I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?


Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

Lost suction my DCO7 lost suction in the hose I started taking it apart and cleaning it and looking for clogs (probably more than I should have) and when I put it back together it has awesome suction in the hose but no suction in the base. It just pulls the pine needles up (christmas tree) but they never appear in the "bag" compartment and when I look they are just all gathered in a clump in the bottom by the brush.


Hi.\015\012\015\012Remove the sole plate turn the 3 plastic screws to unlock & lift off.\015\012\015\012Now remove the blockages that have accumilated from the oppening of short clear hose.\015\012Check you can turn ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

I have an old Miele canister vacuum and I do not know how to disassemble the hose to check for a clog. I think it sucked up a nerf ball the size of a ping pong ball. I changed the bag but it did isn't appear to be in the bag. The vacuum powers on but I do not have suction with the hose, and since the hose has hard plastic elbow joints I do not want to pry them apart and break it


Hi Emily: If you have the model number for your machine you may be able to find your manual on the Miele website. Check ... Miele Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.


Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

I have a power drive baggless vacuum cleaner...it runs well, but suddenly it seems to have lost most of the suction coming through the hose and floor area. When I remove the dirt container, the suction below it seems strong. I have had it to repair twice--they have tuned it up and replaced all filters and belt. It still does not pick up well when I vacuum or use the hose. Can you help ?


There is something stopping it up,you will have to dissasemble the unit to find the blockage,this is the most likely problem. ... Hoover U6660-900 WindTunnel Bagless Upright Vacuum

DYSON DC17 HOSE REPLACEMENT - Dyson DC17 Replacement Suction Hose, Part 911645-02


... Dyson DC17 Replacement Suction Hose, Part 911645-02

The hose inside the cloth bag is detached at the bottom. How do I replace the hose or do I need a whole new outer bag?


Hello, whgrayI was trying to help you out here. Maybe this will help some? I was going backto some customers that asked questions in the recent past and even fartherback. It appeared that no one answeredsome of them, So, I thought I would ... Kirby G4 Bagged Upright Vacuum

Bissell powerforce My lower pickup tube became clogged so I removed it and cleaned it out and reinstalled it.Now everything runs good but the vaccum want pick up any dirt .I replaced the bag andf when I turn it on it just exhaust air but does not have any suction,I tired tp pull the bag door of while it was running whick I could not do so it has plenty of suction inside just not getting any outside can you help?


... Bissell Vacuums

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?


As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

My new Kenmoore Powermate 116 canister has poor suction. I have no pets and light dust. Its not picking up small particles on the wood floor with the floor attachment. When I put my hand to the suction it feels weak. Cleared hose and changed bag. Using again, same issues. This should not be happening with a new vacuum. Is it a bad design in the elbow joint of the hose? I want to return this!!!!


First of all disassemble the handle and hose as much as possible and examine the inside. Make sure there is not any significant debris lodged in the hose somewhere like a plastic bag or something.\015\012\015\012Also check at the top of t ... Kenmore 23912 Progressive PowerMate Bagged Canister Vacuum

Wondering if the head is plugged up because it makes a sound like air is escaping somewhere. I've replaced the original cloth bag with a comparable "O" paper bag from Sears. I tried to see if there was a clog in the hose by placing a broom handle in the hose to see if something would loosen. I also cleaned the filter and the air filter. If the head is plugged, how can I fix it? We can't get the vacuum apart. Thanks.


I had this problem, but suction improved when the attachments were properly secured in their holders. ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

Hi there my dyson suffers from a lack of suction with of without the hose attached. we had our local repair man look at it and he replaced a hose in the head of the machine.i have replaced all the filters and ideas?


What about doing this:\015\012\015\012http://www.fixya.com/support/t2936439-dyson_suffers_from_lack_suction ... Dyson DC07 Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0686 seconds