Having problems with your Kenmore 31079 Upright Vacuum ?

My model # is 31075, I don't see it listed on this website, 31079 is the closest. The suction is almost non existant when I use just the hose around the edges of my room, I've checked the bag and filters, and for something plugging the hose, all is well in these areas, what else could it be?

Answers :

Repair Help & Product Troubleshooting for Kenmore 31079 Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My model # is 31075, I don't see it listed on this website, 31079 is the closest. The suction is almost non existant when I use just the hose around the edges of my room, I've checked the bag and filters, and for something plugging the hose, all is well in these areas, what else could it be?

... Kenmore 31079 Upright Vacuum

Wondering if the head is plugged up because it makes a sound like air is escaping somewhere. I've replaced the original cloth bag with a comparable "O" paper bag from Sears. I tried to see if there was a clog in the hose by placing a broom handle in the hose to see if something would loosen. I also cleaned the filter and the air filter. If the head is plugged, how can I fix it? We can't get the vacuum apart. Thanks.

I had this problem, but suction improved when the attachments were properly secured in their holders. ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

NO POWER My Dyson DCO4 Absolute (purple&lime) won't' switch on. I've checked the plug fuse, wall socket and also filters and hoses on machine all seem fine so think the problem is with the on/off button (maybe loose wire or something) but how do i get to it, is there a special way to remove the green on/off button in order to check the connection? Thankyou in advance for the help i am sure you will be able to provide.

The problem is almost certainly a fatigue break in the flex. These usually happen where the flex enters the handle through the rubber sleeve near the on off switch. You will need to cut about four inches off the wire and reconnect it to the switch. ... Vacuums

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!

... Miele Vacuums

Motor will not come on when hose is plugged in wall outlet. Green light is on, circuit breaker is on, changed bags even though 1/2 full, cleaned sec. filter. What is the problem?

... Broan-NuTone VX475 Bagged Central System Vacuum

Won't start. My son was using the vacuum & Didn't change the bag. The vacuum was making the full bag smell, but the light was't on & it didn't stop. I stopped him, changed the bag, checked the filter, closed the compartments & turned on the vacuum. Nothing happened. I checked to be sure that it was plugged in, that wasn't the problem. I've let the vacuum "rest" for several days, It still won't start. Any suggestions?

There is a reset button at the back of the powerhead. The user manual can be downloaded from the electrolux website, although I didn't find it very useful. There was some info on how to change the powerhead drive belt. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

I have a Kenmore 116.36932 (upright-bagless vacuum) that the motor protector by-pass valve has opened. I've clean out the area between the agitator brush where the flexible extension hose starts. There was some blockage there. I checked the rest of the system (extenstion hose, back filter area, pipe area to canister and area to side filter. I took the 2 filters out and the by-pass valve is still open. Where else could there be a blockage that I can take apart to clean and put back together

... Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

No power to sensor SR 12. I also have cleaned rollers and filters and bags. I have reset the handle. When I hit the power the check brush and full bag lights flash once. That is the only power that is getting through.The unit was in storage for a bit and got wet but its been drying off for a couple months. Is there something I can check or replace. Its a great Vac.

... Windsor SR12 Sensor Bagged Upright Vacuum

My shop vac is plugged. The hose is clear. The filter is removed. The filter bag is not installed. It still won't draw a suction. It sounds like it is plugged. The motor whines at a higher-than-usual pitch. What can I do?

Turn off the vac, take the head off of it and remove the filter paper. Inside, there's a white ball (bigger than golf ball, smaller than baseball) that's inside a cage. This is designed to keep water out of the blower when the vac tips over, and sh ... Vacuums

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But

Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.

I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

I have a Kenmore central vacuum cleaner model number c107 34601. We have emptied the bucket and shaken the filter out to clean it. There is a filter that is filthy so we shook it out into a bag but the cleaner still seems to not have great suction. I notice there is a similar cap to the outlets I plug the central vac hose into on the unit itself that doesn't power the nozzle when used. 1 - what is this for? 2 - Should I somehow remove the entire filter and if so - can you tell me step by step ho

... Electrolux Vacuums

I was vacuuming and noticed that the bag needed changing. the red light with the ! inside the triangle also came on. When the bag was changed, the vacuum would not restart. The red light came on. Tried the reset button but nothing happened. Tried unplugging and re-plugging in and nothing happened. Replaced all the filters and still it wouldh't start. So I brought it downstairs and tried one more time to get it to start. it worked! Is there something wrong with the vacuum cleaner? Was it overheat

It was overheated that is why it worked downstairs after cooling off. ... Miele S548 Bagged Canister Vacuum

I have an Eureka Enviro Vac, I have replaced the filter, cleaned the hose and it still won't pick anything up. The brush is turning and there is suction in the hose. What else can I check?

... Eureka Vacuums

Ive changed the filter and checked the hoses but vacuum doesnt pick up ...when its on the dust is being blown out the bottom of the vacuum....i took the canister off to test the suction its fine...also cleaned the filter ...help!

Have you check the roller brush and drive belt? It may be your belt has broke or is slipping and therefore not turning the brush.\015\012Turn on machine and power head see if brush is turning if it is put a small amount of pressure on the rol ... Kenmore Vacuums

I bought a Kenmore canister vacuum, model 116, in April 2007. This morning, the sound of the motor suddenly began to deepen, and I began to lose suction. Normally, if something is clogging the hose, the motor will wind up to a higher pitch, not a lower one. The filters are clean, the bag is empty, and I can't detect anything lodged in the hose. If this were a car's engine, I would say it's "lugging down". Any pointers?

Okay, bear with me. Is it possible you have a suction adjustment, dial somewhere on vac. Check and see and if it does, be sure it's all the way up. Also, try removing hose and run a broom handle fr. one end to the other...BUT be careful not to stretc ... Vacuums

We have two of these vacuums and both of them have experienced the same problems. First the floor heighth adjustment doesn't work and now neither one will pick up on either carpet or floor when in the brush/floor mode. They both seem to work with the suction hose function. We have removed the back panel to see if there was an obstruction but it was clear. We have changed the bag and the small filter (not the HEPA filter) all to no avail. What else can we do? We are desperate to use our vacu

Did you check the powerhead for obstructions? With a bend in the tube just below where the hose connects, this is a common spot for clogs. To check, detach hose and drop a coin in the hole. If it doesn't drop through, a blockage is present. Use t ... Electrolux Oxygen 3 Upright Vacuum Cleaner - EL5035 Vacuum

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor

On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

Bag full indicator light on only when I plug the hose back in...

Drop a marble or something similar through the hose to see if its clogged ... Bissell 3522 PowerForce Bagged Upright Vacuum

We just were vacuuming and it stopped as if we blew a fuse. I checked the breaker and it is on and plugged something else in the outlet with no problem but the vacuum won't turn on. Any suggestions?

You said you checked the main breaker but did you change the fuse in the plug ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

My vacuum is not picking up like it is suppose to, the bag is clean, there is nothing trapped in the hose, what else can I check?

<span style="FONT-FAMILY: Arial; BACKGROUND: white; COLOR: black; FONT-SIZE: 10.5pt">Hi,<br />Here is a tip that I wrote about my Bissel but I bet you have the same problem and the hose is clogged...<br /><br />Bissell Bagless ... Hoover U6476-900 WindTunnel Vacuum

The hand held attachment no longer has suction. The hose collapses when I try to use it. Have cleaned the vacuum thoroughly and the filter. This still happens. Ive taken all the parts off and cleaned in there too. What else can i do?

Hi, please ensure that the hose is fitted correctly into the base of the Dyson. If this becomes loose or detached the machine will not **** whilst using the hose. Also check that the u bend is fitted correctly. Finally check that the vent on the left ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Eureka 4467AV overheats and shuts down after about 3 or 4 minutes of operation. I pulled all the filters to assure no blocked air flow. I assume the motor is not getting enough cooling air but i can't figure out why. checked bag for blockages as well as hoses. could the thermal protection have gone bad?

... Eureka 4467AV Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0764 seconds