Having problems with your Kenmore 34721 Upright Vacuum ?

Unplugged vaccum hose and head of vaccum but still no vaccum what could be the problem


Answers :

If the motor is running and you have checked airway then you may need a filter
Repair Help & Product Troubleshooting for Kenmore 34721 Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Unplugged vaccum hose and head of vaccum but still no vaccum what could be the problem


If the motor is running and you have checked airway then you may need a filter ... Kenmore 34721 Upright Vacuum

I just got the majestic and it doesn't seem to have a lot of suction power- I ran water thru the hose and it drained out fine I also put the hose on top and blew it out. Could it still be the hose?-or does it sound like a bigger problem?


Did you change the filter cone? Clogged pores can and do inhibit airflow. Bent fan blades can be another problem. Holes, slits, and cracks, no matter how small, in the hose can result in reduced suction.\015\012And you should NEVER run water ... Filter Queen Majestic Canister Vacuum

Power head attachment works great when plugged into the hose part of the vacuum. The problem is when I attach it to the tube for normal use there is no power. I have checked all the connections and switched the power switch on and off still no power from tube to power head. Is there anything else I can try? Model Callisto


Try having someone turn the machine on and off while you pull the cord in and out with the cord more angled towards the on/off switch. Sometimes these models have a break in the cord rewind and will not put the power through to the motor. ... Miele Vacuums

My Dyson Animal is not picking up very well in the drive position. With the hose the pick up is still very good. I have had it for 2 yrs now with very little problems. I have cleaned out all areas etc pipes, the brush underneath and cant find any blockages. The noise of the dyson is the same as usual. Could you tell me if there is a part that it sounds like it needs?


... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

My central vaccum cleaner has no suction at all outlets even at the canister. The motor is still working and blowing air out the air release tube. What could be the problem


Check the filter in the tank. If this is dirty, the motor will still run, but there will be little to no suction. Rinse thoroughly under warm water, then allow to thoroughly air dry before replacing into vacuum. \015\012I recommend having tw ... Electrolux Central Vacuum

I have lost suction on my Bissell. It is also clogging in the Plastic tube that runs from the roller to the hose. What could have caused this? All filters have been cleaned, tube as well, but the problem still persists.


... Bissell 82H1 Cleanview Helix Bagless Upright Vacuum

The vaccum cuts out replaced the wand but still having the same issue - the powermate head is fine and does not appear to be causing the problem. I have two Kenmore Progressive Canister Vacuum and this is happening on BOTH


... Kenmore 25512/ 25513 Progressive Canister Vacuum

My Kenmore Progressive Direct Drive Beltless System Vaccum cleaner is making a loud noise by the filter and hose in the back of the vaccum and is not picking up. I have cleaned the hoses and the bottom of the vaccum where the agitator is located. Still it is not picking up dirt. What can i do?


... Vacuums

I recently lost power to the power head. Thinking the hose was not sending current to the head, I bought a new hose. It did not solve my problem. I have since noticed that a warning symbel is appearing that indicates what looks like a key with TA inside. The vacumn has good suction. Please advise John.


Hi\015\012\015\012Please check the link bellow to diagnose your problem…..\015\012\015\012http://home.howstuffw ... Electrolux Epic 6500 Vacuum

I have a kenmore vacuum cleaner model # 116.23612. When the hose is attached to the canister it runs, but if you remove the head to just use the hose the unit stops working. Is the motor dead or is there some type of reset or fuse. Could you please tell me how to test this. If so could you please send me instructions on how to replace the motor. Thank you in advance for your help, Tony


... Kenmore Vacuums

SEARS KENMORE CANISTER VACCUM, Model No. 107-23050, Volts 120AC, Type AV, Hertz 60, Amps 11: This is a small model vaccum with an on/off switch on the canister. The on/off switch has gone and the vaccum can only be used by plugging and unplugging it. I am looking for the replacement on/off switch part but Sears Kenmore has no listing for this vaccum or parts. I can't recall just how long ago it was purchased but could be 10 years (or more). As this model is perfect for the application neede


... Vacuums

My Hoover Steamvac Widepath will NOT pickup the water after dispensing. I checked the hose inside the cleaner, there was a cut in the hose so I put electrical tape and completely sealed the cut. Still will NOT pick up water. I can't find any other problems with the hose. Any suggestions?


HelloHere are some suggestions you might want to follow to solve this problemFirst double check if there are other cuts in the hose or any sort of blockage or clogging in the hose and be sure to remove any form of debris ... Hoover F6213-900 SteamVac Agility TurboPOWER Steam Vacuum Vacuum

The motor on my Epic 6500 works, the hose is sucking, but the power head isn;t working... I tried the sidestep power head and that one works. Ive opened and replaced the belt and that is fine. The bulb was already burned out and wasn't replaced so I cant tell if theres power to the head. What else could it be?


Connect the power nozzle directly to the hose and try.\015\012Check the terminals where the wand connects to the PN. If any are discolored or cracked, that may be the problem.\015\012Open the PN and check for loose or broken wires and co ... Electrolux Epic 6500 Vacuum

Fantom Canister The vacuum head light keeps going on and off as well as the suction.  I actually purchased a new head, at the recommendation of their service dept., and the problem is still happening w/the new head.  Any suggestions.


It sounds like you have a hose problem. You should be aware that the Fantom company went bankrupt many years ago. I know that the Fantom name was bought by another company and there may be Chinese units sold under that name, but service and parts ava ... Fantom Vacums Lighting Canister Vacuum

Need instruction/care booklet for my Bissell powerforce vaccum model #3522-5. Bacfk of vaccum hose is filled with dirt and when attachment is used, dust & dirt fly everywhere. I don't have the care booklet for the vaccum and need to figure out how to fix the problem. Thanks


... Bissell 3522 PowerForce Bagged Upright Vacuum

Roomba Stops I've had a Roomba for about 2 months. Lately, it runs for about 45 secs, then stops, makes a two-tone (descending) sound, and flashes the CLEAN button while the STATUS button is red. I've emptied the dustbin on it. Can you help? I am seeing the same problem on my roomba today. I cleaned all that I could., the brushes, the pins on the sides and all that and it still gives the same problem..Any other fix?


Run your roomba through a self diagnostic test. I have posted the link below. Tell me your findings.\015\012\015\012\015\012http://mysite.verizon.net/gsplews/Diagnositic-Tests_Proc.v.0.5.htm ... iRobot Roomba 4210 Bagless Robotic Vacuum

I was vacuuming and part of a towel got sucked up, but not into the hose, and now it isn't working. I turned it off, unplugged it, and the hose still works with the attachments, it is just the base


Http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=833476\015\012Generic problem for all Vacuums\015\012I was vacuuming and part\015\012Posted by melly648 ... Vacuums

I have a DC14. About a wk ago it was making loud sound and bar stopped turning. i unclogged everything....now the suction works great. However, the bar still wont turn. The belt inside is still intact and isnt loose. Several solutions suggested resetting the "Red" button...i have searched the vacuum over and over. there is NO red or any other color reset button. The bar is set down perfectly in there, the cover plate is installed properly. What other problems could there be? Or do i just need to


... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

I am charging Remington Shaver FS360 for the first time I have put in charge for almost 12 hrs (the instruction is to charge it for 24 hrs at the first time) but still the charge led is not glwoing. I am not sure wheather it is still charging or not. Could you please help me out to figure out the problem.


... Vacuums

Dyson dc17 hose will not come out/ handle wont release from machine. i've pulled the metal rod up all the way and the handle still won't come away from the machine so i can't use the hose and attachments. anyone know what the problem might be?


Hi there, it is possible that you have a blockage in the wand/hose assembly which is making this difficult to remove. If you are able to remove it to check for this, please contact our Helpline on 1866MYDYSON so that one of our advisors c ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

My kenmore progressive canister vacuum's power head has stopped working. When I check for suction from the hose, it seems strong. Could it be a belt has broken? Is this a repair that I could do myself? Thank you!


... Kenmore Vacuums

When I was using my Bissell ProHeat 7901, I smelled something hot (almost burnt) and turned off the vaccum. When I turned it back on, everything seemed to be working, but the vaccum part was not making the same sound. The bristles are still turning, but it isn't picking up as much and is leaving quite a bit of lint on the carpet. Could the belts be worn? How do I tell? Thanks!


Ya that is probably the issue. Here is a link to the belts you need and to the manual which has instructions:Bissell ProHeat Belts and M ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

My sebo 1.1 has a red light flashing, indicating bag needs emptied or clog. There is plenty suction with the hose attachments, and I cannot see any blockages in hoses etc. Some of the dirt seems to be collecting in the small flap in the base of the hoover. Any tips as to what could be the problem would be gratefully received


... Sebo Automatic X1 Bagged Upright Vacuum

I have a modelF5914-900 steamvac cleaner.serial #0704 0011 4711 I cleaned the carpets in my house and then started to do the stairs with the stair attachment. I got down to the last four stairs and the solution would no longer come out. I checked the tank and hose connection and tried priming the pump per the instruction manual. nothing worked. Could you make a suggestion as to what the problem could be? Thank You


Check fuses goin to the pump, is the pump working? if so you may have an air pocket or a air leak in the intake. ... Vacuums

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.


Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0866 seconds