Having problems with your Kenmore 34723 Grab-N-Go Upright Vacuum ?

The Kenmore grab n go was sucking fine and then stopped sucking.


Answers :

Repair Help & Product Troubleshooting for Kenmore 34723 Grab-N-Go Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

The Kenmore grab n go was sucking fine and then stopped sucking.


Did you check to see if it is clogged? ... Kenmore 34723 Grab-N-Go Upright Vacuum

The Kenmore grab n go was sucking fine and then stopped sucking.


... Kenmore 34723 Grab-N-Go Upright Vacuum

My Bissell 3760-1 has stopped sucking in the roller portion. The grab n go part are working fine. Checked the belt and it looks fine. Did I burn up the motor or a microchip?


Hey Lisa! Sorry you're having difficulty with your Lift-Off vacuum. Here's a link to troubleshooting steps to assist you with the suction.\015\012http: ... Vacuums

Hi good day, I have a Kenmore Grab n Go 12.0AMPS Vacuum cleaner, Model# 116.34722402 & serial#T53601507. The vacuum is now having a problem whereby the rolling brush underneath is not spinning when the vac is on. This has caused it to stop sucking up dust. Could you please advise as to what might be the problem. Thanks in advance for your kind assistance. regards, Clarance


... Kenmore 34722 Grab-N-Go Upright Vacuum

I was given a Kenmore Intuition Vacuum Cleaner the motor works fine but the brush won't turn it had grabbed a piece of carpet and stopped could it be the overload switch?


Hi think your fan belt has come off ... Vacuums

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?


... Kenmore 34722 Grab-N-Go Upright Vacuum

Suction stopped. Roller and belt working-in fine order. Checked hoses have not found any blockage. Blowing out air or sucking so little can't feel it with hand on hose end. Help!


Either a blockage or the main air filter is blocked , some it can be washed and others it must be replaced I would check the owner manual and look at the filter, foam ones can and usually have instructions where they install to wash them. ... Hoover Tempo Widepath Upright Vacuum - Blue

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

My vax power 8, 2200 watts 300 air watts 4L capacity upright Hoover is brand new, I emptied out the dust/dirt collecter and cleaned the motor filter yesterday for the first time, i switched it on and all fine, the brush is spinning and the hose is sucking, put the Hoover to work it's fine for about 30 seconds then then suction stops and its dead it won't collect no more, so switched off taken apart again and the motor filter is blocked and full of dust, so I unblocked it, do the same process aga


I had the same problem. It looks like the seal on the lid on the bottom of the cylinder has fallen out when it was emptied. There is no longer a proper vacuum being created so you don't get the cyclone effect and the dirt doesn't collect where its su ... Vacuums

The rotatory brush stopped turning after sucking rug fringe onto it. The belt looks fine. The suction is fine.


Found on website "dysoninfo.com"A problem I have run into a couple of times at home, generally when I am cleaning the bathroom, is that my Dyson brush won't turn. First off I would say be sure to check that you haven't press ... Dyson Vacuums

Unbeknownst to me, someone took the bag out of my Kenmore Progressive vacuum and failed to replace it. I have been vacuuming without a bag for months, and today the vacuum stopped sucking. When I opened up the front to replace the bag, tons of dirt and dust came pouring out. I thoroughly cleaned the vacuum, put in a new bag, but still no sucking power. Just dust coming from the rear vents where one of the filters is. Is the vacuum ruined, or is it a simple solution of buying a new filter?


Sounds like you need to buy a new motor. All that grit and dust will ruin a motor and I'm surprised it lasted as long as it did.\015\012This is where a vacuum that won't run without a bag would have been nice. (Aerus for one) ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have an older kenmore canister powermate 3.9 and the vacuum itself works fine but the powermate isn't sucking after a toy was sucked up last week. The toy is out but the powermate doesn't work. I assuming that is what it is called. The big long part that hooks to the canister that actually cleans the carpet. I would appreciate any help.


... Kenmore 25512/ 25513 Progressive Canister Vacuum

I have a Kenmore 385.19110 model machine, and the straight and zig zag stitches work just fine, but when I follow the directions in the manual to do a satin stitch (which is use the lowest stitch length) it creates a line that isn't perfect, or uniform, and after an inch or two stops catching the bobbin underneath. Have already tried reinserting the bobbin, rethreading the machine, refilling the bobbin, changing the bobbin, cleaning the needle, changing the tension. Wondering if I just got a mac


... Vacuums

I have a Kenmore upright progrssive intell clean. For some reason it isn't sucking when I use it to vacuum. When I use attachments they work fine, but when I plug the hose back in after using the attachments and turn it back on it makes a weird noise and I can feel air blowing out of the back. Can you help me resolve this problem?


You have the answer and just don't know it. You are there so keep looking. Somewhere between where the suction hose connects with the lower hose and the power-head. There is a blockage, you may need to turn the unit upside down and look there or try ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have a Kenmore canister 'hose 360 swivel' vaccum. It is very new; it is not self-propelling anymore, nor is it sucking. The brushes work great and are rotating just fine. Help!


... Kenmore 27814 Bagged Canister Vacuum

I have a Kenmore progressive bagless vacuum with direct drive that was working fine but then the Inteliclean Technology just stopped working. Lights stayed green even though it should of been red.


... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

My Kenmore vacumn won't turn on . worked fine one minute then stopped. The light works on the handle but no vacumn


You probably have a sensor that needs attention and is clogged up so unclog and see if that takes care of it ... Kenmore Vacuums

Stopped sucking after changing the bag - Kenmore Magic Blue 24195 Bagged Canister Vacuum


... Kenmore Magic Blue 24195 Bagged Canister Vacuum

Hello! I have a Kenmore Progressive bagless vacuum with the Easy Clean extended life filter. The model number on my vacuum is 34728401. I was vacuuming the carpet when it just stopped running. The dirt sensor light will come on, but nothing else. The belt looks fine, and I don't see anything keeping the beaters from rotating. Help Please!!!


You can have power to the dirt light sensor, but it seems like the motor itself is not using the power supplied. ... Vacuums

My Hoover Steamvac is not sucking, it is blowing the air outwards. I was using it it was fine, then I emptied the dirty water tank (not the 1st time) and then it stopped working. Help please, I have taken both tanks off and checked their positions repeatedly


... Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum

My Hoover stopped sucking! If I use the attachment for stairs that works just fine, but in the upright mode for carpet it won't **** at all.


The tube in the power head probably has either a clog or a leak/crack. Since the hose attachment works fine, then the hose should be clear. You may be able to clear it without much difficulty, but replacement should be done at the Hoover shop. ... Hoover F5872-900 SteamVac Wet/Dry Vacuum

I have a Kenmore upright progrssive intell clean. For some reason it isn't sucking when I use it to vacuum. When I use attachments they work fine, but when I plug the hose back in after using the attachments and turn it back on it makes a weird noise and I can feel air blowing out of the back. Can you help me resolve this problem?


Open this manual to page 18 and clean all the filters listed to restore air flow.http://www.managemylife.com/mmh/lis_pdf/OWNM/L0908343.pdf ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

Using a Hoover Steamvac to clean my carpets. It works fine in some areas, but others it makes a clicking noise and stops sucking water. Once I turn the vacuum off and wait a few seconds, it clicks once more and is okay to use again. Certain parts of my carpet this happens so frequently I can't vacuum.


1)clog in the hose or air/tank full you must , need replace or emptied,test the belt for broken or worn.2) noises can be area motor , test for fan blade defective or broken3) You must go http://hoover.com/support/video-instruction-guides/ for ... Vacuums

Bissell ProHeat Pet Makes a popping sound and stops sucking up water


... Vacuums

I have a windsor vsp 14, it is making a bad grinding noise, when I take the top blue piece off it stops, the brush works fine and when I put the top back on it grinds really loud and gets hot. it still vacuums and the belt and brush are working fine, can't figure it out. and when the lid is on I cant see what its grinding on. It only makes a grinding noise when you pull handle back and engade to vacuum flor and stops when you put it upright.


... Windsor VS14 Versamatic Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0595 seconds