Having problems with your Kenmore 35912 / 35913 Progressive Upright Vacuum ?

Everything seems to be working fine except it has no suction. I changed the bag and filter, but still nothing.

Answers :

Probaly a clogged suction tube, unplug the vacuum first then tilt the vacuum upside down and see if you can see a clog .On the back side of the brush it will be kinda funnel shaped and that leads to your suction tube . That is the most common place for a clog.
\015\012Rate my answer with the thumbs..........Thanks
Repair Help & Product Troubleshooting for Kenmore 35912 / 35913 Progressive Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Everything seems to be working fine except it has no suction. I changed the bag and filter, but still nothing.

Probaly a clogged suction tube, unplug the vacuum first then tilt the vacuum upside down and see if you can see a clog .On the back side of the brush it will be kinda funnel shaped and that leads to your suction tube . That is the most common place ... Kenmore 35912 / 35913 Progressive Upright Vacuum

I was vacuuming and noticed that the bag needed changing. the red light with the ! inside the triangle also came on. When the bag was changed, the vacuum would not restart. The red light came on. Tried the reset button but nothing happened. Tried unplugging and re-plugging in and nothing happened. Replaced all the filters and still it wouldh't start. So I brought it downstairs and tried one more time to get it to start. it worked! Is there something wrong with the vacuum cleaner? Was it overheat

It was overheated that is why it worked downstairs after cooling off. ... Miele S548 Bagged Canister Vacuum

I have a Eureka Contour model 2900 type A upright vacuum, the roller works fine nothing clogged, took it apart motor blade is free of debris, no suction from tube and blasts OUT air from the front HEPA filter location. New bag, New belt, nothing in hose.any clues as to why this can be happenning? Air should not be blasting out of the HEPA filter.

Even with your explanation,it seems the hose is clogged.Try taking the hose off,then blow through it or pour water through it.If this doesn't do it,make sure the suction canals are going to the proper areas. ... Eureka 2900A / 2901A Contour Bagged Upright Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!

... Miele Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

We have two of these vacuums and both of them have experienced the same problems. First the floor heighth adjustment doesn't work and now neither one will pick up on either carpet or floor when in the brush/floor mode. They both seem to work with the suction hose function. We have removed the back panel to see if there was an obstruction but it was clear. We have changed the bag and the small filter (not the HEPA filter) all to no avail. What else can we do? We are desperate to use our vacu

Did you check the powerhead for obstructions? With a bend in the tube just below where the hose connects, this is a common spot for clogs. To check, detach hose and drop a coin in the hole. If it doesn't drop through, a blockage is present. Use t ... Electrolux Oxygen 3 Upright Vacuum Cleaner - EL5035 Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos

It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u

Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

I have a mile tt2000 that works fine up to 1300W but if I crank it up higher the motor decreases and increases speed every couple of seconds. I have changed the bag and filters and done the usual cheCks for blockages but can find nothing amiss. Unusually when it is running and I block the intake it will run at full power but as soon as I clear it the motor "hunts" again. Any ideas.

... Miele Cat & Dog 326i Bagged Canister Vacuum

Electrical smell, before drop in suction that comes and goes. Working fine till then, happened after I changed from a full bag to empty one. It seems that the motor might have packed up, but why so suddenly? Can it be repaired, as suctionwas v. good till now. Thankyou.

As above, most likely the motor brushes. They cost around 14 plus vat and take 30 mins to fit ... Numatic Henry Bagged Canister Vacuum

Our kenmore progressive model #11634922 was working fine today. And then - it's not. Plugged in - nothing is working on it. We let it cool down (though it didn't seem hot). Still nothing - no light, no motor. Tried it in some other plugs that we know are functioning well - and still nothing. Any idea what might be wrong with it? It's six years old but doesn't get heavy use. Thanks so much ~ Susan Golden

Hi, it could be a number of things, cord may be bad as well as a problem with the motor. There also is a fuse that could have blown. If you go to sears.com, click on parts, put in your model number, when the page loads, click on the first link ... Kenmore Vacuums

No suction I just replaced the bag, and normally after this I have a lot of suction. Now that I have changed the bag I have less suction that I had before. Not even enough to picj up dog hair. I snaked he hose and checked all of the connections. It seems to have an air leak but no amount of tape will fix this. I cleaned the filer as well with warm water and dried it and re installed but still absolutely no suction. I am ready to throw it out! Any suggestions would be appreciated

1, Does the blower (discharge) side blow bunches of air??Yes: Something is clogged from the bag to the hose end. Try blowing out the hose from the discharge side.Or: The bag is not properly seated. Make sure that the plastic piece is ... Kenmore 23313 Whispertone Bagged Canister Vacuum

Won't start. My son was using the vacuum & Didn't change the bag. The vacuum was making the full bag smell, but the light was't on & it didn't stop. I stopped him, changed the bag, checked the filter, closed the compartments & turned on the vacuum. Nothing happened. I checked to be sure that it was plugged in, that wasn't the problem. I've let the vacuum "rest" for several days, It still won't start. Any suggestions?

There is a reset button at the back of the powerhead. The user manual can be downloaded from the electrolux website, although I didn't find it very useful. There was some info on how to change the powerhead drive belt. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

My hose no longer works no suction buth the vacuume still works how do i fix I checked the hose checked the filters nothing works to get my hose so it has suction.

Check the following after unplugging the power cord from the outlet.\012\012- Check for suction at the back of the unit, after removing the hose where it attaches to the back of the vacuum. If there is NO suction, the machine will need to be ta ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

Oreck XL21 just will not work at all any more. Beater is clean - belt is fine. Fresh bag - inflates. Took the thing apart - checked for blockages at intake, bag entry, and the tube. It just doesn't vacuum anything. No suction at all for anything stronger than air. I'd say it doesn't ****, but that would be ironic. Are these known for just "quitting" after a while? We take it in for maintenance as recommended to replace filters, etc. Is there some miracle trick to make it work or sho

Did you make sure the brush turns freely? Even though it is clean, if it does not turn freely with the belt, it will not beat the carpet and pull debris up into the unit.\015\012\015\012Another (drastic?) thing to try would be to take the unit ... Vacuums

Low suction The beater bar still spins fine, but the suction seems low. I have cleaned all of the filters, but it is still too low to spin a lot of the attachments.

Hi Megan,I'm sorry to hear you're having difficulties with your DC17. If it doesn't seem to be picking up as well as usual, you may have a blockage somewhere in the machine. To check for this, please follow the steps shown in our online suppo ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

I was just using my Bosch 1450W bagged vacuum and all of a sudden, the motor just shut down. No warning, no problems. The light still turns on, but the motor is unresponsive. There is a clean bag and filter, and nothing caught in the front roller. The motor sounded fine - no shaking, or weird frequency variations. There were no weird smells, just a little bit of heat, but nothing beyond normal. I've had this thing for several years, and never had a bit of trouble with it. Any suggestions

Many vacuums have internal thermal switches that need to cool to allow the vac to operate. After 30 minutes, check all 3 air filters and try again.\012Gary ... Bosch BSG71310UC Bagged Canister Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.

Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

Won't work My Eureka Mighty Mite 3670 Bagged, was working fine, and we unplugged it to switch to another outlet in another room and it just stopped. We tried several other outlets and it just won't turn on. We thought maybe it got hot because we had been using it for a while and we let it rest for a while and then changed the bag just to be sure, although it was not full. But it still will not turn on. Any ideas?

Http://geeksquad.fixya.com/ThreadView.aspx?prdid=12151&thid=646957\015\012Won't work (by 2 users)\015\012Posted by AndiR on Jun 04, 2008\015\012My Eureka Mighty M ... Eureka Mighty Mite 3670 Bagged Canister Vacuum

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.

I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

I have a Kenmore central vacuum cleaner model number c107 34601. We have emptied the bucket and shaken the filter out to clean it. There is a filter that is filthy so we shook it out into a bag but the cleaner still seems to not have great suction. I notice there is a similar cap to the outlets I plug the central vac hose into on the unit itself that doesn't power the nozzle when used. 1 - what is this for? 2 - Should I somehow remove the entire filter and if so - can you tell me step by step ho

... Electrolux Vacuums

Electrolux oxy 3 vaccum has stppoed working and all three blue lights flashing My electrolux oxy 3 ZO6330 stopped working suddenly and all lights are flashing. I've changed the bag and filter and its still not working. Any ideas??

... Electrolux Vacuums

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But

Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

Hi there, I have an electrolux mondo (375W suction) vac cleaner.I hoovered 1 room switched it off then when I tried to turn it on again nothing happened.I have changed the bag and the fuse in the plug but still nothing... fiona

... Vacuums

Lost suction I've only used this vacuum a few times, it's practically brand new. Now, one I turn it on, it sounds fine, and the hose feels as if it's getting some suction, but it's not strong enough to actually **** things up from the carpet into the canister. I have completely emptied the canister and bought a new filter. Nothing seems to help.

TOSS IT and forget it! I have never used a hand vac that worked that was worth the effort of turning it on .... I suggest they are all junk ... I found very few vacuum cleaners ... actually **** especially anything made by dirt devil ... I do have a ... Dirt Devil Vibe AllPurpose Hand Vacuum Bagless Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1355 seconds