Having problems with your Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum ?

Rotator brush not spinning. Handle is not in the locked upright position. Says it's beltless, so is this likely an interlock switch or drive motor problem ?

Answers :

Hi, the brush roll will only spin when your handle is not in the locked upright position, once the handle goes upright - the brushroll de-activates
Repair Help & Product Troubleshooting for Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Rotator brush not spinning. Handle is not in the locked upright position. Says it's beltless, so is this likely an interlock switch or drive motor problem ?

Hi, the brush roll will only spin when your handle is not in the locked upright position, once the handle goes upright - the brushroll de-activates ... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

I have a Kirby Dual Sanitronic '50' Vacuum Cleaner I bought in 1966. The motor does not start when I attach the belt lifter of the rug nozzle. When I remove the rug nozzle and detach the belt from the motor fan shaft the motor starts when I depress the nozzle switch and the power switch . Seems like the brushes in the motor are worn out. I do not have a manual for this unit. Can you assist me as to what newer unit is this compatible to and the problem I'm having at present??

... Kirby Vacuums

I have a Hoover, Steam spin scrub, Model F5897-900. Only used it a couple times and the motor gave out. First started being noisy then a bad smell. It did seem noisier that what I would expect from the start but I didn't realize it was a problem with the shaft of the motor. I took it apart and found the motor shaft wasn't true and causing sparks. The motor looks like it can not be taken apart and repaired. This seems like a default from the beginning but it is past warranty. Also noti

You will have to replace the motor and the hose asm. thehooverstore.com may be able to help, or you should be able to find a repair shop that can order them for you. ... Vacuums

Bad Motor I have purchased two of the Kenmore direct drive beltless systems with Progressive systems. The first died after a year, the vacuum motor start making a grinding noies. I pulled the side HEPA filter and could see a fine coating of graphite like dust. Took it to a vacuum repair shop. They said the brushes were going and thus the motor was shot. I liked the vacuum and bought a second, 1 year later the motor is making a slight noise that and removing the HEPA filter I find a slight metall

That dust is from the carbon brushes on the motor. You may need to check them, and also clean out the motor compartment. A slight noise could be a motor bearing starting to go. Does the smell like rubber or electrical. If rubber, then the belt h ... Vacuums

There is no power...seems like a motor problem. The bag is clean...the mouth is clean the plug us in...NOTHING! I took mouth off and manipulated/pushed in that power press area that engages the motor on the front (not the switch on the back) and NOTHING! Not sure if motor died and/or what to do now. Help. I have had this baby for 15 years.

The front safety switch must be pushed in by either the hose or head (or manually), before the on/off switch will operate. The most common reason for no power is a bad cord. Second most common is worn carbons in the motor, and third is a bad switch. ... Kirby G4 Bagged Upright Vacuum

The beater bar motor doenst work when i push the bar button the bar button doesnt light up like power button how can i test bar motor or bar switch or what is the common problem wiyh this model I have 2 that dont work the same way

If it do not work ...and you already are on the second one that behaved in the same way it may be a problem with the power in your place and the cause it may be the main fuse...Im not sure where is located in this model but it has to be near the powe ... Vacuums

I have an Electrolux Commercial Upright vacuum Model U129C. It has a device which turns off the motor driving the beater bar if something gets stuck in it. There is a simple reset button to restart the beater after clearing the obstruction. Just recently on flat dense low pile surfaces the switch cuts in after just a few seconds and turns the beater bar off. This doesn't happen on high pile carpet but the motor doesn't quite sound normal. There is no obstruction - the beater bar can spin freely

The motor is having a problem.There might be two reasons...either the coils inside it got heated up which will be needing rewinding or you can buy a new motor or there r capacitors attached sometimes u can make a check on that also if that's gone Kap ... Vacuums

A problem. There is this littille mechanism on the top of my rainbow E vacume motor it is making a lot of sparks when it spins and there are two peices that have springs in them that are pushing like two flints i think. that are tuching the spinning thing. as you can tell i dont know what any af this stuff is called so please work with me.

Sounds like the carbon brushes. If they are sparkng, then either they are bad or the armature is bad, possibly both. ... Rainbow E series Canister Wet/Dry Vacuum

My Kenmore canister vacuum (model 11627515700) will not turn on. Although when I set it to CARPET the agitator does come on, however the vacuum still doesn't. Is it likely a motor or switch problem??

Your motor in the canister part of your vacuum is bad you can by a nee one for about $84..They have them used on ebay for $40. just type in Kenmore 116. The reason why your agitator is working is because your agitator has a separate smaller motor. Yo ... Vacuums

My nearly new Miele S710 vaccum cleaner just revs like mad when you switch it in but you get no suction. Could there be a drive belt between the electric motor and the vaccum pump that has come off or broken? How can I get at it, if this is the case?

Hi,\015\012\015\012Yes this could be a case due to which there is no suction. I am posting an article which gives you a detailed description of how to open it and repair the internal parts.\015\012\015\012 ... Miele Vacuums

I have a clarke bench grinder model 1002. I have a light that I would like to attach into the wiring though the grinder wiring in it's base. The light has two wires, and the grinder has a ground that is grounded to the base, a black that goes to a switch then to the motor. The white goes directly to the motor. where would I have to splice in the two wires from the light? I have a switch that I would like to put in for the light on off also.

Attach the white wire on your lamp to the white wire on the grinder.\012Attache the black wire on your lamp to the black wire on the motor side of the switch.\012This will give the lamp power any time the grinder is turned on.\012Yo ... Vacuums

Hoover WindTunnel S3765. The motor spins and the belt turns when I turn the brushes on, and the brushes will spin. The problem is that when I do this on carpet, the brushes stop spinning. As soon as I pull the "head" off the carpet, the brushes spin again. It's almost as if the vacuum suction is too great. I took the head apart and watched the motor turn the metal spindle that the belt rests on, and the belt turns as well.

The belt is stretched and needs replacement.(Belt # 38528036) . The brush is not turning against resistance. ... Hoover Vacuums

Dead motor? My 8 year old Miele S251i has worked fine, until I was recently vacuuming and moved the plug from one outlet to another. When I restarted the vacuum, it made rrrrr.....rrrrrr....rrrrr noises and smelled like something was burning. I turned it off, and it's shown no signs of life since. Sound like a motor problem? I've taken the cover off and looked at the cord and seen the motor, nothing looks obviously wrong, but I'm also not mechanical.

... Miele S251 Flamenco II Bagged Canister Vacuum

Motor/Fan does not run. I have removed and taken the top of the canister plastic motor housing apart and tested for power. I have power through the cord to the switch and power from the switch to the two wire terminals. I have not removed the motor. Looks like I will need special tools to take out the motor. The Vac looks almost new. It has been setting for several years. What do you think?

Sorry to read about your problem, I hope this helps you out.Well you can order a new motor at shop vac, check out this link.you dont have to remove to check the motor, just connect power to the motor leads ... Shop Vac QPMH450 Canister WetDry Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

BURNING SMELL My DC 07 has suffered from poor suction in the upright position for some time now but this morning it ground to a halt. It was if the motor had burned out. I turned it upside down and some small stones etc tumbled out. I tried switching on again and the motor kicked in but the smell was horrendous so i switched off immediately. If it's likely to be **** inside the motor area i don't no how to access it. I've removed for fixing screws but still unable to prise apart. Is it just the

Hi.\015\012\015\012Try this site http://dysonmanuals.llc.nu/ has service manuals covering removing the Dc07 motor. ... Dyson DC07 All Floors Bagless Upright Cyclonic Vacuum

My vax power 8, 2200 watts 300 air watts 4L capacity upright Hoover is brand new, I emptied out the dust/dirt collecter and cleaned the motor filter yesterday for the first time, i switched it on and all fine, the brush is spinning and the hose is sucking, put the Hoover to work it's fine for about 30 seconds then then suction stops and its dead it won't collect no more, so switched off taken apart again and the motor filter is blocked and full of dust, so I unblocked it, do the same process aga

I had the same problem. It looks like the seal on the lid on the bottom of the cylinder has fallen out when it was emptied. There is no longer a proper vacuum being created so you don't get the cyclone effect and the dirt doesn't collect where its su ... Vacuums

My dyson dc animal's brush is not spinning. The machine smells like burning rubber. I believe the clutch has gone out but the machine also only sucks from the top of the hose in the handle. I am wondering if the machine is not locking properly which is causing the brush to not need to spin. If this is the problem how do i fix this problem.

... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

I have an older Oreck XL vacuum that sounds like it is running twice as fast as it should. I disassembled the entire vacuum, including disconnecting the motor wires, to clean out the hair, string, and other things. When I put everything back and connected all the wires, everything appears to work, including the light. The only problem is, it sounds extremely loud like the motor is running too fast. The model number is: XL3610HH Ser. No. 3610HHXA039740-6 I do not have as electrical diagram to see

... Oreck XL Ultra Bagged Upright Vacuum

I have Nutone VX550C. Motor runs intermittently (cycles on and off rapidly--the light on the handle is blinking furiously) when I use the on/off switch on the hose. This happens at all of the wall connectors, so suggests a hose contact problem. Motor runs continuously when I turn it on at the switch on the wall unit.

The unit does have a switchs the PVC outlets, and it sounds like the hose mech to operate the switches is broken, and intermittently making contact. A replacement hose would likely fix the problem. Looked them up on the net, and they're not che ... Broan-NuTone VX550 Bagged Central System Vacuum

Switch Problem The red switch to put on wont stay on the motor runs but as soon as you release your finger from it the motor cuts out. what do I need to do to make it work as it should?

It sound like the switch is loose if you are able take the handle apart and plug the leads back into the switch. be sure to unplugit ffirst ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?

... Kenmore 34722 Grab-N-Go Upright Vacuum

My electrolux ambassador power wand quit working. I replaced the switch that shuts it off when the roller stops, but it wasn't the problem. The on/off switch is fine, the motor is fine. We have traced the problem to the wires inside the canister by opening the inside cover to the bag container. We see the power cords going into the canister but we're not able to get to anything. We can't find any screws to undo that would open it up in order to follow the wires deep into the canister. We've bypa

... Electrolux Vacuums

Motor wiring My Vax VS19TL motor died and I have managed to get hold of a new Vax 006 Turboforce motor which is the same size . My problem is that the original motor had two wires (black and white) which ran to the PCB switch. The new motor has three wires (black, white and yellow). I have ordered the PCB wiring loom for the 006 motor but I can't find any documentation that tells me where each wire goes. Can anyone help?

... VAX Appliances Vax X5 Bagless Upright Cyclonic Vacuum

Shopvac 90L400 quit working (4 years old). Thought the switch was bad but not the problem. I read that there is a fuse link in the motor that frequently burns up. I tried to take motor apart but not sure of the process. I was able to get to the motor but cannot pull it out of the armature. It appears I have to take the aluminum blower unit off the shaft (it appears to be pressed on with a retaining washer). Do I have to take it off to pull the shaft and motor assembly out? Is that where the fuse

By pass the switch and take power right to the motor leads.. that should tell you if the motor is ok.. have not seen fuse link on a vac motor.. graingers has new motors, but not inexpensive ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0985 seconds