Having problems with your Kenmore Vacuums ?

Check Bag light is lit? and when you power it up make a weird suction noise?

Answers :

Repair Help & Product Troubleshooting for Kenmore Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Check Bag light is lit? and when you power it up make a weird suction noise?

... Kenmore Vacuums

Weird noise i have a eureka the boss and i am getting a weird noise figured bag was full needed to change it so i did. Noise persisted so i checked make sure nothing was caught in the brushes. I even checked the belt it was fine replaced with a new one.Still the noise is there help me I am out of what else to check.

Squealing ... Vacuums

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos

It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

Samsung sc8442 vacuum - has lost its suction and makes a meduim to high pitched humming noise if turn up above halfway on the suction. this also makes the red light come on. I've cleaned the filter and checked around a bit but cannot find out why it's doing it...?

There are several filters. when you take the dust box out, you need to clean this filter as wellhttp://www.4ourhouse.co.uk/cgi-bin/finder.pl?ftype=443401&brand_change=&section=0&path=&hb=0&brandset=9925&model=10689 ... Samsung Vacuums

SEBO vacuum cleaner makes a strange noise and shuts itself off after a few minutes. Suction not working when tube is attached, but works with hand-held portion only. Indicator light saying bag is full/clogged is on, but we've cleaned out the bag, cut away any fur/strings that were wrapped on the turning portion, and cleaned out the refuse valve. Not sure what else to do. Thanks!

... Sebo Vacuums

Vax powa 4000 wet and dry - no suction Both power and pump switches light up. Pump makes clicking noise. Vac motor only powers up briefley when in switched on cindition and mains plug is being inserted into socket.

... Vacuums

My electrolux oxygen cannister has the "bag change" light on when there is a new bag. The light stays on when the suction power is high (to pick up small particles) and it won't pick up, but the ight goes off when the suction power is low (to pick up big objects). I changed the hepa filter, cleaned the motor filter and changed bags, but all that didn't help.

You may have a clog in the hose, and/or the inlet by the brush roll. A clog will turn on that light as well as a full bag. ... Vacuums

My hoover core plus is making a weird noise, the suction is practically gone and it sounds like something is stuck in there. i have cleaned all the filters and checked for blockages and can't find anything, im hoping someone can give me some advice!

... Vacuums

Was using my Miele Champagne vacuum, powered down, changed the bag, and now I have no power. I checked to make sure all lids were securely closed, still no power. Checked to make sure outlet was working, still no power...help.

Most likely the cord went bad, one side of it opened up, you will have to replace the cord reel asm. if this is the problem, Could also be a switch, electronic control or the motor. ... Miele Vacuums

No power to sensor SR 12. I also have cleaned rollers and filters and bags. I have reset the handle. When I hit the power the check brush and full bag lights flash once. That is the only power that is getting through.The unit was in storage for a bit and got wet but its been drying off for a couple months. Is there something I can check or replace. Its a great Vac.

... Windsor SR12 Sensor Bagged Upright Vacuum

Kirby Sentria Hi, I have a new Sentria & used it for the first time today. It was going fine & then I could smell smoke & it started to make a loud noise so I turned it off quickly. If I turn it on it immediately starts making the noise again & I can see it is all lit up inside like something is burning or sparking. I have checked the roller & it is moving & I have checked the fan which is moving & doesn't appear to be damaged in anyway. This product is from the US & we are in the UK & we are us

Sounds like the motor burned up. not sure if travel adapters will handle a large load like a motor, around 8 or amps. power needs in US are 110 volts ac, 60 hertz.I believe UK is 220 volts and 50 hertz. usually when a vac is brought to eu ... Kirby Vacuums

Won't start. My son was using the vacuum & Didn't change the bag. The vacuum was making the full bag smell, but the light was't on & it didn't stop. I stopped him, changed the bag, checked the filter, closed the compartments & turned on the vacuum. Nothing happened. I checked to be sure that it was plugged in, that wasn't the problem. I've let the vacuum "rest" for several days, It still won't start. Any suggestions?

There is a reset button at the back of the powerhead. The user manual can be downloaded from the electrolux website, although I didn't find it very useful. There was some info on how to change the powerhead drive belt. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Kenmore upright vac model 33922 - good suction but developed loud whining noise after accidentally vacuuming room without bag. Added bag and changed both filters. Still makes noise. How can I stop noise?

The bag is the first stage in your filtration. Most times what you did will draw fine dust right through the filters and into the motor itself, affecting the bearings and clogging the motor fans, throwing them off balance. The fact that there i ... Kenmore 33922 Direct Drive Bagged Upright Vacuum

Poor suction I have a hoover hush s5627 vacuum purchased about 4 years ago from Costco. It's suction power isn't so good anymore. I've checked all the lines & hoses and they're clear and I've changed the bag. I even disconnected the pipe from the vacuum unit and held my hand over the intake. While the machine roars like a jet engine the suction power just ain't like it used to be. What could possibly be the problem?

This vaccuum has a Fan Blade inside connected to the motor that spins to create the suction you feel. After a few years of use (and misuse) the blades on this (plastic) fan will be broken off, thus damaging the unit. These Fans are replaceable if yo ... Vacuums

Electrolux Hi-light Hi, my hoover is making a weird knocking noise and emitting a burning smell. Took the lid off and the belt *seems* okay, but still makes the noise and the smell....

Burnt smell is probably the belt slipping. Even though it looks OK, either the belt needs replacement and/or the roller needs cleaning and/or lubrication at the ends. Try cleaning the roller ends first and then light lubrication with WD40. If belt ... Electrolux Central Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.

Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

Electrolux canister model #1205. worked great. got a new hose and if you check the suction with your hand, great suction, but then the check bag light turns on and machine shuts off.

... Electrolux Vacuums

When I flip the switch on my sebo x1 upright, a red light comes to the brush and bag icons. However, I cleaned out the hose and checked to make sure there is no obstruction from the brush to the hose also, or from the hose to the bag. It is clear that juice is coming to the vacuum, but there is no sign of life except the two red lights.

Thanks for contacting fixya. You should pull out the bag and reset the machine. You should take all the user replaceable items. And turn it on. You will get lot of errors. Then turn the machine off. Put back all the accessor ... Sebo Automatic X1 Bagged Upright Vacuum

I have the Miele S7280...the one without the clog hatch on the back. I took the bag cover off, then continued the remove the screws and cover underneath it to detatch the top from the bottom. Found the clog and cleaned it out. Heres the problem...now the power nozzle light comes on and the vacuum "on" is lite up red, but it will not come on. Checked the filters and the bag. It certaintly seems like the top and bottom are meeting up to latch into each other, but I have no power. Help!!

... Miele S7210 Bagged Upright Vacuum

My Dirt Devil M082476 Full Bag indicator light keeps coming on when I turn my vacum up to full intensity. I have tried changing the bag and checked that all hose is clear. If I leave the vacum on low intensity the suction is minimal and does not increas when I turn up the suction. Is there a solution to this? I look forward to your response

... Dirt Devil M084105 Jaguar Vacuum

My upright kenmore progressive vacuum will not suction up when using the sweeper. It will suction things when I use one of the tools. I have put in a new bag and have tried to see if anything is blocking the bottom. It sometimes makes a very loud noise when I try to vacuum. If I press the intell clean on and off yellow button the noise may go away but it still does not work.

Double check hose placement, making sure you have the hose inserted into the correct slot. The long attachment nozzle stores in the front hole on the right, and the sucking hose inserts into the rear hole on the right. I know this is too simple of a ... Vacuums

Hi my dyson is not sucking up very well when i put it on its side and switch it on the brushes are not going round when i put the white dail to on at the bottom the brushes go round but it makes a terrible noise i have cleaned the brushes checked the soleplate is on correct and taken the clear hose off and checked for splits the suction is there when i have been checking these things hope you can help thx

Hi there,Sorry to hear you're experiencing a problem with your cleaner. Please get in touch with us, free, on 08002980298 (UK), or 1866MYDYSON (US). We can run through some checks over the phone and provide you with the assistance you nee ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

I have power at top of handle, thus start button light up. but when turn on nothing happens. I checked wiring and it all seems plugged in. The lights on the bottom of the cleaner (part of the base) don't light up. so somehow it makes since issue at base. HELP.. retired cop

Hi,\015\012Seems, the motor of vacuum has no power supply ( not connected yet). You may have a loosen/defective connection on motor cables/terminal. Please check and have it fixed. ... Oreck XL2200 Bagged Upright Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!

... Miele Vacuums

I own a Sanyo 35s 3.5 Rice cooker that has stopped cooking and heating. Power is going to the unit power light comes on. We have checked to make sure that the unit was turned off before unplugging as per the instuctions. Unit was new in Feb 2010 and well taken care of. Anything we are missing here?

If you have been washing or scratching the inner pot with something sharp or harsh like a metal spoon or hard sponge it could cause that and even electric shocks. try changing the pot ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1046 seconds