Having problems with your Kirby G5 Bagged Upright Vacuum ?

I have a Kirby G5 Vac Cl, the motor will not run. I checked the ac voltage into the vaccum and is o.k. What is it?

Answers :

I have the same problem with our G5. I check the cord and it's good. Changed the switch, but that actually wasn't the problem. I've tracked my issue down to the motor brushes. When is does run, sometimes blue sparks are seen on the right-side of the motor near the right set of brushes.\015\012
\015\012I was able to rotate the motor spindle simply by turning the front attachment belt lever (the thing on the front to take off the vacuum head). This rotates the motor just enough to get better contact with the motor brushes.\015\012
\015\012I'm next going to replace the brushes and see if that fixes my g5. Good luck.
Repair Help & Product Troubleshooting for Kirby G5 Bagged Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a Kirby G5 Vac Cl, the motor will not run. I checked the ac voltage into the vaccum and is o.k. What is it?

I have the same problem with our G5. I check the cord and it's good. Changed the switch, but that actually wasn't the problem. I've tracked my issue down to the motor brushes. When is does run, sometimes blue sparks are seen on the right-side of ... Kirby G5 Bagged Upright Vacuum

Kenmore canister model 116.25513506 wont turn on. when handle switch is turned to floor. vac motor does not turn on. When switch is turned to carpet, floor nozzle works but vac motor does not. I checked fuse, all o.k. checked continuity for plug, o.k. removed wires for bag full switch...motor wont run. I wired motor directly power cord...motor runs. Thinking it must be the circuit board, how do I bypass it or test it?

... Vacuums

My Electrolux Central Vac E130G stopped running. I checked the motor by circumventing the pc board and putting 110 VAC directly on the motor . It ran at full power. Is it the pc board I should repla

... Vacuums

Oreck model BB870-AS - I was vaccuming when the vac shut off. The motor just spooled down and nothing more since. I have opened the case. Have power at the switch, and to the motor, but can't get a voltage reading to the common lead at the motor. Is there a fusible link, or something similar in that lead that might have burned out? Thanks!

... Oreck Vacuums

After using the vac for 10 minutes or so, the motor starts turning on and off with greater frequency the longer I let it run. Eventually it is on and off so frequently that it has no power. Would this possibly be the 24V relay? I have checked the breaker on the unit and it is not tripped. Does the motor have a thermal overload switch separate from the breaker?

No it dosen't. I fix central vacs all the time and relays usally don't do what you described. They either go out all the way and won't turn on or they will trip and you will have to push the breaker back in. What is probably happening is you have a s ... Electrolux Centralux Vacuum

While vaccuming it just stopped. Tried another outlet and checked power cord. Did find tube clogged with a dirt clog but no motor strain heard. Cleaned it out, Still not running

On the back of most vac's , u will find a red butten,use that to reset the vac. but even if that works u can avoid this usely buy ajusying the vac to a higher set . that helps reduse strian that the belt gets.\015\012 thanks\015\012 ... Bissell 68001 Canister Vacuum

Is it worth trying to fix my kirby vaccum?The motor smells like its burning when we run it

It depends on the age of the vacuum, and the wear and tear on other parts, like the cord, bag, hose, brush, handle, switches, etc.\015\012From my own experience, no. You can often find Kirbys at very reasonable prices at second hand stores, es ... Kirby Ultimate G Bagged Upright Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Sucked up some debris with Kirby, now the motor is not running right.

1) see the diagram attached.2) clean it3) test the belt for broken or crack4) motor can be faulty by enough pressure in the bearing and winding overheating repair or replace. ... Vacuums

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???

Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

WST 1600A I purchased this vaccum about four months ago from Heartland America. Up to this point it's worked fine. After cleaning it this time when I went to start vaccuming again it runa for about 10 seconds and cuts off. I've changed the battery, taken everything that can be removed out checked it and replaced it. THe motor sounds like it's straining. I have not taken the housing off the motor to see what's going on with that. I misplaced my manual.

It sounds like there is a clog. If there is no air flow it could be overheating. ... Westinghouse WST1600 Upright Vacuum

I have a mile tt2000 that works fine up to 1300W but if I crank it up higher the motor decreases and increases speed every couple of seconds. I have changed the bag and filters and done the usual cheCks for blockages but can find nothing amiss. Unusually when it is running and I block the intake it will run at full power but as soon as I clear it the motor "hunts" again. Any ideas.

... Miele Cat & Dog 326i Bagged Canister Vacuum

Barush motor won't turn on when the vac is tipped back as it should be. checked micro cwitch that controls motor it checks ok. what next

... Dyson Ball DC24 Bagless Upright Vacuum

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor

On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

Does not pick up, no vaccum, motor runs, no blockage, should feel suction on hose outlet without hose hook up. Paper filter missing over cloth filter. float overload ball free, seal on section good no leakage. Maybe bad motor but runs.

Here\015\012 is a Link to one of my Tips:www.fixya.com/support/r6311178-vacuum_brush_bar_not_spinningThis\015\012 should solve the problem. ... Minuteman C82906-01 HEPA Vacuum Vacuum

Shop-vac model 90L550A motor wont run

Yes replacing the link would work, but that would not fix the cause. You have either pulled the wiring to the point of pulling apart the connection or there is a short. Which would be in the way of a grounding effect causing the link to heat and melt ... Vacuums

Recently my central vac system started making a louder than usual and laboured sound when in uise, enough so that I took note and inspected the canister and motor while running. The motor was trowing off blue sparks and looked like it could 'POP' at any moment. I will not risk using it until I know what the problem is and how to repair it. My assumption is the motor needs to be replaced. The system came with the resale house I bought 3 yrs ago but I do not know the age of the system itself.

... Vacuums

My Air Vac is 20-21 years old. Recently it stopped running. I found the fuse by the motor was blown and replaced it. It blew immedicately when I turned it on. I think I need to repace the motor. Do you agree and can I buy a motor from you.?

If the fuse does keep blowing yes you do need to replace the motor. I am sorry we do not sell parts though. Try the link below to get the motor.\015\012\015\012 ... M&S Systems Vacuums

Hello, I got a used Kirby Sentria. When I run the vaccum and push and pull on the handle, I can hearing a friction type noise. I got up close to the vaccum and it is not the wheels or roller. It is coming from the base of the handle. It's like it is pushing on something on the vaccum body and is creating the noise. Maybe transmission? Is this normal, or is it something I should be concerned about? Thanks for your help!

Try new belt yours may be slipping ... Kirby G5 Bagged Upright Vacuum

Motor/Fan does not run. I have removed and taken the top of the canister plastic motor housing apart and tested for power. I have power through the cord to the switch and power from the switch to the two wire terminals. I have not removed the motor. Looks like I will need special tools to take out the motor. The Vac looks almost new. It has been setting for several years. What do you think?

Sorry to read about your problem, I hope this helps you out.Well you can order a new motor at shop vac, check out this link.you dont have to remove to check the motor, just connect power to the motor leads ... Shop Vac QPMH450 Canister WetDry Vacuum

I have what I thought to be a Kirby Classic Omega that is in excellent running condition and looks great. I love it and have been using it for years, but it is recently going through an identity crises! I looked on the identification plate under the motor while cleaning it and discovered that the ID sticker says it's a Kirby Classic III. How can this be when every part of my dear kirby is Omega brown? There is not a hint of Red or Rosewood! Is there another way to determine the actual model b

The Kirby Omega was made from 1973 to 1976.The classic III 1976 to 1979When in for repair the case (motor cover) from a Classic could be put on the Omega. This happens in repair shops if the teck. has two apart at the same time and was no ... Vacuums

Samsung Quiet Storm Canister Vacuum VAC-9049 The motor will not run. Power is on to the motorized rug tool. How can I remove the upper housing to get access to the motor? I have removed the six visible screws, but the housing is restrained at the rear. I suspect there are additional screws under the power switch and cord retractor assembly, but I cannot remove that either. HELP!

Hi Daltm,\015\012Thank you for contacting Fixya. This is Anil.\015\012I understand that you need assistance n opening the Samsung Vaccum VAC-9049 motor. I will be glad to help you with it.\015\012Please go through ... Samsung Quiet Storm 9048R Bagged Canister Vacuum

When the vaccum is running the motor gets hot & smells & is very noisy.

Sounds like yu may have a clog, either in the inlet by the brush roll, or the hose. If the hose comes loose, see if there is suction there. If no suction then it is clogged. If suction, then the inlet maybe clogged. ... Dirt Devil Reaction Twin Cyclone Upright Vacuum

My vac then steam 2in1stoped steaming motor runs gets hot but no steam

... Shark Steam Vacuum, 2-in-1 Vac-then-Steam
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0675 seconds