Having problems with your Kirby Heritage II Vacuum ?

Motor dying? recently my herritage has been sounding sick, i tried to use it the other morning and it barely could blow up the bag, there is also a hot smell to it when it is running, the motor doesnt sound as powerful as it use to. Any suggestions?


Answers :

Replace the carbon brushes in the motor.
Repair Help & Product Troubleshooting for Kirby Heritage II Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Motor dying? recently my herritage has been sounding sick, i tried to use it the other morning and it barely could blow up the bag, there is also a hot smell to it when it is running, the motor doesnt sound as powerful as it use to. Any suggestions?


Replace the carbon brushes in the motor. ... Kirby Heritage II Vacuum

I was just using my Bosch 1450W bagged vacuum and all of a sudden, the motor just shut down. No warning, no problems. The light still turns on, but the motor is unresponsive. There is a clean bag and filter, and nothing caught in the front roller. The motor sounded fine - no shaking, or weird frequency variations. There were no weird smells, just a little bit of heat, but nothing beyond normal. I've had this thing for several years, and never had a bit of trouble with it. Any suggestions


Many vacuums have internal thermal switches that need to cool to allow the vac to operate. After 30 minutes, check all 3 air filters and try again.\012Gary ... Bosch BSG71310UC Bagged Canister Vacuum

No suction My Hoover Wind Tunnel vacuum runs but there is no suction. The last two or three times I used it, it shut itself off after having a burning smell. When I unplug it for the suggested 30 minutes, the motor will run again but no suction. What is wrong?? Should I just buy a nve one? This one is 8 years old.


Sounds like your motor bearings are going bad. This is generally indicated by the motor overheating, and the heat transferring out through the motor pulley, which is where the belt attaches. So, your machine is overheating, melting the belt, and then ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Have a Centralux Aerus about 5 years old. Don't see a model number. There is suction but beater brush quit working. Was using for a few minutes, shut it off for a few minutes, turned it back on and suction only. Tried the reset button also. Tried the sidekick attachment and it works fine. There was no smell like something was hot. Belt is fine. Are there any fuses or anything else to try? This vacuum cleaner has not really been used that much, it is hard to believe the motor would need replaced


There probably is a loose wire in the handle near the switch or a wire off near the swivel elbow near the vac power head. With the right fastener tool to remove some screws you can fix it yourself ... Electrolux Centralux Vacuum

Over heating? My 10 gallon 4HP shop vac has started shutting off after about 30 sec. after I turn it on to use. It smells real hot after I shut it off. I have changed the filter and the bag, which did not solve the problem. Any suggestions on what the problem could be? It's only about 31/2 years old and I really don't use it all that much, mainly for getting up dust and cob-webs from my garage.


It sounds like you need to replace the motor in it . thank you for using fixya ... Shop Vac ShopVac 3 HP 2 Stage 10 Gallon--Automotive Wet/Dry Vacuum Vacuum

Just doesnt sound like the motor is running.. it use to be louder than it is now kinda can smell it geting hot sometimes


Check for blockages in pipes and hoses that will make it sound diffarant and overheat. ... Hoover U5172900 Fold Away Widepath Bagless Upright Vacuum

My vacuum motor started to smell "hot" and sound like it was struggling. Also not a lot of suction. Could there be an obstruction? The bag is new and the performance light isn't coming on.


Hi,Here is a tip that I wrote about my Bissel but I bet you have the same problem and the hose is clogged...Bissell Bagless Upright Vacuum not ... Kenmore 25512/ 25513 Progressive Canister Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

When the vaccum is running the motor gets hot & smells & is very noisy.


Sounds like yu may have a clog, either in the inlet by the brush roll, or the hose. If the hose comes loose, see if there is suction there. If no suction then it is clogged. If suction, then the inlet maybe clogged. ... Dirt Devil Reaction Twin Cyclone Upright Vacuum

We have a Kenmore Progressive Model 116 Upright bagged vacuum with Hepa filter. It's at least a couple years old. For quite some time now when ever we use the vacuum the vacuum motor will shut off nafter about 5 min. of use. We then need to let it sit for awhile and then we can run it again for another 5 min. The bag has been change. Any one have any ideas how to fix this?


I suspect that you have a restriction. The motor sounds like the thermal break is stopping the motor before damage, due to heat.\012You must witness that the entire suction and discharge side are clear. This is not always very easy, but necessa ... Kenmore 34612 Bagged Upright Vacuum

I have Nutone VX550C. Motor runs intermittently (cycles on and off rapidly--the light on the handle is blinking furiously) when I use the on/off switch on the hose. This happens at all of the wall connectors, so suggests a hose contact problem. Motor runs continuously when I turn it on at the switch on the wall unit.


The unit does have a switchs the PVC outlets, and it sounds like the hose mech to operate the switches is broken, and intermittently making contact. A replacement hose would likely fix the problem. Looked them up on the net, and they're not che ... Broan-NuTone VX550 Bagged Central System Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Bag change indicater staying on and vacuum smells hot when using


I suspect there is a blockage somewhere along the pipes leading to the dust bag.\015\012The bag full or bag change indicator measures how strong a vacuum is present at or near to the point where the bag is connected to the pipes. Under normal ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I have a Hoover, Steam spin scrub, Model F5897-900. Only used it a couple times and the motor gave out. First started being noisy then a bad smell. It did seem noisier that what I would expect from the start but I didn't realize it was a problem with the shaft of the motor. I took it apart and found the motor shaft wasn't true and causing sparks. The motor looks like it can not be taken apart and repaired. This seems like a default from the beginning but it is past warranty. Also noti


You will have to replace the motor and the hose asm. thehooverstore.com may be able to help, or you should be able to find a repair shop that can order them for you. ... Vacuums

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u


Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

Won't start. My son was using the vacuum & Didn't change the bag. The vacuum was making the full bag smell, but the light was't on & it didn't stop. I stopped him, changed the bag, checked the filter, closed the compartments & turned on the vacuum. Nothing happened. I checked to be sure that it was plugged in, that wasn't the problem. I've let the vacuum "rest" for several days, It still won't start. Any suggestions?


There is a reset button at the back of the powerhead. The user manual can be downloaded from the electrolux website, although I didn't find it very useful. There was some info on how to change the powerhead drive belt. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

I have a Z345 Electrolux cylinder vacuum cleaner, from the 1970s probably, but not used much. I have lost the guide. I forgot to change the bag before it was full. Smoke started to come out - smelling of burnt paper, not rubber. So switched off. It did not blow the fuse, and may be OK. I wish to inspect it. How do I open it up? Alos I have an air filter and a motor filter for it. I have often changed the air filter on the top. How do I get at the motor filter, if there is one? Than


Good day! OK you have to is replaced the bag and that's it.And don't forget to change the bag again to avoid that problem.Thank you ... Electrolux Guardian Bagged Canister Vacuum

I replaced the motor in my Oreck vacuum and it runs much faster than it used to and is very noisy. The wiring diagram that I received with the motor was very hard to read so I don't know if I wired it correctly. I also was not able to hook up the dual head lamps. Thanks, Bob


Hello Bbrote,Please visit the link provided below and find your model and then click for schematic :http://www.hescoinc.com/vacuum_cleaner_parts/oreck.html ... Vacuums

Burning smell While using the vacuum, the running light will get dim. If I hold the handle at the point where the light gets dim the motor will start smoking. I can either raise or lower the handle and the light will brighten up and the vacuum will run fine. Any ideas???


Hi theres two things that could have made it start doing that 1 the whires have a short in it or 2 the motor has gon faulty. you might want to buy a new machine ... Bissell Lift-Off(R) Revolution(R) Turbo Upright Vacuum

I smelled something burning one day , but i kept using my d4c, now the motor part does not run but the top plug in will run


I work on Rainbows. D4C-E2 etc. Not sure what you mean by the top plug in. There are two motors in the rainbow, one in the main unit, one in the power head. Where was the odor coming from? email me back with more info, I can help you with this. ... Rainbow E series Canister Wet/Dry Vacuum

My dyson has started to give off an acrid smell when I use it. I have checked all areas for blockages, cleaned the removable filter and removed all hair from the brush but this has not helped. I am worried the motor is getting hot in use. Whats the best thing to do next? Thanks


... Dyson DC14 All floors Bagless Upright Cyclonic Vacuum

Kirby G4 running very loud and smells hot.


Were you put the belt on see if any thing is rubbing against shaft.it may have been the belt,replace the belt and clean out the bab and also the floor brush. ... Kirby G4 Bagged Upright Vacuum

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after


... Vacuums

I have a Miele s251i vacuum that was working just fine until I umplugged it (while running) and re-plugged it in at a closer socket. When I replugged it, it started for a second and then stopped. Will not start now whether we use the on/off switch or not...suggestions? Would also like to know how to disassemble the unit so I could check out the wiring with a multitester..thanks


I just had exactly the same problem. Opened the vac, checked the circuit\012 next to the motor and it can be clearly seen that the Triac burned thru\012 the PCB. Will replace it and check again. Vac bought long ago, works \012extremely well. ... Miele Vacuums

My Oreck xl makes really loud sound and starts to smell hot when running still picks up but I am afraid I will damage something if I use it. The loud sounds gets very loud then quits for a few seconds then starts again.


... Oreck XL Ultra Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0759 seconds