Having problems with your Kirby Ultimate G Bagged Upright Vacuum ?

There is no foam in the hose as I run the kirby shampooer. What could the problem be?

Answers :

Check out the manual HERE.
It may be clogged valve on the solution tank.
Very dirty or clogged sponge (shampooer tank)
Very dirty or clogged screen(shampooer tank where hose is connected)
It is pretty common that that small screen comes out and stays in the hose elbow.

Repair Help & Product Troubleshooting for Kirby Ultimate G Bagged Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

There is no foam in the hose as I run the kirby shampooer. What could the problem be?

Check out the manual HERE.It may be clogged valve on the solution tank. Very dirty or clogged sponge (shampooer tank)Very dirty or clogged scre ... Kirby Ultimate G Bagged Upright Vacuum

II have the kirby sentria, i have it in canister mode with blower attachment on the hose is on with the hand sprayer attachment the problem is the foam is not coming out the sprayer used it just fine all day went to refill w/ water and cleaner now the foam wont come out whats wrong with it?

Make sure the "straw" is in.See if dust coming out of the hose did not clog the air passages. ... Kirby Heritage II Vacuum

I have lost suction on my Bissell. It is also clogging in the Plastic tube that runs from the roller to the hose. What could have caused this? All filters have been cleaned, tube as well, but the problem still persists.

... Bissell 82H1 Cleanview Helix Bagless Upright Vacuum

Hello. first id like to thank you very much for helping me. There is no problem really. Id just like to know if i can use other soap or product to clean the rug besides the kirby evaporated dry foam.. Also how could i **** up as much water as i can?

I would only use the brand intended to be used in this machine. Home Solutions Turbo Shampoo by Aerus Electrolux. This machine doesn't **** up water, and if used according to the directions, there really shouldn't be much water on the carpet. ... Electrolux Floor Pro Vacuum


It might be clogged. ... Hoover Elite U5349-900 Upright Vacuum

Kirby Sentria Shampooer is not foaming the width of the tray. It is only coming out on one line and is saturating the carpet with water in that area. What is the problem? What do I do? We just bought this 5 mos. ago. Please help.

Your shampooer is not broken. (sorry Fanny)\015\012\015\012You are missing a wee screen that fits on the hole where the little hose plugs into the tank. Check inside the hose end or down inside your shampooer box. Here's a link to my onli ... Kirby Ultimate G Bagged Upright Vacuum

I have a kenmore vacuum cleaner model # 116.23612. When the hose is attached to the canister it runs, but if you remove the head to just use the hose the unit stops working. Is the motor dead or is there some type of reset or fuse. Could you please tell me how to test this. If so could you please send me instructions on how to replace the motor. Thank you in advance for your help, Tony

... Kenmore Vacuums

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

Kirby g6 My kirby is running louder than usual. Kind of like its screaming instead of running now. Its working fine, but the noise is really unbearable. What could it be?

Could be the bearings, especially if the machine is old or the dust filters have not been replaced regularly.\015\012Check to see if the noise is still present after the machine winds down when the power is turned off. A rattling sounds means b ... Kirby G6 Bagged Upright Vacuum

I have Nutone VX550C. Motor runs intermittently (cycles on and off rapidly--the light on the handle is blinking furiously) when I use the on/off switch on the hose. This happens at all of the wall connectors, so suggests a hose contact problem. Motor runs continuously when I turn it on at the switch on the wall unit.

The unit does have a switchs the PVC outlets, and it sounds like the hose mech to operate the switches is broken, and intermittently making contact. A replacement hose would likely fix the problem. Looked them up on the net, and they're not che ... Broan-NuTone VX550 Bagged Central System Vacuum

Kirby heritage 2 will not operate with hose on but with hose off it runs fine

... Vacuums

Kirby shampooer dispensing - NOT a filter problem

I had the same problem and I called my local Kirby guy, he's great, helped me when I thought I blew my kirby up, it was just a cord and he wa able to tell me that over the phone. When I called him with this problem, he knew right away that it was on ... Kirby Ultimate G Bagged Upright Vacuum

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

I just got the majestic and it doesn't seem to have a lot of suction power- I ran water thru the hose and it drained out fine I also put the hose on top and blew it out. Could it still be the hose?-or does it sound like a bigger problem?

Did you change the filter cone? Clogged pores can and do inhibit airflow. Bent fan blades can be another problem. Holes, slits, and cracks, no matter how small, in the hose can result in reduced suction.\015\012And you should NEVER run water ... Filter Queen Majestic Canister Vacuum

Kirby Ultimate G carpet shampooer not producing foam anymore

I was having the same problem. There is a filter plug that came loose on mine and went down into the hose. It belong on the water tank and fits in there tightly and the hose end goes over it. That's what actually makes the foam. ... Kirby Ultimate G Bagged Upright Vacuum

I have a Kirby vacuum with the shampooing attachment. The shampoo/liquid comes out of the shampooer in a drizzle of liquid. There is no foam.

You need to check that the little round screen is in the hole where the hose attaches to the shampoo tank. My guess is that the little round screen is wedged sideways in the end of the hose.\015\012 \015\012Here is a guide to help you further...\015\ ... Kirby Ultimate G Bagged Upright Vacuum

Foam stopped working on my Kirby shampooer

You need to check that the little round screen is in the hole where the hose attaches to the shampoo tank. My guess is that the little round screen is wedged sideways in the end of the hose.\015\012\015\012Marci ... Kirby Ultimate G Bagged Upright Vacuum

Kirby shampooer The suds are not coming out of the shampooer. I made sure it was connected right. The sponge filter and the cap are attached. i have a g4 vacuum and the screen in in properly.. if i move at a snails pace i can get spots of suds about every 6 inches or so but not a lot. i have adjusted the on and off, if verified the video its put together correctly but it acts like no suction .. i thought of a small hole in the hose for the suds and cut off about 1 inch it act better but not by

On the shampooer tank, remove the screen cap from the little hole that the shampooer hose plugs onto. Clean the screen and make sure that it is not plugged up with debris. Make sure that the screen is securely glued to the cap all the way around the ... Kirby G4 Bagged Upright Vacuum

Shampoo-er This seems to be a common problem, the shampooer is putting out alot of water and hardly any suds. I read through the posts about the little filter that sometimes gets out of place and I think I found it in the box - is it about 1" diameter hard plastic ring around very fine mesh? If so where exactly does it go? Some posts say in the hose, and others say in the opening of the tank. Or does it go in the place where the hose attaches to the tray? I also found a round sponge in the box o

It goes on the small hole on the tank where the hose attaches to it. The sponge goes in the hole directly under the on/off valve. Here is a link to my online shampooer instructions.\015\012 \015\012 ... Kirby Ultimate G Bagged Upright Vacuum

My sebo 1.1 has a red light flashing, indicating bag needs emptied or clog. There is plenty suction with the hose attachments, and I cannot see any blockages in hoses etc. Some of the dirt seems to be collecting in the small flap in the base of the hoover. Any tips as to what could be the problem would be gratefully received

... Sebo Automatic X1 Bagged Upright Vacuum

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???

Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

Passat 2000 W Reg Had the rear brakes and disks changed then a month later had a front tyre replaced and as I drove off something went tinkle tinkle on the road (like someone had left a spanner). Week later the ABS light and the brake light come on with the usual STOP Brake Fail Service Manual message. Had brakes checked but they could find no fault. I've tried the ABS under controlled conditions and it works. What could the problem be?? I've been running the car under these conditions and no pr

The ABS module has a history of wearing out on VWs. Nothing wrong with the brakes themselves, but the ABS module would need to be replaced to stop the lights coming on... but the problem is a new ABS module can be very expensive for a new one (~$900 ... Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Low suction Have a Powr-Flite PF 18, suction is good at motor, but low at where hose comes out of top of vacuum. Could new lid seals help the problem? Where can I get new seals for this model. Also my zip is 98801 and my shop is not listed, could you add it please? Sew Creative 1139 N. Princeton Wenatchee, Wa 98801 509-663-5516 Thanks, Lauren-Sew Creative

Replacing the motor cover solved the problem, it must have been warped and was letting suction out thru it. ... Vacuums

For the first time, I tried using my Kirby Sentria shampoo attachment. I've lost the manual but found instructions online for making the swap from regular vac to shampoo-er and got it all assembled. The foam laid down just fine, however, when I run the vac back over the foam to pick it up, there is not a stitch of water showing up in the tray. First I thought maybe it was bc I hadn't put that much of the foam/water onto the carpet, but 12 hours later, the carpet is still wet in spots. Clearly

Http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=638285\015\012Generic problem for all Vacuums\015\012For the first time, I\015\012Posted by MHicks on J ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0845 seconds