Having problems with your Kirby Vacuums ?

KIRBY G-6 RUNS BUT HAS NO SUCTION, BELT IS GOOD, FAN APPEARS TO BE INTACT


Answers :

1. Put the hose instead of the nozzle and see if suction is good with the hose. If it is – brush roll may be worn out (bristles must be sticking out of the nozzle by about 1/8 of an inch).
2. If there is no suction with the hose either – check if bag is not overfilled to the point where dirt is blocking the fill tube hole.
3. If two above are fine – something must be blocking the air passage from the fan to the bag. Check for clogs the fill tube (tube inside the cloth bag) and mini emptor (bag bottom plastic part) and also see if there is nothing in the exhaust on the vacuum. You may not even see it so use a piece of wire. Once I found a sock there and it was so close to the fan that I could not see it in the hole and got a grip of it only a hook made out of old coat hanger.
Repair Help & Product Troubleshooting for Kirby Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

KIRBY G-6 RUNS BUT HAS NO SUCTION, BELT IS GOOD, FAN APPEARS TO BE INTACT


1. Put the hose instead of the nozzle and see if suction is good with the hose. If it is – brush roll may be worn out (bristles must be sticking out of the nozzle by about 1/8 of an inch).2. If there is no suction with the hose eith ... Kirby Vacuums

Hello, I have a Hoover 3200 Turbo Power vaccum. while the motor appears to be working fine the vaccum no longer picks up the dirt. I turned the vaccum upside down and the belt appears to be broken. would a broken belt stop the pick up, there appears to be no suction. This vaccum is approximately 10 years old. is it worth fixing? I live in Virginia Beach Va, where would I take the vaccum for repair? my zip code is 23456- Thanks Cleta Goode


... Hoover Vacuums

My manual says it is DC07, but it is pink and silver in colour. I have 2 problems, firstly the brush has stopped spinning, but belt appears intact. Secondly there are tiny holes in suction pipe near brush i.e. the little section of suction pipe at base of vacuum cleaner.


Hi there, \015\012The DC07 came out in a few different variations so the colour only indicates that yours has a hepa filter. The first problem can be caused by a few different things\015\0121. the brush roller bearings are worn or siexed. ... Dyson DC07 Bagless Upright Cyclonic Vacuum

Not sucking i have a KIRBY G3 that was working great. One day there was a strong smell and the brush roller belt broke so I replaced it. The fan looks good. Now the vacuum does not **** up dirt but instead seems to very gently blow air forward. I took the (new) bag off and it is blowing hard int the bag. I am stumped!


Belt is not connect to the drive pulley, see manual for fitting or see utube for video ... Kirby Generation 3 Bagged Upright Vacuum

I have no suction on my vacuum, I have checked everything, belts are good, and hoses appear to be clear of any blocks, any suggestions


Please give the model number and manufacturer of the vacuum. ... Vacuums

Poor suction from the upright .I have replaced the hepa filter checked the fan belt and replaced the sponge filter.Thre does not appear to be any blockage. Any solution?


Check the hose for any tears. At the very top, directly under the handle, there is a metal tube inside of the hose. Pull the hose downwards, while holding onto the handle to stretch the hose as far as it will go. Check the very top of the hose for ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

I do not have any suction, to the base or the wand. My brushes also do not turn. The belt appears to be attached & in good condition and there are no clogs (that I can find)


Some times there is a pan beneath the vacume and an opening there, it may be clogged there, thats not real unusual, hope this fixed it,, ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

No suction After taking the vacuum apart, I noticed there is no suction at all. The motor runs, belt runs, but no suction coming through.


You have a clog somewhere in the vacuum. Check the hose and the little trap door on the underneath side of sweeper.Does the brush turn? If not, then the belt that drives the brush is broken. Replace the beltJim ... Hoover Tempo Widepath Upright Vacuum - Blue

My Kirby Ultimate G does not have enough suction to pick up pet hair. Is there anyway this can be corrected? I felt under the vacuum when it was running, the roller is running, but I felt very little suction.


An Ultimate G has lots of suction. If you turn on your vacuum and the bag immediately inflates - that is how you can tell if your Kirby is moving air (suction). There is a more modern brush that came out with the Ultimate G Diamond and the Sentria ... Kirby Ultimate G Bagged Upright Vacuum

Hoover windtunnel U6425-900 the brush roll is not turning. Both belts are in good shape, I cleaned the brush roll and it is free of debris, the setting is on carpet and the brush roll still will not turn. There is a "burning rubber" smell when you attempt to push the vaacum forward a few times. The small belt does not seem to be pulling properly but appears to be in good shape.


... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My Eureka/The Boss doesn't seem to have the suction power it had. However, when I place my hand under the hose, it has good suction, then when I try to pull in a small particle, it doesn't, unless I have the hose nozzle completely over the particle. The vac is 10 yrs. old. I cleaned everything. Someone said the belt. Would the belt matter if the hose doesn't **** well? It is just old and worn out? It did shut off recently do to overheating. Help. Thanks. Lorraine


Doesn't "The Boss" Vacuum have a filter? Perhaps your filter is clogged and not allowing it to work properly. ... Vacuums

Bissell powerforce My lower pickup tube became clogged so I removed it and cleaned it out and reinstalled it.Now everything runs good but the vaccum want pick up any dirt .I replaced the bag andf when I turn it on it just exhaust air but does not have any suction,I tired tp pull the bag door of while it was running whick I could not do so it has plenty of suction inside just not getting any outside can you help?


... Bissell Vacuums

Bag was not on good, resulted in dust,dirt, dog hair everywhere...have cleaned pretty thoroughly but vacuum does not have any suction. After taking apart did find that the larger wide belt is broke but I think that just affects the self propel...is there a belt tied to suction? HELP!


Greetings from GoVacuum,\015\012\015\012There are two things that you should check on this vacuum after running it without a bag inside. The first thing you should check is the filter that is underneath of the vacuum bag. This filter i ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Belts I have a Hoover self-propelled windtunnel, purchased 6-04. It gets light use. I have replaced the v belt 3 times, once under warranty, and it must be replaced again. It appears to be in very good condition, but is stretched too big. When I purchased 2 v belts a year ago, one was already too stretched,but when my Dad took it back, the salesman put it on another model and said it was fine (Dad never mentioned this to me). Is there a way to adjust the vacuum to hold the belt tighter? Do t


It is the flat belt that gets stretched and should be replaced at least every 6 months. The V belt wears down so it won't it right in the brush roll V. Maybe the belt tensioner wheel has a problem, sometimes they get hook up and won't engage the V ... Vacuums

Electrolux Epic 6500 SR Carpet Sweeper won't go on. Belt good brush moves, bulb looks good, reset red button I'm not sure, works, looks good. Vacuum starts has suction ,


This link is the manualhttp://www.totalvac.com/manuals/electrolux_manual_Epic6500.pdf ... Vacuums

FAN PROBLEM??? good morning! my vacuum smells like burnt rubber (fan perhaps) but I can't find how to get into main part of the vacuum. it's just very rounded with no latches or screws to get inside where the motor, belts and fans would be located. can you help me? thank you


There isn't any belts, and the fan wouldn't be rubber, so not sure what you are smelling. Maybe this picture will help you.\015\012\015\012 ... Bissell 6700 Butler Revolution Bagged Canister Vacuum

Heater/fan issues I have a Honeywell - Year Round Fan with 1500W Heater that shuts off within five minutes if the fan is not running too. I don't have the oners manual and can't find one online. I have read several reviews that say the same thing. The heat does do much good when the fan above it is blowing cold air. Any ideas?


There is a safety switch which will shut the heater element off if the fan doesn't run. If the fan doesn't circulate air, the element would overheat and could possibly start a fire, so the switch will shut the element down. I'm not familiar with this ... Vacuums

The Panasonic MC-V7515 has two belts. The local vacuum repair guy says he only has a part number for the drive belt, which is UB-9. How do I find a replacement for the other belt, the one which directly drives the beater bars? By the way, this vacuum has great suction, but otherwise is far inferior to my previous Panasonic vacuums. The cheaper models aren't a good buy--stick with the more expensive models.


... Panasonic MC-V7515 Bagged Upright Vacuum

I have a kirby sentria. vacuumed up my son's headphones and immediately shut if off. took brush off, unwound headphones, put it back together. when i turned it back on, the belt snapped. so i went to vacuum place, got new belt, but when i put it on, with the green arrows lined up, it doesn't have much suction. with the red arrows lined up, it just smells like its burning and i don't want to break another belt! HELP!!


Take the front off the vacuum and check inside both the front portion and the canister for additonal clogs. Sometimes something will get caught in the impellor, causing the motor to overheat. Since there's little suction and the smell, I'd guess th ... Kirby Generation 3 Bagged Upright Vacuum

I have a Hoover self-propelled windtunnel, purchased 6-04. It gets light use. I have replaced the v belt 3 times, once under warranty, and it must be replaced again. It appears to be in very good condition, but is stretched too big. When I purchased 2 v belts a year ago, one was already too stretched,but when my Dad took it back, the salesman put it on another model and said it was fine (Dad never mentioned this to me). Is there a way to adjust the vacuum to hold the belt tighter? Do they re


Http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=675093\015\012Generic problem for all Vacuums\015\012I have a Hoover self-propelled\015\012Posted by kl ... Vacuums

Not very good suction on my kirby g6d


Change the bag? Change the Belt? Check the brush roller. It's one of those three 99% of the time. ... Kirby G6 Bagged Upright Vacuum

No suction - motor runs, belt running. - Vacuums


Clogs, som,e times on the bottom there is a pan and a hose opening secured, if its clogged, it won't work, open the bottom where there should be a small latch, also I have used shop vacs to **** clogs out threw hoses? ... Vacuums

Hi. I have a Kirby from back in the early 90s (model G3D). Never had major issues with it. Can't remember the last time I had maintenance/tune up done. It's just sounding different when I run it the last few times...almost like it's louder and kind of echo-ey. Still suctioning well, but something's not right and I don't want to run it until I know if anything's up. Any suggestions? I'd like to try and figure this one out on my own with your help. Thanks in advance for your help. Marci


Check the belt. this is a strong vaccume and even without the belt it will still have a decent amount of suction. If the belt is not tight or intact it can let the motor turn faster which will sound louder. other than that check all the hoses for hol ... Kirby Ultimate G Bagged Upright Vacuum

Hi -- I have a Kirby Sentria and it is great except that I am getting no suction at all through the big silver power head. Suction through all the other attachments works well. I haev tried it with the roller belt on and off, and that doesn't seem to make a difference. Am I missing something?? Thanks!


You can take off the power head and look in that whole where the belt is and see if there is a paper towel or something in there clogging it up. Also tug on the belt and make sure it is tight - because if it is loose it is broken and you ... Kirby Vacuums

Where does the belt go on the kirby as i can not see what it runs of . One side goes on the drum with the brushes but cant see what it runs on


Were dose the belt go on a kirby ... Kirby Generation 3 Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0833 seconds