Having problems with your M&S Systems Vacuums ?

My vac will turn on at the unit but will not come on when I insert the hose into any wall outlet


Answers :

The problem is one of two things...either the hose part is bad or the wiring to the unit is bad....all that needs to happen to make the unit come on is to short between (connect) the two wires going to the unit. Therefore if the hose part is not connecting the two wires, or if the wires are broken somewhere going to the unit it will not turn on with the hose. I would take apart one of the wall outlets and jumper the wires to make sure that the wiring to the unit is good. If that does not work, then start checking for a break in the wiring to the unit. My feeling is that the hose part is probably bad and it is not making the connection in there properly and therefore not turning on the unit.
Repair Help & Product Troubleshooting for M&S Systems Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My vac will turn on at the unit but will not come on when I insert the hose into any wall outlet


The problem is one of two things...either the hose part is bad or the wiring to the unit is bad....all that needs to happen to make the unit come on is to short between (connect) the two wires going to the unit. Therefore if the hose part is not conn ... M&S Systems Vacuums

Stops Immediately. We have a Beam Serenity model 2100 installed in the home and when the hose is inserted into the wall it turns on for a few seconds and then shuts off on it's own. Turning the handle's power switch off/on restarts the unit only to have it once again stop after a few more seconds. The canaster is clean. What could be causing this stopping issue? Thanks.


The Relay Control Board in the 2100 is bad. Replace and it should work just fine. ... Beam Industries 2900 Serenity Plus Central System Vacuum

I installed the Hoover Wind Tunnel Central Vac in my new home. After connecting the wall outlets and successfully turning on the system from the hose control, I discovered there is lots of air flow t


I would recommend checking your wall outlets where the hose plugs in for any type of clog in the tubing. If the vacuum itself ... Vacuums

The Vaccum is not turning on when i plug the hose into the wall. The hoover system will turn on when i turn the switch on at the base and wont go off till i turn the switch off. But it will not come on automatically when i put the hose in to the wall connections. Many Thanks Linda


You can test this out by taking a small metal spoon and with the bottom side of the spoon insert it into the vac outlet on the wall. you want to touch the two metal pins inside the vac outlet to test if the unit is the problem or the hose is the prob ... Beam Industries Vacuums

I have a 3 year old NuTone CV 353W central vac system and recently the switch on the hose handle does not turn the system on from any outlet in the house. I have to plug the hose into the outlet and then turn the unit on from the switch on the cannister. Any help would be greatly appreciated. Thanks


A great way to check if your switch in the hose is bad would be to turn the hose sideways in the inlet. If the unit turns on you most likely need a new switch. ... Broan-NuTone CV450 Central Bagged Central System Vacuum

My BROAN CV-110 hose with the rug beater only works if I turn it on from the base unit. Shouldn't it turn on when I plug the hose into the wall recepticle? Do I need to replace the hardware at the end of this hose and if so, where would I purchase that? This central vac came in a house I just purchased. Thanks for any help. Sherry


... Broan-NuTone CV450 Central Bagged Central System Vacuum

I have Nutone VX550C. Motor runs intermittently (cycles on and off rapidly--the light on the handle is blinking furiously) when I use the on/off switch on the hose. This happens at all of the wall connectors, so suggests a hose contact problem. Motor runs continuously when I turn it on at the switch on the wall unit.


The unit does have a switchs the PVC outlets, and it sounds like the hose mech to operate the switches is broken, and intermittently making contact. A replacement hose would likely fix the problem. Looked them up on the net, and they're not che ... Broan-NuTone VX550 Bagged Central System Vacuum

The unit will not turn on at wall outlet. the unit works fine at other outlets


Check the outlet to make sure you have power going to it. ... Broan-NuTone CV450 Central Bagged Central System Vacuum

On my M&S Air Vac AV425 central vaccuum system, the system usually turns on by inserting the vaccuum hose into one of the vaccuum outlets. However, it now runs continuously. I am able to turn it off only by unplugging the vaccuum from the electrical outlet. I would like to know how to trouble shoot the problem or how to find someone who services Air Vac systems in the Bridgewater, New jersey area.


We are a central vacuum service company and we service all of new jersey. sounds like you have a short some where that keeps your unit running or it could be your relay module thats stuck our number is 908-721-7595 its j&j central vacuum services ... Vacuums

Electrolux Centralux I have a Electrolux Centralux. When I plug the hose in at one of the wall outlets the motor will not start. If I go to the motor and slap the unit it will start.....then...it will not stop unless I unplug the power cord to the motor. If I plug the power cord back in, the unit will not restart until I slap the motor unit again. The unit has only been used 20 - 30 times. Any suggestions?? Thanks, Bruce


I dont know if you had your unit looked at yet but it sounds like the Power module is going. I repair the machines so I know some of the work. ... Electrolux Centralux Vacuum

Just purchased the unit 2 weeks ago. Worked great. Last night I left it plugged into an outlet - but turned "off". This AM the unit comes on; timer showing default @ 5 minutes; however, no "bubbling" action. Would leaving the unit plugged into a surge protector/UPS back-up unit overnight damage the product?


I wonder if you are talking about a coffee maker? It ended up being listed under Vacuums!-Sorry about that-- It sounds like you arehaving trouble getting the maker to boil water, and move it thru the maker, no?Anyway-- I don ... Vacuums

Hoover S3765 I have a Hoover S3765 (serial # 040600024465) and the unit stops working for no apparent reason. The light on top of the unit goes off when it shuts down, so I don't believe it's a problem between the hose, the tube and the floor unit. Sometimes I have to let it sit for over one hour before it will come back on. I've tried different electrical plugs too. Still won't turn on. Any ideas or suggestions? Thanks


If you light and nozzle motor both go off at the same time, you might have a bad power cord. Mine had this problem which I could verify by jiggling/twisting the cord near the strain relief on the nozzle. It would go on and off as I did this. ... Hoover S3765-040 WindTunnel Bagless Canister Vacuum

I have a central vacuum system. When I disconnect the hose from a wall outlet the central canister does not shut down dispite my turning off the vacuum at the handle of the hose. The only way I can get the system to shut down is to pull the plug at the canister. What gives? Rob


What I'm hearing is the canister(Not the Powerhead) portion of the unit is running all the time unless you unplug it. this problem could be caused by a short in one of your low voltage lines running through the house. To determine that just unplug on ... Vacuums

Unit goes on when turn unit on but doesn't pull when hoses are put into wall


The system could be blocked. \012\012the bag door could be open on the unit. \012\012The little black gasket between the dirt pail and the main body of the unit may be missing. \012\012Check those and you may solve ... Broan-NuTone Vacuums

Our Easy-Flo built in vacuum system will not turn off, even when the hose is disconnected. We have to turn it off manually. Could it be a short in one of the wall outlets causing this?


Some models have an on/off switch on the power unit itself. This switch is used to turn your power unit on when you are right at the machine. \015\012 If there is no switch on the power unit, unplug your power unit from the wall socket, loo ... Easy Flo EF1400 Central System Vacuum

The wall outlets do not turn on. The motor runs at the unit. I have reset and it blows/sucks at the unit. The canister is empty. Thanks, Je


You main low voltage line from the vac to the house is likely disconnected. Start by looking at the connection where the small wires enter the vac. Touch across those two wire terminals with a screwdriver or needle nose pliers and the vac should star ... Broan-NuTone CV450 Central Bagged Central System Vacuum

Model 116.1260 i can not figure out how to turn this vacuum on. is there a switch or do you just insert the hose into the wall socket?


Need the complete model #, 116.1260*****. I assume this is a built-in system? Yes you have to plug the hose into the wall outlet, and there usually is a switch on the hose handle to turn it on. ... Vacuums

My central vac wouldn't shut off when I took the hose out of the wall socket, I have to plug and unplug the unit at the electrical outlet.


The start stop command is done by a small switch that is located in the wall socket - this command is then transmitted thru some wires at the relay on the control board of the unit, activating it and powering the machine.So you must check 3 thi ... Broan-NuTone VX475 Bagged Central System Vacuum

Motor will not come on when hose is plugged in wall outlet. Green light is on, circuit breaker is on, changed bags even though 1/2 full, cleaned sec. filter. What is the problem?


... Broan-NuTone VX475 Bagged Central System Vacuum

I have an older model Electrolux central vac. When I put the hose into the wall outlet, the cannister comes on but there is no suction ? What is needed to correct this?


Three things are the most likely.\015\0121. Since it's an older model, the hose is likely well worn and probably has leaks at each end where it attaches to the handle and connector at the other end. If this is the case, a new hose is needed. ... Electrolux Central Vacuum

I have a nutone 350 central vac system and will will not start. Plug in the hose and I can hear a buzz at the unit like it is getting power but is not turning on. Does not matter what outlet I try


Your problem is incide the vaccum some object is stock , and the blower is cut. ... Broan-NuTone CV350 Performance Bagged Central System Vacuum

Unit won't turn off with hose removed from outlet. ???


... Electrolux Centralux Vacuum

Over heating Light Comes on as soon as I try to turn the unit on. I have a Miele S558 Silver Moon vacuum that has only been used once and it shut off and will not come back on. The overheating light comes on as soon as I try to switch speeds on the handle or turn the unit on at the canister, and the vacuum will not run. Do you have any idea what the problem is?


... Miele s558 Silver Moon Vacuum

Shark s3325 stopped working while steaming; thinking the unit had ran out of water I allowed unit to cool before refilling, however unit over flowed with only 700ml water added. When I plugged unit back into outlet it would not turn on (red light was not on) but I hear a click upon plugging in unit, when turning unit power button on and when turning on the handle switch. Please advise how to resolve this problem.


... Euro-Pro S3325 Handheld Steam Vacuum

Hooked everything up per directions. I plugged it in to the closest electrical outlet and nothing happened. The lights did not light up, the connected wall control and sensors leds do not light up. It appears the unit doesn't have power. The electrical outlet socket is fine as everything else I plug into it works fine. I have tried every other electrical outlet available. The unit won't power on from any outlet, and all of those outlets run other things, like power tools an refrigerators


Dear Davehibshman,Firstly; dismantle the plug and replace the fuse with the same rating as the one you have just taken out. Replace the plug cover, put the plug into the socket and try again. If this doesnt work, there may be a problem wi ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0740 seconds