Having problems with your Miele Blue Moon Bagged Canister Vacuum ?

Miele Blue moon vacuum motor surging on and off and power light flashing. After many surges of the motor (on->off->on-> off etc), the motor no longer attempting to start as ferquently ie. now off for many seconds and may turn on for 1 second.. sometimes stops turming on and just power light flashes. There is also no voltage at the plug for the hose for the power head. I noticed that the vacuum first started having probs when hair was caught in the power head and the ovetrheating light went on


Answers :

Repair Help & Product Troubleshooting for Miele Blue Moon Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Miele Blue moon vacuum motor surging on and off and power light flashing. After many surges of the motor (on->off->on-> off etc), the motor no longer attempting to start as ferquently ie. now off for many seconds and may turn on for 1 second.. sometimes stops turming on and just power light flashes. There is also no voltage at the plug for the hose for the power head. I noticed that the vacuum first started having probs when hair was caught in the power head and the ovetrheating light went on


... Miele Blue Moon Bagged Canister Vacuum

Our unit is 7024A Electrolux Oxygen 3 - it seems to work great but suddenly, the head or 'power brush' or whatever it is called - has died. I checked by removing the hose and plugging it directly into the body, but it is still dead. Without that motorized head working, the vacuum is useless. Is it worth replacing? The unit is only about 1 year old and has seen light use only. Very frustrating, since it was the most expensive unit in the store:(


... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Miele Vacuume(Saturn300). Vacuum powerhead(SEB234/236) does not work, no light comes on and no power. is it the hose(SES119) or the powerhead? tried plugging and unplugging.


... Miele Vacuums

Miele Vacuum(Saturn300). Vacuum powerhead(SEB234/236) does not work, no light comes on and no power. is it the hose(SES119) or the powerhead? tried plugging and unplugging.


You need to check your voltage coming out of your hose and wand, be sure that the handle switch is in the on position. Voltage should be +/-120V. If you have voltage there then you have a power head issue. The replacement would be the ... Miele Vacuums

I have a Kenmore central vacuum cleaner model number c107 34601. We have emptied the bucket and shaken the filter out to clean it. There is a filter that is filthy so we shook it out into a bag but the cleaner still seems to not have great suction. I notice there is a similar cap to the outlets I plug the central vac hose into on the unit itself that doesn't power the nozzle when used. 1 - what is this for? 2 - Should I somehow remove the entire filter and if so - can you tell me step by step ho


... Electrolux Vacuums

Miele S5000 (revolution 5000) vacuum cleaner - How do I open the casing? When the power button on the handle is pressed the green power-level lights on the handle light, but the motor sounds like it gives a little 'jump' but nothing more. The orange power light on the body also dims. I assume the motor or fan is jammed, but I can't open the body to find out. I've taken out to screws inside near either end of the handle, but to no apparent effect. I'm assuming the body is held together by plastic


... Vacuums

Electrolux Centralux I have a Electrolux Centralux. When I plug the hose in at one of the wall outlets the motor will not start. If I go to the motor and slap the unit it will start.....then...it will not stop unless I unplug the power cord to the motor. If I plug the power cord back in, the unit will not restart until I slap the motor unit again. The unit has only been used 20 - 30 times. Any suggestions?? Thanks, Bruce


I dont know if you had your unit looked at yet but it sounds like the Power module is going. I repair the machines so I know some of the work. ... Electrolux Centralux Vacuum

I have a Kenmore Progressive upright model 216-37100800. It is only around 1.5 years old. My wife said that one day after she plugged it and turned it on, it whirred up but then shut off. Since then it will not start. I have noticed that right after I plug it in, if I try to turn it on, the first yellow light in the series of dirt sensor lights turns on then shuts off. After that the light will not light up on pressing the power button, unless I unplug it and plug it back in again. I have seen o


... Kenmore 25512/ 25513 Progressive Canister Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

I have a Eureka Boss Power Plus and the beater bar is rolling, the belt is turning, but after vacuuming up around the litter box (not a lot of litter), when I turn the vacuum off, the litter, or even household dirt, falls out. When I hold the vacuum back to turn it off so that it doesn't fall on the floor, it's sitting in the cubby where the wheels are. The bag is empty, the hose is not plugged, the hose is securely fitted on both ends of the unit. This vacuum was purchased in July and is being


Even though the brush is spinning, you probably need to replace the belt because it is s ... Eureka Vacuums

Why does the brushes spins a little when the charger is plug stright in the vacuum and there are no lights on .on the vacuum the power light is not on or no other lights


... iRobot Roomba 4210 Bagless Robotic Vacuum

I was vacuuming and noticed that the bag needed changing. the red light with the ! inside the triangle also came on. When the bag was changed, the vacuum would not restart. The red light came on. Tried the reset button but nothing happened. Tried unplugging and re-plugging in and nothing happened. Replaced all the filters and still it wouldh't start. So I brought it downstairs and tried one more time to get it to start. it worked! Is there something wrong with the vacuum cleaner? Was it overheat


It was overheated that is why it worked downstairs after cooling off. ... Miele S548 Bagged Canister Vacuum

Local vacuum repair shop replaced motor in Oreck XL 2600HH and now the lights blow out immediately upon powering up the machine. I believe the wires for the lights were mis-wired to the terminal blades on the motor housing. is there a wiring diagram available to properly connect the wires to the motor housing?


Hello. if this repair just occurred return this vacuum to that repair shop as they owe you a valid repair. I agree that they caused the lights blowing out problem. They must repair this for no charge. If you work on it yourself they will blame yo ... Oreck XL2600 Vacuum

I have a motor for the Bissell 3750 power head with a black and brown wire, which wire is connected to what?? The old motor just had 2 black wires. There is a blue wire coming from the vacuum and blue wire coming from the light that are together, and a blue wire coming from the light and a black wire that are together. What does the blue and brown wire coming from the motor connect too? Thanks


... Bissell 3750 Lift Off Bagless Upright Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

Electrolux 2100 hot motor light came on because hose was plugged


The thermal switch should reset itself after it has cooled. If it still won't restart after a while longer, put a a new bag in the machine and turn the machine off and back on. The only other things that should keep it from running other than the the ... Electrolux Epic 6500 Vacuum

Where do you hook the clear hose that is in the compartment with the motor ? Second where the vacuum hose connects to the bag it keeps cutting in and out of power. I replaced the female cord to motor and still cuts out."no suction "


Would you care to tell us the make and model of the vacuum you're asking about? ... Vacuums

Vacuum dead I have oreck XLx2 bagged upright - the belt ,plug and cord have been replaced - has been working great - now went to plug it in and it does not work - the light goes on in the on/off switch so power is working but vacuum is dead - any suggestions


If the cord coming from the bottom up to the handle is loose, and is a plug, push it in. If that doesn't help. then could be a problem with the motor. One other thing to check is inside the handle, maybe a wire came loose. ... Oreck XL2200 Bagged Upright Vacuum

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?


Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

Power head attachment works great when plugged into the hose part of the vacuum. The problem is when I attach it to the tube for normal use there is no power. I have checked all the connections and switched the power switch on and off still no power from tube to power head. Is there anything else I can try? Model Callisto


Try having someone turn the machine on and off while you pull the cord in and out with the cord more angled towards the on/off switch. Sometimes these models have a break in the cord rewind and will not put the power through to the motor. ... Miele Vacuums

Manual A friend of mine just cleaned out her garage and gave me a Westinghouse WST1600 vacuum that was rarely used. I purchased new #25 fuses and have had the battery pack plugged in for over 10 hours and when I put in into the vacuum and press the on button a green light flashes, but the motor does not start. Can I get this vacuum to work?


Here is a copy of the manual for your vacuumwww.thinkvacuums.com/pdf/uprights/Westinghouse-WST1600A.pdfWhat could be the problem is the battery could be shot after not being used for so many years that the life of the battery ... Westinghouse WST1600 Upright Vacuum

I was vacuuming the vent in the bottom of the fridge. I must have picked something because the motor got wildly noisey. I cleaned out hoses, etc. There is no suction. I can see the blades of the motor and they are not turning around. Model U4269-930 Series B.72. Can I get at the motor to see if something is keeping the blades from turning? What would be your suggestion. Many thanks. Pat Sauerman


Hi Pat, my name is John I will do my best to assist you.\015\012\015\012You certainly can get at the motor, with simple hand tools. \015\012\015\012Referring to this ... Hoover Vacuums

Windtunnel Hello: I was reading thru another readers problem of power to vacuum but won't turn on. Same problem for me. All hoses are free of clogs and I have the vacuum basically taken apart as far as I can. You state a THERMO by the motor may be open. What does this part look like? Thank you. Craig


The thermo is a small square piece with two wires coming out of it. Did you check the switch? The switch has a high failure rate. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

We have inherited a Filter Queen Majestic Triple Crown Model 99C vaccum and have no owners manual stating the year it was purchased and parts available. Our power hose electic wire connection (about 6 inches long) which plugs into the main unit is split in the hose attachment end. The motor sound went instantly quieter and I wondered if this was why when I found this frayed electical wire. It has not been used since this problem was found. How much is this single replacement part? I live


... Vacuums

I was using my Heritage 11 vacumn with the hose attachment and the motor shut down like the power went off .When you push the switch on the housing the light comes on but the motor does not run.


Hi, the motor could be overheating. Most vacuums have a heat sensor that shuts the vac. off if there is a clog. Let it sit, feel if it's hot. If so you may have a blockage of dirt etc. Try to clear it, let it cool and tart it up. I hope this helps, i ... Kirby Heritage II Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1713 seconds