Having problems with your Miele S251 Flamenco II Bagged Canister Vacuum ?

Dead motor? My 8 year old Miele S251i has worked fine, until I was recently vacuuming and moved the plug from one outlet to another. When I restarted the vacuum, it made rrrrr.....rrrrrr....rrrrr noises and smelled like something was burning. I turned it off, and it's shown no signs of life since. Sound like a motor problem? I've taken the cover off and looked at the cord and seen the motor, nothing looks obviously wrong, but I'm also not mechanical.


Answers :

Repair Help & Product Troubleshooting for Miele S251 Flamenco II Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Dead motor? My 8 year old Miele S251i has worked fine, until I was recently vacuuming and moved the plug from one outlet to another. When I restarted the vacuum, it made rrrrr.....rrrrrr....rrrrr noises and smelled like something was burning. I turned it off, and it's shown no signs of life since. Sound like a motor problem? I've taken the cover off and looked at the cord and seen the motor, nothing looks obviously wrong, but I'm also not mechanical.


... Miele S251 Flamenco II Bagged Canister Vacuum

I have an older Oreck XL vacuum that sounds like it is running twice as fast as it should. I disassembled the entire vacuum, including disconnecting the motor wires, to clean out the hair, string, and other things. When I put everything back and connected all the wires, everything appears to work, including the light. The only problem is, it sounds extremely loud like the motor is running too fast. The model number is: XL3610HH Ser. No. 3610HHXA039740-6 I do not have as electrical diagram to see


... Oreck XL Ultra Bagged Upright Vacuum

I have a Hoover, Steam spin scrub, Model F5897-900. Only used it a couple times and the motor gave out. First started being noisy then a bad smell. It did seem noisier that what I would expect from the start but I didn't realize it was a problem with the shaft of the motor. I took it apart and found the motor shaft wasn't true and causing sparks. The motor looks like it can not be taken apart and repaired. This seems like a default from the beginning but it is past warranty. Also noti


You will have to replace the motor and the hose asm. thehooverstore.com may be able to help, or you should be able to find a repair shop that can order them for you. ... Vacuums

WST 1600A I purchased this vaccum about four months ago from Heartland America. Up to this point it's worked fine. After cleaning it this time when I went to start vaccuming again it runa for about 10 seconds and cuts off. I've changed the battery, taken everything that can be removed out checked it and replaced it. THe motor sounds like it's straining. I have not taken the housing off the motor to see what's going on with that. I misplaced my manual.


It sounds like there is a clog. If there is no air flow it could be overheating. ... Westinghouse WST1600 Upright Vacuum

Recently my central vac system started making a louder than usual and laboured sound when in uise, enough so that I took note and inspected the canister and motor while running. The motor was trowing off blue sparks and looked like it could 'POP' at any moment. I will not risk using it until I know what the problem is and how to repair it. My assumption is the motor needs to be replaced. The system came with the resale house I bought 3 yrs ago but I do not know the age of the system itself.


... Vacuums

Hi, I have a Dyson DC04, (silver/lime) making ear popping screams! Does not happen all the time, and more noticeable when it is pulled back.The suctions not a problem and no funny smells or strange noises from the motor. Ive taken the base plate off and the belt and brush bar seem fine, but when I turn the belt, it seems to be the motor spindle thats squeaking, almost as if it need oiling, any help please


... Vacuums

Windtunnel Hello: I was reading thru another readers problem of power to vacuum but won't turn on. Same problem for me. All hoses are free of clogs and I have the vacuum basically taken apart as far as I can. You state a THERMO by the motor may be open. What does this part look like? Thank you. Craig


The thermo is a small square piece with two wires coming out of it. Did you check the switch? The switch has a high failure rate. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My pet hair eraser smells like it is burning all the time and sounds funny. The brush will not spin once you have it on the carpet unless you hold it up a little while you are cleaning but then the whole vaccume is not on the floor. I have cleaned all filters and all and it does the same thing. My sister has the same machine because I raved at how wonderful this thing was for pet hair and mine has not worked right since it was about a year old and hers has had the same exact problem since it was


We had the same problem, and it turned out that the roller wheel height setting had broken, for no apparent reason, and was "floppy" so we had to lock it in to one setting with epoxy. Limits utility, but it works. Sort of. ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

Miele S5000 (revolution 5000) vacuum cleaner - How do I open the casing? When the power button on the handle is pressed the green power-level lights on the handle light, but the motor sounds like it gives a little 'jump' but nothing more. The orange power light on the body also dims. I assume the motor or fan is jammed, but I can't open the body to find out. I've taken out to screws inside near either end of the handle, but to no apparent effect. I'm assuming the body is held together by plastic


... Vacuums

I'm not really a technician, but I used to sell Filter Queens and was taught how to maintain them, and have tackled "fixing" some problems. I am a 71 year old great-grandmother of 8, but have good health and am very active. The Filter Queen I have is r, usedeally old, and I have kept it up. Just this week, however, I turned it on and it had a noise which sounds like something might be loose in the motor. I have always been very careful to have a clean hepa filter to protect the motor, so I know


It's tricky to hold screws with one hand and screwdriver with other hand; however, I am 65-yr-old female and do it yearly with 100% perfection! Take a break, relax, and try again! I sit on floor, put attachment between legs for supporting vacuum, h ... Filter Queen Majestic Canister Vacuum

I have a Filter Queen Majestic 360 and am having problems with the powerhead. There is a loud rattling noise in the powerhead, especially when I vacuum thicker carpet. I have replaced the motor, roller brush, and belt, but the rattling remains. It sounds like it is coming from the roller brush area,and when I turn the powerhead over, it rolls free and sounds fine. Any thoughts?


Hi there, as per your information i guess its a problem of power transformer. He can't supply the proper power in the motor & thats why the noise will come from the transformer. Thanks & waiting for your feedback. ... Filter Queen Majestic Canister Vacuum

We have inherited a Filter Queen Majestic Triple Crown Model 99C vaccum and have no owners manual stating the year it was purchased and parts available. Our power hose electic wire connection (about 6 inches long) which plugs into the main unit is split in the hose attachment end. The motor sound went instantly quieter and I wondered if this was why when I found this frayed electical wire. It has not been used since this problem was found. How much is this single replacement part? I live


... Vacuums

My Dyson Animal vacuum sounds like the motor is going? It has also lost suction power and I have cleaned all areas and washed the filter. Is there anything I can do to fix the problem? Where is the closest repair center? My zip code is 17972


... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

I have a Nutone CV-450. When the unit is turned on the motor makes a high pitched whining sound. The suction seems like it is reduced and there is a burning rubber smell coming from the unit. Suction at the unit itself is also reduced. Any ideas about the cause of the problem and the solution?


... Broan-NuTone CV450 Central Bagged Central System Vacuum

We have a kirby generation 3 and it slows down and speeds up almost sounds like it is going do quit could this be a brush problem in the motor sometimes it will quit.


You may need to service you Kirby. Go this page HERE, fill out Service Reques ... Kirby Generation 3 Bagged Upright Vacuum

Dyson DC04 hello, my dyson seems to run ok in upright but when i tilt back the motor sounds like it is struggling, do you think it's down to the rollers being to low and can you adjust height of rollers to overcome said problem? yours chris


Hi.\015\012\015\012If the motor is struggling check to see how easy it is to rotate brush by hand it is stiff to rotate the bearings in the roller may be siezed or the roller could be clogged with hair etc check it & let me know what ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

I have a new Hoover BH50015 hand vac. The noise is terrible. It sounds like the bearing are bad. When you take off the cup and the filter and listen to the motor as it slows down after turning it off it definitely sounds like bad motor bearings. Hoover tells me the loud noise is normal. Can you help?


Yes the bearing is full of dust and dirt\015\012unscrew the housing and clean the bearing area and shaft\015\012then add a dap of Vaseline to the shaft and reassemble\015\012The shaft rides on a nylon bushing which acts like a beari ... Hoover BH50015 Bagless Handheld Cyclonic Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

I have a NUTONE central vac, when I turn on the power, It sounds like its grinding glass and doesnt suction. Could it be that broken glass got caught in the motor and all I need to do is clean it, or is this the sound of a failed motor?


More likely it's something in the fan. However, I suggest taking it to a vacuum repair shop to make sure. Something could have got into the fan system and is making a racket, but the motor itself won't crunch up glass. ... Electrolux Central Vacuum

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???


Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

I am trying to install a train air horn. i bought a viair compressor for it. the horns themselves have a 12 volt hookup going to what i believe is acting like a solenoid. when charged, you complete the circuit and walah, the horn blasts. the problem im having is when the compressor is building pressure, the air horn is automatically putting out a dull sound, getting louder as the pressure gets more and more. it sounds like its out of one horn however. it is doing that without the 12 v hookup. is


Hi! just a tip regarding the sound that comes up when building pressure. Is there a gasket or rubber seal on the horn? You may need to replace this for it may be worn. The air may be coming out of the worn seals resulting to sound even when not trigg ... Vacuums

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?


... Kenmore 34722 Grab-N-Go Upright Vacuum

Model 533 sounds like motor is running but wheels don't spin


... iRobot 530 Roomba Vacuuming Robot, White Vacuum

Motor problem I just picked up a screw. It appears to be stuck in motor. The sound of the motor changed to a whirring noise and it started to smoke. How can i access the motor?


First six pictures HERE will let you know how to remove shell to see the motor. I would not recommend starting it before you get the screw out (you will need to ... Kirby Generation 3 Bagged Upright Vacuum

I have a Kirby Dual Sanitronic '50' Vacuum Cleaner I bought in 1966. The motor does not start when I attach the belt lifter of the rug nozzle. When I remove the rug nozzle and detach the belt from the motor fan shaft the motor starts when I depress the nozzle switch and the power switch . Seems like the brushes in the motor are worn out. I do not have a manual for this unit. Can you assist me as to what newer unit is this compatible to and the problem I'm having at present??


... Kirby Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0736 seconds