Having problems with your Miele S251i Plus Bagged Canister Vacuum ?

Our vacuum bag was full and we keep on vacuuming. I believe some lent and hair got sucked into the vacuum motor. We've changed the bag and filters. Now the motor makes a loud noise especially when shutting off. what should we do?


Answers :

Get a professional repairer to examine it. Even with an over-full bag, dirt will not have got in to the motor if the pre-motor filter was correctly positioned and in good condition. However, the motor may have been damaged through lack of air flow and consequent over-heating. Your machine may well need a new motor, and that's a job you won't be able to do for yourself.\015\012
\015\012Sorry to be the bearer of bad news. I value your feedback, so please remember to rate this response. Good luck!
Repair Help & Product Troubleshooting for Miele S251i Plus Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Our vacuum bag was full and we keep on vacuuming. I believe some lent and hair got sucked into the vacuum motor. We've changed the bag and filters. Now the motor makes a loud noise especially when shutting off. what should we do?


Get a professional repairer to examine it. Even with an over-full bag, dirt will not have got in to the motor if the pre-motor filter was correctly positioned and in good condition. However, the motor may have been damaged through lack of air flow an ... Miele S251i Plus Bagged Canister Vacuum

Kenmore upright vac model 33922 - good suction but developed loud whining noise after accidentally vacuuming room without bag. Added bag and changed both filters. Still makes noise. How can I stop noise?


The bag is the first stage in your filtration. Most times what you did will draw fine dust right through the filters and into the motor itself, affecting the bearings and clogging the motor fans, throwing them off balance. The fact that there i ... Kenmore 33922 Direct Drive Bagged Upright Vacuum

Won't start. My son was using the vacuum & Didn't change the bag. The vacuum was making the full bag smell, but the light was't on & it didn't stop. I stopped him, changed the bag, checked the filter, closed the compartments & turned on the vacuum. Nothing happened. I checked to be sure that it was plugged in, that wasn't the problem. I've let the vacuum "rest" for several days, It still won't start. Any suggestions?


There is a reset button at the back of the powerhead. The user manual can be downloaded from the electrolux website, although I didn't find it very useful. There was some info on how to change the powerhead drive belt. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

I have a Z345 Electrolux cylinder vacuum cleaner, from the 1970s probably, but not used much. I have lost the guide. I forgot to change the bag before it was full. Smoke started to come out - smelling of burnt paper, not rubber. So switched off. It did not blow the fuse, and may be OK. I wish to inspect it. How do I open it up? Alos I have an air filter and a motor filter for it. I have often changed the air filter on the top. How do I get at the motor filter, if there is one? Than


Good day! OK you have to is replaced the bag and that's it.And don't forget to change the bag again to avoid that problem.Thank you ... Electrolux Guardian Bagged Canister Vacuum

Miele Cat & Dog vacuum gets VERY hot and is VERY loud. Hose has no restrictions and I have changed the dust compartment (motor) filter and the exhaust filter. It still gets hot when I run it with the top open and all filters removed, so I'm guessing the problem is with the motor. Should I be going into the motor compartment? If so, what am I looking for?


Hi\015\012\015\012The fact that it gets very hot could be due to a number of issues.,but the fact that it started making a very loud noise at the same time suggests that there might be more problems maybe brushes etc.\015\012\ ... Miele S514 Solaris Bagged Canister Vacuum

We have a Kenmore Progressive Model 116 Upright bagged vacuum with Hepa filter. It's at least a couple years old. For quite some time now when ever we use the vacuum the vacuum motor will shut off nafter about 5 min. of use. We then need to let it sit for awhile and then we can run it again for another 5 min. The bag has been change. Any one have any ideas how to fix this?


I suspect that you have a restriction. The motor sounds like the thermal break is stopping the motor before damage, due to heat.\012You must witness that the entire suction and discharge side are clear. This is not always very easy, but necessa ... Kenmore 34612 Bagged Upright Vacuum

Bad Motor I have purchased two of the Kenmore direct drive beltless systems with Progressive systems. The first died after a year, the vacuum motor start making a grinding noies. I pulled the side HEPA filter and could see a fine coating of graphite like dust. Took it to a vacuum repair shop. They said the brushes were going and thus the motor was shot. I liked the vacuum and bought a second, 1 year later the motor is making a slight noise that and removing the HEPA filter I find a slight metall


That dust is from the carbon brushes on the motor. You may need to check them, and also clean out the motor compartment. A slight noise could be a motor bearing starting to go. Does the smell like rubber or electrical. If rubber, then the belt h ... Vacuums

Vorwerk ET 340 - been great but now noticing strong burning smell after vacuuming some hair from the bathroom. Bag is nearly empty. Gave it a rest then unscrewed the cover housing the motor and all looks clean (dust is sucked up the pipe and doesn't appear to get near the motor). When I restarted it, burning smell still there. Are there any filters that might need changing? What could be causing the smell? Could the hair have gotten caught somewhere? Thanks.


Jessica,\015\012\015\012Try changing the dirt bag.\015\012Check if the motor gets hot after operation. You can come to check it by touching outside the motor housing. If it is hot or just warm.\015\012Is the smell of burning hair or something e ... Vacuums

I have a Kenmore Elegance model 116 that has lost suction. There is no blockage and both the filter and bags have been changed. The powerhead turns on but the vacuum itself is fairly quiet, not sure if that motor is running. How can I regain the suction?


... Kenmore Vacuums

Miele s4212 vacuum accidently used with no bag now making very loud noise and slight burning smell ,is the motor damaged beyond repair or is there a way of repairing this ?


... Miele S4212 Bagged Canister Vacuum

I have a Filter Queen Majestic 360 and am having problems with the powerhead. There is a loud rattling noise in the powerhead, especially when I vacuum thicker carpet. I have replaced the motor, roller brush, and belt, but the rattling remains. It sounds like it is coming from the roller brush area,and when I turn the powerhead over, it rolls free and sounds fine. Any thoughts?


Hi there, as per your information i guess its a problem of power transformer. He can't supply the proper power in the motor & thats why the noise will come from the transformer. Thanks & waiting for your feedback. ... Filter Queen Majestic Canister Vacuum

I have a Kenmore vacuum cleaner 116.35922 and it's making a loud noise and not picking up dirt. I checked the hose for a clog and changed the bag. What else can I do?


Check to see if the brush is spinning when the unit is running. If not, the drive belt may have broken and will need to be replaced. Common sized replacement belts can be purchased at most department stores. Kenmore belts should be available at most ... Vacuums

I was using the vacuum and noticed the filter had fallen down. It's making a very loud sound now. Appears the dirt might have gotten into the motor. Any way to clean this out? Any other thoughts?


Solution: cleaned out plugged hose lines. Changed filter and made sure it snapped into place and that bottom cap was secure. Also changed hepa filter and everything is good now. ... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

My electrolux oxygen cannister has the "bag change" light on when there is a new bag. The light stays on when the suction power is high (to pick up small particles) and it won't pick up, but the ight goes off when the suction power is low (to pick up big objects). I changed the hepa filter, cleaned the motor filter and changed bags, but all that didn't help.


You may have a clog in the hose, and/or the inlet by the brush roll. A clog will turn on that light as well as a full bag. ... Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

I was vacuuming and noticed that the bag needed changing. the red light with the ! inside the triangle also came on. When the bag was changed, the vacuum would not restart. The red light came on. Tried the reset button but nothing happened. Tried unplugging and re-plugging in and nothing happened. Replaced all the filters and still it wouldh't start. So I brought it downstairs and tried one more time to get it to start. it worked! Is there something wrong with the vacuum cleaner? Was it overheat


It was overheated that is why it worked downstairs after cooling off. ... Miele S548 Bagged Canister Vacuum

I have a nearly 9 year old Electrolux Excellio Z5228 vacuum cleaner. It has recently started cutting out during operation. I cleaned the micro filter (between bag & motor) via brush & hitting against wall & seems / looks quite clean. I washed the gore filter (output from motor to clean the exhaust air) as per instructions, then let to dry. It was very clogged but now very clean. The vacuum clearner still cuts out often. Even after a long rest (say overnight) it still won't start, then ano


... Electrolux Vacuums

My eureka vacuum was fine but then suddenly got loud. We cleaned the filters and replaced the belts, but it is still loud. We have not seen any clogs in the tubing or in the vacuum. What other problems could the vacuum have to make it loud?


The noise could be coming from the Beater Bar's ball bearings. ... Vacuums

Need technical help for my miele s2180 momentum canister vacuum .Bought a display open box at fure shop..Came with a filter bag..there are no tears in the bag...Perhaps they put the wrong bag..Anyway after 30 minutes of use..The motor stopped working ..so I opened up the unit only to see,.the dirt was everywhere inside the vacuum...only a little was in the bag itself..can you hepl..Dave


... Vacuums

I was just using my Bosch 1450W bagged vacuum and all of a sudden, the motor just shut down. No warning, no problems. The light still turns on, but the motor is unresponsive. There is a clean bag and filter, and nothing caught in the front roller. The motor sounded fine - no shaking, or weird frequency variations. There were no weird smells, just a little bit of heat, but nothing beyond normal. I've had this thing for several years, and never had a bit of trouble with it. Any suggestions


Many vacuums have internal thermal switches that need to cool to allow the vac to operate. After 30 minutes, check all 3 air filters and try again.\012Gary ... Bosch BSG71310UC Bagged Canister Vacuum

Overheated vacuum After I finished vacuuming the library last night I changed the bag and shook out both filters and vacuum would not restart. The canister unit felt real warm to the touch but I had been using it a least 1/2 hour non stop. The bag was pretty full but not overly so. It's a Simplicity canister with power head. The carpet is long shag from the 70's Did it just over heat? Thanks Shauna


It normally won't over heat unless the bag is too full, the filters are clogged, or you have have a clog in the hose or down by the brush roll, the inlet may be clogged. Some will restart after a while, some others have a reset to push. If it won't ... Simplicity 7850 Premier Bagged Canister Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

Motor quit working. i was vacuuming and all seemed fine. then the motor went really low. when I opened it I noticed that the bag was not attached and the cannister had filled up with stuff and the filter was full. the vacuum will not run now.


My friend, the dirt you sucked up went right into the motor and it burned up. I am very sorry to tell you this. It is probably not worth repairing unless you are able to replace it yourself.\015\012\015\012In addition to not being able ... Kenmore 31912 Progressive Direct Drive Bagged Upright Vacuum

Wondering if the head is plugged up because it makes a sound like air is escaping somewhere. I've replaced the original cloth bag with a comparable "O" paper bag from Sears. I tried to see if there was a clog in the hose by placing a broom handle in the hose to see if something would loosen. I also cleaned the filter and the air filter. If the head is plugged, how can I fix it? We can't get the vacuum apart. Thanks.


I had this problem, but suction improved when the attachments were properly secured in their holders. ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.


Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1073 seconds