Having problems with your Miele S5211 Deep Black Vacuum Cleaner Bagged Canister Vacuum ?

S5211 vacuum: will not stay switched on, red sign appears immediately. Bag is empty, filter in place - what to do?

Answers :

Repair Help & Product Troubleshooting for Miele S5211 Deep Black Vacuum Cleaner Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

S5211 vacuum: will not stay switched on, red sign appears immediately. Bag is empty, filter in place - what to do?

... Miele S5211 Deep Black Vacuum Cleaner Bagged Canister Vacuum

Vorwerk ET 340 - been great but now noticing strong burning smell after vacuuming some hair from the bathroom. Bag is nearly empty. Gave it a rest then unscrewed the cover housing the motor and all looks clean (dust is sucked up the pipe and doesn't appear to get near the motor). When I restarted it, burning smell still there. Are there any filters that might need changing? What could be causing the smell? Could the hair have gotten caught somewhere? Thanks.

Jessica,\015\012\015\012Try changing the dirt bag.\015\012Check if the motor gets hot after operation. You can come to check it by touching outside the motor housing. If it is hot or just warm.\015\012Is the smell of burning hair or something e ... Vacuums

My kenmore vacuum 35922502 sensor dirt lights stay on red all the time. I have changed the bag, filter, little sponge filter, still they stay on. What is wrong? Lynn [email protected]

... Kenmore 31912 Progressive Direct Drive Bagged Upright Vacuum

Wondering if the head is plugged up because it makes a sound like air is escaping somewhere. I've replaced the original cloth bag with a comparable "O" paper bag from Sears. I tried to see if there was a clog in the hose by placing a broom handle in the hose to see if something would loosen. I also cleaned the filter and the air filter. If the head is plugged, how can I fix it? We can't get the vacuum apart. Thanks.

I had this problem, but suction improved when the attachments were properly secured in their holders. ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have a Kenmore central vacuum cleaner model number c107 34601. We have emptied the bucket and shaken the filter out to clean it. There is a filter that is filthy so we shook it out into a bag but the cleaner still seems to not have great suction. I notice there is a similar cap to the outlets I plug the central vac hose into on the unit itself that doesn't power the nozzle when used. 1 - what is this for? 2 - Should I somehow remove the entire filter and if so - can you tell me step by step ho

... Electrolux Vacuums

Vacuum will not stay on, new bag in place and power to machine.

It sounds like you have a bad control valve. Take it to you nearest Aerus (formerly Electrolux) dealer and have them change it for you. It shouldn't be too expensive. Good Luck!! ... Electrolux UltraLux 2000 Bagged Canister Vacuum

My Kenmore canister vacuum cleaner model 116.27514700 has unacceptably low suction.It is much less than my older GE Walmart canister vacuum. the 2 filters are very clean and there is no blockage in the hose and the dust collection bag is empty. Is poor suction a characteristic of this model or if not is there a way to fix this problem?

... Panasonic Kenmore Canister Vacuum Vacuum

Bissell cleanview 11 bagless special edition model 3576-2 I took apart to clean the filters and don't remember howto put the bottom of the dirt container back. I thought I put the empty container back in place correctly but the dirt when vacuuming is flowing through another part of the vacuum.

... Bissell Vacuums

I have a Kenmore Progressive Upright Vacuum - Purple, and it worked just fine. I emptied the canister (like always) and put it back in place. I turned on the vacuum to it immediately shutting down (motor) and only the lights come on. There is no movement/noise/suction at all! Any suggestions? I have tried everything. I have no idea why it did this.

Make sure that something didn't fall into the fan assembly in the base when the canister was removed. The motor should have an overload reset switch. Try moving the motor manually (power plug out) to make sure that it isn't bound up. ... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

Unbeknownst to me, someone took the bag out of my Kenmore Progressive vacuum and failed to replace it. I have been vacuuming without a bag for months, and today the vacuum stopped sucking. When I opened up the front to replace the bag, tons of dirt and dust came pouring out. I thoroughly cleaned the vacuum, put in a new bag, but still no sucking power. Just dust coming from the rear vents where one of the filters is. Is the vacuum ruined, or is it a simple solution of buying a new filter?

Sounds like you need to buy a new motor. All that grit and dust will ruin a motor and I'm surprised it lasted as long as it did.\015\012This is where a vacuum that won't run without a bag would have been nice. (Aerus for one) ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I bought a Kenmore canister vacuum, model 116, in April 2007. This morning, the sound of the motor suddenly began to deepen, and I began to lose suction. Normally, if something is clogging the hose, the motor will wind up to a higher pitch, not a lower one. The filters are clean, the bag is empty, and I can't detect anything lodged in the hose. If this were a car's engine, I would say it's "lugging down". Any pointers?

Okay, bear with me. Is it possible you have a suction adjustment, dial somewhere on vac. Check and see and if it does, be sure it's all the way up. Also, try removing hose and run a broom handle fr. one end to the other...BUT be careful not to stretc ... Vacuums

The hose is disconnected, new bag in unit, new filter, unit runs when hose is detached but immediately turns off when hose is attached but hose has no obstruction, etc.. i was told i need some sort of valve. HELP! I have birds, a cat and 2 large dogs and no vacuum :)

There is a vacuum hose that attaches inside the unit to a round clear plactic piece. In most cases you can simply cut the small vacuum hose and it will fix the problem. ... Electrolux Epic 3500 Vacuum

Bought a Kenmore Progressive canister vacuum at a garage sale that looked in better than average condition, filters clean, new bag, all accessories intact, some debris in roller brush. problem is no suction when turned on. There does not appear to be any obstruction in hose. did not have manual

Hello,Carnister vacuum cleaners are all built with the same principle in mind. A motor \015\012generates power which powers a vacuum which, in turn, creates suction to\015\012 lift debris. The most common areas of suction loss are within ... Kenmore 25512/ 25513 Progressive Canister Vacuum

My Hoover Mach 5 model number u5194-900 series ZF12.O will vacuum for about 15-10 min then it shuts its self off and will not turn back on., I have cleaned out all the hoses, filters and cleaned off brush. What can I do to fix this so that it will **** into the chamber. The hoses get clogged and it doesn't appear to be sucking into the "bag area"

... Hoover U5194-900 Mach5 Multi-Chamber Cyclonic Vacuum Cleaner Bagless Vacuum

Model el7001 You can push the button on the hose and the unit will come on then immediately stop. Once in awhile it will stay running. I have replaced the bag and the hepa filter but that didn't help. Any thoughts

... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

My Miele White Star Model # S3141 was running fine, then stopped mid-vacuuming. I changed the bag and cleaned the filters (which were dirty), let it cool off, and tried to start it up again, but no luck. What do I do now? Are there any repair places in Ft. Myers, FL?? Thank you for your help.

... Miele Vacuums

We have an electrolux Vacuume & the lower hard part that plugs into the power nozzle does not stay in. Cay U sendf us 1 new peice and a price on new bags & filters. Thanking U in advance. Mrs. B. Wells. Pls. reply to [email protected]

It costs around $5 to replace it u can get it in ebay too ... Electrolux Vacuums

The vacuum leaks dust around the joint between the bag and the vacuum. I unlatched the bag, removed and emptied it, and replaced it. However, the vacuum still leaks dust around the joint and the bag keeps working loose. How can I make sure that the bag is securely latched so that it does not leak or come loose? I have no manual. Thanks.

... Bissell 3065 Power Partner Vacuum

Won't start. My son was using the vacuum & Didn't change the bag. The vacuum was making the full bag smell, but the light was't on & it didn't stop. I stopped him, changed the bag, checked the filter, closed the compartments & turned on the vacuum. Nothing happened. I checked to be sure that it was plugged in, that wasn't the problem. I've let the vacuum "rest" for several days, It still won't start. Any suggestions?

There is a reset button at the back of the powerhead. The user manual can be downloaded from the electrolux website, although I didn't find it very useful. There was some info on how to change the powerhead drive belt. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

No vacuum My Floormate has plenty of air moving, but no vacuum at the nozzle. When I turn it on, the filter hops up to the black rubber "intake", rather than staying in its spot. It seems to me that the intake should be in contact with the filter when the reservoir is installed. And I don't understand why the intake isn't closer to it, but it seems fixed there, almost an inch higher than the filter. When I remove the bottom reservoir and turn the h3000 on, I feel vacuum at the intake, and air

Someone must have lost the filter cover from the machine. It is a clear blue plastic cover that goes over the filter and has a hole that lines up with the motor intake. It is approx. 3 inches square and has an angular top to coincide with the motor i ... Hoover Floormate H3000 Upright Wet/Dry Vacuum

I have an Ecectrolux Epic canister vacuum. As soon as it starts sucking, the vacuum cuts off. I put a new filter and bag in, but it doesn't seem to help. If I open the front where the bag goes, take the bag out and depress the safety button the vacuum will run. Need some help or direction. Thank you

Try this.\015\012Disconnect hose. Turn machine on and place hand over intake. If it shuts off immediately, first try turning dial on top of machine so largest dot matches up with arrow. Turn on and place hand over intake again. If it still ... Electrolux Vacuums

Bag light stays on, powers on then shuts off immediately. What is the problem?

First check to make sure there is a bag in the machine, if so make sure that its in securely, there is a pin switch in the bag door that wont allow the machine to turn on if there is no bag in it. If that's okay, then find the knob on the top of the ... Electrolux UltraLux 2000 Bagged Canister Vacuum

Need technical help for my miele s2180 momentum canister vacuum .Bought a display open box at fure shop..Came with a filter bag..there are no tears in the bag...Perhaps they put the wrong bag..Anyway after 30 minutes of use..The motor stopped working ..so I opened up the unit only to see,.the dirt was everywhere inside the vacuum...only a little was in the bag itself..can you hepl..Dave

... Vacuums

My Grandson bought a Kirby (2009 Model) for his wife. They have since divorced and I have the vacuum cleaner without instruction book or bags. I have ordered bags but can't understand how to place bag on vacuum. The bags came with a black ring and I don't know what to do with that either. Please explain this to me. Thanks

You can order one from Ebay. Price varies, but expect to pay around $10.\015\012http://shop.e ... Kirby Generation 3 Bagged Upright Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1365 seconds