Having problems with your Miele s558 Silver Moon Vacuum ?

Silvermoon overheated and shut down. we've waited for it to cool down. When attempting to start the sweeper the red caution light (red triangle with exclamation mark comes on) but sweeper does not turn on. There are no obstructions in the hose or sweeper bag. There is a reset button. I pushed that but still no luck. Is there a fuse or something that needs to be replaced?

Answers :

Repair Help & Product Troubleshooting for Miele s558 Silver Moon Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Silvermoon overheated and shut down. we've waited for it to cool down. When attempting to start the sweeper the red caution light (red triangle with exclamation mark comes on) but sweeper does not turn on. There are no obstructions in the hose or sweeper bag. There is a reset button. I pushed that but still no luck. Is there a fuse or something that needs to be replaced?

... Miele s558 Silver Moon Vacuum

When I flip the switch on my sebo x1 upright, a red light comes to the brush and bag icons. However, I cleaned out the hose and checked to make sure there is no obstruction from the brush to the hose also, or from the hose to the bag. It is clear that juice is coming to the vacuum, but there is no sign of life except the two red lights.

Thanks for contacting fixya. You should pull out the bag and reset the machine. You should take all the user replaceable items. And turn it on. You will get lot of errors. Then turn the machine off. Put back all the accessor ... Sebo Automatic X1 Bagged Upright Vacuum

The red replace bag came on so i replaced the bag when i turn it on again the red light is still on

Make sure you have the bag on tightly. Also...before you replace the bag, check and see that there is no dust remaining in the tube going to the bag. It could be clogged and blocking the sensor to the red light; which is keeping it on.Good Luck ... Hoover Vacuums

The hose is disconnected, new bag in unit, new filter, unit runs when hose is detached but immediately turns off when hose is attached but hose has no obstruction, etc.. i was told i need some sort of valve. HELP! I have birds, a cat and 2 large dogs and no vacuum :)

There is a vacuum hose that attaches inside the unit to a round clear plactic piece. In most cases you can simply cut the small vacuum hose and it will fix the problem. ... Electrolux Epic 3500 Vacuum

The power nozzle on my c141b model aerus electrolux canister vaccum no longer turns on. It was working when a large stringy object was sucked in. When hitting the red reset button, nothing happens. Is it likely that it is the fuse that needs to be replaced? All wires appear intact (I replaced the elbow assembly a few months ago.), and the sweeper moves freely.

It's not a fuse.\015\012Turn the power nozzle on it's top. Try to rotate the brush. If it won't spin, there's till something holding it. Remove all strings, threads, and whatnot from the roller. Try to rotate it again. If it still won't sp ... Vacuums

I have replaced the bag and when I connect the hose the vacuum shuts off and the full bag light comes on and the vacuum turns off

Sorry I disconnected us by accident. The url for the site where you can download a manual is http://www.aerusvacuums.com/support/manuals/index.cfmSelect your model from the "older models" listing ... Electrolux Epic 6500 Vacuum

My electrolux 7000 shuts off red filter light goes on i have changed the bag, changed the filter. the slightest amount of interruption in suction (including reconnecting the hose) makes the red light go off and turns off the vac. Whats a clean freak to do?

... Electrolux Lux 7000 Bagged Canister Vacuum

Burning smell took everything apart suction is working throughout hose and bag, replaced bag and belt, roller is turning seems to be missing the suction from the main floor section into the roller?

I had burning smell and some visible smoke which I tracked down to the handle area. The mains socket at the bottom of the handle had burned out. When I pulled the plug out I noticed that the prongs were blackened and scorched. I will replace the sock ... Oreck XL Ultra Bagged Upright Vacuum

Suction power greatly diminished . Bag replaced...hose is clear...Performance indicator light is on and red..much less suction that it should have'

Clean the filter. ... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

Bought a Kenmore Progressive canister vacuum at a garage sale that looked in better than average condition, filters clean, new bag, all accessories intact, some debris in roller brush. problem is no suction when turned on. There does not appear to be any obstruction in hose. did not have manual

Hello,Carnister vacuum cleaners are all built with the same principle in mind. A motor \015\012generates power which powers a vacuum which, in turn, creates suction to\015\012 lift debris. The most common areas of suction loss are within ... Kenmore 25512/ 25513 Progressive Canister Vacuum

Will not turn on. tried different outlets and replaced bag. came on for a second then stopped working even though switch was on. trying to only use hose.

It is probably clogged up or its suction motor is burned up. Hop this helps!?\012\012\012Please rate solution - Thanks. ... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

Faithful Sebo X1 upright, about 12 years old, stopped working today. I replaced old with new dust bag, checked all dust paths were clear, checked main brush was clear/clean, and drive spindle rotated OK with fingers. When power switched on, the two red indicators briefly flash on then off, but nothing more happens, motor does not start - even with power reaching machine. Tried removing all consumables, refitting and turning on a few times to reset, no joy. Removed base cover, both belts were i

At 12 years, this vacuum has had a good long life. I suspect the motor is shot, but it could be due to faulty wiring and connections. A bad switch, break in the power cord, and worn brushes in the motor are other causes.\015\012I recommend ta ... Sebo Automatic X1 Bagged Upright Vacuum

My vacuum turns on for a second and shuts off. I have replaced the bag and filter, and it still happens. The replace bag light turns on after I do this.

1. Detach the hose and turn on. If it runs, place hand over opening. If it shuts off, the control valve assembly is dirty or worn out and needs cleaned/replaced. This is a job that should be done by an authorized Aerus Electrolux service tech. I ... Electrolux Epic 6500 Vacuum

I Have two questions concerning my AIRVAC AV2500 Red Series Vacuum System. How do you replace the light in the floor power head sweeper and can you replace the permanent fabric filter? We had the system installed in 2004 and the light in the sweeper head just went out and can not find any manual on line on how to replace it. The filter if not torn but avter 6 years it probably needs some kine of cleaning or replaced even though it says permanent. Any help would be appreciated. Jim McCluskey

... Vacuums

Vaccum does not seem to have good suction replaced bag & hose is clear

... Kenmore 23812 Progressive PowerMate Bagged Canister Vacuum

The rotating sweeper on my Electrolux Discovery II isn't turning. Can I assume there is a belt that needs to be replaced? Also, how do I get at the sweeper unit to replace the belt? Finally, where can I find a replacement belt? Thanks!! Dewey

... Electrolux Vacuums

I have a Eureka Boss Power Plus and the beater bar is rolling, the belt is turning, but after vacuuming up around the litter box (not a lot of litter), when I turn the vacuum off, the litter, or even household dirt, falls out. When I hold the vacuum back to turn it off so that it doesn't fall on the floor, it's sitting in the cubby where the wheels are. The bag is empty, the hose is not plugged, the hose is securely fitted on both ends of the unit. This vacuum was purchased in July and is being

Even though the brush is spinning, you probably need to replace the belt because it is s ... Eureka Vacuums

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!

... Miele Vacuums

My BROAN CV-110 hose with the rug beater only works if I turn it on from the base unit. Shouldn't it turn on when I plug the hose into the wall recepticle? Do I need to replace the hardware at the end of this hose and if so, where would I purchase that? This central vac came in a house I just purchased. Thanks for any help. Sherry

... Broan-NuTone CV450 Central Bagged Central System Vacuum

The hose inside the cloth bag is detached at the bottom. How do I replace the hose or do I need a whole new outer bag?

Hello, whgrayI was trying to help you out here. Maybe this will help some? I was going backto some customers that asked questions in the recent past and even fartherback. It appeared that no one answeredsome of them, So, I thought I would ... Kirby G4 Bagged Upright Vacuum

My Dirt Devil M082476 Full Bag indicator light keeps coming on when I turn my vacum up to full intensity. I have tried changing the bag and checked that all hose is clear. If I leave the vacum on low intensity the suction is minimal and does not increas when I turn up the suction. Is there a solution to this? I look forward to your response

... Dirt Devil M084105 Jaguar Vacuum

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

Kenmore progressive vacuum model: 116.25614506, I replaced the bag and filter and now it seems to **** the bag up against the hose outlet with very little suction at the hose end

... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

Electrolux epic series 6000 sr model canister...we put a new bag in machine but it wont turn on and the light is on saying the bag is full and needs to be replaced...we tried the on-off switch several times but it wont turn on...why?

... Electrolux Vacuums

I was vacuuming and noticed that the bag needed changing. the red light with the ! inside the triangle also came on. When the bag was changed, the vacuum would not restart. The red light came on. Tried the reset button but nothing happened. Tried unplugging and re-plugging in and nothing happened. Replaced all the filters and still it wouldh't start. So I brought it downstairs and tried one more time to get it to start. it worked! Is there something wrong with the vacuum cleaner? Was it overheat

It was overheated that is why it worked downstairs after cooling off. ... Miele S548 Bagged Canister Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0781 seconds