Having problems with your Miele Vacuums ?

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


Answers :

Repair Help & Product Troubleshooting for Miele Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But


Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

Wondering if the head is plugged up because it makes a sound like air is escaping somewhere. I've replaced the original cloth bag with a comparable "O" paper bag from Sears. I tried to see if there was a clog in the hose by placing a broom handle in the hose to see if something would loosen. I also cleaned the filter and the air filter. If the head is plugged, how can I fix it? We can't get the vacuum apart. Thanks.


I had this problem, but suction improved when the attachments were properly secured in their holders. ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have a Hoover windtunnel T series. Model #UH70105. The system check indicator was almost red so I cleaned the filter. There are no clogs and it vacuums fine without the hose, but when I go to use the hose there is very little suction and all the vacuum dust flys out of the end the hose piece fits into when not in use. Can you please tell me what is wrong?


... Hoover Vacuums

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.


I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

Arrgh! I have an upright Bissell vacuum. Everytime I use it, it smells like a cloud of dust. I have made sure countless times that all the filters are clean and the hoses are intact, so I don't know what the problem is. Is this problem normal? Or am I somehow blowing dust everywhere? Any insight it much appreciated, thanks!!


I believe you have a clogg in the suction pipe. ... Bissell 3590 CleanView Bagless Upright Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

I bought a Kenmore canister vacuum, model 116, in April 2007. This morning, the sound of the motor suddenly began to deepen, and I began to lose suction. Normally, if something is clogging the hose, the motor will wind up to a higher pitch, not a lower one. The filters are clean, the bag is empty, and I can't detect anything lodged in the hose. If this were a car's engine, I would say it's "lugging down". Any pointers?


Okay, bear with me. Is it possible you have a suction adjustment, dial somewhere on vac. Check and see and if it does, be sure it's all the way up. Also, try removing hose and run a broom handle fr. one end to the other...BUT be careful not to stretc ... Vacuums

The performance indicator light will not go out. I have cleaned the bag, filter and hose. there does not seem to be enough suction.


You are clogged somewhere ... \015\012\015\012no suction? \015\012performance indicator says no suction?\015\012\015\012find and remove the clog.\015\012\015\012id be looking in the hose about 4 inches from ... Vacuums

My Kenmore canister vacuum cleaner model 116.27514700 has unacceptably low suction.It is much less than my older GE Walmart canister vacuum. the 2 filters are very clean and there is no blockage in the hose and the dust collection bag is empty. Is poor suction a characteristic of this model or if not is there a way to fix this problem?


... Panasonic Kenmore Canister Vacuum Vacuum

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u


Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

Unbeknownst to me, someone took the bag out of my Kenmore Progressive vacuum and failed to replace it. I have been vacuuming without a bag for months, and today the vacuum stopped sucking. When I opened up the front to replace the bag, tons of dirt and dust came pouring out. I thoroughly cleaned the vacuum, put in a new bag, but still no sucking power. Just dust coming from the rear vents where one of the filters is. Is the vacuum ruined, or is it a simple solution of buying a new filter?


Sounds like you need to buy a new motor. All that grit and dust will ruin a motor and I'm surprised it lasted as long as it did.\015\012This is where a vacuum that won't run without a bag would have been nice. (Aerus for one) ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

Change dust bag indicator frequently turns on


... Bosch BSG81360UC Premium Health Guard Bagged Canister Vacuum

Hoover SteamVac Model F6056-900 SteamVac/SpinScrub. Indicator light and high pitch suction noise indicates that dirty water tank is full. However, water level indicator (yellow bobbing plastic thing) is at the bottom of the tank and there is no water in the tank. Have check all the hoses for clogs, none found. Checked water port from motor area to receptacle tank for clogs, none found. Fixed broken hose to upholstery wand with duck tape, (wire not broken, just cracked plastic hose). The onl


There are 2 filters, make sure they are clean, one is on the tank lid, the other is from the bottom, it is red, pull it out and clean it. If yours has a foam filter on the tank lid covering the yellow ball, make sure there is at least a 1/4 in. gap ... Hoover Vacuums

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after


... Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.


Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

I have the Aerus Lux7000-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)


Hi, you very likely have a defective control valve under the dial on top of\015\012the vac , or a kink or blockage in the tiny pressure hose that feeds\015\012the air from the throat of the vac or the back of the bag chamber\015\012against the two si ... Electrolux Guardian Bagged Canister Vacuum

I have just replaced the bag in my miele and the indicator is showing that the bag is full. The air coming from the exhaust is hot and the machine is making a higher pitched sound as it does when the bag is full. When the hose is detached, the indicator registers as empty and there doesn't seem to be a blockage.


... Miele Vacuums

I have the electrolux guardian-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)


Hi,\015\012Check your hose you have something stuck in the hose...stretch it out straight and run something through it to push out whatever is stuck in there...\015\012\015\012heatman101 ... Electrolux Guardian Bagged Canister Vacuum

Bag full indicator light on only when I plug the hose back in...


Drop a marble or something similar through the hose to see if its clogged ... Bissell 3522 PowerForce Bagged Upright Vacuum

Kenmore progressive vacuum model: 116.25614506, I replaced the bag and filter and now it seems to **** the bag up against the hose outlet with very little suction at the hose end


... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

When I turn on my Kenmore Premier 4.5 Peak HP 10.0 Amp after about a minute of running I get a burning smell. When I opened up the compartment that holds the dust collection bag, and remove the bag I found a filter. The filter was minimally dusty and has been cleaned. After sniffing around, I could not identify the source of the smell.


Dose it smell like rubber check your belt ... Vacuums

Hello, I have the same model. And though it is three years old, starting from the last month, it does not clean anything anymore. Cannot even pick up one single thing from the floor. Every dirt gets stuck in the hose. I cleaned the hose and cleaned the filters but it still does not pick anything up. Is three years its normal lifetime or do I have the change the filters, instead of cleaning them? Thanks.


I know bissell vacuums are very cheap but they should last more than 3 years. there should be two parts to the dirt cup. remove the dirt cup and above it there should be a round plastic part. unscrew it and check that filter. ... Bissell 6594 PowerForce Bagless Upright Vacuum

I recently lost power to the power head. Thinking the hose was not sending current to the head, I bought a new hose. It did not solve my problem. I have since noticed that a warning symbel is appearing that indicates what looks like a key with TA inside. The vacumn has good suction. Please advise John.


Hi\015\012\015\012Please check the link bellow to diagnose your problem…..\015\012\015\012http://home.howstuffw ... Electrolux Epic 6500 Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0962 seconds