Having problems with your Nilfisk Vacuums ?

My Nilfisk GWD 300s had been working fine, however today i could smell something like burning smoke from the motor, when i opened up the motor i could see a carbon metal rod touching the motor shaft a

\015 GWD 300s\015

Answers :

Repair Help & Product Troubleshooting for Nilfisk Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My Nilfisk GWD 300s had been working fine, however today i could smell something like burning smoke from the motor, when i opened up the motor i could see a carbon metal rod touching the motor shaft a


... Nilfisk Vacuums

Bissell PowerForce Turbo: The motor spindle becomes very hot while spinning, causing the new belt to burn and break. Is this because the motor is overheating?


Something is preventing the brush roller from turning even though it seeems to be OK when not in contact with the floor. The motor shaft is spinning on one spot of the belt, causing the heating, the smell, and eventual belt failure. I have had brush ... Bissell 6594 PowerForce Bagless Upright Vacuum

No power I ran over an elastic hair band with the hose that wrapped around the shaft (not the brush). Since then, no power. could the motor have burned up?


If pieces wrapped around the fan fins and jammed the fan from turning, this could be the problem. You may have to remove the front of the vac to get to the fan. ... Kirby G5 Bagged Upright Vacuum

The motor on my Epic 6500 works, the hose is sucking, but the power head isn;t working... I tried the sidestep power head and that one works. Ive opened and replaced the belt and that is fine. The bulb was already burned out and wasn't replaced so I cant tell if theres power to the head. What else could it be?


Connect the power nozzle directly to the hose and try.\015\012Check the terminals where the wand connects to the PN. If any are discolored or cracked, that may be the problem.\015\012Open the PN and check for loose or broken wires and co ... Electrolux Epic 6500 Vacuum

Kirby Sentria Hi, I have a new Sentria & used it for the first time today. It was going fine & then I could smell smoke & it started to make a loud noise so I turned it off quickly. If I turn it on it immediately starts making the noise again & I can see it is all lit up inside like something is burning or sparking. I have checked the roller & it is moving & I have checked the fan which is moving & doesn't appear to be damaged in anyway. This product is from the US & we are in the UK & we are us


Sounds like the motor burned up. not sure if travel adapters will handle a large load like a motor, around 8 or amps. power needs in US are 110 volts ac, 60 hertz.I believe UK is 220 volts and 50 hertz. usually when a vac is brought to eu ... Kirby Vacuums

Vorwerk ET 340 - been great but now noticing strong burning smell after vacuuming some hair from the bathroom. Bag is nearly empty. Gave it a rest then unscrewed the cover housing the motor and all looks clean (dust is sucked up the pipe and doesn't appear to get near the motor). When I restarted it, burning smell still there. Are there any filters that might need changing? What could be causing the smell? Could the hair have gotten caught somewhere? Thanks.


Jessica,\015\012\015\012Try changing the dirt bag.\015\012Check if the motor gets hot after operation. You can come to check it by touching outside the motor housing. If it is hot or just warm.\015\012Is the smell of burning hair or something e ... Vacuums

I have a Eureka 4870GZ. It turns on, but the brush roller doesn't move. The belt looks fine. I do have an extra belt and would try replacing the old belt, but I can't get the old one off the motor shaft or the new one on. I called Eureka customer service. The lady said there's supposed to be a small space between the motor shaft and the outside edge of the vacuum where I can slip the old belt off and the new one on. I don't see it. It looks like the motor shaft goes into a recessed place in the


Remove the top cover so that you can access to belt, You'll find 2 rows of 4 decorative holes on the top cover, In two of the holes you'll find the screws, Please use a flash light to see in that., Once the screws are removed, you'll be able to ... Eureka Vacuums

Shopvac 90L400 quit working (4 years old). Thought the switch was bad but not the problem. I read that there is a fuse link in the motor that frequently burns up. I tried to take motor apart but not sure of the process. I was able to get to the motor but cannot pull it out of the armature. It appears I have to take the aluminum blower unit off the shaft (it appears to be pressed on with a retaining washer). Do I have to take it off to pull the shaft and motor assembly out? Is that where the fuse


By pass the switch and take power right to the motor leads.. that should tell you if the motor is ok.. have not seen fuse link on a vac motor.. graingers has new motors, but not inexpensive ... Vacuums

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?


... Kenmore 34722 Grab-N-Go Upright Vacuum

HI, my motorized brush barely turns.It makes a hot rubber smell. I took apart and noticed the spindle the belt turns on discolored from heat. Cleaned it, but still no turning of the brush.The vac is a hoover wind tunnel. As it moved accidentally touched the belt/ spindle and burned my hand a little. Very hot in area. Bright spark from motor noted. Was careful not to touch that part!


That means that the belt is stretched and it is slipping on the motor shaft, that is why it is hot and smells like burning rubber. You need to replace the belt. Here is the correct belt you need: ... Hoover S3765-040 WindTunnel Bagless Canister Vacuum

Dyson DC04 is making a grinding sound & smells of burning. Hi. I have been told that the above is due to the carbon motor brushes burning out. The brush at the bottom still turns ok. I have bought 2 new carbon brushes & wondered how I would go about replacing them. Any help would be much apprecieated!


Hi there SmartAlec from NelsonVacuums.com.au here, this is not a repair for the faint hearted. First i am assuming you are not using a clutch model - with a selector for ca ... Vacuums

Bad Motor I have purchased two of the Kenmore direct drive beltless systems with Progressive systems. The first died after a year, the vacuum motor start making a grinding noies. I pulled the side HEPA filter and could see a fine coating of graphite like dust. Took it to a vacuum repair shop. They said the brushes were going and thus the motor was shot. I liked the vacuum and bought a second, 1 year later the motor is making a slight noise that and removing the HEPA filter I find a slight metall


That dust is from the carbon brushes on the motor. You may need to check them, and also clean out the motor compartment. A slight noise could be a motor bearing starting to go. Does the smell like rubber or electrical. If rubber, then the belt h ... Vacuums

Motor When i turn my steam vac on the motor flashes sparks and smokes and it smells as if the motor is burning out. I have it plugged into a normal household socket, i've tried different sockets with the same outcome.


You have it right either the motor is going out or water got in there causing it to spark and smell.sorry.lease leave feedback...pete ... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

I have an Electrolux LITE upright carpet cleaner - about 15 years old. Suddenly last night when using it, from the normal motor (whooshing) sound, the motor suddenly went very slow and with a slight grinding sound. The brushes are now just turning round very slowly and areobviously not picking up anything. Has the motor gone or is this repairable, or should I just get a new cleaner? I have tried to open the machine from the bottom to see if anything is obviously wrong, but it looks complicated a


... Electrolux Vacuums

Oreck model BB870-AS - I was vaccuming when the vac shut off. The motor just spooled down and nothing more since. I have opened the case. Have power at the switch, and to the motor, but can't get a voltage reading to the common lead at the motor. Is there a fusible link, or something similar in that lead that might have burned out? Thanks!


... Oreck Vacuums

Hello i own the bissle proheat steamer it turns on but no water or soap or suction from floor or the utensiles ive taken the take off the back to scope out anything that could be in the way but dont see anything the motor is making that clogged vacume noise witch makes me believe something could be stuck somewhere in it but it could also be no water is getting to the pump or despencer but the brissels still work belt for that is good where would i be best to check and where is the location of th


... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

I have a raynor flight star garage opener. Had a lighting strike 4 days ago. All power is good. The opener even has a little green light on the switch that is attached to it. However the opener is not responding. Is there a way to reset on the motor by taking off the housing? I don't see any reset button on the out side of the housing.thnx w


You could always try unplugging the unit and plugging it back in. If that doesn't work the logic board is probably fried and unfortunately there is no replacement available for it any longer. You would need to buy a new opener. I'd recommend Liftm ... Vacuums

Motor problem When i plug my steam vac in the motor sparks and smokes. It smells as if the motor is burning out. I've tried different outlets through out the house and get the same outcome, what can i do to solve this?


Nothing you can do im affraid its the motor armature so unless it can be stripped down then you will need to replace the motor i would get a price for the motor to decide if it is worth doin sorry. ... Vacuums

OPENING CANISTER UP TO SEE IF BEARINGS OR MOTOR IS GONE


You really don't want to get into the vacuum. After you get in, there's not much that you can do other than look. If you really want to get in, there are two strips,one on each side of the cleaner under the rubber bumpers. The strips have to be remov ... Electrolux UltraLux 2000 Bagged Canister Vacuum

The powerhead will turn until you touch it down on the carpet then the belt just spins (burning rubber smell). Is there supposed to be a fitting around the metal shaft opposite the powerhead or does the belt ride on the metal shaft?


That means that the belt is stretched and worn and needs to be replaced. Here is the belt you need and the manual which has instructions: ... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

Was hoovering when my DC04 made a funny high pitched noise then a whirring noise, this was accompanied by a smell of burning and a puff of smoke! Almost sounds like it might be a clutch slipping, is this possible or is it more likely to be a motor burn out?


OK... the DC04 doesn't have a clutch. My best guess is that the belt that drives the brush roll has broken. The smell of burning and smoke puff were probably caused by the motor suddenly speeding up when freed of its burden of driving the brush roll. ... Vacuums

Vorwerk VK121 vacuum cleaner - smell of burning from housing enclosing motor. How do I get into the housing to inspect the motor? After tilting the bag sideways, there are two screws holding the housing visible, but there seems to be a thrid fixing inside the point where the handle shaft is attached - is the handle simply clipped in place? Thanks


Yes the handle is clipped in place and should come out when the button in front is pushed. Remove the screws you wrote about. After that the puzzle begins. At the bottom of the vacuum where the head is attached, remove the head by pressing the but ... Vacuums

Wife sucked up a nickel cleaning daughters car. Vacuum stopped, smoked before she could turn it off. New motor? Is it worth it? How much is a new motor? Thanks in advance. Jim Troup [email protected]


You can buy a new motor HERE and we will install it with no additio ... Kirby G4 Bagged Upright Vacuum

I have bosch forumla vaccum and cord got stuck. It is very hard for me to see the screws to open it. Could somebody help me how to open this safely.


This problem is solved easily after I found the third screw to open the top cover. You will find the third screw under the top cover where the variable regulator is. But be patience, your small mistake can screw up whole system. You will need a torx ... Bosch BSG71360UC Bagged Canister Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0810 seconds