Having problems with your Oreck XL Ultra Bagged Upright Vacuum ?

Motor is random like a short

\015 Vacuum is cutting on and off during operation\015

Answers :

It sounds like you probably have a bad spot in the cord. What happens is you get a kink in a spot or you run over the cord and it loses continuity there, but only when it's bent a certain way. Turn it on and wiggle the cord from one end to the other I think you'll find the problem there.
Otherwise, if that isn't it, your motor is possibly the problem. Does it smell like burnt electrical when its running? A frozen motor carbon brush will cause this or just plain worn out carbons can do it as well.
Lastly It could be the switch but they generally just stop working and its on or off and no in between.

I'd bet it's the cord.

Happy Vacuuming!
The Vac Dr

Repair Help & Product Troubleshooting for Oreck XL Ultra Bagged Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Motor is random like a short

It sounds like you probably have a bad spot in the cord. What happens is you get a kink in a spot or you run over the cord and it loses continuity there, but only when it's bent a certain way. Turn it on and wiggle the cord from one end to the other ... Oreck XL Ultra Bagged Upright Vacuum

I have a Bissell 9400 E pro heat turbo. It's only been used 4 times, today it sounded like something blew. All my house electrics went off...( blew the main trip) I did read some place that the motor can short out and blow the PCB. Hubby and I just took it apart..( what a pain that was) We can't see a thing wrong with the board...( I expected to see something black, or damaged).... because when it blew today there was a weird smell... sort of like garlic. Question... how on this spinning earth

I have the exact same problem! Just occurred today. When I switch it on it fires for a couple of seconds then takes all the electrics in the house out again.\012\012\012Did ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

It acts like it has a short in the hose you can hear the motor running and then it will quit. Moving the hose around you can get it to turn back on.

Hello. There is either a short or a poor contact at some location within the hose. In order to fix this you may have to replace the power hose. Joe ... Kenmore 23913 Progressive PowerMate Bagged Canister Vacuum

Power Head keeps cutting in and out while vacuuming???Canister motor keeps running but the power head starts and stops like there is a short or some loss of connection somewhere. Any ideas?

My kenmore progressive vacuum had the same problem. The electrical terminal at the bottom of the wand was corroded. I used a flat head screw driver to scrape the female portion of the connector as best as I could. I then took off the plastic cover on ... Kenmore 23913 Progressive PowerMate Bagged Canister Vacuum

I have a Hoover, Steam spin scrub, Model F5897-900. Only used it a couple times and the motor gave out. First started being noisy then a bad smell. It did seem noisier that what I would expect from the start but I didn't realize it was a problem with the shaft of the motor. I took it apart and found the motor shaft wasn't true and causing sparks. The motor looks like it can not be taken apart and repaired. This seems like a default from the beginning but it is past warranty. Also noti

You will have to replace the motor and the hose asm. thehooverstore.com may be able to help, or you should be able to find a repair shop that can order them for you. ... Vacuums

Bad Motor I have purchased two of the Kenmore direct drive beltless systems with Progressive systems. The first died after a year, the vacuum motor start making a grinding noies. I pulled the side HEPA filter and could see a fine coating of graphite like dust. Took it to a vacuum repair shop. They said the brushes were going and thus the motor was shot. I liked the vacuum and bought a second, 1 year later the motor is making a slight noise that and removing the HEPA filter I find a slight metall

That dust is from the carbon brushes on the motor. You may need to check them, and also clean out the motor compartment. A slight noise could be a motor bearing starting to go. Does the smell like rubber or electrical. If rubber, then the belt h ... Vacuums

Motor is sparking and smells like burning rubber. When it first happened I thought the vacuum had something jamming the beater bar. That was the smell it had, like when the belt gets burned. But when we turned it over, it wasn't jamming. Took off the base plate and turned it on. The motor area is sparking and it makes a weird noise (I assume that is because the motor fails and restarts). I looked for loose wires, can't find any. I believe I need some sort of part replaced, maybe even a n

From sound and description most possible is motor is burnt up sparks usually mean metal on metal either bearing or bushings went on motor if u can jiggle the shaft thats bearing if u rotate the shaft by hand and feel and or hear rough grinding the br ... Oreck Vacuums

Dead motor? My 8 year old Miele S251i has worked fine, until I was recently vacuuming and moved the plug from one outlet to another. When I restarted the vacuum, it made rrrrr.....rrrrrr....rrrrr noises and smelled like something was burning. I turned it off, and it's shown no signs of life since. Sound like a motor problem? I've taken the cover off and looked at the cord and seen the motor, nothing looks obviously wrong, but I'm also not mechanical.

... Miele S251 Flamenco II Bagged Canister Vacuum

I have an animal dyson. The front nose dives into the carpet when moving the dyson in the forward motion, fine when pulling back. A huge amount of effort is required to move it forward. Took it to a technician and he said he could find nothing wrong. He had only short nap carpet for test. Works fine on short nap, if the carpet nap has any lenght to it like shag, the dyson severly nose dives. It's like the nose is sucked into the carpet. This problem just occured after the wife used the ho

... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

I have an older Oreck XL vacuum that sounds like it is running twice as fast as it should. I disassembled the entire vacuum, including disconnecting the motor wires, to clean out the hair, string, and other things. When I put everything back and connected all the wires, everything appears to work, including the light. The only problem is, it sounds extremely loud like the motor is running too fast. The model number is: XL3610HH Ser. No. 3610HHXA039740-6 I do not have as electrical diagram to see

... Oreck XL Ultra Bagged Upright Vacuum

I have a clarke bench grinder model 1002. I have a light that I would like to attach into the wiring though the grinder wiring in it's base. The light has two wires, and the grinder has a ground that is grounded to the base, a black that goes to a switch then to the motor. The white goes directly to the motor. where would I have to splice in the two wires from the light? I have a switch that I would like to put in for the light on off also.

Attach the white wire on your lamp to the white wire on the grinder.\012Attache the black wire on your lamp to the black wire on the motor side of the switch.\012This will give the lamp power any time the grinder is turned on.\012Yo ... Vacuums

I have a new Hoover BH50015 hand vac. The noise is terrible. It sounds like the bearing are bad. When you take off the cup and the filter and listen to the motor as it slows down after turning it off it definitely sounds like bad motor bearings. Hoover tells me the loud noise is normal. Can you help?

Yes the bearing is full of dust and dirt\015\012unscrew the housing and clean the bearing area and shaft\015\012then add a dap of Vaseline to the shaft and reassemble\015\012The shaft rides on a nylon bushing which acts like a beari ... Hoover BH50015 Bagless Handheld Cyclonic Vacuum

Rick E1, it looks like the Motor Pulley, Elna #440152-20 needs to be replaced on my 722010 model (flat on one side from standing around. It looks like some kind of a set screw which keeps it attached but are you familiar with how to get this item off the little shaft it is on. Also, any idea where I could find a reasonably priced Motor Pulley.

... Vacuums

Bissell Powerwash Proheat. model 1698-j, 220-240v, 50/60Hz, 1200-1400w. Motor stopped suddenly (ident label specifies type Ametek 119464-02), supply inline fuse at motor ruptured, fuse replaced but motor sparks like an angle grinder at armature and blew replacement fuse. Where can I obtain a replacement carbon brush set for the motor. UK based

... Bissell Vacuums

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after

... Vacuums

I have a Kirby Dual Sanitronic '50' Vacuum Cleaner I bought in 1966. The motor does not start when I attach the belt lifter of the rug nozzle. When I remove the rug nozzle and detach the belt from the motor fan shaft the motor starts when I depress the nozzle switch and the power switch . Seems like the brushes in the motor are worn out. I do not have a manual for this unit. Can you assist me as to what newer unit is this compatible to and the problem I'm having at present??

... Kirby Vacuums


Hi there, \012Most likely you have a damaged commutator. I used to change the brushes on the dyson vacuums but what i found is that it is almost never completely successful. THe Dyson motor is not as good quality as say a miele and when the bru ... Dyson DC08 Cylinder Bagless Canister Cyclonic Vacuum

Motor/Fan does not run. I have removed and taken the top of the canister plastic motor housing apart and tested for power. I have power through the cord to the switch and power from the switch to the two wire terminals. I have not removed the motor. Looks like I will need special tools to take out the motor. The Vac looks almost new. It has been setting for several years. What do you think?

Sorry to read about your problem, I hope this helps you out.Well you can order a new motor at shop vac, check out this link.you dont have to remove to check the motor, just connect power to the motor leads ... Shop Vac QPMH450 Canister WetDry Vacuum

Recently my central vac system started making a louder than usual and laboured sound when in uise, enough so that I took note and inspected the canister and motor while running. The motor was trowing off blue sparks and looked like it could 'POP' at any moment. I will not risk using it until I know what the problem is and how to repair it. My assumption is the motor needs to be replaced. The system came with the resale house I bought 3 yrs ago but I do not know the age of the system itself.

... Vacuums

There is no power...seems like a motor problem. The bag is clean...the mouth is clean the plug us in...NOTHING! I took mouth off and manipulated/pushed in that power press area that engages the motor on the front (not the switch on the back) and NOTHING! Not sure if motor died and/or what to do now. Help. I have had this baby for 15 years.

The front safety switch must be pushed in by either the hose or head (or manually), before the on/off switch will operate. The most common reason for no power is a bad cord. Second most common is worn carbons in the motor, and third is a bad switch. ... Kirby G4 Bagged Upright Vacuum

Where can I order the following parts for my 1952 KENMORE SEWING MACHINE MODEL #117583, SERIAL #48054: : #5107 carbon motor brush (2) #5110 motor brush spring (2) #5111 motor brush spring cap (2) String for starter control lever Pulleys, screw and nut washer to attach string control Best sewing machine ever and still working like new, and I want to keep it that way. Thanks.

... Vacuums

I have a Eureka 4870GZ. It turns on, but the brush roller doesn't move. The belt looks fine. I do have an extra belt and would try replacing the old belt, but I can't get the old one off the motor shaft or the new one on. I called Eureka customer service. The lady said there's supposed to be a small space between the motor shaft and the outside edge of the vacuum where I can slip the old belt off and the new one on. I don't see it. It looks like the motor shaft goes into a recessed place in the

Remove the top cover so that you can access to belt, You'll find 2 rows of 4 decorative holes on the top cover, In two of the holes you'll find the screws, Please use a flash light to see in that., Once the screws are removed, you'll be able to ... Eureka Vacuums

I have had my Bissell Healthy Home for just over a year. I use it once or twice a week on five area rugs and two small bedrooms with wall to wall carpet. Just recently, the motor started to sound extremely loud and it smells like it's burning. The vacuum still picks up everything and all the brushes are turning. Advice? I really like this vacuum and would really like to fix it rather than replace it!

Hi,Here is a tip that I wrote about my Bissel but I bet you have the same problem and the hose is clogged...Bissell Bagless Upright Vacuum no ... Bissell 5770 Healthy Home Bagless Upright Cyclonic Vacuum

How do I gain access to the motor of an Electrolux 2000 canister vacuum. The air intake on the motor must be partially blocked as there is a loss of suction and the motor makes that high pitched whine like it does when you cover the hose with your hand

Dismantling the vacuum probably won't help much, and reassembling can be a bear. \015\012To check the intake, remove bag and look into bottom of bag well. It there's a filter there, remove it and check intake at bottom of bag well. Clear if t ... Electrolux UltraLux 2000 Bagged Canister Vacuum

Have a rainbow e series with 2 speed motor replaced motor with another now after 5 minutes on the vacuum the motor cuts off intermitently like a power surge. all the connections and wires have continuity any ideas???

... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0716 seconds