Having problems with your Rainbow E series Canister Wet/Dry Vacuum ?

VACUUM RUNS FOR A MIN AND THEN SHUTS OFF

\015 CAN ANYONE HELP ME WITH A PROBLEM I AM HAVING WITH MY E SERIES VACUUM? WE HAVE HAD IT WORKED ON AND NOW IT WILL ONLY RUN FOR ABOUT A MIN AND THEN IT SHUTS OFF B/C IT GETS TOO HOT AND AFTER ABOUT 20 MINS IT WILL START RUNNING AGAIN BUT ONLY FOR A MIN. AND WHEN I SAY A MINUTE, I MEAN A MINUTE. VERY FRUSTRATING. THE REPAIR MAN TOOK OUT THE HEPA FILTER B/C HE THOUGHT THAT'S WHAT WAS MAKING IT HOT AND KICK OFF.\015

Answers :

It sounds like a problem with you motor. The hepa filter has nothing to do with the motor, and should not have been removed. It sounds like the repair man doesn't know much about rainbows. It could be a short in the motor housing or faulty/improper wiring. It may have happened after it when it was worked on the first time. Is it similar to the problem you were having before?

If you bought it from a rainbow dealer, you need to contact them, you should have a warranty, depending on when you bought it. If it is still under warranty, they will fix or replace it for free. If the warranty has expired, they may be able to work out a deal to get it fixed or may be able to direct you to a rainbow repairman.
Repair Help & Product Troubleshooting for Rainbow E series Canister Wet/Dry Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

We have a Kenmore Progressive Model 116 Upright bagged vacuum with Hepa filter. It's at least a couple years old. For quite some time now when ever we use the vacuum the vacuum motor will shut off nafter about 5 min. of use. We then need to let it sit for awhile and then we can run it again for another 5 min. The bag has been change. Any one have any ideas how to fix this?


I suspect that you have a restriction. The motor sounds like the thermal break is stopping the motor before damage, due to heat.\012You must witness that the entire suction and discharge side are clear. This is not always very easy, but necessa ... Kenmore 34612 Bagged Upright Vacuum

VACUUM RUNS FOR A MIN AND THEN SHUTS OFF


It sounds like a problem with you motor. The hepa filter has nothing to do with the motor, and should not have been removed. It sounds like the repair man doesn't know much about rainbows. It could be a short in the motor housing or faulty/imprope ... Rainbow E series Canister Wet/Dry Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

Runs for 5 mins., shuts off for 1 min., starts itself again, runs for 4 mins, shuts off for 1 min., starts itself again, runs for 3 mins.


... Henry Numatic "" Canister Vacuum

I have a Windsor Sensor s12 and power shuts off after 5 min. of vacuuming. I'm wondering if it's overheating of if there is some other sensor that causes it to shut off.


Your Sensor most likely has an internal heat sensor that is shutting off the motor. Some vacuums install an external heat sensor with a reset button that you must push to re-start the vacuum. If your model does not have an external reset button it is ... Windsor SR12 Sensor Bagged Upright Vacuum

Fantom vacuum vacuum starts running fine at first,but after about 15 mins the suction stops but the vacuum continues to run


Sounds like a partly clogged filter ... Fantom Vacums FM741 Twister Bagless Upright Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

My Eureka Airspeed vacuum keeps shutting off after about 5 min...It takes for about 3 days to vacuum because it will not turn back on for several hours...and it is not clogged. What is the problem


... Vacuums

When I sart to run my bagless vacuum, it runs for a second and then shuts off. I replaced the belt and the filter. The repairman told me that on bagless vaccuums, the motor and bearings get clogged w


Take the brush roller off and on the ends are the bearing caps.try to take those off and clean the bearings ,carpet strands and hair will cause that.after you do that make sure the roller turns freely if not then the bearings might be bad and if that ... Vacuums

Nilfisk GD-2000. Same problem with the new vacuum as the old one, runs 30 seconds to a minute & shuts down. Sometimes it'll start & run another 30 seconds or so, but shuts down. Other times it won't start back up at all. No clogs & bag is new. Please help.


... Vacuums

I was using my easy flow central vacuum, and shut it off. When I went to start it up again 5 min later, it would not turn on. I emptied out the filter, and reset the switch. When the reset button was pushed, it started up the vacuum, but the vacuum was not turned on in the house. It can only be turned on from in the garage and not on the actual hose. What is going on?


... Easy Flo EF2300 Central System Vacuum

I have an easy flo vacuum model # 199C and it won't shut off. It started out as an intermitent problem but now will not shut off when the hose is unplugged, nor when the off/on switch on the main unit is shut off. the only way to get the motor to stop running is to unplug the unit. Any ideas?


Just had this same problem. I unplugged the low voltage signal wires and the vacuum stayed on. Thus eliminating the possibility of the signal wires shorting out somewhere. I'm not really sure which wire(s) were causing the problem. But when I disasse ... Easy Flo EF1500 Vacuum

My vacuum cleaner will run for a few minutes and then shuts off. The plug light on the panel blinks. I thought the motor was shut, but after a long time it will turn on again, but again, only for a few minutes and then shuts off again. Any ideas? I bought an Oxygen Ultra a few years ago, but I don't like it nearly as much as the old Epic.


I know nothing about your particular vacuum, but many vacuum cleaners these days have\015\012safety cut out's, which causes the motor to do exactly what you describe. Sadly blockages, faulty switches, over stretched cables, carbon brushes etc c ... Electrolux Epic 6500 Vacuum

Dyson runs about 5 min then shuts off


REMOVE AND CLEAN FILTERS AND YOU MAY FIND IT WILL WORK OK IF STILL CUTS OUT YOU MAY HAVE A FAULTY THERMAL CUT OUT BLOCK INSIDE THE MOTOR HOUSING \012THIS HAPENS WHEN DYSON IS USED WITH CLOGGED FILTERS AND HEAT DAMAGE TO THERMAL BLOCK\012 ... Dyson DC14 Full Gear Bagless Upright Cyclonic Vacuum

We have a Eureka built in vacuum system model cv800B. The unit is about 15 years old. It runs for about 5 minutes then shuts down. If you wait atleast 10 minutes you get another 5 of run time. Any help would be appreciated. Steven


... Vacuums

My lux 7000 has a new bag but when i start to use it with the power unit or without the unit shut's it self off i can reset the lites or the motor if you will by clicking the on off switch 4or 5 times and i'm ready to go again untill you start to work and off it goes you can repeat the switch thing as long as u want, it just won't let u vacuum ,it turn's it self off .I blew it all out but found nothing in it. if u don't try to vacuum it will run as long as u want to listen to it. Can you


Have you replace the afterfilter? It may also cause this if rather dirty. It's located under the tool caddy/air diffuser on the back half of the machine.\015\012Try this: Disconnect hose, turn on vacuum. Does it continue running? If so, pl ... Electrolux Lux 7000 Bagged Canister Vacuum

Power nozzle on E-series won't start when cold unless the red 'reset' button is pressed multiple times while also holding the trigger to 'warm it up'...this is w/the power nozzle off the floor - no restriction on it turning. Once it's been running and then turned off the button must be pressed w/the trigger to get it to run - again w/the nozzle off the floor. It also seems to shut off too easily while vacuuming. I replaced the motor,which didn't fix it. Is the reset switch next on my list? T


... Rainbow E series Canister Wet/Dry Vacuum

Thermal senser on the side of the vacuum motor there is a little thermal senser that has rust all inside of it ,my ? is will that cause the motor to shut down ,could the rust in the senser causing it to cut off ,cause the vacuum runs well then cuts off


If it is going bad, it will cause the motor to shut down, replace it then you will know if that is the problem or a problem with the motor itself. ... Vacuums

No suction My Hoover Wind Tunnel vacuum runs but there is no suction. The last two or three times I used it, it shut itself off after having a burning smell. When I unplug it for the suggested 30 minutes, the motor will run again but no suction. What is wrong?? Should I just buy a nve one? This one is 8 years old.


Sounds like your motor bearings are going bad. This is generally indicated by the motor overheating, and the heat transferring out through the motor pulley, which is where the belt attaches. So, your machine is overheating, melting the belt, and then ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My hoover vacuum runs for about 10-15 minutes then the saftey feature shuts it off(overheat?). i have taking it apart a cleaned it with no results, added new bag also. after an hour it cools down and works again. do i just need a new vacuum?


Do you have suction through the tools? Does it look like it picks up when it runs? The machine could be clogged and that would cause the problem, but unfortunately the sensor that shuts the machine off could be bad if the machine isnt clogged. Its no ... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

After I run my vacuum for a couple of minutes it shuts off. If I unplug the vacuum and plug it into a different outlet most of the time it will start working again.


I would say check inside the plug and make sure the connections are tight. If the vacume runs fine on the other socket outlet then it will bw a faulty socket which cuts your hoover out. Can buy a new socket frount from diy stores for about 2-3 pounds ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Nutone Broan CV556 runs continuously and will not shut off until I unplug it.. I disconnected the low voltage wires and it still runs when I plug it in. Inside the top of the vacuum are 3 electrical devices - one looks like a transformer wire -- one is a rectangular electronic black box. The third is an on off rocker switch. Which piece it likely to be shorted out? It is about 8 years old.


... Broan-NuTone CV556 Cyclonic Bagless Central System Vacuum

My Shark vacuum sweeper will run for 10 minutes and shut off. After it sets for 15 minutes it will run for 10 minutes more.


If it runs on NiCad batteries it probably has programmed batteries which can happen, best solution, get new battery, and use til dead before recharge, every time. ... Vacuums

My powerhead on my EXL Tri-Star goes on then shuts off. When youturn it upside downit runs, then back on the floor it stops. Is it the belt inside the powerhead and if so to I take the head apart and replace this belt. Can any vacuum repair place fix this if I have the part. Vacuum was purchased in March 2000 Thank you, Dianne Miller [email protected]


A vac shop is probably going to require you to use their parts for warranty purposes. but its pretty simple. most shops should be capable to do it. ... Vacuums

Nutone model cv-350 vacuum motor will not shut off. I have to unplug system in garage. I disconnected wire to house vacuum inlets and motor is still running. There must be a reset on the motor. I have turned the external switch on and off and still no help.


Mine is the same, and it is the relay welding itself closed. The relay is switched by the low-voltage wiring that connects to the vacuum outlets, and it switches the motor on and off. Mine was welded in the energized position. I have cleaned and file ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0876 seconds