Having problems with your Rainbow E series Canister Wet/Dry Vacuum ?

D3 Rainbow Vacuum separator problem

\015 I have an older Rainbow d3 series vacuum. One day while running, the hose sucked onto something and I heard a pop. On checking I found that the separator had broken. I replaced it with a new one. When I started the vacuum it ran great for about 3 mins. until I again heard a pop. The separator had broken again. Any idea what could be causing this and what to do to fix it?\015

Answers :

Something loose underneath the separator?
Repair Help & Product Troubleshooting for Rainbow E series Canister Wet/Dry Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

D3 Rainbow Vacuum separator problem


Something loose underneath the separator? ... Rainbow E series Canister Wet/Dry Vacuum

Having problems removing separator on Rainbow Vacuum....


Not a good sign. If your Rainbow is SE or newer - separator should not spin freely.Some may recommend torch but I am afraid that you may end up melting some plastic parts so be careful. I'd say put a wrench on the nut, hold the separator ... Rainbow 75th Anniversary Canister Vacuum

Vacuum smells I have a 6 year old rainbow vacuum model E and it smells terrible everytime I use it. Probably because often times i don't remove the water basin after vacuuming and just let it sit. It's my own fault however now I don't know what to do to get rid of this terrible smell. I've water cleaned the hepa filter, not able to remove the separator screw to clean. Can you give me some suggestions?


In addition to vinegar, baking soda (sodium bicarbonate) is also an excellent remedy for many odour problems. Try generously sprinkling baking soda on a rug you wish to clean, and afterwards, vacuum up the spot. Rugs, and dirt ... Vacuums

The Rainbow vacuum doesn't work on high speed, though it will work for low, what could be the problem?


... Rainbow E series Canister Wet/Dry Vacuum

Filter problems The filter on a Rainbow vacuum cleaner is 'stuck', and will not come loose. Any suggestions on how to loosen it?


Are youreferring to the air intake filter? If so.. once the cover is removed ..you can try a little veg oil to loosen it...\015\012or.. are you taking about the blower wheel? The nut to release them often sticks and can be loosened with pentra ... Vacuums

Trying to get the separator off of a Rainbow Vacuum cleaner to clean it and the screw just spins and will not loosen up.


... Vacuums

My rainbow e-series canister vacuum cleaner has a horrible smell. i cleaned out the water tray and it STILL smells horrible. how do i fix this problem?


Get a new hepa filter.\012\012It is at the back side of it, behind that rectangular cover, where the exhaust cover is. It either snaps off with two plastic tabs on the bottom of it, or has two screws on the bottom of it, and two screws be ... Rainbow E series Canister Wet/Dry Vacuum

My rainbow vacuum has a problem. whenever i turn it on, it makes a rattling noise, there is a blue circle, and it starts to smell. can anyine help me?


Make sure your motor is working properly.also make sure you have the seperator ... Rainbow Technologies D4 Bagless Vacuum

Troubleshooting i have a rainbow vacuum model D4C that has minimal suction power. hose if free and clear, but i am missing the gasket that fits under motor. could thius be the problem?


That gasket is a water seal, but it can impact the suction, the top of the water tank can't seal without it. ... Vacuums

Rainbow stops shortly after starting to vacuum


There is a thermal fuse on the motor field that sometimes fails. Sometimes the fuse does what it is supposed to do - prevents motor from ov ... Rainbow E series Canister Wet/Dry Vacuum

My Riccar 1700 will intermittently lose power while vacuuming. I have had the vacuum for 4 years and this is the second time that I have had this problem. The first time the authorized repairperson said the problem was a dirty hepa filter. The second time, the repairperson put on a "pig-tail"(?) and said that he did not have a shut-down problem when he tested the vacuum in the store. I just picked it up from the store today, brought it home and the same problem occurred within minutes.


... Riccar RC1100 Compact Vacuum

Suction problem I have a Hoover Widepath Fold Away, 12 amp motor vacuum cleaner and the problem I am having is every time I vacuum, the vacuum gets clogged up with carpet. I am probably only able to do one stroke then it gets clogged and I have to stop and unclog it or it spits it out on the carpet. This is very frustrating and I don't get much vacuuming done. Please can you help me. Thank you. Gwen email is [email protected]


Get rid of the carpet its shredding and falling apart.no sence in vacuuming old rotten carpet.or try using a vacuum without a brush roller and just suction ... Hoover U8145-900 Savvy Bagless Upright Cyclonic Vacuum

Rainbow E Series Suction Problem


Being an E series some have a corrgated filter in the top, there is also a filter on the back. Could be a motor problem, not turning as fast as it should, in which case you will have to replace the motor. You might check, some had a 10 year warrant ... Rainbow E series Canister Wet/Dry Vacuum

Ran my Rainbow SE (1996 model)without separator


... Rainbow Vacuums

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

While vacuuming the red light for the bag of the vacuum came on and the vacuum stopped. The bag was no where near full so I replaced it with a new bag - same problem. It vaccumes for a minute or then stops with bag light on. It is the correct bag for the machine - so what's the problem?


I'm assuming this is the Epic 6500 or similar model.\015\012Detach the hose, turn vacuum on. If it runs, place palm of hand against inport hole. If it shuts off the problem is with either the control valve setting or the control valve assembl ... Electrolux Vacuums

Belt burning on Rainbow Vacuum


You could have the wrong belt or maybe that the belt you have is stretched out too much from use. I'd take the vacuum to an authorized repair shop and have it looked at. ... Vacuums

Electrolux AP280 vacuum - cannot separate hose from wand


... Electrolux Vacuums

Dirt devil vacuum cleaner--trouble vacuuming dirt and pet hair on carpeting --is the problem with the spinning brush which contacts the floor,  not contacting the carpeting??  I thought (when I bought this vacuum) that the aforementioned brush was adjustable to various heights of carpeting.  Sometimes, it seems like nothing is being vacuumed up --unless I have just put a new bag on the vacuum... Do I need or can I replace the spinning brush on the bottom of the vacuum so it kicks up and vacuums


Try replacing the belt. Rubber belts stretch out after about a year. ... Dirt Devil CE6100 Featherlite Upright Vacuum

My Rainbow SE vacuum was working fine until I ran over the edge of a rug and it went in to the nozzle. I immediately switched the vacuum off and proceeded to move the rug. When I tried to turn the Rainbow back on the brush was no longer spinning. I've tried the reset button and checking the nozzle for any debris, there are none. The brush just won't spin.


Hello lilbutmunch1,\015\012The brush is motor/belt driven so you probably either broke the belt or it shifted off the motor or brush shaft. I suggest you unplug it,flip it over and look for screws that hold the baseplate together.. remove those ... Rainbow E series Canister Wet/Dry Vacuum

I have a Eureka Upright vacuum (4800 Series). When I try to start it by turning the switch on, it wont. For few days, I was able to get around this problem by repeatedly turning the switch on and off until it turned on but that does not work any more. Could it be something related to the switch it self or the power cable. My wife mentioned that one of my kids might have pulled the power cable too hard (at the back of the vacuum). Any help to solve this problem will be very much appreciated. Tha


... Eureka Smartvac 4870 Bagged Upright Vacuum

Problems with the Rainbow Aquamate II


Do you hear the pump running? ... Rainbow E series Canister Wet/Dry Vacuum

I have a d4c rainbow vacuum, need help replacing the electrical cord


You have to splice them. \015\012Use crimp-on wire connectors (best), or threaded twist-on wire connectors. Do NOT just twist wire strands together and tape wires without using wire connectors . . . that is a NO-NO. ... Rainbow 75th Anniversary Canister Vacuum

Windtunnel Hello: I was reading thru another readers problem of power to vacuum but won't turn on. Same problem for me. All hoses are free of clogs and I have the vacuum basically taken apart as far as I can. You state a THERMO by the motor may be open. What does this part look like? Thank you. Craig


The thermo is a small square piece with two wires coming out of it. Did you check the switch? The switch has a high failure rate. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I purchased a Eureka Vacuum The Boss SmartVac one year ago, I misplaced my manual. The problem is when I try to vacuum dust blows every where as dust storm. How do I resolve this problem?


It sounds like your filters are dirty and if it is a bag system the bag is full or not seated properly ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0951 seconds