Having problems with your Samsung Easy 1300 Lightweight Compact Canister Vacuum Cleaner ?

Our Samsung Easy1300 canister vacuum has lost suction (even with a new bag) and there doesn't seem to be anything blocking the hose. Any suggestions as to what to check next would be appreciated!


Answers :

Repair Help & Product Troubleshooting for Samsung Easy 1300 Lightweight Compact Canister Vacuum Cleaner

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Our Samsung Easy1300 canister vacuum has lost suction (even with a new bag) and there doesn't seem to be anything blocking the hose. Any suggestions as to what to check next would be appreciated!


... Samsung Easy 1300 Lightweight Compact Canister Vacuum Cleaner

No suction I just replaced the bag, and normally after this I have a lot of suction. Now that I have changed the bag I have less suction that I had before. Not even enough to picj up dog hair. I snaked he hose and checked all of the connections. It seems to have an air leak but no amount of tape will fix this. I cleaned the filer as well with warm water and dried it and re installed but still absolutely no suction. I am ready to throw it out! Any suggestions would be appreciated


1, Does the blower (discharge) side blow bunches of air??Yes: Something is clogged from the bag to the hose end. Try blowing out the hose from the discharge side.Or: The bag is not properly seated. Make sure that the plastic piece is ... Kenmore 23313 Whispertone Bagged Canister Vacuum

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But


Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

I have the yellow altima vac. for a while now I can not get the darn thing to pick up properly. Or should i say keep it up.. The vac does seem to be getting everything picked up but as soon as you turn it off, you have a mess under the vac.. I have checked for clogks and can't seem to find any.. I have removed the hose, Nothing there.. And yep have removed the yellow thing inside the trash cup.. Is there anything else you could suggest??


If it smells hot, then there's a strain on the motor no doubt about it. Check the suction channel behind the sole plate and remove all of the hoses to check for a clog. It could well be that there is a clog inside the machine after the dust channel f ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

Bissell 7700 series, pro heat all rounder. Won't spray water. Have checked the line from the unit to the spray nozzel and all seems clear. Water doesn't seem to be flowing from the tank to the end of the unit where the hose connects into. What could be the problem? Any assistance would be greatly appreciated. Thank You. Steve


HelloGrasp the cleaning solution tank, and remove it from the machine. Reinsert the tank into the machine, making sure it fits snugly in the machine. If the tank is even slightly dislodged, water cannot get into the machine. Visually insp ... Vacuums

The vaccum has been cleaned and checked but the brush is not rotating and no suction at the bottom, but through the hose. In reading the instructions to remove the brush cover it says to lift tab one and release 2-4. Where is the tab for tab 1 can not find anything for tab one to be able to lift, nothing there any ideas for help would be greatlly appreciated/


3 on the front and one on the back. where the belt runs ... Bissell 6594 PowerForce Bagless Upright Vacuum

Need A manual for U5025-900 Hoover Sprint vacuum want to check if the filters are correct. Was given the vacuum, seems like there is very little suction for the hose. Any help would be appreciated


Wasn't able to locate a manual, but you may be able to get the info you need from this page:\015\012\015\012U5025900 Parts ... Hoover U5025-900 Bagless Upright Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.


Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?


Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My bissell proheat upright steam cleaner is spraying out through the attachments just fine, but will not spray to the floor when using upright. we've taken it apart to find that there is no water at all going through one of the hoses, but it appears the hose is connected behind the on/off and heat switches, we can't seem to figure out how to get in there to replace that hose....any suggestions on how to access this?? just curious how you would get in to replace the hose, we know it is the hose..


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

The hose on my Samsung 9048R is torn partly from the swivel base. The main problem is that the carpet attachment with the beater bar will not operate now. My brother checked the connectivity at both ends of the hose and there is juice at the bottom swivel part but at the other end of the hose where the carpet wand plugs in it is dead. is there any way to fix this? How does the wire go up through the hose? I have looked around on the internet and it would seem that the entire hose assembly is


... Samsung Quiet Storm 9048R Bagged Canister Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

I recently bought a chefmate racket bug zapper from target, but can't seem to get it going. I pressed the buttons over and over so it would make it's high pitch sound and then i would know it was charged. never happened. what do i do next? I don't hear anything happening but do see the green light on. can you help?


... Vacuums

Electrolux Diplomat canister vacuum. The bag light comes on and it stops. It has to do with the hose because if I take the hose off, then the vacuum keeps running. I can't see anything blocking the connection. any suggestions on what else to look at?


... Electrolux Vacuums

Kenmore 21875 One day it's working fine. Next day, it won't turn on. When I attach the hose to another vacuum cleaner, it runs. Is there a reset button on the canister? Could it be the receptacle is bad? My Kenmore Progressive won't turn on today either -but was fine last week. I cleaned the filters checked for blocked air, tried a different outlet and no luck. I'll check the pins on the connections and see if one of them is not matching up or appears worn.


Give the prongs a wiggle and see if there is any play in them.Might just be a plug end. ... Kenmore 25512/ 25513 Progressive Canister Vacuum

My Miele capricorn has started making an odd noise. It seems like something is blocking the engine. I've turned if off and on, and reset it and it still have the odd, almost loud barking noise. The power nozzle also does not seem to be working. I've checked the connections. Right before this happened I was using the vacuum. I didn't notice anything out of the ordinary until this.


Greetings,\015\012\015\012This is a major problem. The Miele vacuums motor should never make a loud noise, period. The way the motor is designed, it's quiet and should be quiet for the life of the motor. There are two motors on your ... Vacuums

I have a modelF5914-900 steamvac cleaner.serial #0704 0011 4711 I cleaned the carpets in my house and then started to do the stairs with the stair attachment. I got down to the last four stairs and the solution would no longer come out. I checked the tank and hose connection and tried priming the pump per the instruction manual. nothing worked. Could you make a suggestion as to what the problem could be? Thank You


Check fuses goin to the pump, is the pump working? if so you may have an air pocket or a air leak in the intake. ... Vacuums

No suction I cleaned and checked all hoses, sounds like something is stuck inside, like a sock, took machine apart as much as I could and couldn't find anything. Any suggestions?


Ok first thing to do is remove & clean the 2 piece premotor filter or purchase new.Now remove soleplate from bottom of machine to do this rotate the 3 plastic screws to unlock position. Lift sole plate off now remove any blockagers or ... Dyson DC07 All Floors Bagless Upright Cyclonic Vacuum

I am having problems with the roller on my Oreck DTX-1300. It turns on and off intermittantly while I'm vacuuming. I have completly taken it apart and cleaned and inspected the roller unit.(I am very much mechanically inclined) This has stumped me, I have checked the electrical from the vacuum to the floor unit, and everything else that I could think of. Question: what does the metal sensore plate on the bottom of the roller unit do?? Anything anybody can tell me, I would greatly appreciate. Cap


... Oreck DutchTech DTX1300A Bagged Canister Vacuum

It will not pick dirt on the floor lint or anything else. Checked all the hoses for leaks and clogs, and have nothing blocking the path way.


Please check your hoses again. Run a broom stick handle through if necessary. Check the passage of air through the hose by applying suction from another machine ... like a ShopVac or similar. Somewhere, there is a clog. ... Vacuums

My dyson will quit running in the middle of vacuuming the hose attatchment isnt picking up I checked for clogs and nothing seems to be blocking the passage ways


... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Fantom Twister Our Fantom Twister is not picking up dirt. There does not seem to be any blockage in the hoses and I replaced the hepa filter and the second filter that sits just below the canister where the dirt is collected. It is still not working. Any suggestions yuo have will be appreciated. William Moran


When cleaning everything change the main filter which it's the filter inside the yellow mesh holder. the filter number is 1010fs. One filter is 26.90 with s&h. This needs changing every 2 years.\015\012call customer service number above. ... Fantom Vacums FM741 Twister Bagless Upright Vacuum

I have no suction on my vacuum, I have checked everything, belts are good, and hoses appear to be clear of any blocks, any suggestions


Please give the model number and manufacturer of the vacuum. ... Vacuums

Hi. I purchased a Simplicity Freedom about 2 years ago. I have had it in for various repairs several times. One persistant problem that the repairman cannot seem to fix is the dirt does not fall down into the bag - it just stays up around the suction hole. I only use simplicity bags. Any suggestions would be most appreciated. thank you


You can let the vacuum run alittle longer so the bag fills up with air, also make sure that the bag in on correctly and you have the right bag for the unit. Let me know if this helps. ... Simplicity Vacuums

Hoover 6446 900 WindTunnel Bagged Upright has little suction at the floor brush but plenty at hose if disconnected. It does not seem that there is anything blocking the inlet at the floor brush.


Check for a clog in the brush hose ... Hoover Tempo Widepath Upright Vacuum - Blue
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0931 seconds