Having problems with your Sanyo Permax SC-U125 Bagged Upright Vacuum ?

Suction hose has a hole in it - Sanyo Permax SC-U125 Bagged Upright Vacuum

Answers :

Repair Help & Product Troubleshooting for Sanyo Permax SC-U125 Bagged Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Suction hose has a hole in it - Sanyo Permax SC-U125 Bagged Upright Vacuum

... Sanyo Permax SC-U125 Bagged Upright Vacuum

I have a Kenmore Progressive Inteleclean Upright vacuum cleaner (with Bag) . It has good suction only through the hose now and none through the bottom for cleaning carpets. and, there is a noise like it has a suction leak. the brush is rotating.

Theres a little bendable neck that hose with suction plugs into. Thats the one thats clogged. You will have to fish it out by taking off the roller and clearing the clog. ... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

I have a Sanyo Performax 12 amp upright vaccuum. It has lost its suction completely. All hoses and airways are clear, new bag, exhaust works, roller bar works.... but no suction - what might the problem be? thanks, Shelley

... Sanyo Permax SC-A102 Bagged Upright Vacuum

Bosch Vacuum Cleaner: I changed bag. Cleaned out all suction hose and hepa filters, however, my 1450 w 12 amp upright vacuum cleaner will die after five minute run - overheating. Please advise.

Greetings from GoVacuum.com,It sounds like you may have a bad thermal switch inside the machine. Most vacuum cleaners have a switch connected to the motor, so if the vacuum cleaner is running hot, it will shut off to prevent any damage ... Bosch Vacuums

I have an old Miele canister vacuum and I do not know how to disassemble the hose to check for a clog. I think it sucked up a nerf ball the size of a ping pong ball. I changed the bag but it did isn't appear to be in the bag. The vacuum powers on but I do not have suction with the hose, and since the hose has hard plastic elbow joints I do not want to pry them apart and break it

Hi Emily: If you have the model number for your machine you may be able to find your manual on the Miele website. Check ... Miele Vacuums

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But

Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

No Suction I have the Eureka Upright Vacuum. I have no suction when doing regular vacuuming but it seems to have function with just the hose. Also, the height adjustment doesn't seem to work at all. The vacuum has only be usede 3 times. Thanks

Is your brush roller turning? unplug the vacuum and see if you can turn the brushroller by hand.if it turns real freely the the belt is broke ,if its real hard to turn then something is caught up around the bearings on the ends of the roller.my sugge ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

When I flip the switch on my sebo x1 upright, a red light comes to the brush and bag icons. However, I cleaned out the hose and checked to make sure there is no obstruction from the brush to the hose also, or from the hose to the bag. It is clear that juice is coming to the vacuum, but there is no sign of life except the two red lights.

Thanks for contacting fixya. You should pull out the bag and reset the machine. You should take all the user replaceable items. And turn it on. You will get lot of errors. Then turn the machine off. Put back all the accessor ... Sebo Automatic X1 Bagged Upright Vacuum

No suction vacuum won't pick up -- I've checked the bag, hose...and it seems to have no sucking power. The internal hose may be jammed (I vacuumed up a lot of shredded paper), but nothing as far as I can stick in fingers in. I don't have a metal coat hanger to slip down, but I'm afraid that might tear the hose and then the darn thing won't work anyway. :o(

If it is plugged, try using a tape measure, i know it sounds stupid but it will work to unplug your line and will not tear your hose.. ... Kirby G4 Bagged Upright Vacuum

Poor suction I have a hoover hush s5627 vacuum purchased about 4 years ago from Costco. It's suction power isn't so good anymore. I've checked all the lines & hoses and they're clear and I've changed the bag. I even disconnected the pipe from the vacuum unit and held my hand over the intake. While the machine roars like a jet engine the suction power just ain't like it used to be. What could possibly be the problem?

This vaccuum has a Fan Blade inside connected to the motor that spins to create the suction you feel. After a few years of use (and misuse) the blades on this (plastic) fan will be broken off, thus damaging the unit. These Fans are replaceable if yo ... Vacuums

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!

... Miele Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

Vacuum won't **** in upright position, but there is suction from the hose in the upright position

Theres a knob that switches it from floors to carpet turn the to floors.please leave feedback ... Vacuums

When I disconnect the hose attachment from the vacuum to use it, the dust shoots up from the hole. Where is there something to make the hose have suction instead of the base of the vacuum?

Da house is stop up ... Vacuums

My new Kenmoore Powermate 116 canister has poor suction. I have no pets and light dust. Its not picking up small particles on the wood floor with the floor attachment. When I put my hand to the suction it feels weak. Cleared hose and changed bag. Using again, same issues. This should not be happening with a new vacuum. Is it a bad design in the elbow joint of the hose? I want to return this!!!!

First of all disassemble the handle and hose as much as possible and examine the inside. Make sure there is not any significant debris lodged in the hose somewhere like a plastic bag or something.\015\012\015\012Also check at the top of t ... Kenmore 23912 Progressive PowerMate Bagged Canister Vacuum

I get plenty of suction at the hose, and none at the brushes. Also, the vacuum will not remain upright when I push it up. It appears that the part that switches the suction from the hose to the brush area is not engaged.

I looked up the problem where the machine would not stand upright, used that solution, and it worked. ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Kenmore progressive vacuum model: 116.25614506, I replaced the bag and filter and now it seems to **** the bag up against the hose outlet with very little suction at the hose end

... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

My old bissell 3510 upright vacuum seems to have no suction into the bag...I replaced a broken belt several days ago, and now the vacuum picks up debris, but seems to just collect it behind a wheel..The bag does not "puff out" like it used to...How can I fix this??

... Bissell 3510 PowerPartner Upright Vacuum

My upright kenmore progressive vacuum will not suction up when using the sweeper. It will suction things when I use one of the tools. I have put in a new bag and have tried to see if anything is blocking the bottom. It sometimes makes a very loud noise when I try to vacuum. If I press the intell clean on and off yellow button the noise may go away but it still does not work.

Double check hose placement, making sure you have the hose inserted into the correct slot. The long attachment nozzle stores in the front hole on the right, and the sucking hose inserts into the rear hole on the right. I know this is too simple of a ... Vacuums

My Kirby vacuum is a G100 upright. It has no suction. It has been cleaned and the bag is empty (new bag). My mother-in-law bought the same kind and hers is doing the same thing. It has no suction and won't pick up anything. Thank you, Rachel Souza - [email protected]

... Kirby Vacuums

I have the Eureka Whirlwind upright vacuum. All of a sudden there is no suction- the hose has suction but not main part. I have no idea- but the brush part is not turning??? should I get a new vacuum or is this an easy fix? thanks!!!!!

If the belt isn't turning then it has snapped. Check the top of the hood for two or three crosshead screws; two at the front and one under neath by the left hand side if looking at the upright from the front. Its easy to fix if you take your ti ... Eureka WhirlWind Litespeed 5844 Upright Vacuum

I have a Eureka 4800 series the Boss upright with a bag and Hepa filter. I love it! I was just vacuuming with the hose part and all was well and then suddenly the lower brush came on and a "burning" smell followed. Thought it was the belt so my husband was going to put on the new belt which I had on hand! When he turned it over, the "bar" that holds the belt looks as though it "shot through" the plastic side of the housing on the vacuum. There is melted plastic on the outside of the vacuum and o

I had the same problem. Take out the old belt if possible. Remove the 4 screws inside the filter and the 3 on the front of that housing. pull out the foam around the motor. carefully pull out the suction tube that is press fit against the motor. ... Eureka 4874 Bagged Upright Vacuum

No suction whether I'm using the tools or using the vacuum upright, there is no suction. I have checked the hose to make it is not clogged- still no suction. What is the problem?

Your intake hose might be clogged at the bottom ,it the clear hose that comes up from the bottom .you will see it from the back.take the dirt cup off there is a filter inside that most likely is clogged ... Dirt Devil M086700 Vision Bagless Upright Vacuum

Miele upright, good suction through hose none through vacuum head

... Miele S7210 Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1156 seconds