Having problems with your Scunci Vacuums ?

Scunci steamcanister model 52038 Steam does not get from canister through hose to nozzle. No apparent leaks - hose does not get warm. appears may be valve problem from canister to hose. Only used bottled water - barely used this machine.

Answers :

Repair Help & Product Troubleshooting for Scunci Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Scunci steamcanister model 52038 Steam does not get from canister through hose to nozzle. No apparent leaks - hose does not get warm. appears may be valve problem from canister to hose. Only used bottled water - barely used this machine.

... Scunci Vacuums

DC07 DYSON REPLACEMENT HOSE. HOW DO YOU REMOVE IT FROM THE HANDLE. I have a kenmore whispertone 8540 canister vaccum. The electrical wires (3) to power the beater are embedded in the hose, in a spiral fashion. The yokes that hold the hose on both ends (and attach to the beater on one end and the unit on the other) have no screws or pressure latches; i don't want to use brute force as i may damage the attachment device inside the yoke. If someone can tell me the trick to get these yokes off each

Should be a pry off dot on the underside revealing a screw ... Vacuums

We have a series e rainbow cleaner. my wife had been using it i turned off and turned the canister up sie down to get the serial number. it would not turn back on.we need a new hose and thats why i was looking for the serial num. it has a rocker switch and the motor will work on low but will not run on the suction side. i have checked the wiring harnesses out as best i could without taken it all apart. im wondering if it may be the switch. it started once and then stopped.

There is one way to verify if it is the switch.It's kind of dangerous though,but not too bad.You need an extra piece of wire,fairly thick.I would use 4 guage myself.Hold it with pliers,just in case it gets hot.Turn the switch on and hold the wire to ... Rainbow Vacuums

I have an older model F6056-900 Hoover steamvac Spin Scrub Cleaner. My first problem was that I loaned it out to a friend. Anyway she ran over the hose (used for attachments) with her car. I tried using the cleaner for carpet cleaning this morning but when I tried to put the solution tank into place...its loose...won't snap back in like it used to. When I can get it somewhat in place the solution just complete drains out through the bottom fo the tank. The leak is where the small hole on the bot

... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

I'm using (or WAS using) a Eureka ''the boss'' model 8803. The belt broke, no biggie, so I replaced it with a Eureka model U belt, the problem is when I put the new belt on and turn on the vaccuum, the belt breaks again. I am also having trouble getting the brush roller to fit right when the belt is in place. I can't find any sharp edges that would cut the belt,nor can I find where any small bits may have broken. Anyone have a solution for me?

First, make sure you have the right belt, second, i am thinking that you are not lineing the roller up right, it will only fit one way. look at the ends of the roller and the grooves where it slides in, you should be able to see clearly how it goes. ... Vacuums

Dyson DC 14 hose has no suction, with or without brush attachments. Hot air shoots out from the base of the canister when I try to use the hose. I cleaned the top filter, but can't figure out how to remove the hepa filter to clean it without destroying the case. It looks like it might take three hands to insert pennies and "flip" the case open as is suggested on a youtube video for a different model. Would this even help, assuming I could get the thing open?

... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Lost suction I've only used this vacuum a few times, it's practically brand new. Now, one I turn it on, it sounds fine, and the hose feels as if it's getting some suction, but it's not strong enough to actually **** things up from the carpet into the canister. I have completely emptied the canister and bought a new filter. Nothing seems to help.

TOSS IT and forget it! I have never used a hand vac that worked that was worth the effort of turning it on .... I suggest they are all junk ... I found very few vacuum cleaners ... actually **** especially anything made by dirt devil ... I do have a ... Dirt Devil Vibe AllPurpose Hand Vacuum Bagless Vacuum

I have a Everstar canister vac 1200 (owned for about 4 years) and the hose broke apart. I taped it together and have used it for about a year but it has failed. The telephone # in the manual no longer belongs to Everstar (if it ever did). I bought this vac from Home Depot but no longer have a receipt. Any ideas on where I'll get a new hose?

... Vacuums

I've got a Kenmore canister vacuum, Progressive 236123, and there's a burning smell from the belt side of the head--smells a lot like hot rubber. I've cleaned the agitator and changed the belt, but I still get the smell. It's stronger when I'm using "carpet" mode than when I'm using "bare floor" mode. Any ideas what the problem is?

... Kenmore 23612 Progressive PowerMate Bagged Canister Vacuum

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?

Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I have a Craftsman wet dry vac with blower capability (22 L). While I was using it to **** up water, the water came out of the blower hose. Now I can't get it to work as a vacuum. What can I do to fix this problem? Is there a toggle switch somewhere that allows me to choose vacuum or blower? Also, will the vacuum still work without the filter nut attached to the plate? Please let me know at your earliest convenience. Thank you.

... Craftsman Vacuums

Recently purchase SC-N500 vacuum cleaner. Worked well only the first 2 times I used it to clean up plaster dust from floor after sanding. Since then it has not worked at all well wiht very poor suction. Fluff gets stuck in the hose and has to be manually removed. Suction power is very poor. I have washed the filter to remove the dust with no difference. Who do I contact in Brisbane to service or assess the problem further.

... Sanyo Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

I have a Eureka Altima vaccuum and it no longer suctions like it use to and also has a burning smell. I have cleaned all filters, brush, hoses, and filters. There are no blockages. I have also checked the belt and it's still good. Any other ideas as to what may be the problem?

This bagless model gets buildup of really fine dirt in the motor and starts to clog up the fan airducts. You will need to take the motor out and clean it. ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

The motor overheats and shuts off. This annoying because it has done it at least 5 times today during normal vacuuming. It shuts off easily when you use the hose and canister to clean the steps or around the floor. What can I do to alleviate this problem?

Almost all vacuum cleaners have a thermal cut-out, which operates when the machine gets too hot and resets automatically when it cools down. Overheating is almost always caused by a blockage. Either the filters need cleaning or changing, or the ... Bissell Lift-Off(R) Revolution(R) Turbo Upright Vacuum

II have the kirby sentria, i have it in canister mode with blower attachment on the hose is on with the hand sprayer attachment the problem is the foam is not coming out the sprayer used it just fine all day went to refill w/ water and cleaner now the foam wont come out whats wrong with it?

Make sure the "straw" is in.See if dust coming out of the hose did not clog the air passages. ... Kirby Heritage II Vacuum

Burned out The best way for me to describe the problem is to post reviews I made on Amazon.com, which is where I purchased them. ________________ Based on my past experience, I bought another 6 months ago. I live in a very tiny 2 room apartment and do not vacuum lots of dirt. I noticed this new vac getting very hot to the touch where the motor is located with only a few minutes of use. Today it just STOPPED. When I felt the canister, it was HOT. It obviously has burned out. Upon closer inspect

... Euro-Pro HEPA Shark EP238 Bagged Canister Vacuum

Hi, I have a Sebo X4 which is almost 3 years old. I haven't had any problems with it until the last couple of days when I notice a slight screeching noise when in upright position, coming from the roller mechanism area. If I slightly push the sebo forwards it gets worse, if I tip it back it stops. If I take the roller out and switch on, there is no noise. I have always been careful not to tip the machine forwards when using the hose, but I recently lent it to a friend whose hoover had broken do

I dismantled the top part of the machine from the bottom and there stuck right down in the bowels of the tubes was a piece of card, a dress label! somehow it was only making a noise when the machine was in an upright position. It took a bit of stretc ... Sebo X4 Bagged Upright Vacuum

My bissell proheat upright steam cleaner is spraying out through the attachments just fine, but will not spray to the floor when using upright. we've taken it apart to find that there is no water at all going through one of the hoses, but it appears the hose is connected behind the on/off and heat switches, we can't seem to figure out how to get in there to replace that hose....any suggestions on how to access this?? just curious how you would get in to replace the hose, we know it is the hose..

Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

We have an Epic6500. when we plug it in the machine works without the hose. We even purchased a new hose thinking there was a problem with the hose. However as soon as we put the hose on the machine the machine does not work. What do you think the problem may be?

Wow, this is a good one. I wonder if anyone has wrked on this machine before. Do you remember what happened when it stopped working / Obviously there is a foul up in the wiring. I need more info. When the machine is on does it shut off as soon as the ... Electrolux Epic 6500 Vacuum

The problem is that the cleaner is heavy to use and does not pull itself forward as it should. It has been back to the supplier 3 times but they have not fixed the problem. The LED's on the front flicker and I think it may be a problem with the sensor. If you have any info. on how the sensor works and where it is located it would be useful as well as any other suggestions to fix the problem please.

If it heavy then do some muscle work and body building ... Vacuums

No power. I was getting intermittent power with my miele s558 midsize canister, but it was predicated with me fiddling with the retractable cord to get it to come on and then not move the canister while I was vacuuming. Now I can get no power. I have taken it apart and can see no issues with connectors, cord, casings, etc. It all looks fine. It is about 5 years old and I have had no problems with it.

... Miele S558 Red Velvet Bagged Canister Vacuum

My electrolux ambassador power wand quit working. I replaced the switch that shuts it off when the roller stops, but it wasn't the problem. The on/off switch is fine, the motor is fine. We have traced the problem to the wires inside the canister by opening the inside cover to the bag container. We see the power cords going into the canister but we're not able to get to anything. We can't find any screws to undo that would open it up in order to follow the wires deep into the canister. We've bypa

... Electrolux Vacuums

Hello, I have a Kenmore Progressive Canister Vacuum 116.20912006. It won't turn on. On the hose assembly, the end where the hose swivel is, there are 4 metal pins that plug into the canister. One of the pins looks like it broke off. There are only three pins remaining. I assume there should be four pins as there are four holes. Is this the problem and is it fixable? The vacuum is from 2002 so I am not sure a replacement part is even available and at what price. Thank you. Susan susan.eng@

Hi Susan, if the pin has broken off you can do one of two things, first, would be to find a local vacuum repair shop and take it there for them to look at. they may be able to look at the hose and fix it for you pretty cheaply. what ... Kenmore Progressive 20912 Bagged Canister Vacuum

I have a central vacuum system. When I disconnect the hose from a wall outlet the central canister does not shut down dispite my turning off the vacuum at the handle of the hose. The only way I can get the system to shut down is to pull the plug at the canister. What gives? Rob

What I'm hearing is the canister(Not the Powerhead) portion of the unit is running all the time unless you unplug it. this problem could be caused by a short in one of your low voltage lines running through the house. To determine that just unplug on ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1083 seconds