Having problems with your Sebo X4 Bagged Upright Vacuum ?

I think the assist motor on the head is not working.

\015 How can I verify that this is not working, and can I fix it. It will spin when I turn it but it does not seem to assist when in use.\015

Answers :

Repair Help & Product Troubleshooting for Sebo X4 Bagged Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I think the assist motor on the head is not working.

... Sebo X4 Bagged Upright Vacuum

The motor on my Epic 6500 works, the hose is sucking, but the power head isn;t working... I tried the sidestep power head and that one works. Ive opened and replaced the belt and that is fine. The bulb was already burned out and wasn't replaced so I cant tell if theres power to the head. What else could it be?

Connect the power nozzle directly to the hose and try.\015\012Check the terminals where the wand connects to the PN. If any are discolored or cracked, that may be the problem.\015\012Open the PN and check for loose or broken wires and co ... Electrolux Epic 6500 Vacuum

Power head motor is good,runs great from test cord switch seems to work. brush roll cleaned but power head motor will not run

If you have checked the power delivery down to the powerhead and you have current running to the powerhead, then you likely have a burned fuse. There is a fuse built into the powerhead motor and is usually located on the field winding. This is not ea ... Eureka 6831A Bagged Canister Vacuum

The brush wouldn't work when the selector switch was in carpet mode. Took the power head apart and removed the motor. Everything o.k. in the power head. Checked and found that the neutural wire had pulled out of the connector, the connector was never crimped at the factory. What a day! Took 2 hours and a large pizza to get it done. Neutral wire was in the hose just below the handle. Reconnected the wire and crimped it, put everything back together. It works!!!!

Great. ... Kenmore Vacuums

Our unit is 7024A Electrolux Oxygen 3 - it seems to work great but suddenly, the head or 'power brush' or whatever it is called - has died. I checked by removing the hose and plugging it directly into the body, but it is still dead. Without that motorized head working, the vacuum is useless. Is it worth replacing? The unit is only about 1 year old and has seen light use only. Very frustrating, since it was the most expensive unit in the store:(

... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Numatic Henry Hound Turbo Head stopped working. Checked wires and contacts and cleaned. lOOKED AT THE MOTOR IN THE HEAD BUT DONT know how to check it is working

... Henry Numatic "" Canister Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos

It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

Kenmore canister model 116.25513506 wont turn on. when handle switch is turned to floor. vac motor does not turn on. When switch is turned to carpet, floor nozzle works but vac motor does not. I checked fuse, all o.k. checked continuity for plug, o.k. removed wires for bag full switch...motor wont run. I wired motor directly power cord...motor runs. Thinking it must be the circuit board, how do I bypass it or test it?

... Vacuums

We have a dyson dc 07 animal the machine was working fine then switched off after returning to the machine minutes later it wouldnt switch on, i removed on off switch cover and used a short piece of wire across the brown wires flicked the wall switch and it worked, aha i thought faulty switch aquired a new one to no avail and now even the short piece of wire trick doesnt work, has the motor died do you think, it wasnt over heating or making strange noises prior to refusing to work

It could be the motor. I'm having to replace the brushes on my DC 05. It appears that you can only get brushes for the YDK motors in the DYSON, not the Panasonic motor. Which might be saying something about the YDK motors. What happens is that the ca ... Dyson DC05 Cylinder Bagless Canister Cyclonic Vacuum

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after

... Vacuums

The motor in my Powermate (Kenmore Canister 116.27614700) is whining, high pitched, but still works. A local shop told me the motor is dying (the one in the Powermate that drives the beater bar) and would cost $150 for them to repair. The machine is only 1.5 years old and I paid $300...yikes. I think I can fix it but don't understand why the foam gasket that apparently wraps around the motor costs as much as the motor. This is assuming that part 32 (ks747156) is the foam I see glued to my cur

I think you are right! Buy the motor.....use the gasket from the old motor if you can cut it off clean and just glue it on the new one.\015\012\015\012The connectors are just brass blade connectors which you should be able to get at a Ho ... Kenmore 23913 Progressive PowerMate Bagged Canister Vacuum

I have an eureka deep steam extractor 2590 series and everything is working fine except for the motor it isn't moving is there a replacement part for the motor?? we think iit is the motor but could be wrong ??

Repairing unit wouldnt be cost effective . parts/labor $75.00 /$100.00 .if parts even available . ... Eureka Atlantis 2590A Wet/Dry Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert

Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Dc35 pulsing Hi I have a DC35 it works fine until i put the main head on and then the motor starts pulsing and cuts out after about 10 secs. If i remove the main brush head it runs fine again ? Please HELP :)

Check for debris in the head and remove ... Dyson DC35 Handheld Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert

Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

I have a kenmore vacuum cleaner model # 116.23612. When the hose is attached to the canister it runs, but if you remove the head to just use the hose the unit stops working. Is the motor dead or is there some type of reset or fuse. Could you please tell me how to test this. If so could you please send me instructions on how to replace the motor. Thank you in advance for your help, Tony

... Kenmore Vacuums

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?

... Kenmore 34722 Grab-N-Go Upright Vacuum

From reading comments i think my motor has burnt out (nasty smell then wont work at all) where can I buy a new motor (on line preferable) in the UAE - Dubai or UK - going home this week? thanks

Hi there you can get a motor from dysondoctor.net he is in the UK but will post anywhere in the world really ... Dyson DC08 Cylinder Bagless Canister Cyclonic Vacuum

I have an older Wega 2 group espresso machine. Looks like a date of 1992 on the group head, but not sure. This has no model name that I can find. Anyway, when I turn it on I get all lights flashing after it heats up 5 minutes or so. I do get nice steam from the wands. I drained teh tank and found a little scale, but not much. I took apart the group heads and cleaned them thinking it may be a clog there, but that doesn't seem to have worked. Also fwiw the water level float is not visible and whe

For a new fridge, need more time to maintain the required temperature of the fridge abut mainly the goods in it? So everything seems normal. The time will be reduced day by day since the goods will stay for longer time in and door opening will bec ... Vacuums

Stopped working Was working fine then it smelled like burning rubber, not the belt I checked. It sounds like the motor wants to run then it just stopped but the light is on. What do you think, go by a new one?? This has been a great vacuum cleaner and I can not seem to find a Sharp anywere. Thanks for your time.

Well it could be the motor, if it is it would cost around $80 or so for a motor. May be better to buy new, thre are a number of good brands out there. ... Sharp Twin Energy EC-12TWT4 Bagged Upright Vacuum

I have a vax cylinder model V-094. Working fine then started to play up. Switch it on and the motor seems to struggle to power up. Kind of wurrs up and down. Was thinking it could be the brushes have worn. Tokk to bits and cleaned her up, took a look at motot and brushes, cleaned them too, back together and still them same problem. Help please, hoover is not old but has done some work really don't want to through away something that can be fixed.

Hi.\015\012\015\012after all you have done I would be pretty confident its the motor thats faulty they are expensive to buy so machine is going to be scrap,\015\012\015\012Sorry.\015\012\015\012 ... Vacuums

Hey I have a kenmore model 116.23185800c vacuum. The vacuum stopped working but the power head still works is there a reset for the motor

... Kenmore Vacuums

Motor works, but no suction! what do you think?

No suction usually means a clog somewhere or bad filters. The hose and/or the dirt inlet by the brush roll may be coulded. The belt may have stretched enough to not turn the brush roll under load and that can seem like no suction. The worst is the ... Vacuums

My miele titan is not turning on when plugged in. i think it might be some sort of clog? but the electric head is working... help!

Wow!, that's not typical of a Miele, especially a new model like the Titan which has been on the market for less than 2 years. If I read this correctly, your power nozzle (electric head) is working, but the main suction motor is not. Thta's usually a ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0967 seconds