Having problems with your Sharp Twin Energy EC-T5980 Bagged Upright Vacuum ?

Sharp 8.5 amp, 900 w upright vacuum, new bag, cleared out clog from all intakes, no suction at all...heeeelp


Answers :

Repair Help & Product Troubleshooting for Sharp Twin Energy EC-T5980 Bagged Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Sharp 8.5 amp, 900 w upright vacuum, new bag, cleared out clog from all intakes, no suction at all...heeeelp


... Sharp Twin Energy EC-T5980 Bagged Upright Vacuum

Poor suction I have a hoover hush s5627 vacuum purchased about 4 years ago from Costco. It's suction power isn't so good anymore. I've checked all the lines & hoses and they're clear and I've changed the bag. I even disconnected the pipe from the vacuum unit and held my hand over the intake. While the machine roars like a jet engine the suction power just ain't like it used to be. What could possibly be the problem?


This vaccuum has a Fan Blade inside connected to the motor that spins to create the suction you feel. After a few years of use (and misuse) the blades on this (plastic) fan will be broken off, thus damaging the unit. These Fans are replaceable if yo ... Vacuums

I have a Sanyo Performax 12 amp upright vaccuum. It has lost its suction completely. All hoses and airways are clear, new bag, exhaust works, roller bar works.... but no suction - what might the problem be? thanks, Shelley


... Sanyo Permax SC-A102 Bagged Upright Vacuum

35922, sounds like there is a clog , have cleared hoses, put new bag in loss of suction, still hear loud clogged noise near rear vent hole


Try putting the vacuum hose end into vent hole while running. That may dislodge the clog. Otherwise, you will need to disassemble the machine far enough to get to the clog area. ... Vacuums

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.


I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

My Dirt Devil M082476 Full Bag indicator light keeps coming on when I turn my vacum up to full intensity. I have tried changing the bag and checked that all hose is clear. If I leave the vacum on low intensity the suction is minimal and does not increas when I turn up the suction. Is there a solution to this? I look forward to your response


... Dirt Devil M084105 Jaguar Vacuum

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?


Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

I have a DC17 which is only one year old. Today I lost suction and called for assistance. A Dyson technician told me to pull off the wand and see if it is clear. It was clogged so cleared out the obstruction. My filter was cleaned more than 24 hours ago. The vacuum still has no suction. Is it dead, any other suggestions. Please help.


Take the hoses off and give them a good shaking.\012or get a long piece of stiff wire and gently poke through the obstruction. ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Bissell powerforce My lower pickup tube became clogged so I removed it and cleaned it out and reinstalled it.Now everything runs good but the vaccum want pick up any dirt .I replaced the bag andf when I turn it on it just exhaust air but does not have any suction,I tired tp pull the bag door of while it was running whick I could not do so it has plenty of suction inside just not getting any outside can you help?


... Bissell Vacuums

Poor suction...continued Wow, thanks for answering so quickly! To answer your question, yes, there is suction at the screen, but it is very weak. I keep that screen clean. As a side note, I noticed that when I remove the top clear plastic cover (that would be part # 37 on the diagram, as far as I can tell) there is decent suction coming from the intake there--part 36? 30? it's hard to tell. But with the cover on, I feel no suction (from where it sucks up the water directly from the carpet),


Wish I had it in my shop, it is hard to figure your problem. I do know that you must have something out of place and you may have to take it apart to find it. You may feel some suction there at the top of the clear nozzle, but maybe it isn't strong ... Hoover F6212-900 / F6215-900 SteamVac Agility Upright Vacuum

Lost suction my DCO7 lost suction in the hose I started taking it apart and cleaning it and looking for clogs (probably more than I should have) and when I put it back together it has awesome suction in the hose but no suction in the base. It just pulls the pine needles up (christmas tree) but they never appear in the "bag" compartment and when I look they are just all gathered in a clump in the bottom by the brush.


Hi.\015\012\015\012Remove the sole plate turn the 3 plastic screws to unlock & lift off.\015\012\015\012Now remove the blockages that have accumilated from the oppening of short clear hose.\015\012Check you can turn ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

No suction my riccar 8850 has no suction. I cant find any clogs and there is some suction on the hose when using cleaning tools but when hooked up to the vaccum bag it wont clean


Replace your belt. Remove the baseplate, remove the brushroll, place a new belt around the motor pulley, then around the pulley on the brushroll, and pull the brushroll back into place in the nozzle. Spin it by hand to make sure it spins, (otherwise ... Riccar 8850 Vacuum

Poor suction (new bag, clean filter, clear hose)


Check the impeller on the moter it may be missing a fin or two (question does it make any unusual noise or vibration ?) ... Vacuums

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?


As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

I cleaned out the hose and removed brush to clean and checked belt. Everything seems to work but will not pick up or suction on carpet. The hose is totally clear from clogs. I can see the floor from one end to the other. What am I missing that might be causing lack of suction?


Hi troupdavid,I see that your Vacuum is having issues with it suction, you mentioned that you took it a part to clean it, see steps below.\015\012\015\012Check if everything is inserted prope ... Hoover Tempo Widepath Upright Vacuum - Blue

Model 8850 riccar no suction at all bag is new, no clogs, brush is turning,everything, seems fine,just no suction


The bag has a cardboard collar with latex. It must seal over the inlet. Make sure not to tear the bag when replacing.Is the cover closing properly? The cover seals against a gasket. The same with the filter. ... Riccar 8955 Upright Vacuum

My new Kenmoore Powermate 116 canister has poor suction. I have no pets and light dust. Its not picking up small particles on the wood floor with the floor attachment. When I put my hand to the suction it feels weak. Cleared hose and changed bag. Using again, same issues. This should not be happening with a new vacuum. Is it a bad design in the elbow joint of the hose? I want to return this!!!!


First of all disassemble the handle and hose as much as possible and examine the inside. Make sure there is not any significant debris lodged in the hose somewhere like a plastic bag or something.\015\012\015\012Also check at the top of t ... Kenmore 23912 Progressive PowerMate Bagged Canister Vacuum

Poor suction We bought a model home about 11 years ago and it had the Cental M&S Cyclonic Cleaning system. The suction has steadily been weakening. Now it is almost non-existant. I clean the filter bag in the main unit, but how clean does it need to be. Could there be a clog in the wall lines. If yes, how does one unclogg them. Thank you. I liked the system and would hate to just give up on it. Jean


This page has useful tips for unclogging a central vac. https://www.centralvacuumstores.com/cvs/trouble_help.php ... M&S Systems FX-3000 Bagged Central System Vacuum

Suction problem I have a Hoover Widepath Fold Away, 12 amp motor vacuum cleaner and the problem I am having is every time I vacuum, the vacuum gets clogged up with carpet. I am probably only able to do one stroke then it gets clogged and I have to stop and unclog it or it spits it out on the carpet. This is very frustrating and I don't get much vacuuming done. Please can you help me. Thank you. Gwen email is [email protected]


Get rid of the carpet its shredding and falling apart.no sence in vacuuming old rotten carpet.or try using a vacuum without a brush roller and just suction ... Hoover U8145-900 Savvy Bagless Upright Cyclonic Vacuum

My almost new miele Dog and Cat vac keeps telling me the bag is full when it's not (new bag, no clogs)and I have almost no suction. Any ideas?


Remove the hose and check the suction. It it is still bad check to see if the canister is closing on the bag. Most likely the hepa filter needs replaced. Here ... Miele S514 Solaris Bagged Canister Vacuum

Oreck XL21 just will not work at all any more. Beater is clean - belt is fine. Fresh bag - inflates. Took the thing apart - checked for blockages at intake, bag entry, and the tube. It just doesn't vacuum anything. No suction at all for anything stronger than air. I'd say it doesn't ****, but that would be ironic. Are these known for just "quitting" after a while? We take it in for maintenance as recommended to replace filters, etc. Is there some miracle trick to make it work or sho


Did you make sure the brush turns freely? Even though it is clean, if it does not turn freely with the belt, it will not beat the carpet and pull debris up into the unit.\015\012\015\012Another (drastic?) thing to try would be to take the unit ... Vacuums

Suction power greatly diminished . Bag replaced...hose is clear...Performance indicator light is on and red..much less suction that it should have'


Clean the filter. ... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

I have a Eureka Boss Model 411... I need to know where the reset button is for the suction motor. The canister was clogged on the backside, I didn't see it and the suction motor shut off. I have cleared the obstruction, but don't know where the reset is for that motor. I know how to reset the brush head motor.


If your vacuum motor overheats, it will stop working. it will start working again once it cools. ... Eureka 411A Upright Vacuum

I have a Sebo X4 vacuum cleaner which has lost suction and is displaying the red bag clogged light. There is no apparent blockage in the pipework from brush to bag Any clues as to reasons/solutions?


There could be a few reasons:\015\012\015\012Check that the main filters are completely clean - open the door to see if there is any dirt on the main slide out roll filter and also the main exhaust filter on top of the hood of the X4 (by pushin ... Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.


Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0870 seconds