Having problems with your tristar vacuum sweeper ?

motor gets ery loud and very hot but still has suction

it works but is loud and gets very very hot is just a few minutes

Answers :

Repair Help & Product Troubleshooting for tristar vacuum sweeper

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Miele Cat & Dog vacuum gets VERY hot and is VERY loud. Hose has no restrictions and I have changed the dust compartment (motor) filter and the exhaust filter. It still gets hot when I run it with the top open and all filters removed, so I'm guessing the problem is with the motor. Should I be going into the motor compartment? If so, what am I looking for?

Hi\015\012\015\012The fact that it gets very hot could be due to a number of issues.,but the fact that it started making a very loud noise at the same time suggests that there might be more problems maybe brushes etc.\015\012\ ... Miele S514 Solaris Bagged Canister Vacuum

Bissell lift-off revolution, motor gets hot, loud whining sound

... Bissell Lift-Off(R) Revolution(R) Turbo Upright Vacuum

Rainbow Vacuum, about 5 yrs old (bought new, no issues prior) - my 6yr old tipped it on it's side while water was in basin. Now when I turn the power on, it makes a very loud sound in the motor and you can feel the vibration on the floor. The suction still works and basin still catches dirt - the noise is just so loud and I'm not sure if I should continue use or how to fix -?

Although a wet/dry vacuum, it cannot tolerate water in the motor. Water will cause the motor to short out, which will cause the motor to act/sound like yours does now, if it continues working at all.\015\012To prevent additional problems, the ... Rainbow E series Canister Wet/Dry Vacuum

My Oreck xl makes really loud sound and starts to smell hot when running still picks up but I am afraid I will damage something if I use it. The loud sounds gets very loud then quits for a few seconds then starts again.

... Oreck XL Ultra Bagged Upright Vacuum

Our kenmore progressive model #11634922 was working fine today. And then - it's not. Plugged in - nothing is working on it. We let it cool down (though it didn't seem hot). Still nothing - no light, no motor. Tried it in some other plugs that we know are functioning well - and still nothing. Any idea what might be wrong with it? It's six years old but doesn't get heavy use. Thanks so much ~ Susan Golden

Hi, it could be a number of things, cord may be bad as well as a problem with the motor. There also is a fuse that could have blown. If you go to sears.com, click on parts, put in your model number, when the page loads, click on the first link ... Kenmore Vacuums

Vacuum motor overheating. Never happened before till last nite and today. It seems to be getting hot and tripping an overload switch or something like that. Starts back up after a long cooldown. Roller brush will still come on, even though the vacuum motor will not. Any idea what may be causing that?

... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Motor sounds loud and high pitched. Suction seem ok, can't find any blockages. Cleaned filter at top of removable canister. Exhaust seems hot and low. Can there be a blockage within the motor housing?

Most likely your bearings are shot. it will need a new motor ... Kenmore Vacuums

Bissell lift off vacuum about 4yrs old. Extremely noisy. OK until before Christmas but getting worse every time it's used. Washable filters washed, HEPA filter replaced. brush bar cleaned of every scrap, hose empty,everything that can be cleared has been. Noise high pitched, screeching and can only bear to use it for a few seconds at a time. Suction OK. Mine is so loud I can't use it very long-high pitch screech. Can this be fixed or does the whole vacuum need to be replaced? It still cleans gr

Sounds like a bad motor. Could be either foot motor or main motor either way cost will be more than half of the unit. ... Bissell Lift-Off(R) Revolution(R) Turbo Upright Vacuum

I have a CT600 power brush that would not power up. Thinking the motor was bad in it, I replaced it with a new CT700 power brush, I am still experiencing the same problem the power brush itself does not seem to be getting electic power, but the Vacuum unit does come on with suction.

First try connecting the power nozzle directly to the hose. If it works, the problem is due to a broken wire or faulty connection in the wands. At least one wand will need to be replaced.\015\012My guess is it's probably due to a broken or di ... Broan-NuTone VX550 Bagged Central System Vacuum

I have a windsor vsp 14, it is making a bad grinding noise, when I take the top blue piece off it stops, the brush works fine and when I put the top back on it grinds really loud and gets hot. it still vacuums and the belt and brush are working fine, can't figure it out. and when the lid is on I cant see what its grinding on. It only makes a grinding noise when you pull handle back and engade to vacuum flor and stops when you put it upright.

... Windsor VS14 Versamatic Bagged Upright Vacuum

Hello i own the bissle proheat steamer it turns on but no water or soap or suction from floor or the utensiles ive taken the take off the back to scope out anything that could be in the way but dont see anything the motor is making that clogged vacume noise witch makes me believe something could be stuck somewhere in it but it could also be no water is getting to the pump or despencer but the brissels still work belt for that is good where would i be best to check and where is the location of th

... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

Dyson has lost it's suction...i've cleaned all filters and checked all the hoses. The motor appears to be getting too hot

The filter housing can also be an issue. Check this:\015\012\015\012http://www.ehow.com/how_5870417_modify-dyson-prefilter-suct ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

Motor gets hot in moments and shuts off

True, the motor has safety measures to stop it from overheating... that's why it shut down. You smelled something, so some kind of damage was done. It's possible that the over temp switch itself got fried. Doesn't sound too good from here. ... Filter Queen Majestic Canister Vacuum

Shark navigator no suction and getting hot

Sounds to me there's a blockage somewhere .the link below is the manual it will show you where to look for blockages..http://www.totalvac.com/manua ... Euro-Pro NV22 Shark Navigator Bagless Upright Vacuum

Motor gets hot and stops running

Is there suction?\015\012\015\012call bissell and do a walk through.. you have a clog somewhere and its killing that motor.. with the hose off (completely) the machine does it still have the problem? if no add a part. check again.. this m ... Bissell Lift-Off(R) Revolution(R) Turbo Upright Vacuum

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor

On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

Motor getting really loud!

Your Kirby most likely needs a new fan. Please see this link to get the part and do it yourself repair instructions... ... Kirby Generation 3 Bagged Upright Vacuum

Altrev, I have an ODC325 Black&Decker spacemaker coffeemaker on my boat and it stopped working this weekend although the hot plate still gets hot. I suspect it is the thermal switch as you described (I hear a click when I switch the machine on but nothing happens and the heating element does not kick in). I would be very happy to receive one or two of these 14 spare switches you mention so I can repair the unit. If still available I would appreciate hearing from you how we can do the transact

We don't sell parts individually on the site here.... was it some other solution for another person you saw about the switch? I don't believe there really is a part called a thermal switch... there is a thermal fuse but if the hotplate gets hot I wo ... Vacuums

Flames and fine carbon particles came out of my Dydon DC29 which also partly melted the bottom filter. The motor is still working tho. I feel that the brushes are gone. How to get to the motor and where to get new brushes???

Hi Joel,I'm sorry to hear about your experience with your DC29. We'd appreciate the opportunity to provide further assistance, so if possible, please call us on 1800 239 766. Alternatively, if you email your contact details to us at ... Dyson Vacuums

HI, my motorized brush barely turns.It makes a hot rubber smell. I took apart and noticed the spindle the belt turns on discolored from heat. Cleaned it, but still no turning of the brush.The vac is a hoover wind tunnel. As it moved accidentally touched the belt/ spindle and burned my hand a little. Very hot in area. Bright spark from motor noted. Was careful not to touch that part!

That means that the belt is stretched and it is slipping on the motor shaft, that is why it is hot and smells like burning rubber. You need to replace the belt. Here is the correct belt you need: ... Hoover S3765-040 WindTunnel Bagless Canister Vacuum

Bissell upright has weak suction and motor running hot but can't find a blockage

... Bissell 8975 CleanView Bagless Upright Vacuum


... Hoover V1 SteamVac SpinScrub Vacuum

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.

I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0674 seconds